18:00:58 <kohsuke> #startmeeting
18:00:58 <robobutler> Let the Jenkins meeting commence!
18:01:14 <kohsuke> #chair rtyler hare_brain danielbeck
18:01:14 <robobutler> Current chairs: danielbeck hare_brain kohsuke rtyler
18:01:28 <kohsuke> #topic Recap last meeting's actions
18:01:41 <kohsuke> #info http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-06-10-18.01.html
18:01:48 <kohsuke> #info https://issues.jenkins-ci.org/projects/MEETING
18:02:10 <danielbeck> no actions to recap
18:02:20 <kohsuke> OK
18:02:31 <kohsuke> It's been a while we do this
18:02:55 <kohsuke> #topic 1.609.2 RC status check
18:03:11 <ogondza> kohsuke: thanks for the calendar access
18:03:11 <kohsuke> ogondza: ^^
18:03:18 <ogondza> we are ready
18:03:23 <kohsuke> No problems, thanks for asking!
18:03:38 <danielbeck> ogondza Unless you consider JENKINS-28058? It was filed as Improvement but is a bug
18:03:39 <kohsuke> danielbeck told me there's one last minute change that he thought we should pull in?
18:03:41 <jenkins-admin> JENKINS-28058:Excessive classes being sent to slave machine (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-28058
18:03:56 <danielbeck> kohsuke Nope, all the really important ones are in. This one is nice to have I think
18:04:02 <ogondza> danielbeck: I have not, let me see
18:04:22 <kohsuke> OK, then I can crank the wheel now?
18:04:36 <danielbeck> kohsuke Oliver backported all previously proposed issues, including Stephen's queue fixes yesterday
18:04:42 <danielbeck> kohsuke Wait a minute
18:04:44 <kohsuke> OK, I think that's the one you told me
18:05:26 <danielbeck> For reference, Oliver used the delayed RC to backport JENKINS-28690, JENKINS-28840, JENKINS-27289, JENKINS-14899 and JENKINS-28926
18:05:28 <jenkins-admin> JENKINS-28690:Deadlock in hudson.model.Executor (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-28690
18:05:30 <jenkins-admin> JENKINS-28840:Deadlock between Queue.maintain and Executor.interrupt (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-28840
18:05:32 <jenkins-admin> JENKINS-27289:Masking classLoader doesn`t work on remote Slave (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-27289
18:05:34 <jenkins-admin> JENKINS-14899:consoleText stops updating at 5000 lines until end of build job (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-14899
18:05:35 <ogondza> I assume we can live without J28058
18:05:36 <jenkins-admin> JENKINS-28926:Jenkins queue self-locking without apparent reason? (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-28926
18:06:22 <danielbeck> Then it's time for the RC
18:06:27 <kohsuke> Great
18:06:38 <kohsuke> #agreed 1.609.2 RC is good to go
18:07:15 <kohsuke> I think we can finish very quickly today and maybe we can use the rest of the time fixing SPoF and other infra work
18:07:20 <danielbeck> so did this delay push back future releases?
18:07:20 <kohsuke> #topic next meeting
18:07:34 <kohsuke> danielbeck: I think so, no?
18:07:43 <danielbeck> i.e. +2w until 609.2, +6w 609.3, +10w NNN.1?
18:07:52 <danielbeck> Just asking to get confirmation
18:07:59 <ogondza> danielbeck: yes
18:08:03 <kohsuke> ogondza: thanks for creating calendar entries
18:08:35 <ogondza> I will try to make the process more visible for devs and testers
18:09:43 <kohsuke> danielbeck: you and I talked about reviving the office hours. Any thoughts on when we'd start?
18:10:24 <danielbeck> I'll try to get something set up for next week if I have the time, otherwise two weeks later
18:10:48 <kohsuke> looking forward to a blog post for that one
18:10:59 <kohsuke> should we wrap up the meeting?
18:11:07 <danielbeck> I think so
18:11:11 <kohsuke> #topic next time
18:11:34 <kohsuke> #info Next meeting would be July 22nd same time
18:11:41 <kohsuke> #endmeeting