18:01:20 <kohsuke> #startmeeting
18:01:20 <robobutler> Let the Jenkins meeting commence!
18:01:44 <kohsuke> #chair abayer  hare_brain rtyler danielbeck orrc
18:01:44 <robobutler> Current chairs: abayer danielbeck hare_brain kohsuke orrc rtyler
18:01:50 <kohsuke> that should cover enough peopl
18:02:02 <kohsuke> #topic recap of actions
18:02:19 <kohsuke> I've missed two previous ones, let's see...
18:02:25 <KostyaSha> https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:02:44 <danielbeck> http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-05-27-18.19.html
18:03:12 <danielbeck> orrc and I changed UC generation as discussed
18:03:16 <KostyaSha> orrc, confluence has meeting notes plugin that can automatically create jira issues AFAIR
18:03:18 <kohsuke> Yay
18:03:22 <danielbeck> on June 1st
18:03:47 <danielbeck> So now wiki URLs are mandatory, with previously existing plugins pointing to a wiki page that says "this plugin has no wiki page"
18:03:57 <danielbeck> To be reviewed in a few months
18:04:02 <kohsuke> #topic Let's fix SPoFs
18:04:25 <kohsuke> orrc: so I'm happy to report that INFRA-75 is done like just 3 minutes ago
18:04:27 <jenkins-admin> INFRA-75:Move backend-crawler to ci.jenkins-ci.org (Open) https://issues.jenkins-ci.org/browse/INFRA-75
18:04:49 <KostyaSha> kohsuke, /o/
18:04:56 <rtyler> \o/
18:05:22 <kohsuke> The other list of SPoFs are here: https://issues.jenkins-ci.org/browse/INFRA-75?jql=project%20%3D%20INFRA%20AND%20component%20%3D%20spof%20ORDER%20BY%20updated%20DESC%2C%20priority%20DESC%2C%20created%20ASC
18:05:50 <KostyaSha> i think we need component called "kohsuke" under jira :D
18:06:24 <orrc> kohsuke: great :)
18:06:33 <kohsuke> INFRA-244 and INFRA-249 looks like that's on me
18:06:35 <jenkins-admin> INFRA-244:Kohsuke is SPoF for update center root CA private key (Open) https://issues.jenkins-ci.org/browse/INFRA-244
18:06:37 <jenkins-admin> INFRA-249:Kohsuke might be the only one who can decrypt statistics data (Open) https://issues.jenkins-ci.org/browse/INFRA-249
18:06:39 <kohsuke> INFRA-180 is something another person can help
18:06:41 <jenkins-admin> INFRA-180:Extension point list missing core (Open) https://issues.jenkins-ci.org/browse/INFRA-180
18:06:48 <kohsuke> INFRA-243 is rtyler?
18:06:50 <jenkins-admin> INFRA-243:jenkins-ci.org domain name still appears to be registered under Tyler's personal account (Open) https://issues.jenkins-ci.org/browse/INFRA-243
18:07:10 <kohsuke> Ig guess someone needs to contact SPI to work out the logistics of the transfer
18:07:10 <danielbeck> kohsuke I can do INFRA-180 if you point me to the generator/migrate to JonJ
18:07:30 <kohsuke> danielbeck: sounds good
18:08:26 <kohsuke> UC root CA private key: I guess I'm going to share that with the board?
18:08:48 <kohsuke> And ditto for the key in INFRA-249
18:08:51 <jenkins-admin> INFRA-249:Kohsuke might be the only one who can decrypt statistics data (Open) https://issues.jenkins-ci.org/browse/INFRA-249
18:08:52 <KostyaSha> kohsuke, should it be periodically re-generated?
18:09:19 <kohsuke> root key cannot be easily regenerated
18:09:38 <kohsuke> UC key, we should
18:09:57 <danielbeck> Doesn't that expire all the time anyway?
18:10:00 <kohsuke> But that feels like a separate task
18:10:29 <kohsuke> cert expires all the time, but I don't think I rotate keys
18:11:25 <kohsuke> Should we move on to the next topic?
18:11:33 <kohsuke> Unless there are more SPoFs we should talk about?
18:12:00 <kohsuke> #topic Using labels for pull requests to core
18:12:08 <ogondza> kohsuke:  is it this job https://ci.jenkins-ci.org/job/infra_extension-indexer/?
18:12:23 <kohsuke> Right, I think so
18:13:09 <danielbeck> So far we've renamed PRs to indicate they still need some work, like [WIP] [FIX JENKINS-12345]. The idea now is to use labels instead.
18:13:11 <jenkins-admin> JENKINS-12345:Publishing Selenium report blocks concurrent builds (Open) https://issues.jenkins-ci.org/browse/JENKINS-12345
18:13:20 <danielbeck> thanks jenkins-admin
18:13:47 <kohsuke> I guess we'll run some bulk process to create labels in all repos?
18:13:53 <KostyaSha> no
18:14:02 <danielbeck> kohsuke jenkinsci/jenkins for now I think
18:14:04 <KostyaSha> repos already has labels that they need
18:14:10 <KostyaSha> *plugins
18:14:18 <danielbeck> plugin repos sometimes already use them
18:14:25 <danielbeck> so we'd just mess with what works there
18:14:40 <kohsuke> Sounds like a good idea to me
18:14:42 <danielbeck> So a "work-in-progress" label would make sense, possibly also "regression"
18:14:55 <KostyaSha> imho just WIP should be enough
18:15:25 <KostyaSha> danielbeck, also "UI"
18:15:35 <danielbeck> So... start with WIP for now, and review in a few weeks?
18:15:40 <ogondza> we can agree on particular labels and their definition later and put it on wiki
18:15:46 <kohsuke> Not sure how to create labels
18:15:56 <KostyaSha> ogondza, you can later just rename or remove useless labels
18:16:06 <KostyaSha> kohsuke, repo -> settings -> labels
18:16:12 <danielbeck> kohsuke https://github.com/jenkinsci/jenkins/labels
18:16:26 <ogondza> KostyaSha: my point is it is necessary to agree on fixed set of labels now
18:16:33 <ogondza> *it is _not_
18:16:46 <kohsuke> OK, I created work-in-progress
18:17:12 <KostyaSha> ogondza, imho thinking a lot about labels is waste of time, create some minimal set and later it will be clear what else is needed
18:17:27 <danielbeck> kohsuke I can go through existing PRs later and fix them accordingly
18:17:29 <kohsuke> I guess danielbeck wants "regression" as they are more important
18:17:38 <kohsuke> or more urgent/timely
18:17:48 <danielbeck> Yes. Regression fixes should be preferred.
18:18:04 <oleg-nenashev> We have a set of labels in many repos. Let's add "work-in-progress" and "regression"
18:18:05 <danielbeck> Well, 'regression-fix' I guess would be more appropriate
18:18:13 <KostyaSha> long labels (╯°□°)╯︵ ┻━┻
18:18:38 <danielbeck> KostyaSha Try Objective-C development :-)
18:18:45 <kohsuke> KostyaSha: I think it's OK, and hopefully more understandable to people
18:18:52 <kohsuke> Or Win32 APIs
18:19:06 <KostyaSha> win api is another storry
18:19:18 <kohsuke> I'm going to create 'regression-fix'
18:19:28 <danielbeck> :+1:
18:19:56 <kohsuke> let's see how they'll turn out
18:20:02 <kohsuke> I hope people won't put it on every bug fix
18:20:05 <danielbeck> red, THANK YOU
18:20:11 <kohsuke> ... which would probably defeat the purpose for danielbeck
18:20:12 <KostyaSha> what is "regression-fix"?
18:20:25 <KostyaSha> have you ever seen "regression not fix" PRs?
18:20:33 <danielbeck> alright, that's it for this topic I think
18:20:42 <oleg-nenashev> kohsuke, danielbeck: Should we allow everybody to set labels?
18:20:47 <KostyaSha> oleg-nenashev, you can't
18:20:49 <danielbeck> KostyaSha PRs that introduce regressions? :-)
18:20:57 <KostyaSha> oleg-nenashev, only team can do it
18:21:04 <kohsuke> KostyaSha: I think the regression-fix label is for stuff like https://github.com/jenkinsci/packaging/pull/3
18:21:07 <oleg-nenashev> Probably jenkinsci/core is enough
18:21:19 <kohsuke> ones that we need to incorporate ASAP
18:21:33 <KostyaSha> danielbeck, my point is that labels should be short and clear ( i have have project that has many labels and they are long and it terrible)
18:21:49 <danielbeck> Well, we have two.
18:21:52 <kohsuke> #agreed jenkinsci/jenkins now has 'work-in-progress' and 'regression-fix'. Will see how theey turn out
18:21:54 <KostyaSha> kohsuke, fix is always fix for some regression...
18:22:00 <danielbeck> It's not like we cannot revise that once necesary
18:22:08 <danielbeck> KostyaSha Or things never worked.
18:22:09 <kohsuke> OK, I'm OK with 'regression' if KostyaSha feels strongly
18:22:26 <KostyaSha> it looks more compact and clear IMHO
18:22:42 <danielbeck> alright, let's go with regression and see what happens
18:22:51 <kohsuke> done
18:22:53 <danielbeck> first guy to get it wrong and we'll change it :P
18:22:55 <KostyaSha> danielbeck, rename works without loosing attachment
18:23:00 <kohsuke> moving on to the next topic...
18:23:11 <danielbeck> KostyaSha Which is why I said we can always change it later.
18:23:29 <KostyaSha> danielbeck, changing after is always harder :(
18:23:36 <kohsuke> #topic "Action items are tracked in JIRA" — can we agree to do this?
18:24:00 <oleg-nenashev> +1 from me
18:24:01 <KostyaSha> as usual my 5 cents
18:24:03 <KostyaSha> [21:03]  <KostyaSha> orrc, confluence has meeting notes plugin that can automatically create jira issues AFAIR
18:24:03 <kohsuke> Basically I take a blame for not being dilligent
18:24:15 <KostyaSha> we have confluence and confluence is the right place for such things
18:24:25 <KostyaSha> btw it can replace html based reports
18:24:35 <kohsuke> KostyaSha: can you walk us through how that works?
18:24:46 <oleg-nenashev> BTW we should track our action items somehow. Even JIRA assignments become forgotten sometimes
18:24:49 <kohsuke> (btw, obviously +1 from me)
18:25:24 <KostyaSha> when confluence has integration you just press "meeting items" and appears new page in it you can very fast assign items. AFAIR it can also create new issues in jira
18:25:58 <danielbeck> +1 on MEETING resurrection, -0 on Confluence, because so much appears to be broken there currently I fear this'll break as well.
18:25:59 <KostyaSha> so the main idea separate documentation/text and actions
18:26:08 <kohsuke> I'm mostly happy with the current robobutler
18:26:26 <KostyaSha> kohsuke, yeah it just works, but it like 90's :)
18:26:37 <KostyaSha> and project has place for documentation
18:26:44 <kohsuke> And I don't think there's any people claiming that we should NOT use the MEETING project to track AIs
18:26:55 <KostyaSha> (note i don't insist on killing robobutler, but this can be an option)
18:27:02 <kohsuke> So in my mind I think we just need to make it easier to file AIs, so that the right thing happens automatically
18:27:20 <kohsuke> "automatically" as in people do the right thing
18:27:34 <kohsuke> (not saying we need to automate ticket creation)
18:27:40 <KostyaSha> maybe from this... http://blogs.atlassian.com/2013/04/how-to-run-effective-meetings-with-confluence/
18:27:55 <KostyaSha> so my suggestion will be to check plugins for jira+confluence
18:28:16 <kohsuke> In my company JIRA there's some projects that have the "Backlog" UI where it's very easy to file tickets
18:28:26 <kohsuke> There's one textbox and you just need to type it and hit ENTER
18:28:37 <kohsuke> I wonder if we can activate that here
18:28:51 <KostyaSha> kohsuke, you can create command to bot
18:29:03 <kohsuke> or that, if somebody is willing to tackle
18:29:20 <kohsuke> jenkins-admin picking up "#action" or something like that
18:29:44 <danielbeck> different user names would be an issue
18:29:52 <danielbeck> for assigning
18:30:04 <kohsuke> in practice only a handful of people get assigned to AIs
18:30:11 <kohsuke> I think we can do something dumb
18:30:15 <KostyaSha> but in the same way we can automate to post everything to confluence and have convenient tree and page called "meetings"
18:31:33 <kohsuke> All right, since there's no one volunteering to get this dashboard in JIRA or modify jenkinsadmin, let's just leave it at "we re-agreed to use the MEETING project to track AIs"
18:32:06 <KostyaSha> kohsuke, well with such ancient confluence...
18:32:11 <KostyaSha> no way
18:32:20 <KostyaSha> either jira either html files
18:32:40 <kohsuke> #info filed this as INFRA-324
18:32:42 <jenkins-admin> INFRA-324:ircbot should auto-file #action into MEETING project (Open) https://issues.jenkins-ci.org/browse/INFRA-324
18:32:57 <kohsuke> Until then, let's try to be more dilligent
18:33:13 <kohsuke> #topic Time to move to servlet 3.0
18:33:32 <kohsuke> Yes indeedy
18:34:37 <kohsuke> Let's  see if this can be done before JUC...
18:35:13 <kohsuke> #agreed we should move to servlet 3.0 indeed
18:35:24 <kohsuke> I guess we need to start from upgrading Winstone?
18:35:57 <kohsuke> Not it already supports 3.0
18:36:04 <kohsuke> s/Not/No,/
18:36:21 <kohsuke> anyway, the details of the conversation probably doesn't belong here
18:36:47 <kohsuke> All right, I think that's it for this week
18:36:50 <KostyaSha> i think you need raise it in maillist
18:36:55 <KostyaSha> afair there was topic about that
18:37:05 <KostyaSha> and some people that wanted to help with it
18:37:10 <kohsuke> great
18:37:22 <kohsuke> do you have a URL to the conversation?
18:37:26 <KostyaSha> no :(
18:37:40 <kohsuke> I'm going to close this meeting and spend the rest of time actually working on AIs
18:37:47 <kohsuke> #topic next meeting
18:37:55 <danielbeck> JUC in two weeks
18:38:06 <kohsuke> oh yes
18:38:16 <kohsuke> BTW do I get to see anyone there?
18:38:25 <KostyaSha> maybe this https://groups.google.com/d/msg/jenkinsci-dev/On4ED4c64d8/hItcdTVxBX0J
18:38:55 <kohsuke> #info the next meeting is in Jul 8th same time
18:39:05 <kohsuke> #info we are skipping one due to a conflict with JUC
18:39:13 <kohsuke> #endmeeting