18:19:31 <danielbeck> #startmeeting
18:19:31 <robobutler> Let the Jenkins meeting commence!
18:19:40 <danielbeck> #topic Implementing wiki page requirement
18:19:50 <danielbeck> #chair ogondza jglick
18:19:50 <robobutler> Current chairs: danielbeck jglick ogondza
18:20:39 <ogondza> Lets skip first item
18:20:52 <danielbeck> sorry, let's go by agenda
18:20:57 <ogondza> oh, we already did
18:20:58 <ogondza> nm
18:21:05 <danielbeck> #topic Recap last meeting's actions
18:21:24 <danielbeck> http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-05-13-18.07.html
18:21:54 <danielbeck> I was unable to work on my actions unfortunately
18:21:58 <danielbeck> rtyler?
18:22:46 <danielbeck> doesn't look like he's here, and the rest of the items are mostly the wiki changes
18:22:58 <danielbeck> #topic LTS RC status check
18:23:07 <danielbeck> ogondza Do we need kohsuke for this?
18:23:19 <ogondza> I will let him know we are ready
18:23:24 <KostyaSha> danielbeck, have you seen any issues related to publisher statuses?
18:23:24 <orrc> the atlassian admins thing was done by rtyler
18:23:40 <ogondza> we can move on
18:23:41 <KostyaSha> danielbeck, i will try promote lts-candidate then
18:24:15 <danielbeck> KostyaSha Will need to look this up, but it's a little late for 1.509.1
18:24:30 <jglick> 1.609.1 you mean?
18:24:34 <danielbeck> right
18:24:42 <KostyaSha> +-100 versions :)
18:24:50 <jglick> I think we just need to wait for KK to be on the ground and publish it.
18:24:58 <danielbeck> alright, let's move on
18:25:01 <danielbeck> #topic When to flip the switch on plugins without wiki pages?
18:25:25 <KostyaSha> I have a question, why do you enforce confluence url for "wiki"?
18:25:50 <danielbeck> KostyaSha I think this was discussed last time, the plugin info sheet at the top
18:26:05 <danielbeck> IIRC
18:26:24 <ogondza> orrc: what is complex about koji plugin?  there is unmerged PR with fix. (maintained by a colleague of mine)
18:26:50 <orrc> ogondza: it was renamed twice I think, between koji and koji-plugin
18:27:12 <orrc> so we need to make sure a new version is released and we can deprecate the old one (I think)
18:27:26 <ogondza> orrc: is there anything I can do?
18:27:28 <orrc> I wrote the maintainer an email with the details, but didn't hear back yet
18:27:36 <orrc> I can forward the mail to you? :)
18:27:51 <orrc> vtunka, right?
18:27:58 <ogondza> yeah
18:28:01 <danielbeck> #info https://github.com/jenkinsci/backend-update-center2/pull/20
18:28:04 <orrc> ok, will do
18:28:07 <KostyaSha> danielbeck, why not provide bage image that can be included in any docs?
18:29:05 <danielbeck> KostyaSha It's always possible to relax the rules later, but we need to start with something. A wiki page that basically contains one paragraph description and a link to Github README/GH pages would be fine IMO and not exactly a big obstacle
18:29:39 <KostyaSha> danielbeck, with not working captcha and constant issues?
18:29:50 <orrc> so the next steps are to make sure the plugins with no wiki page at all don't get removed. I should create a "plugin page missing" page or so, and add wiki overrides
18:30:07 <orrc> a few plugins have already added wiki pages *and* made a release, which is good. a few still need to make a release
18:30:47 <orrc> but the sooner the UC changes are merged, the less time I have to go checking every new plugin update/release is still correct :)
18:31:11 <danielbeck> KostyaSha Apparently some plugin authors were successful in creating wiki pages. It's not like these would need to be updated constantly. And if there's really a persistent problem we can always add an exception. Not a reason to not implement this IMO.
18:31:55 <KostyaSha> danielbeck, you can have this check periodically and notify authors without magically not publishing this plugins. What developer should do with such release them?
18:31:55 <rtyler> danielbeck: was ist los?
18:32:01 <KostyaSha> *then
18:32:04 <orrc> oh er ist wach
18:32:40 <orrc> rtyler: the question was what action items got done from the last meeting
18:32:59 <KostyaSha> danielbeck, you can even automatically create issues for plugins
18:33:06 <orrc> rtyler: that was the atlassian puppet thing and the fastly prototype
18:33:17 <rtyler> I'm on an airplane, so i'll make this short
18:33:31 <rtyler> the atlassian work got done, kohsuke wants more finer grained controls to be put in place
18:33:58 <rtyler> the fastly stuff hasn't come to fruition yet, I erred on the side of the atlassian thing in last week's jenkins time budget :p
18:34:40 <orrc> rtyler: ok, thanks
18:36:52 <orrc> danielbeck: I think we mainly just need to pick a date?
18:37:12 <danielbeck> KostyaSha If a new plugin is affected, the archetype and wiki pages on hosting plugins explain what's going on. For existing plugins, we have the exceptions list (and will continue using it when there are technical reasons) and a months long grace period after introduction
18:37:28 <danielbeck> orrc I'm fine with June 1st as discussed last week
18:37:59 <orrc> ok. mondays are good for me
18:38:00 <KostyaSha> danielbeck, people are joining jenkinsci for hosting plugins, they doesn't accept any rules, it bad to enforce rules after they did a real work
18:38:31 <KostyaSha> central build system may enforce rules in obvious way and btw help doing releases
18:38:40 <orrc> danielbeck: can you #info or #action that, please -- unless anybody doesn't like June 1st?
18:41:01 <danielbeck> KostyaSha It's a trivial change to the plugin metadata, provided in the form of a PR. Just needs to be merged within a few months and a release created, and you're done. The benefits outweigh the drawbacks a lot.
18:41:38 <KostyaSha> danielbeck, you shifting your cool idea to headache of 1k plugin developers
18:42:02 <KostyaSha> danielbeck, because any plugin may hit missed urls (like me with docker)
18:42:06 <danielbeck> KostyaSha It affects about 50, because 95% are doing it right already
18:42:25 <danielbeck> KostyaSha That's why there's an exceptions list and grace period. We're not aiming to depublish.
18:42:43 <KostyaSha> danielbeck, after you merge your change there will be no exceptions
18:43:17 <danielbeck> KostyaSha "All current plugin releases which do have a wiki page, but do not list the URL in the POM have been grandfathered in via #14."
18:44:43 <KostyaSha> danielbeck, so no any released plugins will disappear?
18:44:56 <KostyaSha> released in any time, before your changes and after
18:45:53 <danielbeck> KostyaSha The plan is that in a few months we will review the exceptions list and remove plugins that have no reason to not have a wiki page and <url> pointing to it.
18:46:03 <danielbeck> for now, no plugins will disappear
18:46:20 <danielbeck> Some plugins will get a new wiki link to a page that basically says "This plugin has no wiki page"
18:46:28 <KostyaSha> i don't like part "we will review and remove"
18:47:55 <danielbeck> KostyaSha Again, there's a several months grace period, and we allow for exceptions due to technical reasons (like you mentioned for Docker IIRC).
18:48:17 <KostyaSha> danielbeck, why you (not plugin developers) enforcing your rules to this plugins?
18:48:59 <KostyaSha> again, nobody from joined to jenkinsci developers accepted any rules for publishing plugins
18:49:24 <KostyaSha> "i want host plugin" Ulli: "you are welcome"
18:49:25 <batmat> KostyaSha: chiming in, didn't get your last two sentences
18:49:44 <batmat> three
18:50:36 <danielbeck> To clarify, you want us to add terms of service with a checkbox that needs to be clicked?
18:50:56 <KostyaSha> danielbeck, at least if you want filter out plugin publishing by any rules
18:51:26 <KostyaSha> i'm against hidden magic
18:51:43 <batmat> KostyaSha: well, IMO the Jenkins infra isn't something granted forever, I don't how respecting some rules could hurt
18:52:03 <batmat> don't *see
18:52:29 <danielbeck> KostyaSha It's documented, has been announced on the dev list, the output of the UC generator has been improved, many plugins got PRs... how is this hidden magic?
18:52:35 <batmat> KostyaSha: https://wiki.jenkins-ci.org/display/JENKINS/Hosting+Plugins#HostingPlugins-CreatingaWikipage
18:53:01 <batmat> +1 danielbeck like discussed last time, this was always required when asking for hosting.
18:53:17 <KostyaSha> batmat, i may fix url, but in case of docker url was missed by technical reason. And in my place can be any person. I found this issue only after release and i don't want "kill" my brain with debugging why it not appeared in UC
18:53:32 <batmat> That's just the forking process was somehow too kind sometimes.
18:54:18 <batmat> KostyaSha: the technical reasons you expressed about being unable to release multimodules with Maven, I suppose
18:54:33 <KostyaSha> https://wiki.jenkins-ci.org/pages/diffpages.action?originalId=79495453&pageId=79495455
18:54:57 <batmat> And I suppose also some committers fork their own new plugins by themselves, which I think shouldn't be done (to get at least peer review)
18:55:37 <danielbeck> KostyaSha https://wiki.jenkins-ci.org/display/JENKINS/Hosting+Plugins#HostingPlugins-Help\!Mypluginisnotshowingupintheupdatecenter. Step 5 links to the generator, and it'll include output that explicitly says https://github.com/jenkinsci/backend-update-center2/pull/20/files#diff-dc0efec0ef96602ff821f97fbdd82fc3R278
18:56:00 <danielbeck> So it's not like we're trying to hide things
18:56:02 <KostyaSha> danielbeck, i think you know how many questions UC is causing
18:56:26 <danielbeck> We're trying to improve the situation for users without a lot of friction for the developers.
18:56:45 <KostyaSha> instead of providing possibility of doing easy release through some central build system with signing you adding rules
18:56:45 <batmat> KostyaSha: https://wiki.jenkins-ci.org/pages/viewpage.action?pageId=53609042#HostingPlugins-AddingaWikipage
18:57:04 <batmat> I you mean this is new, that version is from 2011
18:57:16 <batmat> And I didn't even check it may be even older
18:57:18 <danielbeck> KostyaSha We don't have a central build system, and given our resource limitations it's unlikely to show up any time soon.
18:57:32 <danielbeck> Once we have we can always change our approach to this.
18:57:48 <KostyaSha> batmat, looking
18:57:55 <danielbeck> But I'd rather go for "good enough" now instead "perfect" years from now
18:58:58 <danielbeck> So I suggest we implement this on Monday as discussed last week.
18:59:04 <KostyaSha> batmat, ok it exists
18:59:06 <danielbeck> any opinions on that? y/n?
18:59:27 <KostyaSha> danielbeck, then i will prefer to have automatic issue creation and not filtering
18:59:38 <danielbeck> correction, as discussed last time
19:00:02 <batmat> then nothing will ever happen for the really problematic ones
19:01:06 <danielbeck> orrc Do you have time on Monday to react to any possible issues?
19:01:52 <orrc> danielbeck: yeah. though having repo access would be good; the UC is one of those repos not in a team
19:02:28 <KostyaSha> batmat, my idea is simplifying and helping developers to do releases instead of enforcements in current ancient processes
19:02:54 <danielbeck> orrc I expect to be available on Monday anyway so would be able to fix anything that comes up
19:03:24 <batmat> well, the process is currently dead simple IMO, and has always been. How can add a simple tag in a pom.xml and re-release be an issue?
19:03:42 <batmat> I don't get it. That seems to me a reasonable requirement for users
19:03:53 <KostyaSha> batmat, maven-release plugin failed for everybody
19:04:21 <oleg-nenashev> jenkins-admin: Create docker-workflow-plugin in the bug database for jglick
19:04:21 <jenkins-admin> Adding a new subcomponent docker-workflow-plugin to the bug tracker, owned by jglick
19:04:22 <jenkins-admin> New component created
19:04:40 <KostyaSha> batmat, and many other issues, building plugins on developers PCs is also from dinosaur times
19:05:06 <oleg-nenashev> jenkins-admin: Create docker-traceability-plugin in the bug database for oleg_nenashev
19:05:06 <jenkins-admin> Adding a new subcomponent docker-traceability-plugin to the bug tracker, owned by oleg_nenashev
19:05:07 <jenkins-admin> New component created
19:05:28 <KostyaSha> docker docker docker docker docker for CloudBees CloudBees CloudBees CloudBees
19:05:41 <danielbeck> I'd like to get some more opinions on whether to implement this change on Monday. oleg-nenashev jglick batmat orrc ?
19:05:46 <danielbeck> ogondza?
19:05:46 <orrc> +1
19:06:55 <oleg-nenashev> danielbeck: +1
19:07:08 <jglick> Sorry, was not paying attention I am afraid.
19:08:15 <jglick> But if you are proposing to require <url>…wiki…</url> then yes +1
19:08:34 <danielbeck> jglick requiring Jenkins Wiki <url>s for future plugin releases. orrc prepared it in https://github.com/jenkinsci/backend-update-center2/pulls/20 and we were discussing whether to merge this on Monday
19:08:40 <danielbeck> so yeah basically that
19:09:46 <jglick> https://github.com/jenkinsci/backend-update-center2/pull/20 you mean
19:09:58 <KostyaSha> Could say me any project that blocks releases when wiki/homepage is wrong?
19:10:05 <KostyaSha> *Could you
19:10:19 <ogondza> +1 from me too
19:10:37 <KostyaSha> ogondza, does rhel or redhat declining rpms with bad urls?
19:11:09 <jglick> Definitely Ubuntu has strict criteria for packages.
19:11:39 <jglick> If a maintainer cannot be bothered to have proper metadata for the package, then it is rejected.
19:11:41 <ogondza> KostyaSha: I would say fedora has some packaging guidelines, not sure how they are enforced
19:11:42 <KostyaSha> jglick, right, but do you have any real example when their package was not released because of url?
19:11:48 <ogondza> not applicable for RHEL
19:11:54 <KostyaSha> ogondza, i know guidelines of different distros
19:12:27 <ogondza> KostyaSha: sonatype rejects maven releases when they do not follow guidelines
19:12:29 <KostyaSha> jglick, nobody checks/blocks because of urls
19:12:52 <ogondza> KostyaSha: not to attach sources or javadoc .jar and deploy fails
19:12:53 <jglick> Only an UC admin would know of such examples. And yes Maven Central does reject artifacts that do not meet specific POM criteria.
19:12:56 <KostyaSha> ogondza, cool, can artifact be rejected during uploading to jenkins repo?
19:13:12 <KostyaSha> so i will know that it wouldn't be hosted? RIGHT WHEN I DO RELEASE
19:13:19 <jglick> I do not think we have time to implement a custom Artifactory rule, though it would be nice.
19:13:25 <danielbeck> KostyaSha Actually Artifactory supports this I think. Not sure about hosted Artifactory.
19:13:43 <danielbeck> KostyaSha Great idea, I'll try to look into it
19:13:58 <ogondza> KostyaSha: that would be more elegant
19:14:12 <KostyaSha> ogondza, danielbeck this will be more obvious for developer
19:14:39 <KostyaSha> and it will be possible to understand and not after waiting 1day and debugging jenkins jobs
19:14:41 <danielbeck> KostyaSha I like that. But I still think we should go ahead as discussed previously
19:14:55 <jglick> Agreed, +1 on proceeding as planned.
19:14:58 <danielbeck> #action orrc and danielbeck to implement Wiki <url> requirement on Monday June 1
19:15:03 <danielbeck> per majority vote
19:15:18 <KostyaSha> 5 guys voted for 1k plugins, ok
19:16:18 <danielbeck> #topic Can we start to look at fixing the single points of failure?
19:16:34 <danielbeck> orrc We need kohsuke for this one I guess?
19:16:38 <KostyaSha> i think answer - yes, you can :)
19:16:49 <orrc> danielbeck: right
19:17:15 <KostyaSha> we need clone kohsuke :)
19:17:33 <nanonyme> Oh, I assumed this was a software problem, not a human problem :)
19:18:21 <danielbeck> INFRA-75
19:18:23 <jenkins-admin> INFRA-75:Clarify where backend-crawler is running (Open) https://issues.jenkins-ci.org/browse/INFRA-75
19:18:25 <danielbeck> INFRA-225
19:18:27 <jenkins-admin> INFRA-225:Appears backend crawler hasn't run since Oct 2014 (Reopened) https://issues.jenkins-ci.org/browse/INFRA-225
19:19:15 <danielbeck> doesn't make a lot of sense to rehash everything discussed about spof before today I think
19:19:32 <KostyaSha> danielbeck, there is SPOF label
19:19:46 <KostyaSha> or just sort kk assigned issues :D
19:20:03 <danielbeck> KostyaSha Linked from the linked issues *cough*
19:20:11 <danielbeck> so, yeah... let's move on
19:20:32 <danielbeck> #topic next meeting
19:21:08 <danielbeck> June 10
19:21:33 <danielbeck> #endmeeting