18:05:09 <kohsuke> #startmeeting
18:05:09 <robobutler> Let the Jenkins meeting commence!
18:05:31 <kohsuke> #charis rtyler hare_brain
18:05:48 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:05:57 <kohsuke> #topic Recap of actions
18:06:11 <KostyaSha> i have question from missed meetings
18:06:18 <kohsuke> ga
18:06:30 <KostyaSha> Build/publisher steps & AbortException handling  https://github.com/jenkinsci/jenkins/pull/1577
18:06:37 <kohsuke> #topic http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-04-01-18.02.html
18:06:44 <kohsuke> oops
18:06:49 <kohsuke> #topic Recap of actions
18:06:51 <kohsuke> #info http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-04-01-18.02.html
18:07:17 <kohsuke> KostyaSha: OK, I'll add it to the end
18:08:04 <kohsuke> #action kohsuke to still write to Christina
18:08:16 <kohsuke> "kohsuke to log #jenkins-infra"
18:08:33 <kohsuke> how did we invite the current logger to this channel?
18:08:52 <kohsuke> echelog
18:09:08 <KostyaSha> try /invite from infra channel
18:09:13 <KostyaSha> maybe it supported...
18:09:30 <kohsuke> oh but echelog isn't here
18:09:31 <KostyaSha> If you wish to have your channel on Freenode logged or have any other inquiries, please mail me at: brian@matzon.dk.
18:09:31 <KostyaSha> If you wish to have your channel on Freenode logged or have any other inquiries, please mail me at: brian@matzon.dk.
18:09:50 <kohsuke> looks like we lost that logger since April 13th
18:10:01 <kohsuke> see http://echelog.com/logs/browse/jenkins/1429048800
18:10:21 <kohsuke> All right, so I really need to write to that address
18:10:24 <KostyaSha> just wrote email to this person :)
18:10:36 <kohsuke> great, thanks KostyaSha
18:10:55 <kohsuke> CC infra@lists.jenkins-ci.org for extra credit
18:11:06 <kohsuke> "danielbeck to ask oleg if he can hack ircbot to do this"
18:11:14 <kohsuke> do what? let me see...
18:11:33 <kohsuke> "we'll run jenkins-admin bot also in #jenkins-infra and restrict destructive commands to people with +v on #jenkins-infra"
18:11:39 <kohsuke> oleg-nenashev: ^^ ?
18:11:41 <oleg-nenashev> I have not received anything from @daniel-beck
18:11:44 <kohsuke> is that something we can ask you to take on?
18:11:47 <KostyaSha> kohsuke, i have some suggestions about bot from missed meeting
18:11:51 <oleg-nenashev> BTW, +1 for it
18:12:01 <kohsuke> KostyaSha: sure,
18:12:10 <KostyaSha> kohsuke, if you fear about logging of bot actions, then infra may have logging server and bot may push to it
18:12:31 <oleg-nenashev> I've made several generalisation improvements in the bot, so we can easily launch it against INFRA
18:12:51 <kohsuke> oleg-nenashev: so the context of that conversation from the last meeting is that ...
18:13:07 <kohsuke> jenkins-admin bot has some commands that are more destructive than others
18:13:12 <kohsuke> (such as renaming components)
18:13:32 <kohsuke> and to do access control on those commands, we wanted jenkins-admin to join #jenkins-infra, and ...
18:13:40 <kohsuke> only allow people with the voice in #jenkins-infra to run those commands
18:13:49 <oleg-nenashev> Ahh, got it
18:13:58 <kohsuke> So not much to do with the INFRA project on JIRA, just to be on the same page.
18:14:14 <kohsuke> KostyaSha: you mean we can run our own IRC logging service?
18:14:31 <oleg-nenashev> The feature can be added to the bot
18:14:39 <KostyaSha> kohsuke, i think just logging server, but then we can push any king of logging to it
18:14:46 <KostyaSha> *kind
18:15:07 <oleg-nenashev> kohsuke: Is there any urgency regarding the feature?
18:15:10 <KostyaSha> infra related commands, just irc and etc...
18:15:17 <Err0> https://botbot.me/ works pretty good
18:15:37 <kohsuke> I think we've been mostly happy with echelog, so my suggestion would be to wait to hear back from them before taking it onto ourselves
18:15:46 <Err0> example: https://botbot.me/freenode/chef/
18:15:53 <kohsuke> I'm trying to offload services to others, and focus on smaller number of things.
18:16:24 <KostyaSha> kohsuke, searching in echangelog is bad
18:17:04 <kohsuke> Err0: KostyaSha: but if you guys want to come up with a Docker container that packs the bot, I can get that deployed
18:17:27 <kohsuke> botbot.me does look more beautiful than echelog, I agree
18:17:56 <kohsuke> oh we could just request our channel be logged from botbot.em
18:18:22 <KostyaSha> https://github.com/BotBotMe
18:18:43 <KostyaSha> kohsuke, we can log in to bots ;)
18:18:51 <KostyaSha> in both
18:19:06 <KostyaSha> more bots against humans :)
18:19:22 <kohsuke> all right, so I'll submit requests to botbot.me
18:19:32 <kohsuke> and KostyaSha will hopefully get echelog back for us
18:19:40 <kohsuke> And if we have two log bots, well, more the merrier.
18:19:49 <KostyaSha> ok, because i used wrong grammar tense in my sentence :)
18:20:03 <Err0> here is the docker container: https://registry.hub.docker.com/u/gwadeloop/botbotbot/
18:20:07 <kohsuke> Moving on to next action...
18:20:17 <kohsuke> Kamran to look into adding MEETING issue creation to robobutler
18:20:58 <kohsuke> then "danielbeck to ask for ideas on improving the documentation on the dev list"
18:21:03 <kohsuke> I guess danielbeck isn't here today
18:21:41 <kohsuke> ndeloof to do the move [of Jenkins docker repo from cloudbees to jenkinsci]
18:21:46 <kohsuke> Let me see, is it still there?
18:22:07 <kohsuke> Yup, it's still there: https://github.com/cloudbees/jenkins-ci.org-docker
18:22:21 <KostyaSha> kohsuke, documentation for docker<->jenkinsci interaction will be appreciated
18:22:40 <KostyaSha> in case ndeloof dissappear so at least we will know what to do and how it works
18:22:40 <kohsuke> Let me ask this repository be transferred to jenkinsci
18:24:10 <kohsuke> We can just fork it, but if I'm lucky this gets done in 5 mins.
18:24:30 <kohsuke> moving on to the next action...
18:24:37 <kohsuke> "danielbeck to figure out how to get rid of clone in Jira" but he isn't here
18:24:42 <kohsuke> kohsuke to disable mirror.bit.edu.cn
18:25:23 <kohsuke> ha, since then this mirror came back into action: http://mirrors.jenkins-ci.org/status.html
18:25:57 <kohsuke> Do we still want to kill it?
18:26:01 <KostyaSha> my eyes...
18:26:10 <KostyaSha> like 90'
18:26:14 <arminius> hah. successfully using a bunch of jenkins jobs just for VM provisioning with libvirt/qemu/kvm, including automatic integration into the VPN and assignment of IP, and assignment of a DNS name, all via seperate jenkins jobs triggering around.
18:26:42 <arminius> it's quite useful.
18:26:49 <KostyaSha> arminius, sorry meeting is going on this channel, try ask your question after meeting
18:27:15 <kohsuke> I'm going to punt on this until danielbeck comes back
18:27:26 <kohsuke> Maybe they saw this and fixed something on their side
18:27:31 <arminius> oh my apologies, didn't want to disturb anything ongoing. sorry.
18:28:07 <kohsuke> #action danielbeck to reconfirm if we should still remove mirror.bit.edu.cn given that it appears to be functioning again
18:28:16 <jenkins-builds> Project jenkins_main_trunk build #4086: FAILURE in 3 hr 0 min: http://ci.jenkins-ci.org/job/jenkins_main_trunk/4086/
18:28:16 <jenkins-builds> * Stephen Connolly: [FIXED JENKINS-27708][FIXED JENKINS-27871]  Ensure that identification of blocked tasks is using the live state.
18:28:17 <jenkins-builds> * o.v.nenashev: [JENKINS-27871] - Added a direct unit test for the issue
18:28:19 <jenkins-admin> JENKINS-27708:Concurrent build limits not honored on Jenkins 1.607 (Open) https://issues.jenkins-ci.org/browse/JENKINS-27708
18:28:21 <jenkins-admin> JENKINS-27871:Block on upstream projects does not work (Open) https://issues.jenkins-ci.org/browse/JENKINS-27871
18:28:37 <kohsuke> All right, so that's the recap
18:28:44 <kohsuke> #topic Migrate Jenkins-on-Jenkins jobs onto jenkins.ci.cloudbees.com
18:28:51 <kohsuke> rtyler: ping
18:28:54 <kohsuke> but he's away
18:29:05 <KostyaSha> Why jenkins should be hosted under CB?
18:29:31 <KostyaSha> what we will do if cloudbees.com will be blocked?
18:29:34 <kohsuke> The context is that we feel we are taking on too many services on our own than we can handle with our resources
18:29:59 <oleg-nenashev> it would reduce infra support efforts in general
18:30:10 <kohsuke> So we offload services to other SaaS where we can.
18:30:28 <kohsuke> IRC logger being one, datadog is another, MySQL is yet another.
18:31:13 <kohsuke> KostyaSha: I'm sensitive that some people are concerned with us the project relying more on CB infra
18:31:51 <kohsuke> But in many ways it's really no different from us getting database hosting from OSUOSL for Wiki&JIRA
18:31:52 <KostyaSha> kohsuke, then only CB will be able to support/count resources/etc
18:31:58 <kohsuke> Oh no
18:32:08 <kohsuke> This is a part of FOSS hosting of Jenkins
18:32:20 <rtyler> i'm here is
18:32:21 <rtyler> ish*
18:32:31 <KostyaSha> so why domain need to be changed then?
18:32:45 <kohsuke> People will have to create accounts but people can have access
18:33:03 <oleg-nenashev> A significant infra part is being already hosted on CB infra (PR builders, etc.)
18:33:27 <KostyaSha> oleg-nenashev, and only CB can fix pr builder, right?
18:33:37 <KostyaSha> that constantly disappears
18:33:55 <oleg-nenashev> Actually, it's a topic for discussion
18:34:18 <rtyler> the primary problem is that we're underinvesting in terms of time to manage Jenkins ourselves
18:34:27 <kohsuke> It's true that jenkins.ci.cloudbees.com uses some additional proprietary plugins
18:34:30 <KostyaSha> well, i expect to have jenkins infra on jenkins domain and some note that it sponsored by CloudBees
18:35:13 <KostyaSha> kohsuke, what plugins? can i replace PR builder with my FOSS variant if i will support hooks?
18:35:51 <kohsuke> KostyaSha: yeah, I think that's fine
18:36:01 <KostyaSha> having parts of jenkins infra on different domains is not obvious for users imho
18:36:10 <rtyler> that's easy to fix with cnames KostyaSha
18:36:29 <kohsuke> Logistically I'm not sure if it's that easy rtyler
18:36:40 <rtyler> I'm most interested in problems we might experience in terms of maintainership and ownership of jenkins if it's on enterprise jenkins
18:36:58 <KostyaSha> rtyler, https://issues.jenkins-ci.org/browse/INFRA-185
18:37:01 <jenkins-admin> INFRA-185:disable old buildhive.cloudbees.com/job/jenkinsci PR builder (Reopened) https://issues.jenkins-ci.org/browse/INFRA-185
18:37:22 <rtyler> buildhive is not the same as enterprise jenkins
18:37:23 <KostyaSha> Created:	22/Oct/14 11:57 PM
18:37:46 <rtyler> kohsuke: is it possible to use our LDAP with enterprise jenkins, are we already doing that? I can't remember
18:37:50 <kohsuke> We can disable those plugins if people feel use of that would act as a trap
18:38:18 <kohsuke> No, I don't think it's possible to use LDAP
18:38:41 <kohsuke> But SAML I believe we support, so maybe there's a way to make it work
18:38:55 <oleg-nenashev> rtyler: It should not be a blocker IMO. There're very few people accessing the infra CI
18:39:39 <rtyler> right
18:39:59 <rtyler> I want to make sure that we're providing the best service possible, and I think a sponsored host from CB will be the best means to approach it
18:40:10 <rtyler> I think sharing auth is a requirement
18:40:22 <rtyler> the FOSS plugins being used is probably just a good idea
18:41:19 <KostyaSha> kohsuke, rtyler can the whole existed server can be migrated to CB infra without migrating just only jobs?
18:41:26 <kohsuke> Let me talk to the team to see if LDAP can be used through SAML
18:41:35 <KostyaSha> if this server uses proprietary plugins, then it will be separate question
18:42:14 <kohsuke> KostyaSha: we'll have to copy jobs and tweak them, no problem.
18:42:43 <KostyaSha> what will be run on this server other?
18:42:58 <kohsuke> ?
18:43:04 <KostyaSha> if jenkins decided to broke this server, will it affect CB?
18:43:16 <kohsuke> #action kohsuke to check the feasibility of using ldap.jenkins-ci.org with jenkins.ci.cloudbees.com
18:43:36 <kohsuke> I'm still not sure if I understand your question, KostyaSha
18:44:16 <oleg-nenashev> kohsuke: There may be dependencies on local resources, etc. The migration to an external CI provider will take much time, but IMO it's a right way. DEV@Cloud is much more preferable than Travis CI :)
18:44:54 <kohsuke> Yes, we need to run a slave on cucumber to be able to continue running some infra tasks
18:45:39 <KostyaSha> what CB provides then? Existed jenkins and not just a VM?
18:46:11 <kohsuke> A monitored & patched Jenkins instance
18:46:27 <KostyaSha> SaaS
18:46:29 <kohsuke> patched as in "properly upgraded"
18:46:47 <KostyaSha> so jenkins is project wouldn't use it's own jenkins
18:46:49 <KostyaSha> *as
18:47:26 <kohsuke> We will use Jenkins but we won't try to keep it up & running ourselves, yes.
18:48:22 <KostyaSha> Will be able to run jenkins infra if users donate enough money?
18:48:26 <KostyaSha> *will we
18:48:40 <hare_brain> It’s not just about money. It’s about people’s time.
18:48:51 <KostyaSha> I have no idea how 8 servers can ate much money
18:49:35 <rtyler> we don't need money
18:49:39 <rtyler> for this anyways
18:49:52 <hare_brain> “rtyler: the primary problem is that we're underinvesting in terms of time to manage Jenkins ourselves
18:49:52 <hare_brain> [11:34am]”
18:49:53 <rtyler> kohsuke: is Enterprise Jenkins on LTS?
18:50:14 <kohsuke> This is basically LTS + some plugins
18:50:31 <rtyler> is it kept up to date with LTS?
18:50:44 <KostyaSha> hare_brain, maillist get enough replies of persons that want help with infra
18:50:44 <kohsuke> Generally, yes
18:50:58 <publiccert> Is there a way to get the output from the console and parse it then trigger an action based on the output?
18:51:21 <kohsuke> I think overall I'm hearing the support for this move
18:51:34 <KostyaSha> no way
18:51:42 <kohsuke> KostyaSha: what is your concern?
18:52:10 <KostyaSha> kohsuke, provide full state of jenkins infra for discussion, how many servers, how many services, what need to be supported
18:52:21 <rtyler> that's not what we're discussing here
18:52:46 <KostyaSha> we are discussing migration because current support people have no time and new persons not added
18:53:19 <KostyaSha> so yes, easy migrate jenkins somewhere else
18:54:08 <kohsuke> Adding more people to infra / creating structure to make part-timer volunteers more effective in infra is something we are doing, but I think that's not mutually exclusive from reducing the burden we take on?
18:55:01 <kohsuke> So that's why I'm asking if you have concerns in offloading J-on-J to jenkins.ci.cloudbees.com
18:55:14 <KostyaSha> Imho using latest jenkins LTS for J-o-J is good for jenkins as project - more testing, prove that it can works
18:55:37 <KostyaSha> allow -rc testing for ogondza for example
18:55:49 <rtyler> I disagree strongly with that actually
18:55:54 <rtyler> dog fooding is definitely great
18:55:58 <rtyler> that I don't disagree with
18:56:19 <rtyler> but affecting plugin developers, for example, by basically beta-testing on our core infrastructure, is pretty risky
18:56:35 <ogondza> rtyler: even lts rc?
18:56:35 <KostyaSha> rtyler, have you asked them?
18:56:39 <rtyler> and is not an acceptable substitution IMO for actual test automation and things like that
18:57:06 <KostyaSha> rtyler, i'm jenkins dev and i will be glad to have better tested LTS, i think all maintainers understand that it has benefits
18:57:08 <rtyler> KostyaSha: I hear about it every time update center generation slows or fails due to J-on-J instability
18:57:35 <rtyler> KostyaSha: I'm not saying we shouldn't be dogfodding or testing, I'm saying that running our core project operations on pre-release software is inherently risky
18:57:36 <sfisque> from an enterprise standpoint your build env should be STABLE, not bleeding edge.  but that's my 2c worth
18:57:53 <rtyler> running LTS RCs however, is something I can be convinced of
18:57:57 <KostyaSha> sfisque, LTS != dev version
18:58:15 <KostyaSha> if LTS can't be stable with jenkins dev tasks, then it can't be stable for users
18:58:19 <oleg-nenashev> Mission-critical infrastructure should be launched on the most stable release even if it's a patched version from CB
18:59:13 <ogondza> anyway, I thing we are off topic here. +1 on simplifying infra
18:59:14 <KostyaSha> oleg-nenashev, then it a shame for project ;)
18:59:26 <rtyler> there's an assumption under here that I don't like, which is that by the mere fact taht we're running a pre-release version, we're somehow going to spot bugs before they affect users
18:59:51 <KostyaSha> rtyler, i think you don't know what is LTS, what kind of quality it have
19:00:07 <oleg-nenashev> We could leave J-o-J  as a playground with stubbed versions of all jobs we use
19:00:31 <kohsuke> The other parts of this is to relieve cucumber which is very congested
19:00:48 <rtyler> ogondza: it sounds like there's a supplemental requirement here for an integration test environment
19:01:07 <kohsuke> so if we want to run Jenkins instance for dogfooding, we want it elsewhere.
19:01:55 <ogondza> We have very little people reporting back during the lts rc period
19:01:56 <rtyler> I suggest we run jenkins.ci.cloudbees.com for our primary CI, but we start to flesh out as well a better dogfooding and integration testing/staging environment for core
19:02:09 <ogondza> giving them a playground could help
19:02:38 <KostyaSha> i remember rtyler words that he hates jvm based tools, i saw 0 commits in jenkins code, i don't want to swear
19:02:42 <kohsuke> rtyler: +1, and I assume you still want to find out if our LDAP can be used over there, right?
19:02:52 <rtyler> yes
19:02:52 <KostyaSha> so +1 for migration, no way
19:03:02 <KostyaSha> do what you can and want
19:03:10 <kohsuke> KostyaSha: there are many ways to contribute to the project, a commit count is just one of them.
19:03:28 <rtyler> #action rtyler to write out some ideas on managing and providing a staging Jenkins infrastructure for developers
19:03:33 <kohsuke> I need you to pay respect that a long time contributor like rtyler deserves
19:03:49 * rtyler shrugs
19:03:51 <kohsuke> I'm sorry, but I really need to go
19:03:52 <rtyler> I'm not offended
19:04:00 <rtyler> do we have other topics to discuss?
19:04:03 <kohsuke> I am offended
19:04:12 <kohsuke> Yes, we have other topics
19:04:19 <rtyler> #action kohsuke to figure out what job migration from J-on-J looks like
19:04:40 <rtyler> the security bounties?
19:04:48 <kohsuke> That and another agenda from KostyaSha
19:05:12 <rtyler> what's KostyaSha's item?
19:05:16 * rtyler is looking at the wiki
19:05:23 <KostyaSha> rtyler, from previous meeting
19:05:26 <rtyler> ah
19:05:28 <kohsuke> Some technical question
19:05:39 <kohsuke> Can we do that in the office hours next week, KostyaSha ?
19:05:44 <kohsuke> I think it's a better avenue to do that
19:05:44 <KostyaSha> but danielbeck added additional item to my question :)
19:06:09 <KostyaSha> kohsuke, can i just ask you to look on PR and open issue? Probably you can comment in any free time?
19:06:27 <kohsuke> Do you guys want to leave the meeting open or should I end it and push the rest to the next time?
19:06:38 <KostyaSha> kohsuke, as you wish
19:06:45 <KostyaSha> if you need go, then let's end
19:06:58 <kohsuke> Let's do it next time. The next topic is from danielbeck and he isn't here.
19:07:04 <kohsuke> #topic next meeting
19:07:21 <kohsuke> #info the next meeting is 4/29
19:07:27 <kohsuke> the same time as always
19:07:29 <kohsuke> #endmeeting