#jenkins Meeting

Meeting started by kohsuke at 18:02:31 UTC (full logs).

Meeting summary

    1. https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda (kohsuke, 18:02:38)

  1. recap of actions (kohsuke, 18:02:47)
    1. https://issues.jenkins-ci.org/browse/MEETING (kohsuke, 18:03:04)
    2. ACTION: kohsuke to write to christina (kohsuke, 18:04:50)

  2. JUC 2015 - obtain approval for a Mobile Morning mini-track that focus on Jenkins mobile development (Alyssa) (kohsuke, 18:05:45)
  3. Build/publisher steps & AbortException handling (kohsuke, 18:10:51)
  4. Defining guidelines on expected behavior and/or structure for plugins? If so, should we enforce them? (kohsuke, 18:11:40)
  5. Would changing the meeting time to 10 AM PST/PDT allow overruns? (kohsuke, 18:12:43)
    1. AGREED: if oleg, kostyasha or anyone else really want to change the time, we'll reconsider, but for now we keep the time as is. (kohsuke, 18:17:16)

  6. Who gets voice on IRC? "Committers"... to any plugin? To core? (kohsuke, 18:17:25)
    1. ACTION: kohsuke to log #jenkins-infra (kohsuke, 18:26:13)
    2. AGREED: we'll run jenkins-admin bot also in #jenkins-infra and restrict destructive commands to people with +v on #jenkins-infra (kohsuke, 18:27:59)
    3. ACTION: danielbeck to ask oleg if he can hack ircbot to do this (kohsuke, 18:28:13)

  7. JENKINS-27268 (kohsuke, 18:28:50)
    1. http://en.wikipedia.org/wiki/Master/slave_%28technology%29 generally (jglick, 18:45:26)

  8. Bug bounties/rewards for security issues (kohsuke, 18:55:35)
    1. http://blog.cloudbees.com/2015/01/breakingbuilds-twitter-contest-results.html (danielbeck, 19:00:04)
    2. https://www.shapeways.com/product/NZAN5AGUS/mr-jenkins-v2 (kohsuke, 19:01:20)
    3. AGREED: non-cash gifts to be provided to reporters of SECURITY issues if and when the issue is accepted as a vulnerability (not merely security hardening) and a fix published. Maximum one gift per reporter and Jenkins committers are excluded. (jglick, 19:09:46)

  9. Resurrecting the MEETING Jira project (maybe even have the bot create issues for action items automatically) (danielbeck, 19:11:45)
    1. https://issues.jenkins-ci.org/browse/MEETING (danielbeck, 19:13:21)
    2. https://issues.jenkins-ci.org/browse/MEETING (jglick, 19:13:46)
    3. ACTION: Kamran to look into adding MEETING issue creation to robobutler (danielbeck, 19:23:00)

  10. The important content of the Wiki is difficult to find (between outdated or even empty pages), and there's no real introduction to Jenkins – What can we do about it? (danielbeck, 19:23:29)
    1. https://wiki.jenkins-ci.org/display/JENKINS/Meet+Jenkins (danielbeck, 19:24:59)
    2. ACTION: danielbeck to ask for ideas on improving the documentation on the dev list (danielbeck, 19:38:33)

  11. Proposal: move Jenkins official image repo to jenkinsci org so enhancement / version updates can be managed by the community (danielbeck, 19:39:09)
    1. https://github.com/cloudbees/jenkins-ci.org-docker (jglick, 19:40:55)
    2. https://github.com/jenkins-infra (jglick, 19:43:04)
    3. https://registry.hub.docker.com/_/jenkins/ (jglick, 19:47:28)
    4. https://registry.hub.docker.com/search?q=library&f=official (jglick, 19:47:56)
    5. AGREED: move Jenkins docker repo from @cloudbees into @jenkinsci, rename to jenkins-docker-container (danielbeck, 19:53:30)
    6. ACTION: ndeloof to do the move (jglick, 19:53:53)

  12. Disabling "Clone" feature in JIRA (danielbeck, 19:54:16)
    1. AGREED: Remove/disable clone action in Jira (danielbeck, 19:59:05)
    2. ACTION: danielbeck to figure out how to get rid of clone in Jira (danielbeck, 19:59:38)

  13. The Chinese mirror is a mess (danielbeck, 19:59:49)
    1. http://mirrors.jenkins-ci.org/status.html (danielbeck, 19:59:58)
    2. ACTION: kohsuke to disable mirror.bit.edu.cn (kohsuke, 20:08:13)
    3. ACTION: somebody needs to file INFRA ticket to puppetize mirrobrain (kohsuke, 20:08:44)

  14. next meeting (kohsuke, 20:12:56)


Meeting ended at 20:13:22 UTC (full logs).

Action items

  1. kohsuke to write to christina
  2. kohsuke to log #jenkins-infra
  3. danielbeck to ask oleg if he can hack ircbot to do this
  4. Kamran to look into adding MEETING issue creation to robobutler
  5. danielbeck to ask for ideas on improving the documentation on the dev list
  6. ndeloof to do the move
  7. danielbeck to figure out how to get rid of clone in Jira
  8. kohsuke to disable mirror.bit.edu.cn
  9. somebody needs to file INFRA ticket to puppetize mirrobrain


Action items, by person

  1. danielbeck
    1. danielbeck to ask oleg if he can hack ircbot to do this
    2. danielbeck to ask for ideas on improving the documentation on the dev list
    3. danielbeck to figure out how to get rid of clone in Jira
  2. Kamran
    1. Kamran to look into adding MEETING issue creation to robobutler
  3. kohsuke
    1. kohsuke to write to christina
    2. kohsuke to log #jenkins-infra
    3. kohsuke to disable mirror.bit.edu.cn
  4. robobutler
    1. Kamran to look into adding MEETING issue creation to robobutler
  5. UNASSIGNED
    1. ndeloof to do the move
    2. somebody needs to file INFRA ticket to puppetize mirrobrain


People present (lines said)

  1. danielbeck (156)
  2. kohsuke (144)
  3. Kamran (111)
  4. jglick (50)
  5. rtyler (15)
  6. orrc_ (13)
  7. jenkins-admin (10)
  8. ogondza (10)
  9. hare_brain (6)
  10. aheritier (5)
  11. arminius (4)
  12. schristou (3)
  13. robobutler (3)
  14. jenkins-builds (3)
  15. bookwar (2)
  16. batmat (2)
  17. jieryn (1)
  18. sjmikem (1)
  19. microm (1)


Generated by MeetBot 0.1.4.