19:13:51 <kohsuke_> #startmeeting
19:13:51 <robobutler> Let the Jenkins meeting commence!
19:13:59 <kohsuke_> #chairs hare_brain
19:14:03 <kohsuke_> #chair hare_brain
19:14:03 <robobutler> Current chairs: hare_brain kohsuke_
19:14:33 <kohsuke_> #topic 1.580.2 RC status check
19:14:48 <ogondza> kohsuke_: we are ready fro rc
19:14:54 <ogondza> for*
19:15:26 <kohsuke_> My calendar presumably incorrectly shows that today is a release date, but it's actually an RC date?
19:15:41 <ogondza> IMHO the RC was not published
19:15:48 <kohsuke_> Right
19:15:49 <ogondza> or way it?
19:15:55 <kohsuke_> My apologies
19:16:06 <ogondza> np, we have to postpone by 2 weeks
19:16:40 <kohsuke_> Moved the dates on the calendar
19:17:04 <kohsuke_> I will produce RC today after this call
19:17:16 <kohsuke_> #topic Mark usage request from CloudBees
19:18:15 <kohsuke_> I don't think I succeeded in attracing more comments in the dev list
19:18:46 <kohsuke_> But I think we've done all we can
19:19:07 <autojack> nod. silence implies consent?
19:19:12 <autojack> sort of?
19:19:37 <hare_brain> It seems like the few extra responses we got showed some concern about confusion as well.
19:19:43 <danielbeck> where was the thread again?
19:19:58 <autojack> I think I was the only one who replied after the previous meeting discussion.
19:20:18 <oleg-nenashev> https://groups.google.com/forum/#!topic/jenkinsci-dev/rzNetnrhPRI
19:20:35 <autojack> oops, me and Jan.
19:22:36 <kohsuke_> autojack: you suggested perhaps we should consider CloudBees Enterprise Jenkins, I didn't follow up with it because it wouldn't work with JOC and Analytics
19:23:19 <KostyaSha> what if somebody else create JOC?
19:23:31 <KostyaSha> for example oss version by jenkins contributors
19:24:38 <kohsuke_> When I say it doesn't work with Jenkins Operations Center, I meant I cannot swap the word order in the same way he did "CloudBees Jenkins Enterprise" to "CloudBees Enterprise Jenkins"
19:24:47 <autojack> what's JOC?
19:24:51 <autojack> ah.
19:24:55 <danielbeck> Cloudbees Operation Center Jenkins :-)
19:24:56 <kohsuke_> "CloudBees Operations Center Jenkins" doesn't make sense
19:24:56 <KostyaSha> Jenkins Operation Center
19:25:09 <KostyaSha> for solves questions :)
19:25:11 <autojack> got it.
19:25:25 <autojack> ok, noted.
19:25:45 <KostyaSha> Should FOSS version that be called like MMJ? master-master jenkins :D
19:25:51 <KostyaSha> s/that/then/
19:26:47 <autojack> I sense that this discussion could go down a rat-hole about approved names, new suggestions, etc.
19:26:51 <danielbeck> KostyaSha I think we should focus on the actual topic
19:27:29 <kohsuke_> I still feel like there's a confusion about the nature of confusion in question --- the question at hand is about creating the confusion about the origin of the effort, that is to trick users to think it is genuine community effort instead of a company effort by CloudBees.
19:27:30 <KostyaSha> kohsuke_ i think we can have wiki page where we can track all names with descriptions. So people may at least register names on this page :)
19:27:36 <autojack> when it comes to commercial use of the mark, Marketing people are the ones who will come up with proposed ideas. I don't see myself as a good person to do that, so I probably shouldn't have put forward alternatives.
19:27:59 <autojack> KostyaSha: ick.
19:28:07 <hare_brain> This has gone on for way too long. And I don’t want to keep holding up CloudBee’s ability to move foward with their business. I would like to propose a vote to approve the following:
19:28:36 <kohsuke_> It's not a question of whether the name implies community did more work vs the company did more work --- in that line of reasoning, one can't even rename them completely to avoid the mark usage, which is something anyone can do.
19:28:53 <kohsuke_> Yes, I agree, I think I beat this horse to the death, let's do a round of votes and call that final.
19:29:16 <hare_brain> I propose to approve CloudBees request to use the Jenkins mark for the following usages: CloudBees Jenkins Enterprise, CloudBees Jenkins Operations Center, CloudBees Jenkins Analytics, with the stipulation that:
19:29:56 <hare_brain> - the full names must always be used in CloudBees material, and that it is CloudBees’ responsibility to ensure that 3rd party references to their products go by their full names.
19:30:12 <hare_brain> - the abbreviations CJE, CJOC, and CJA are allowable
19:30:34 <hare_brain> I propose that we do NOT approve Acme Jenkins Foo as a generally acceptable usage.
19:31:51 <hare_brain> Basically, I am proposing special dispensation for CloudBees in recognition of the contributions of its employees to the project.
19:32:10 <danielbeck> hare_brain Looks reasonable, except the 3rd party part. How is that supposed to work?
19:32:10 <autojack> hare_brain: OK. so in future if another party wants to use the same naming convention, the group has to approve it.
19:32:32 <hare_brain> autojack: yes
19:32:35 <autojack> thus hopefully avoiding any egregious misuse.
19:32:39 <oleg-nenashev> The stipulation works for me. It would be also useful to make a mandatory reference to Jenkins OSS project in footnotes of any docs
19:32:42 <hare_brain> danialbeck: I’m basically making it CloudBees’ responsibility. :)
19:32:55 <danielbeck> we're also not approving "CloudBees Jenkins $Product" IIUC.
19:32:59 <kohsuke_> danielbeck: I think the intention is that when we work with 3rd parties, we need to tell those guys that we need that full name be used
19:33:13 <kohsuke_> oleg-nenashev found a number of cases where that wasn't done correctly today
19:33:15 <hare_brain> oleg-nenashev: Brilliant! kohsuke: would that work for CloudBees?
19:33:33 <hare_brain> “Making a mandatory reference to the OSS project”
19:34:29 <hare_brain> danielbeck: Yes, that’s correct. We are not approving CloudBees Jenkins $Product in general today.
19:34:40 <kohsuke_> So I suppose this works like the attribution clause in the MIT license
19:34:58 <kohsuke_> That the due credit be shown where such things generally show up
19:35:26 <oleg-nenashev> kohsuke_: Yes, we can just copy this paragraph from the license
19:36:18 <oleg-nenashev> Hmm, I suppose it wasn't a MIT license
19:36:43 <kohsuke_> I think we'd be very happy to be explicit that this is a derivative work of the Jenkins project
19:36:50 <autojack> I don't know if I get a vote, I'm just some guy... but it sounds good to me.
19:37:40 <kohsuke_> But I hope people understand that these marks often get used in places where no such attribution places to exist, such as in a menu bar, a title, a table drape, a sticker, ...
19:38:44 <kohsuke_> But I'm happy to take whatever I can get. So let's go along with that
19:39:12 <hare_brain> Yes. I don’t want to ask for too much. :)
19:39:56 <autojack> nod
19:40:53 <oleg-nenashev> In the case of  site pages one footnote about Jenkins trademark is definitely enough. Nothing to do with menus
19:41:20 <hare_brain> Or even in the documentation that accompanies the products.
19:41:47 <kohsuke_> Let me capture this in another document for clarity.
19:41:50 <kohsuke_> https://gist.github.com/kohsuke/573cb5620fcc25c9e5c0
19:41:56 <hare_brain> I see a Legal section in a lot of software documentation these days.
19:42:22 <danielbeck> kohsuke_ Looks good
19:42:23 <hare_brain> Typo in the third bullet: “approal"
19:42:33 <hare_brain> But yes. The summary is correct.
19:42:41 <oleg-nenashev> LGTM
19:43:04 <autojack> thumbs up
19:43:21 <hare_brain> Oh. Capture autojack’s other obversation that we are not approval a general usage of CloudBees Jenkins Foo
19:43:21 <ogondza> +1
19:43:22 <kohsuke_> Typo fixed and added website.
19:43:33 <hare_brain> Not approving.
19:43:53 <danielbeck> hare_brain 3rd item
19:44:01 <kohsuke_> Doesn't the 3rd bullet cover that? I'll make it explicit.
19:44:03 <danielbeck> (implied)
19:44:09 <hare_brain> Yes, it’s implied by the third item.
19:44:58 <kohsuke_> Updated to https://gist.github.com/kohsuke/573cb5620fcc25c9e5c0/4adb656ca15cac5707ee8fa1e4dabb56855e31c3
19:45:19 <hare_brain> +1 for https://gist.github.com/kohsuke/573cb5620fcc25c9e5c0/4adb656ca15cac5707ee8fa1e4dabb56855e31c3
19:45:42 <danielbeck> Now that we know what we're voting on, could we get to the actual voting?
19:45:42 <autojack> +1
19:46:01 <hare_brain> +1
19:46:08 <hare_brain> (And I need to drop off for the rest of the meeting)
19:46:09 <oleg-nenashev> +1
19:46:29 <danielbeck> +1
19:47:01 <kohsuke_> #info autojack hare_brain danielbeck oleg-nenashev voted +1 on https://gist.github.com/kohsuke/573cb5620fcc25c9e5c0/4adb656ca15cac5707ee8fa1e4dabb56855e31c3
19:47:22 <kohsuke_> anyone else wants to cast a vote? going once, going twice, ...
19:47:27 <ogondza> +1
19:47:34 <kohsuke_> #action kohsuke_  to get abayer's vote recorded
19:47:54 <kohsuke_> (he was OK with the original proposal to begin with, so I don't expect a problem there)
19:48:10 <kohsuke_> #info ogondza voted +1 and kohsuke_ abstained for conflict of interest
19:48:27 <kohsuke_> #agreed https://gist.github.com/kohsuke/573cb5620fcc25c9e5c0/4adb656ca15cac5707ee8fa1e4dabb56855e31c3 is approved
19:48:34 <oleg-nenashev> Great!
19:48:40 <danielbeck> finally
19:48:43 <kohsuke_> Yay! I have some happy news to bring back to the CB folks
19:48:50 <kohsuke_> Thank you
19:48:54 <autojack> sorry for any part I had in dragging that out.
19:49:12 <kohsuke_> No, it's good thing we spent time on things like this
19:49:20 <kohsuke_> #topic release process improvements
19:49:32 <danielbeck> Let's postpone this.
19:49:39 <oleg-nenashev> Off-topic: We definitely need to register Jenkins  trademark. I have not found it in databases
19:49:56 <kohsuke_> #topic INFRA components
19:50:26 <kohsuke_> oleg-nenashev: apparently software freedom conservancy lawyers are having a problem and still going at it
19:50:31 <kohsuke_> I'll forwward that email
19:50:36 <oleg-nenashev> ty
19:50:53 <kohsuke_> INFRA-169
19:50:56 <jenkins-admin> INFRA-169:Move/Fork INFRA repos from jenkinsci to jenkins-infra org (Open) https://issues.jenkins-ci.org/browse/INFRA-169
19:51:17 <oleg-nenashev> Regarding INFRA.... It makes sense to move the discussion to the mailing list, but nobody reads it :(
19:51:48 <danielbeck> oleg-nenashev Infra list?
19:51:57 <kohsuke_> My bad. I need to fix this
19:51:57 <oleg-nenashev> danielbeck: yep
19:52:32 <oleg-nenashev> BTW, thereis a related topic to INFRA guidelines and owner references
19:52:51 <kohsuke_> Practically what email I see is up to whether Gmail marks it important or not
19:53:02 <kohsuke_> #info I'm happy with INFRA-169
19:53:03 <jenkins-admin> INFRA-169:Move/Fork INFRA repos from jenkinsci to jenkins-infra org (Open) https://issues.jenkins-ci.org/browse/INFRA-169
19:53:28 <kohsuke_> And for the record I think rtyler is also an owner of the jenkinsci org so he has a permission to do it
19:53:48 <bub> Hi, I have a question the dropdownDescriptorSelector. I use it similar to the vsphere plugin. the "base" config.jelly contains a select element, which is used to pick a cloud configuration. in the "child" element I have a select element, which I would like to fill depending on the selected cloud config of the parent... is there a way to access the selected value of the parent?
19:53:58 <danielbeck> bub: Project meeting right now, please wait a few minutes
19:53:58 <kohsuke_> oleg-nenashev: I should just transfer all the repos, and rename "infra-" and "backend-" prefixes, right?
19:54:04 <bub> ok
19:54:34 <oleg-nenashev> Does it make sense to grant permissions to more contributors? rtyler is frequently busy with his work, so it makes sense to have several backups
19:54:38 <KostyaSha> kohsuke_ infra documentation is restricted
19:55:03 <oleg-nenashev> kohsuke_: +1 regarding the renaming. I'm not sure about dependencies BTW
19:55:07 <kohsuke_> oleg-nenashev: I agree, which permission are you talking about?
19:55:29 <kohsuke_> lib-* I will keep in jenkinsci
19:55:33 <KostyaSha> +1 for adding oleg-nenashev permissions for infra
19:56:09 <kohsuke_> #agreed to do INFRA-169
19:56:11 <jenkins-admin> INFRA-169:Move/Fork INFRA repos from jenkinsci to jenkins-infra org (Open) https://issues.jenkins-ci.org/browse/INFRA-169
19:56:13 <oleg-nenashev> kohsuke_: JIRA admin (labels cleanup, working with TEST project, etc), JENKINS_INFRA github and proba bly the access to IRC bot restart procedures
19:56:44 <kohsuke_> #action kohsuke to transfer repos in INFRA-169 except lib-* and remove prefixes
19:56:46 <oleg-nenashev> KostyaSha: I would voste -1, but seems I have no chance to avoid it after the proposal
19:56:54 <oleg-nenashev> *vote
19:57:10 <kohsuke_> oleg-nenashev: we have your CLA on file, right?
19:57:15 <danielbeck> oleg-nenashev Did you offer to do infra work?
19:57:19 <KostyaSha> bot restart should be extend with sudo puppet module
19:57:31 <kohsuke_> or not: https://github.com/jenkinsci/infra-cla/tree/master/collected/icla
19:57:56 <oleg-nenashev> kohsuke_: No, I can do it
19:58:21 <kohsuke_> If you can do that, that'd be great
19:58:32 <oleg-nenashev> danielbeck: I can do some work on this front. BTW, I'm also busy with my own infrastructures at Synopsys
19:59:00 <kohsuke_> In the mean time, I'll write to rtyler for the record. I don't expect him to say no
19:59:02 <oleg-nenashev> #action oleg-nenashev to sign CLA
19:59:37 <oleg-nenashev> kohsuke_: I don't know Ruby, hence anything may happen :)
19:59:44 <KostyaSha> oleg-nenashev, i will help ;)
19:59:45 <kohsuke_> #action kohsuke to write to rtyler notifying that oleg-nenashev is being added as an admin on infra
20:00:01 <kohsuke_> #action oleg-nenashev will file CLA https://github.com/jenkinsci/infra-cla
20:00:17 <kohsuke_> oleg-nenashev: And I need to know your SSH public key
20:00:30 <kohsuke_> Oops, I duped the action
20:00:54 <kohsuke_> danielbeck: And while I'm at it, shouldn't you be, too?
20:00:57 <oleg-nenashev> I'll submit a PR with the required stuff
20:01:11 <kohsuke_> Or were you already?
20:01:25 <kohsuke_> Are you already an admin with shell acount on the boxes with sudo access, that is.
20:01:34 <danielbeck> kohsuke_ I'm not
20:01:43 <kohsuke_> OK, then shouldn't you be?
20:01:53 <danielbeck> Not sure :-) Do you have backups?
20:02:18 <kohsuke_> I think your being on board would be great
20:02:42 <kohsuke_> But only if you are interested.
20:02:54 <danielbeck> alright, go ahead
20:03:28 <kohsuke_> danielbeck: Yay! You have CLA in place, so I just need your public key
20:03:42 <danielbeck> kohsuke_ via email later
20:03:54 <kohsuke_> I guess this takes care of the 3rd one?
20:04:01 <kohsuke_> "Guidelines describing current INFRA permissions and contacts"
20:04:15 <kohsuke_> #topic Test environment: Confluence clone for plugins testing (macros, etc.)
20:04:32 <oleg-nenashev> I suppose we need rtyler for this topic
20:04:46 <kohsuke_> #info Yes, we want to do it, no, I don't think anyone is currently actively working on it.
20:04:55 <KostyaSha> on confluence update?
20:04:58 <oleg-nenashev> Does the license from Atlassian allow it?
20:05:00 <KostyaSha> i work
20:05:13 <kohsuke_> Yes, atlassian gives us free license
20:05:24 <kohsuke_> I might have let it expired but I can get new ones generated any time
20:05:48 <KostyaSha> you can request free 30 days evaluation key that you can generat many times
20:05:53 <KostyaSha> just in their web ui
20:05:59 <KostyaSha> for jira, crowd etc
20:06:13 <kohsuke_> I'm talking about a yearly unlimited license for OSS projects. Not a trial license.
20:06:29 <KostyaSha> kohsuke_ have you already prepared puppet?
20:06:34 <kohsuke_> No
20:06:39 <oleg-nenashev> KostyaSha: It's a bad practice to debug something without a cclose server
20:06:51 <oleg-nenashev> *clone
20:06:54 <KostyaSha> oleg-nenashev, you don't need 1y license for this task
20:07:39 <KostyaSha> evaluation keys are fully functional, i'm using them for crowd plugin development/debugging
20:07:48 <kohsuke_> I think license is a secondary issue. The bigger task would be containerization or managing confluence via puppet
20:08:01 <KostyaSha> kohsuke_ rtyler said that conainer not needed
20:08:20 <KostyaSha> kohsuke_ also, open infra docs!
20:08:26 <kohsuke_> One can do it without container, that's true
20:09:01 <kohsuke_> But I think it's the best way forward
20:09:22 <KostyaSha> kohsuke_ i already working on it, but rtyler is busy for answers
20:09:28 <kohsuke_> And if we are not doing a container, we need confluence managed by puppet and a eggplant equivalent in the 'staging' environment
20:09:29 <KostyaSha> so no information about infra at all
20:09:48 <kohsuke_> KostyaSha: oh, it's great to hear you are working on it!
20:10:01 <kohsuke_> which infra doc?
20:10:13 <KostyaSha> kohsuke_ mostly fighting with ruby stuff and their bugs :E
20:10:52 <kohsuke_> All right, let me go through the infra archive. I assume your pending unanswered questions are there
20:11:03 <KostyaSha> kohsuke_ https://issues.jenkins-ci.org/browse/INFRA-41?focusedCommentId=216710&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-216710
20:11:04 <jenkins-admin> INFRA-41:Upgrade JIRA (Open) https://issues.jenkins-ci.org/browse/INFRA-41
20:11:17 <oleg-nenashev> #idea What about monthly #jenkins-infra meetings for sync-ups? Seems there's not enough communications :)
20:11:28 <kohsuke_> #info KostyaSha is working on puppetizing JIRA (INFRA-41) but currently blocked and need help from existing admins
20:11:37 <KostyaSha> oleg-nenashev, better clone kohsuke_
20:11:51 <danielbeck> oleg-nenashev ... due to too little time. What would an additional meeting help?
20:12:03 <kohsuke_> I think more delegation is needed, but today we made some progress on that front.
20:12:06 <KostyaSha> kohsuke_ i think jira+conluence will be resolved in the same time, i also hit rubymine bugs ;D
20:12:20 <KostyaSha> kohsuke_ ok, what about jetbrainz licenses?
20:12:28 <oleg-nenashev> danielbeck: I'm not sure. INFRA topics are not interesting to the most of participants
20:12:44 <KostyaSha> kohsuke_ 1) kicked them directly, but have no replies 2) i want rubymine license for infra stuff
20:12:47 <oleg-nenashev> * of the project meeting
20:12:55 <kohsuke_> KostyaSha: I'm not understanding how puppetizing them has anything to do with, but I'll follow up
20:13:55 <KostyaSha> kohsuke_ as i understand you want setup new server for new jira/conluence that need to be setupd with puppet, so we need test puppetizing before and then try migrate home folders with plugins
20:14:15 <kohsuke_> I need to pull in another CB guy (Adam) for more infra work
20:14:51 <kohsuke_> Can we do the last topic quickly before we are done? I know we are already running late
20:14:58 <kohsuke_> But it'd be hopefully easy
20:15:31 <kohsuke_> #topic Patron message changes from CloudBees
20:15:49 <kohsuke_> https://github.com/jenkinsci/patron/pull/2/files
20:16:03 <danielbeck> kohsuke_ Email aliases. Try it. :-)
20:16:12 <kohsuke_> This is about the "patron of Jenkins" program: https://wiki.jenkins-ci.org/display/JENKINS/Patron+of+Jenkins+program
20:16:46 <danielbeck> LGTM
20:16:47 <kohsuke_> There's some message changes
20:17:31 <KostyaSha> big kohsuke face on top of the page with message "please donate to jenkins" like it was in wiki? :D
20:17:33 <kohsuke_> I think they should be all non-controversial
20:17:52 <kohsuke_> But I do need the blessing of the meeting
20:18:01 <kohsuke_> KostyaSha: you know we've done that one year, right?
20:18:19 <KostyaSha> kohsuke_ no)
20:19:00 <danielbeck> kohsuke_ There was no picture of you though, like Wikipedia has (of their founder)?
20:19:07 <kohsuke_> A few more +1 votes would be much appreciated
20:19:26 <danielbeck> +1
20:19:32 <KostyaSha> +1
20:19:38 <KostyaSha> will read page later :)
20:19:56 <kohsuke_> Thank you, thank you!
20:20:01 <kohsuke_> #topic next meeting
20:20:28 <KostyaSha> should patron be moved to infra?
20:20:42 <kohsuke_> Next meeting will be Dec 10th
20:20:52 <kohsuke_> #info Next meeting will be Dec 10th
20:21:13 <kohsuke_> Happy Thanksgiving for those of us in the US. For the rest of the world. enjoy the time without pesky Americans
20:21:16 <KostyaSha> and restore topic...
20:21:17 <kohsuke_> #endmeeting