18:02:50 <jglick> #startmeeting
18:02:50 <robobutler> Let the Jenkins meeting commence!
18:03:02 <jglick> #topic JUC
18:03:11 <jglick> Alyssa take it away
18:03:13 <Alyssa> JUC SF is Oct 23. Registration page is up http://www.eventbrite.com/e/jenkins-user-conference-us-west-san-francisco-oct-23-2014-tickets-10558684309
18:03:24 <hare_brain> Woohoo
18:03:29 <jglick> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-Jul23thMeeting
18:03:49 <Alyssa> We have early bird price so pls help spread the word
18:04:39 <jglick> #info early bird price in effect
18:04:58 <Alyssa> In the last meeting. we talked about opt-in/out option. Lisa wanted to know if it was ok to share title of attendees w platinum/gold sponsors
18:06:22 <hare_brain> To me, that’s a reasonable ask.
18:06:28 <Alyssa> Originally, we were to share name, company name, city/state/country and email address
18:06:50 <hare_brain> Would that be a required field for registration then?
18:07:09 <Alyssa> right. we'll ask for title but is it ok to share that w/ platinum & gold sponsors?
18:07:43 <hare_brain> “hare_brain: To me, that’s a reasonable ask. [11:06am]"
18:08:20 <jglick> Anyone else have an opinion?
18:08:30 <jglick> if not,
18:08:40 <jglick> #agreed can share title w/ Pt/Au sponsors
18:08:49 <Alyssa> thanks!
18:09:14 <jglick> Anything else about JUC? Meetup?
18:09:26 <Alyssa> yes for meet up pls
18:09:43 <Alyssa> do we want to do a meet up along w/ JUC ?
18:09:53 <jglick> #topic JUC meetup
18:09:56 <Alyssa> rather..after or before juc?
18:10:23 <hare_brain> Along the lines of the Jenkins Scalability Summit last year?
18:10:49 <Alyssa> similar I think. I haven't talk to KK about details
18:11:01 <jenkins-builds> Starting build #3544 for job jenkins_main_trunk (previous build: SUCCESS)
18:11:15 <Alyssa> just wanted to see what folks think about doing similar along that line
18:11:27 <hare_brain> Is there a topic? Seems like there was a big thread on Jenkins UI.
18:11:53 <jglick> Seems like a decent idea.
18:12:04 <Alyssa> I think it may be on Workflow
18:12:15 <jglick> (a subject near and dear to me)
18:12:16 <jglick> :-)
18:12:23 <hare_brain> Confirmation bias. :)
18:12:30 <Alyssa> jglick: :o)
18:12:46 <jglick> Maybe send out a call for requests for meetup themes?
18:12:51 <hare_brain> +1
18:12:55 <jglick> With some initial suggestions?
18:12:57 <Alyssa> good idea
18:13:06 <hare_brain> Would it be at the hotel, or at CloudBees office again?
18:13:08 <hare_brain> Or somewhere else.
18:13:17 <jglick> #action Alyssa to call for meetup theme suggestions/votes
18:13:20 <hare_brain> If it’s too far from the hotel, people may have transportation issues
18:13:32 <hare_brain> CloudBees was reasonably close to JCC last year.
18:14:13 <Alyssa> @hare_brain: JUC is in Burlingame this year..we've out grown JCC. We're not sure re: location yet
18:15:00 <hare_brain> Yes. That’s what I meant. I was asking if the meetup would be near JUC location.
18:15:30 <Alyssa> @hare_brain: dunno yet :(
18:15:42 <hare_brain> Ah.
18:16:06 <hare_brain> I think that should be factored in. If it’s not near JUC, people traveling for the conference may have a hard time getting to it.
18:16:34 <Alyssa> thanks. will keep in mind as we work this out.
18:16:36 <jglick> Alyssa, as an aside, is there a reason JUC is not close to J1? Other than making people spend 2× the airfare if they want to get to both?
18:16:43 <jglick> (close in time I meant)
18:17:39 <Alyssa> Jglick: it a resource issue for us. short on man power ..i'm afraid
18:18:00 <jglick> Alright, OT anyway I guess.
18:18:01 <Alyssa> doing back to back events is hard on the team
18:18:10 <jglick> Anything else on JUC?
18:18:19 <Alyssa> that's it thnx
18:18:38 <jglick> moving on then…
18:18:39 <jglick> #topic JIRA components
18:18:56 <jglick> danielbeck: I do not see oleg_nenashev (correct nick?) here
18:19:19 <danielbeck> oleg-nenashev I think, but he's not here
18:19:33 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/2014+JIRA+Components+Refactoring
18:19:41 <danielbeck> Proposals look fairly reasonable
18:20:05 <danielbeck> And I've written a script to add the '-plugin' suffix to all components that are a plugin as I suggested a few weeks ago
18:20:28 <jglick> Excellent.
18:20:37 <danielbeck> Requires admin + API though. Tested on my Jira instance.
18:20:58 <jglick> So who would be driving this? Oleg? In that case we should defer discussion till a time when he can join, or ask on the list to proceed.
18:21:29 <danielbeck> As Oleg isn't here we should probably postpone further discussion. Maybe suggest on the list we do this in two weeks.
18:21:57 <danielbeck> Until then everyone interested can review the suggestions and suggest changes.
18:22:00 <jglick> Sensible. His last message: “If everyone agrees, it would be great if somebody with JIRA administration rights takes the action point.”
18:22:13 <jglick> Probably that would be kohsuke.
18:22:31 <jglick> #action oleg-nenashev to report on status of JIRA component change
18:22:39 <jglick> #action kohsuke to implement JIRA component change
18:23:10 <jglick> I would also like to see a final list of components for concreteness.
18:23:32 <jglick> Anything else on this?
18:23:38 <jglick> If not, any other topics?
18:23:50 <hare_brain> I’d like to request rules/conventions for when new components are created.
18:24:14 <john_doe_jr> How do I install jenkins on Ubuntu 14.04.1 LTS?
18:24:20 <hare_brain> There’s some that are already implicit: which is -plugin for components related to a plugin. Component maps to repo
18:24:31 <jglick> john_doe_jr: later please, meeting in progress
18:24:40 <hare_brain> Are there others that should be codified?
18:24:42 <john_doe_jr> k sorry
18:24:54 <jglick> hare_brain: I think that is the only real rule, that when you make a plugin you add a matching component.
18:25:39 <hare_brain> Looks like a lot of existing components are going to get merged into core. Will that make it harder to manage looking through core issues?
18:25:56 <danielbeck> Easier actually IMO
18:25:56 <hare_brain> Or is the solution to that, just break more core into plugins?
18:25:59 <jglick> Most things physically in core are already filed in it.
18:26:09 <danielbeck> Right now you have no idea where something in core would be filed.
18:26:15 <jglick> And yes, breaking out functionality into plugins is great when it is possible!
18:26:31 <jglick> (I am working on hudson.tasks.test/junit, FYI.)
18:26:45 <jglick> Agreed with danielbeck, predictability is crucial.
18:27:02 <jglick> Can always use labels to indicate what aspect of the code you are dealing with.
18:27:03 <hare_brain> As a matter of personal preference, I think that “unsorted” is rather non-descript.
18:27:19 <hare_brain> re: labels. Great.
18:27:21 <danielbeck> The goal should be to keep unsorted empty.
18:27:23 <danielbeck> IMO
18:27:32 <hare_brain> I agree with that.
18:27:33 <jglick> Well yes.
18:27:51 <jglick> #agreed want unsorted component empty, but maybe need a more descriptive name
18:28:32 <jglick> Anything else before I close?
18:28:37 <hare_brain> A few more questions
18:28:37 <ogondza> we are ready for 1.565.1
18:28:50 <jglick> #topic 1.565.1
18:28:52 <hare_brain> Is the intent of the unsorted component to be a holding place for “I don’t know where to file this” or
18:29:02 <jglick> sorry
18:29:07 <jglick> #topic JIRA components
18:29:12 <hare_brain> Is it things that haven’t been triaged. If the latter, then that seems to be duplicative for the untriaged stage.
18:29:43 <jglick> I think the intent was as a temporary holding place for historical issues in anomalous components, or newly filed things where the reporter is just clueless.
18:29:46 <jglick> But I am not really sure.
18:30:10 <hare_brain> i.e., if we have an unsorted component, does moving it out of that component mean that a ticket has been triaged?
18:30:13 <danielbeck> typically users are filing in the component they believe responsible anyway. Not sure what to do with issues that don't have the component (plugin) in Jira
18:30:48 <jglick> Right, typically you would know the right component when you are filing. (If not, probably you should not be filing issues to begin with.)
18:31:13 <jglick> #action oleg-nenashev to document intended usage of unsorted
18:31:21 <hare_brain> OK, I’m done. Thanks.
18:31:26 <jglick> OK.
18:31:30 <jglick> #topic 1.565.1
18:31:40 <jglick> ogondza you say we are ready for a release?
18:31:46 <ogondza> yes
18:31:50 <jglick> then
18:31:55 <jglick> #action kohsuke cut 1.565.1
18:32:33 <hare_brain> Haha
18:32:37 <jglick> JENKINS-18065 is on my short list for 1.565.2 backporting.
18:32:39 <jenkins-admin> JENKINS-18065:AbstractLazyLoadRunMap.iterator() calls .all() (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-18065
18:33:08 <jglick> I think kohsuke is traveling and busy today and perhaps for a few days, but can probably get to it Monday or thereabouts.
18:33:29 <jglick> Anything else?
18:33:50 <hare_brain> #info jglick runs meetings really well
18:34:01 <jglick> #info next meeting Aug 06
18:34:18 <jglick> (thanks! though I know little about the JUC planning)
18:34:29 <jglick> #endmeeting