18:01:10 <kohsuke> #startmeeting
18:01:10 <robobutler> Let the Jenkins meeting commence!
18:01:37 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:02:10 <lisa_> Can we add JUC as a standing item to agenda till after JUC?
18:02:13 <kohsuke> #topic 3D model of Mr.Jenkins
18:02:34 <kohsuke> lisa_: sure, my apologies not putting up agenda until late
18:02:38 <kohsuke> but feel free to add on
18:02:39 <kohsuke> one
18:03:53 <kohsuke> CloudBees have produced a bobble-head of Mr.Jenkins as a give away, and it has been very popular
18:04:30 <lisa_> kohsuke: added JUC to agenda, thanks!
18:04:41 <kohsuke> And someone suggested me that we should have a 3D model of Mr.Jenkins
18:04:55 <kohsuke> ... so that people can print those, or make some additional derivative works
18:05:21 <kohsuke> ... and I could even conceivably assemble that as a LEGO model
18:05:36 <kohsuke> So I started talking to a designer in Japan
18:05:37 <kohsuke> http://www.fast-d.com/search/engineers/2798?locale=en#.U4YkzHWx1FQ
18:06:15 <kohsuke> and got the work under way for about $300
18:06:44 <kohsuke> As per the license of the original logo, the resulting data will be in CC-BY-SA
18:07:01 <kohsuke> Now, my question is, is this a legitimate use of the project money?
18:07:39 <kohsuke> Failing that, I also thought about perhaps this could be my first kickstarter project
18:08:11 <happytux> hi
18:08:16 <happytux> So one pushes a feature branch to the ci repository, the ci builds it, tests it and when everything passes, it is merged with master?
18:08:18 <happytux> Does Jenkins directly support git merging?
18:08:36 <kohsuke> happytux: we are in the project meeting, so let's hold off questions until that wraps up (https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda)
18:08:53 <kohsuke> Any thoughts on this, any one?
18:08:58 <hare_brain> This is a weird kohsuke. :)
18:09:04 <hare_brain> weird request
18:09:42 <hare_brain> On the one hand, it’s fun and harmless. On the other hand, I’m trying to think how this actually benefits the project.
18:09:57 <programmerq> I would totally throw renders of the 3d model into presentations
18:10:35 <hare_brain> What’s the actual deliverable?
18:10:54 <kohsuke> I've seen various derivative works of 2D logo, so I guess my admittedly weak argument is enabling derivative work
18:11:11 <kohsuke> So the actual deliverable is the OBJ/STL file (shape data) and texture file for color printing
18:11:20 <lisa_> then if anyone wants to print them, they can easily get a 3D Jenkins, right? that's kind of fun
18:11:58 <programmerq> (speaking as a community member only) I'd think something like this would benefit the project just as much as stickers/tshirts/mugs/etc
18:12:50 <kohsuke> see, there's at least one fan!
18:13:01 <hare_brain> programmerq: I think this is a little bit different. Those are physical things that get handed out. This is more like a binary distribution.
18:13:10 <programmerq> hare_brain: at first, yes
18:14:11 <programmerq> if you're familiar with zazzle/cafepress, you can upload your design, others order it, and some of the end customers' money goes back to the original designer. I'm pretty sure I've seen that business model, but for 3d printed objects.
18:14:18 * programmerq shrugs
18:15:03 <programmerq> I have been using jenkins as part of my job for the last *several* projects I've worked on across 3 different companies. I would totally pay for a 3d printed mr jenkins to stick on a shelf.
18:15:58 <kohsuke> All right, sounds like I should raise money separately for this to be on the safe side
18:16:24 <kohsuke> I expected a push back like that from hare_brain
18:16:35 <hare_brain> Ha.
18:16:54 <hare_brain> I’m not *against* it per se. I just don’t have any experience to map this to.
18:17:05 <hare_brain> I’m still thinking my way through it.
18:17:15 <kohsuke> But nonetheless I wanted to try it on you to see how you react
18:17:35 <hare_brain> You successfully threw me for a loop. :)
18:17:57 <lisa_> given that there is now revenue from ads... $300 isn't that much to give people the tools to create something that will create enthusiasm about Jenkins
18:18:06 <danielbeck> Maybe email the lists to determine user interest?
18:18:20 <kohsuke> danielbeck: that's a good idea
18:19:13 <kohsuke> OK, enough about this topic.
18:19:20 <hare_brain> Lisa_, it’s not the amount I’m concerned about. I’m thinking about it from the perspective of, what does the project get for it’s money? programmerq’s idea
18:19:46 <hare_brain> that we can upload the model to cafepress to sell more physical toys is interesting.
18:19:49 <lisa_> hare_brain: i think it's like stickers - it just requires one more step (someone to produce it)
18:20:18 <kohsuke> #action kohsuke to write to the users list to sense the level of interest
18:20:59 <kohsuke> #topic 1.554.2 status check
18:21:23 <kohsuke> ogondza: I saw your email that it's good to go
18:21:30 <ogondza> kohsuke: yes
18:21:37 <kohsuke> So I think we will just proceed as planned and ship it today
18:21:47 <kohsuke> I'm really happy that the train model appears to be working
18:21:52 <ogondza> ATH is not as stable as I wish, though
18:22:03 <ogondza> but working on it
18:22:24 <kohsuke> I noticed that -stable seems to have more regressions than the mainline
18:22:51 <ogondza> kohsuke: we got a lot of new manual testers, hope it is a trend
18:23:03 <kohsuke> nice
18:23:12 <kohsuke> I think it's helping that our schedule is predictable and people can plan ahead
18:23:31 <kohsuke> #agreed 1.554.2 release is a GO
18:23:40 <kohsuke> #topic JUC
18:24:21 <lisa_> Not sure if Alyssa_ is here?
18:24:31 <kohsuke> doesn't look like it
18:24:54 <lisa_> The US East Conference (Boston) is almost full - about 290 out of 300 registered
18:25:03 <lisa_> looks like we may release more tickets though
18:25:24 <kohsuke> Sounds like this would be worth a blog post of its own
18:25:34 <lisa_> The European conference in Berlin has 260 registrants already. so attendance is looking really good
18:26:15 <kohsuke> Marco Miller who is lately involved in the acceptance test harness is coming to JUC Boston
18:26:25 <lisa_> there's also a Continuous Delivery Summit featuring Jenkins in NYC the day after JUC Boston (June 19) and one the day before Berlin (Jun 24)
18:26:40 <lisa_> @kohsuke is speaking
18:26:41 <lisa_> http://www.eventbrite.com/e/how-to-accelerate-innovation-with-continuous-delivery-berlin-tickets-11576524697?mkt_tok=3RkMMJWWfF9wsRokv6jPZKXonjHpfsX%2F6eokWrHr08Yy0EZ5VunJEUWy24QERdQ%2FcOedCQkZHblFnVwASa2lV7oNr6QP
18:26:55 <kohsuke> Just a random thought, but I wonder if we can do a small impromptu get together right after JUC
18:26:57 <lisa_> http://www.eventbrite.com/e/how-to-accelerate-innovation-with-continuous-delivery-new-york-tickets-11576484577
18:27:14 <lisa_> like dinner or something?
18:27:17 <kohsuke> I should check with them first
18:27:34 <kohsuke> I need to check I have enough time after JUC before I head to the airport
18:27:43 <lisa_> that could be an issue ;)
18:27:49 <kohsuke> lisa_: but yeah, if there's time, like a dinner or something
18:28:25 <lisa_> I wanted to thank our new sponsors too - Assembla for Boston and XebiaLabs for upgrading to Gold in Berlin.
18:28:41 <kohsuke> lisa_: Berlin's capacity is set to 300 too, right?
18:28:50 <lisa_> and then we have three Community sponsors - Berlin JUG, Lightweight JUG Munich, and Polish JUG. so excellent community support
18:28:58 <kohsuke> indeed
18:29:33 <lisa_> yes, 300. alyssa_: do we have the option to find more space n Berlin?
18:29:49 <kohsuke> #action kohsuke to do a blog post on "thanks, we are almost filled up" post
18:30:02 <lisa_> kohsuke: check with me, i've already started one :)
18:30:03 <alyssa_> kohsuke_: I've increased capacity to 400
18:30:18 <kohsuke> lisa_: great, thanks
18:30:19 <lisa_> for Berlin too?
18:30:41 <kohsuke> alyssa_: oh well, in that case the post would have to be "we are filling up so we added more seats" post
18:31:06 <alyssa_> we can add more space for Berlin as well
18:31:31 <alyssa_> kohsuke_: it's a good problem to have :o)
18:31:38 <kohsuke> yes
18:32:11 <lisa_> any questions or thoughts on JUC?
18:32:28 <kohsuke> So a bunch of us will be in Berlin in the night before, right?
18:32:37 <kohsuke> I wonder if it's worth trying to organize a dinner
18:32:44 <abayer> kohsuke: +1 - I was hoping for that. =)
18:32:46 <kohsuke> maybe the dinner of the JUC day or the day before
18:32:54 <lisa_> great idea
18:32:55 <kohsuke> I think we do that in San Francisco all the time
18:33:06 <alyssa_> day after would be better IMO
18:33:17 <kohsuke> ... except people sign up and then disappear, which makes reservation arrangement tricky
18:33:20 <alyssa_> sorry, meant to say after JUC
18:33:34 <kohsuke> Right, I think you feel more relaxed that  way, right? :-)
18:33:44 <kohsuke> abayer: does that work?
18:33:48 <alyssa_> i thought you setting up the meetup page for dinner like you did for SF worked well
18:34:03 <abayer> kohsuke: Yup, I've already blocked off Tuesday and Wednesday nights just in case. =)
18:34:13 <kohsuke> I could really use someone local picking a venue for us
18:34:33 <kohsuke> Let's see, who lives in Berlin...
18:34:53 <alyssa_> i can ask my contact in Berlin too
18:35:04 <kohsuke> abayer: have you been there before?
18:35:09 <kohsuke> alyssa_: yeah, that'd be great
18:35:13 <abayer> Yup, but I don't know restaurants.
18:35:25 <kohsuke> It probably should be nearby the event venue
18:35:27 <alyssa_> kohsuke_: will do
18:36:40 <kohsuke> tweeted
18:36:51 <kohsuke> Are we done on this topic?
18:37:04 <kohsuke> #topic next meeting
18:37:22 <kohsuke> #info the next meeting would be June 11th
18:37:46 <kohsuke> #info For the first time I have seen >300 attendants in the room
18:37:50 <kohsuke> #endmeeting