#jenkins Meeting

Meeting started by kohsuke at 19:01:23 UTC (full logs).

Meeting summary

    1. https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda (kohsuke, 19:01:29)

  1. name grant request take 2 (kohsuke, 19:01:55)
    1. in the previous meeting I've asked for "Jenkins Multi-master by CloudBees" and that subsequently got approved (kohsuke, 19:02:37)

  2. LTS status (kohsuke, 19:07:06)
    1. ACTION: kohsuke to produce 1.532.1 RC today (kohsuke, 19:08:07)
    2. ACTION: ogondza to create 1.532.x testing page in Wiki (kohsuke, 19:12:56)
    3. AGREED: we'll aim for a release in a week (kohsuke, 19:22:10)
    4. ACTION: kohsuke to look at selenium-tests and try to help maintain it (kohsuke, 19:22:31)
    5. ACTION: kohsuke to make sure https://jenkins-ci.org/stable-rc shows the RC version number (kohsuke, 19:24:09)
    6. ACTION: kohsuke to make sure https://jenkins-ci.org/changelog-stable shows 1.532.1 changes after posting RC (kohsuke, 19:25:28)

  3. commit loss status updates (kohsuke, 19:25:57)
    1. so in case people haven't been paying attention to the dev list, on Saturday an accident resulted in the effective "git push -f" on a large number of repositories in the jenkinsci org (kohsuke, 19:26:43)
    2. ... resulting in us losing about a month worth of commits in various branches (kohsuke, 19:27:20)
    3. GitHub support helped us recover a large number of it, although exactly how they identify what commits, we don't know (kohsuke, 19:27:55)
    4. and I wrote a program that reconstructs what commits were lost from GitHub API and resurrected the rest of the commits that GitHub support missed (kohsuke, 19:28:33)
    5. At this moment we consider all commits recovered in all the branches in all the repositories (kohsuke, 19:29:01)
    6. but your checking sanity on this claim by looking at your repositories would be greatly appreciated (kohsuke, 19:29:21)
    7. we'll write up something and post it on http://jenkins-ci.org/node (kohsuke, 19:30:52)

  4. next meeting (kohsuke, 19:34:49)
    1. AGREED: next meeting is Dec 11th (kohsuke, 19:36:58)


Meeting ended at 19:37:11 UTC (full logs).

Action items

  1. kohsuke to produce 1.532.1 RC today
  2. ogondza to create 1.532.x testing page in Wiki
  3. kohsuke to look at selenium-tests and try to help maintain it
  4. kohsuke to make sure https://jenkins-ci.org/stable-rc shows the RC version number
  5. kohsuke to make sure https://jenkins-ci.org/changelog-stable shows 1.532.1 changes after posting RC


Action items, by person

  1. kohsuke
    1. kohsuke to produce 1.532.1 RC today
    2. kohsuke to look at selenium-tests and try to help maintain it
    3. kohsuke to make sure https://jenkins-ci.org/stable-rc shows the RC version number
    4. kohsuke to make sure https://jenkins-ci.org/changelog-stable shows 1.532.1 changes after posting RC
  2. ogondza
    1. ogondza to create 1.532.x testing page in Wiki


People present (lines said)

  1. kohsuke (76)
  2. ogondza (13)
  3. hare_brain (8)
  4. kpfleming (4)
  5. scl (2)
  6. jglick (2)
  7. rpetti (2)
  8. robobutler (1)
  9. KaibutsuX (1)


Generated by MeetBot 0.1.4.