18:01:03 <kohsuke> #startmeeting
18:01:03 <robobutler> Let the Jenkins meeting commence!
18:01:13 <kohsuke> #chair rtyler hare_brain abayer
18:01:13 <robobutler> Current chairs: abayer hare_brain kohsuke rtyler
18:01:22 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:01:31 <kohsuke> #topic backporting
18:01:50 <kohsuke> I have the entire dev thread unread :-(
18:02:23 <kohsuke> but Maven 3.1 change seems like a highly desirable feature
18:02:31 <kohsuke> vjuranek: ^^
18:02:52 <jglick> a bit dangerous but certainly desirable
18:03:19 <kohsuke> Yeah
18:03:34 <kohsuke> In a way, the audience of LTS shouldn't be the kind of people who jump on to the latest Maven release
18:04:24 <kohsuke> 12 votes https://issues.jenkins-ci.org/browse/JENKINS-15935
18:04:27 <jenkins-admin> JENKINS-15935:Can't build using maven 3.1.0 (Resolved) http://jenkins-ci.org/issue/15935
18:05:06 <jglick> True, no one is forcing them to run 3.1.0.
18:05:07 <vjuranek> I backported it in my git branch, but I wasn't completely sure it it should be included as it's more like feature request + I don't have enough time to check if it's backported properly (but tests pass)
18:05:50 <kohsuke> Until I've heard that you've already done the work, I was inclined to say push this out to 1.509.4 or the next LTS
18:05:52 <jglick> If we do not backport it, IMHO we at least need to clearly *report* that 3.1.0 is unsupported.
18:06:04 <jglick> Because currently you just get a nasty NCDFE.
18:06:34 <jglick> Which from a user perspective was completely unexpected.
18:07:37 <kohsuke> I don't feel too strongly one way or the other, but if it's up to me, skipping would be my call
18:07:57 <jglick> Then I suggest a small fix to the process factory to detect 3.1.0 on the remote side and abort with a clean message.
18:08:15 <jglick> Did something similar recently for JDK 5.
18:08:51 <kohsuke> vjuranek: ?
18:08:58 * vjuranek thinks
18:09:36 <vjuranek> given my time constrains, I would either backport it (already done) or leave it as it is
18:10:01 <kohsuke> Googling "NoClassDefFoundError: org/apache/maven/cli/MavenLoggerManager" would bring JENKINS-15935 at the top, so anyone worth a dime would be able to pinpoint the cause
18:10:03 <jenkins-admin> JENKINS-15935:Can't build using maven 3.1.0 (Resolved) http://jenkins-ci.org/issue/15935
18:10:05 <vjuranek> or no problem to iclude this small fix if somene implements it:-)
18:11:25 <vjuranek> as for backporting, I have no storng preference as well (one of the reasons I bring it to the meeting)
18:11:33 <kohsuke> Is it fair to summarize this as "JENKINS-15935 will miss 1.509.3. If anyone wants to make the failure mode nicer, he is welcome.
18:11:35 <jenkins-admin> JENKINS-15935:Can't build using maven 3.1.0 (Resolved) http://jenkins-ci.org/issue/15935
18:12:28 <jglick> MavenVersionCallable.call() can check ≥ 3.1.0 and throw IOException, perhaps
18:12:44 <kohsuke> #agreed JENKINS-15935 will miss the 1.509.3 train. If anyone wants to make the failure mode nicer (by detecting and reporting Maven 3.1), please feel welcome
18:12:45 <jenkins-admin> JENKINS-15935:Can't build using maven 3.1.0 (Resolved) http://jenkins-ci.org/issue/15935
18:13:05 <kohsuke> I think jglick is volunteering for the latter part
18:13:12 <jglick> I guess so!
18:13:16 <vjuranek> sound good to me (and backport is eventually prepared for 1.509.4)
18:13:51 <kohsuke> Might be worth improving Maven tests to run the tests with different Maven versions
18:13:57 <kohsuke> I think right now it only uses one version
18:14:07 <jglick> No, they run on 2.2.1, 3.0, 3.1
18:14:19 <kohsuke> oh ok.
18:14:25 <kohsuke> I love the problems that are already solved by other people
18:14:36 <jglick> Especially when the other person is olamy.
18:14:40 <kohsuke> #topic Schedule Credentials:1.6, SSH Credentials 1.0, SSH Slaves 1.0 for integration in 1.509.4 if there is one
18:15:08 <jglick> Why?
18:15:19 <kohsuke> stephenc said I should defend this proposition on behalf of him but he didn't tell me why this is important
18:15:36 <vjuranek> :-)
18:16:10 <jglick> Unless we are generally updating all bundled plugins I see no reason why these should be special.
18:16:18 <kohsuke> Yeah
18:16:39 <kohsuke> Well, the proposal is for the next LTS, so I'm going to sync up with him again as to why he thinks this is important
18:17:01 <kohsuke> #action kohsuke to post a blog about his [NOTICE] post and call for the need for updating all at once
18:17:35 <kohsuke> I hope this post doesn't mean those plugins have broken compatibility...
18:17:45 <jglick> I think they did. Ideally the Jenkins plugin metadata could express that.
18:17:53 <kohsuke> it can
18:18:33 <kohsuke> In my reading of his post I don't think any of them is compatibility breaking
18:18:44 <jglick> ssh-credentials: <compatibleSinceVersion>1.0</compatibleSinceVersion>
18:18:45 <kohsuke> It's just that the upgrade is one way (SSH credentials)
18:18:51 <kohsuke> oh ok
18:18:55 <kohsuke> oh boy
18:19:25 <jglick> Not sure whether he meant only that the upgrade is one way, or whether something explodes if you only upgrade one of them.
18:19:48 <kohsuke> it'd be good to check the code
18:20:05 * kohsuke brings touches the bytecode compatibility transformer on his hip
18:20:27 <kohsuke> I'll check with stephenc to find out
18:20:42 <jglick> I.e. ssh-credentials 1.0 + ssh-slaves 0.x = ?
18:21:02 <kohsuke> oh looks like we already have an aswer in the dev list
18:21:09 <kohsuke> it does blow up: http://pastebin.com/F5e9rTVX
18:21:19 <jglick> I think that means that your SSH slaves will not find any credentials.
18:22:02 <jglick> The pastebin snippet I think meant that Plugin Manager allowed him to upgrade ssh-slaves 1.0 while ssh-credentials was 0.x, which is a bug incore.
18:22:23 <jglick> (The kind of issue OSGi would catch.)
18:22:39 <kohsuke> OK, that's fixable
18:23:06 <kohsuke> let me file that
18:23:28 <kohsuke> I guess I have already done that: https://issues.jenkins-ci.org/browse/JENKINS-18608
18:23:30 <jenkins-admin> JENKINS-18608:When updating a plugin, check versions of dependencies (Open) http://jenkins-ci.org/issue/18608
18:23:50 <jglick> If you upgrade just ssh-credentials, existing credentials will get converted, so the old slave launcher will never find them.
18:24:07 <jglick> I.e. they would not appear in the list of credentials to pick.
18:24:25 <jglick> Probably easily resolved by upgrading ssh-slaves too.
18:25:01 <kohsuke> "Breaks" header would have been useful like the one you find in *.deb
18:25:32 <kohsuke> oh well
18:25:50 <kohsuke> Let's close the meeting
18:26:06 <jglick> What about backporting the Stapler fix?
18:26:11 <jglick> Did that get taken care of?
18:26:11 <kohsuke> #action kohsuke to circle back on stephenc to find out why these plugins should be in 1.409.4
18:26:28 <kohsuke> I guess now I see his argument --- it's because it has to be updated all at once
18:26:39 <kohsuke> saves troubles if we do it for users
18:26:50 <kohsuke> stapler fix?
18:26:58 <jglick> https://github.com/stapler/stapler/commit/fb1fa99985058151732a73c1a071383dbd20e116
18:26:58 <ogondza> https://groups.google.com/forum/#!msg/jenkinsci-dev/QoXu9XJ5zbs/Qyg5tcPXFKQJ
18:27:26 <jglick> JENKINS-18776
18:27:28 <jenkins-admin> JENKINS-18776:@QueryParameter with @RelativePath broken (Resolved) http://jenkins-ci.org/issue/18776
18:27:55 <stephenc_> Hey! The topic I am after
18:27:59 <kohsuke> I think in the past I've been liberal about updating stapler/winstone/etc versions in LTS
18:28:02 <jglick> Backporting the fix in jenkinsci/jenkins means pulling in months’ worth of over changes.
18:28:15 <jglick> Including at least one known serious regression.
18:28:32 <stephenc_> You guys move off my agenda item already?
18:28:48 <jglick> JENKINS-18641
18:28:50 <jenkins-admin> JENKINS-18641:People View does Not Populate (makeStaplerProxy) (Reopened) http://jenkins-ci.org/issue/18641
18:29:06 <kohsuke> let's take care of the stapler fix first and we can come back to credential plugins
18:29:12 <jglick> stephenc_: yes but could circle back to it if need be
18:29:12 <kohsuke> #topic backporting stapler fix
18:29:47 <stephenc_> I just care if I have a "go" in principle
18:30:01 <kohsuke> I can check what else went in between 1.207 to 1.214 but I tend to prefer picking existing releases
18:30:11 <kohsuke> as opposed to have 1.207.1
18:30:26 <jglick> Then can we get JENKINS-18641 fixed in 1.215 or whatever?
18:30:28 <jenkins-admin> JENKINS-18641:People View does Not Populate (makeStaplerProxy) (Reopened) http://jenkins-ci.org/issue/18641
18:30:36 <kohsuke> In my mind if whatever stapler release passes the soak time rule I'm good
18:30:48 <jglick> Either by reverting the original change, or adjusting it somehow.
18:31:05 <kohsuke> that went in after 1.207?
18:31:21 <kohsuke> is that why ogondza is asking for 1.207.1?
18:31:28 <ogondza> yes
18:31:29 <kohsuke> (if so, I'd be happy to create that, too)
18:31:45 <jglick> See thread: “RE: JENKINS-18641: Changes to Stapler's JavaScript proxy will break plugins depending on it”
18:31:47 <jenkins-admin> JENKINS-18641:People View does Not Populate (makeStaplerProxy) (Reopened) http://jenkins-ci.org/issue/18641
18:32:15 <ogondza> the 2 commits are backported already. tests passes
18:32:45 <kohsuke> oh ok, then sounds like the least I can do is to do 1.207.1
18:32:47 <jglick> rsandell thinks there might be a simple fix for JENKINS-18641 (which would be in core, so no need to change Stapler version)
18:32:49 <jenkins-admin> JENKINS-18641:People View does Not Populate (makeStaplerProxy) (Reopened) http://jenkins-ci.org/issue/18641
18:33:27 <kohsuke> and just for the record I believe anyone can release stapler
18:33:29 <kohsuke> at least that's my intent
18:33:31 <jglick> If that in fact works (have not yet tried it myself), would we rather go that way?
18:33:46 <jglick> (kohsuke: distribution to gh-pages was the issue IIRC)
18:34:22 <kohsuke> "If that [simple 18641 fix] in fact works (have not yet tried it myself), would we rather go that [releasing 1.215] way?" ?
18:34:30 <jglick> right
18:34:48 <jglick> i.e. +<st:adjunct assumes="org.kohsuke.stapler.framework.prototype.prototype" includes="org.kohsuke.stapler.json2"/>
18:34:50 <kohsuke> Then it sounds like I should be working on this ASAP
18:35:04 <stephenc_> :-)
18:35:26 <kohsuke> So here's what I'll do.
18:35:39 <kohsuke> I'll release 1.207.1 sine ogondza did all the hard work
18:35:49 <kohsuke> And I'll work on JENKINS-18641
18:35:50 <jglick> kohsuke: if you are checking it, you can use cloudbees-template as a test case.
18:35:51 <jenkins-admin> JENKINS-18641:People View does Not Populate (makeStaplerProxy) (Reopened) http://jenkins-ci.org/issue/18641
18:36:14 <kohsuke> if that fix comes up in time and we are happy, we'd propose bundling 1.215
18:36:39 <kohsuke> but 1.509.3 can always fall back to 1.207.1
18:36:47 <jglick> 1.216 actually.
18:36:53 <jglick> Or not, 1.217.
18:36:56 <kohsuke> whatever
18:37:11 <kohsuke> stapler+18641 fix
18:37:33 <jglick> Or sorry no, 1.215, since the proposed fix is in core.
18:37:37 <kohsuke> ogondza:  Is that satisfiable?
18:38:04 <ogondza> sure
18:38:08 <jglick> I.e. stable branch already specifies 1.215; we just need to check if reverting the existing workaround in core, and adding the proposed workaround in core, solves the originally reported issue as well as those in plugins.
18:38:29 <jglick> Or 1.214 I mean is in stable.
18:38:40 <jglick> Sorry for confusion.
18:38:42 <kohsuke> OK
18:39:16 <kohsuke> #topic SSH credentials
18:39:25 <kohsuke> stephenc:  ^^
18:39:42 <kohsuke> I think we lost him
18:39:57 <kohsuke> #topic next meeting
18:40:04 <jglick> _stephenc: ?
18:40:11 <jglick> nope, gone
18:40:25 <kohsuke> #info next meetin would be in Aug 21st
18:40:50 <kohsuke> #endmeeting