00:57:46 <rtyler> #startmeeting
00:57:46 <robobutler> Let the Jenkins meeting commence!
00:58:02 <rtyler> #info The meeting agenda can be found here https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-JenkinsUserConferenceMeeting@SanFrancisco
00:58:47 <aslanb> Agenda Items
00:58:51 <aslanb> Future funding
00:59:12 <aslanb> Doni added a number of things
00:59:16 <aslanb> Where would you like to start
00:59:19 <aslanb> Future fundings
00:59:19 <rtyler> #topic Discussion about future funding source/plan / fiance report
00:59:26 <aslanb> Tyler is using a robot
00:59:34 <aslanb> recodring all things we are doing.
00:59:36 <rtyler> #info meetings are recorded and logged under meetings.jenkins-ci.org
00:59:46 <aslanb> LEt me show you the current project funding stuff.
01:00:06 <aslanb> I'll quickly summarize
01:00:09 <aslanb> where we spent money
01:00:18 <aslanb> we started collecting money a year and half ago
01:00:21 <aslanb> 14020
01:00:24 <aslanb> dollars
01:00:30 <aslanb> 5%
01:00:32 <aslanb> was taken
01:00:38 <aslanb> 13,090.95
01:00:39 <aslanb> left
01:00:41 <rtyler> #info our financial management group/parent organization is the SPI http://spi-inc.org
01:00:41 <aslanb> more or less
01:00:45 <aslanb> major spending
01:00:49 <aslanb> 500 dollars
01:00:49 <rtyler> #info aslanb is transcribing live
01:00:54 <aslanb> fixing a system
01:00:57 <aslanb> 4000 stickers
01:01:00 <aslanb> 1000 dollars
01:01:10 <aslanb> in past 18 months
01:01:14 <aslanb> raised 13000
01:01:17 <aslanb> spent 7000
01:01:21 <aslanb> have 6000 left
01:01:48 <aslanb> we can survive 7 more years
01:01:53 <aslanb> at this rate
01:02:04 <aslanb> We keep the assets in gold! Ha Ha
01:02:13 <aslanb> LEts engage the audience
01:02:20 <aslanb> Sorry about the transcription errors.
01:02:48 <aslanb> How do we feel about funding drives?
01:03:01 <aslanb> Taking people to conferences
01:03:12 <aslanb> Sending people across the ocean, and bringing them over here
01:03:21 <aslanb> We had a discussion at Scale 10
01:03:50 <aslanb> IRS issues
01:03:56 <aslanb> Targeted donership was not ok
01:04:42 <aslanb> In terms of number of donors: 120
01:04:50 <aslanb> Individuals vs corporations?
01:05:12 <aslanb> Feels like there are a lot of smaller donors
01:05:22 <aslanb> $20 or $30 dollars
01:05:28 <aslanb> Did anyone notice the last donation drive
01:05:39 <aslanb> A lot of people didn't notice.
01:05:49 <aslanb> For t5hose that didn't notice
01:06:19 <aslanb> We put a picture of koske (sorry for the mispelling) on the web page
01:07:11 <aslanb> IF there is reason for us to raise money we should try otherwise we shouldn't.
01:07:47 <aslanb> The difficulty with targeted donations, a lot of the time it doesn't match up with budgets of companies.
01:08:00 <aslanb> At the end of the year books are closing, making for more generous donations.
01:08:33 <aslanb> Audience: targeted donations, sponsor a plugin a lot of people would like. Essentially buying developer time through a sponsoring.
01:08:51 <aslanb> This has been identified before.
01:08:55 <kohsuke2> #idea perhaps we should do more of the grant proposals?
01:08:58 <aslanb> We have been talking about this.
01:09:17 <aslanb> The types of things we are talking about now are around the operations of the project.
01:09:18 <kohsuke2> #info we started using freedomsponsors.org that's somewhat related to this
01:10:12 <aslanb> I think the action we should pull out of this, that at the open source folsden conference. Travel grants, end of the year.
01:10:29 <aslanb> Targeted funds for travel grants (3,000).
01:10:33 <rtyler> #action project to start a targeted donation drive for FOSDEM travel grants
01:10:37 <rtyler> #chair kohsuke2
01:10:37 <robobutler> Current chairs: kohsuke2 rtyler
01:11:05 <rtyler> #agreed project to try a targeted donation drive for FOSDEM travel grangts
01:11:10 <aslanb> Next topic? Yes.
01:11:19 <aslanb> What do you all want to talk about?
01:11:35 <aslanb> We are trying to focus on what you would like to talk about?
01:12:03 <aslanb> What needs priority?
01:12:15 <aslanb> You tell us, we will go off list if you don't have anything?
01:12:51 <aslanb> Audience: Every session I have attended, Jenkins documentation has been bashed. How can we work to make this better?
01:12:51 <rtyler> #topic How can we fix documentation/make it better
01:13:12 <kohsuke2> abayer says "yes, dev documentation is hard and quite lacking"
01:13:18 <aslanb> Developer perspective is hard? If you don't know your way around, What do you do?
01:13:27 <aslanb> Any sugestions?
01:13:38 <jieryn> nothing worth doing was easy
01:14:04 <aslanb> Documentation: For users is in good shape.
01:14:05 <rtyler> jieryn: thanks for volunteering xD
01:14:17 <aslanb> Even a couple a books, training course. Better coverage.
01:14:23 <aslanb> Than the development of plugins.
01:14:30 <aslanb> Which what are we concerned about
01:14:37 <jieryn> there are jenkins books, there is jenkins $ training
01:14:38 <aslanb> Audience: Mainly the plugin one.
01:14:41 <aslanb> Yes it is lacking.
01:15:04 <aslanb> Audience: When should we write a plugin, if you do this is how you do it.
01:15:21 <aslanb> Audience: Very simple guidance, reference plugin, these are the interfaces.
01:15:34 <aslanb> Audience: A Workflow for making decisions in a development cycle.'
01:15:36 <aslanb> ?
01:15:53 <jieryn> i'll give you some credit here, the de facto plugin walk through is like 4 or 5 years old
01:16:04 <aslanb> Without getting to much into details, this kind of exists in the implemetnation of functioning code.
01:16:34 <aslanb> For popular extension points, directing developers to good example existing plugins could be a way.
01:16:58 <aslanb> Kohsuke2 knows the extension points cause he wrote them.
01:17:22 <jieryn> there already exists a wiki page which shows every plugin which implements every extension point
01:17:28 <aslanb> Audience: How are devs to konw?
01:17:31 <jieryn> and it automatically generated, so .. it shouldn't be out of date
01:17:36 <kohsuke2> #idea maybe a reverse map of the "extension point list" wiki page
01:17:46 <rtyler> jieryn: there's the issue of knowing which implementation point maps to a visual thing in the UI
01:18:01 <jieryn> nod
01:18:05 <aslanb> I think some level of curation is useful.
01:18:14 <rtyler> #action kohsuke to look into building a reverse mapping for extension points
01:18:40 <aslanb> Some stuff could be crowd sourced?
01:18:52 <jieryn> save yourself some effort, https://wiki.jenkins-ci.org/display/JENKINS/Extension+points already does this :)
01:19:03 <kohsuke2> (aslanb is transciribing conversations in the room)
01:19:03 <aslanb> Audience: Something to point a Newbie to standards.
01:19:23 <aslanb> Audience: Something you could do as a sample project, Maintain some maven archetypes.
01:19:24 <rtyler> jieryn: think more visual
01:19:43 <rtyler> jieryn: there's an issue of mapping something you see the Violations plugin adding to a page, and the extension point needed
01:19:55 <EricL> I wonder what percentage of Jenkins users write plug ins.
01:19:55 <kohsuke2> #idea skeleton code generation for more extensions (ala jenkins.rb)
01:19:57 <aslanb> Audience: A easy solution, "If you want to do this way" point people to reference solutions.
01:20:18 <jieryn> rtyler: roger
01:20:31 <aslanb> Site map, for example based on a page, point to the code that needs manipulation.
01:20:32 <kohsuke2> #idea code generation hooked up in the UI --- "click this button if you add stuff here"
01:20:42 <aslanb> The problem is the lack of automation around that stuff.
01:21:05 <rtyler> hare_brain dropped the H-bomb
01:21:07 <rtyler> no bueno
01:21:07 <kohsuke2> ... that generates the new skeleton
01:21:25 <aslanb> Context menu in jenkins that could generate skeleton from existing code.
01:21:39 <aslanb> Kohsuke2 had begun a prototype of this type of thing.
01:21:51 <aslanb> However, some extension points are not tied to any UI.
01:21:53 <rtyler> #action kohsuke to talk more and open up his prototype extension point thingie
01:22:11 <aslanb> Those not focused on the UI, probably have deeper knowledge already.
01:22:32 <aslanb> If someone would like to develop a training course, Kohsuke2 is willing to work with you.
01:22:45 <aslanb> The motivation has been lacking obviously.
01:23:16 <aslanb> Audience: IS there any thought of getting a code review in process, stimulating comments.
01:23:39 <aslanb> Its a good idea, however not currently being done.
01:23:52 <rtyler> #topic How can we improve the stable releases
01:24:04 <aslanb> What can we do?
01:24:12 <aslanb> Increase and improve testing.
01:24:34 <aslanb> Audience: We saw issue in loading build history, when there are more than 20.
01:24:52 <aslanb> We aren't getting much feedback currenly
01:25:01 <jieryn> we ought to have plugin developers strive for validating their plugins, and then updating their requiredCore, to the latest LTS -- lets see real drive from the community to bump up their plugins and validate!! https://wiki.jenkins-ci.org/display/JENKINS/Plugin+Report+Card
01:25:19 <aslanb> We pick the candidates based on feedback and early usage in larger orginizations.
01:25:46 <aslanb> The perception could be that the newest release broke it, however it might be an intermediate.
01:26:03 <aslanb> Short of more automated testing, probably need more people in effort.
01:26:30 <aslanb> Audience: Question of releases, what is important to community, you asked us for survey.
01:26:33 <jieryn> eclipse has the concept of a release train where tons of plugins hop on board, we ought to do that with LTS
01:26:38 <aslanb> Audience: What is the strategy for what gets done?
01:26:58 <aslanb> How do we decide what gets done.
01:27:03 <aslanb> Audience: Process is unclear.
01:27:04 <aslanb> Fair
01:27:06 <abayer> jieryn: I agree. I try to do that with at least some of mine, but I'm not good enough.
01:27:24 <aslanb> Small group that commit to core, it is what is important to them.
01:27:33 <jieryn> it is hard.
01:27:35 <aslanb> The rest of the community contributes plugins.
01:27:52 <aslanb> People report bugs, they get voted on, however does not translate to priority.
01:28:01 <aslanb> Best solution, is fix it yourself, and contribute it back.
01:28:16 <aslanb> Audience: We try do, however sometimes all we can do is make noise.
01:28:22 <aslanb> The survey was great last year.
01:28:29 <aslanb> We made UI improvements base on it.
01:29:06 <aslanb> We should start adding to the project meeting. (Currently its about processing the momemtum of the community)
01:29:09 <rtyler> #idea part of the project meeting should maybe address "project management" in a sense of what is prioritized, etc
01:29:16 <aslanb> Maybe we should add dedicated project management.
01:29:27 <aslanb> Audience: Ok with how it is.
01:29:42 <kohsuke2> #info to have your voice heard into what gets implemented, 1) fill in the survey 2) vote on issues
01:29:45 <aslanb> However what you are talking about is fair, we don't currently have a good mechanism, beyond this IRC.
01:30:09 <aslanb> We need more feedback to make prioritization.
01:30:35 <aslanb> Make it into an interesting bug and then push it.
01:31:16 <aslanb> Plugin developers can get prioritization because of the downstream communities of the plugin developers.
01:31:36 <aslanb> Do other open source projects have project managers?
01:32:21 <aslanb> We have a mailing list, we could send out what issues are being looked at in the short term by core team, illicit feedback before work is done,.
01:32:32 <aslanb> We talk about core team, it is really a federated group of people.
01:32:37 <lifeless> aslanb: ITYM elicit
01:32:40 <pradeepto> aslanb: #info some have module maintainers. KDE for example has a module maintainers.
01:32:45 <lifeless> aslanb: illicit being rather different ;)
01:32:50 <EricL> Federated band of misfits + cloudbees = new code
01:33:44 <aslanb> The challenge, as a developer, you are focused on problem.
01:33:57 <rtyler> #idea perhaps we should send out a bi-weekly report of what is being focused on, or at least being considered for future releases
01:34:02 <aslanb> But then you go do your thing, how do you get the knowledge back to the community.
01:34:06 <rtyler> the #topic is way off right now, oh wells
01:34:11 <kohsuke2> #info so far according to the running tally of the survey, documentation, examples, and quality does come high
01:34:18 <kohsuke2> they are the top two
01:34:25 <aslanb> As people got on the team, write a wiki about something your learning.
01:34:45 <aslanb> Maybe the plugin developers could do this.
01:34:50 <aslanb> Crowd source documenation.
01:34:50 <rtyler> #idea encourage plugin developers to document as they learn things in the core/extension points
01:35:04 <aslanb> However the adoption of this technique, didn't quite happen.
01:35:32 <aslanb> Maybe people are unsure of their own work in the plugin, so spreading it isn't a good idea (or at least as thought of as good idea)
01:35:34 <dapak> just a random note about commenting / docblocks in jenkins core — it could be a lot better, at least that's my initial observation from poking around in core
01:35:47 <abayer> I've written all of one piece of decent documentation - https://wiki.jenkins-ci.org/display/JENKINS/Gradle+JPI+Plugin
01:35:50 <aslanb> Maybe we just start writing documenation (good or bad), then fix it if you need to.
01:35:54 <abayer> And that's no better than decent.
01:36:06 <aslanb> You are encouraged to fail fast.
01:36:07 <dapak> some functions aren't doced, some are, what standards there are appear to be all over the place
01:36:10 <aslanb> Even in your docs.
01:36:13 <aslanb> Then fix it.
01:36:34 <aslanb> Maybe that is the way to do it.
01:36:38 <rtyler> #topic next meeting
01:37:10 <aslanb> Some of the highlights: 90% people consider it mission critical.
01:37:27 <rtyler> #idea I suggest October 10th
01:38:00 <aslanb> Jenkin survey stats...
01:38:16 <aslanb> We will get to the details when the survey is finished.
01:38:17 <kohsuke2> #topic next meeting time
01:38:31 <kohsuke2> Oct 19th Wednesday
01:38:39 <rtyler> Oct 17th
01:38:58 <rtyler> #agreed Oct 17th 2012, next meeting
01:39:07 <kohsuke2> #endmeeting