#jenkins Meeting

Meeting started by kohsuke at 19:03:41 UTC (full logs).

Meeting summary

    1. https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda (kohsuke, 19:04:00)

  1. recap of actions (kohsuke, 19:04:48)
    1. http://meetings.jenkins-ci.org/jenkins/2012/jenkins.2012-01-25-19.00.html (kohsuke, 19:04:52)
    2. my apologies about the SSL certs. renewal of SSL certificates is in progress, pending approval from rtyler (the domain contact) (kohsuke, 19:05:54)

  2. Pull requests and inbound contributor funnel discussion (kohsuke, 19:08:45)
    1. I've actually been meaning to go through the org teams and repos and (a) update the teams to reflect the contributors (including people with multiple pull requests) of the teams and tie the teams to repos more accurately and narrowly. (abayer, 19:11:40)
    2. https://wiki.jenkins-ci.org/display/JENKINS/Pending+Pull+Requests (hare_brain, 19:17:21)
    3. the same list in 2011 Sep https://wiki.jenkins-ci.org/pages/viewpage.action?pageId=58002442 (kohsuke, 19:19:53)
    4. ACTION: kohsuke to improve the pending pull request list generator to also post comments on old pull requests (kohsuke, 19:35:48)
    5. IDEA: Mark plugin projects with maintained/abandoned status to set expectation of how long a pull request may be outstanding (hare_brain, 19:43:33)
    6. IDEA: Track list of who are potential reviewers for a pull request (hare_brain, 19:43:57)
    7. IDEA: Use a tool like Gerrit to do automatic validation and merge after pull requests have been outstanding for X days (hare_brain, 19:44:32)

  3. Hosted Maven repository (kohsuke, 19:45:18)
    1. so if anyone is willing to volunteer with PoC, you'd be very welcome (kohsuke, 19:49:29)
    2. ACTION: kohsuke to check if rtyler is willing to spend some time doing hosted artifactory PoC (kohsuke, 19:51:41)

  4. next meeting time (but really, this is just a formality) (kohsuke, 19:53:59)
    1. AGREED: next meeting is 2/22, the same time (kohsuke, 19:55:17)
    2. ACTION: jieryn to follow ask cafepress if they discount for non-profits (hare_brain, 19:58:49)
    3. ACTION: ndeloof jieryn to confirm cloudbees foss requirements for sponsor logo (hare_brain, 19:59:06)


Meeting ended at 19:59:44 UTC (full logs).

Action items

  1. kohsuke to improve the pending pull request list generator to also post comments on old pull requests
  2. kohsuke to check if rtyler is willing to spend some time doing hosted artifactory PoC
  3. jieryn to follow ask cafepress if they discount for non-profits
  4. ndeloof jieryn to confirm cloudbees foss requirements for sponsor logo


Action items, by person

  1. kohsuke
    1. kohsuke to improve the pending pull request list generator to also post comments on old pull requests
    2. kohsuke to check if rtyler is willing to spend some time doing hosted artifactory PoC
  2. ndeloof
    1. ndeloof jieryn to confirm cloudbees foss requirements for sponsor logo
  3. rtyler
    1. kohsuke to check if rtyler is willing to spend some time doing hosted artifactory PoC


People present (lines said)

  1. kohsuke (95)
  2. hare_brain (46)
  3. abayer (24)
  4. imod (6)
  5. Slide-O-Mix (5)
  6. ndeloof (4)
  7. robobutler (2)
  8. orrc (2)
  9. DarkRift (2)
  10. vjuranek (2)
  11. jenkins-admin (1)
  12. monkeysmuggler (1)
  13. rtyler (0)


Generated by MeetBot 0.1.4.