19:01:36 <kohsuke> #startmeeting
19:01:36 <robobutler> Let the Jenkins meeting commence!
19:01:48 <kohsuke> #chair hare_brain rtyler
19:01:48 <robobutler> Current chairs: hare_brain kohsuke rtyler
19:01:59 <rtyler> #chair abayer
19:01:59 <robobutler> Current chairs: abayer hare_brain kohsuke rtyler
19:02:09 <rtyler> #info agenda: https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-Nov30thMeeting
19:02:14 <Creeture> kohsuke: This enough of a trace? Shit - don't start the meeting yet. :) https://gist.github.com/1410322
19:02:16 <rtyler> #topic Recap last meeting action items
19:02:30 <rtyler> this is kohsuke, kutzi and vjuranek
19:02:33 * rtyler steps back
19:02:48 <kohsuke> I think I created the board alias
19:02:57 <rtyler> #info last meeting notes http://meetings.jenkins-ci.org/jenkins/2011/jenkins.2011-11-09-19.00.html
19:02:57 <kohsuke> I'll double check and do so during this meeting if I haven't
19:03:18 <kohsuke> Contacting SPI, still TODO.
19:03:28 <kohsuke> LTS RC has been respined
19:03:57 <kohsuke> And I did get the report of failing tests from hare_brain but I don't think I did from imod, kutzi, and Majost
19:04:22 <imod> I reported to you, that I was not able to reproduce these
19:04:31 <kohsuke> Ah, that's right. my bad.
19:04:44 <kohsuke> And for vjuranek, 1.424 LTS test wiki page is https://wiki.jenkins-ci.org/display/JENKINS/LTS+1.424.x+RC+Testing
19:05:14 <kohsuke> I also wonder if abayer had heard back from GitHub about a private repository to host CLAs?
19:05:18 <vjuranek> yup, wiki created, test done
19:05:27 <kohsuke> (technically it's not listed in this action items)
19:05:35 <abayer> kohsuke: Ack, yes, I did. ksawicki had another suggestion, but I forgot to reply. Will pick that up again.
19:05:43 <kohsuke> cool
19:05:49 <rtyler> abayer: #action for this meeting then?
19:06:11 <abayer> 'k
19:06:44 <rtyler> ...
19:06:52 <abayer> Sorry, doing like five things at once. =)
19:06:53 <kohsuke> #action abayer to pick up GitHub private repository conversation for CLA
19:06:57 <rtyler> heh
19:06:59 <rtyler> abayer: noted
19:07:07 <kohsuke> I think that's it for the actions
19:07:20 <kohsuke> #topic infra update from rtyler
19:07:42 <rtyler> so
19:07:43 <rtyler> where to start
19:07:55 <rtyler> #info Tonight there will be an hour or so downtime of cucumber.jenkins-ci.org
19:08:03 <rtyler> which is because the NIC and riser card arrived
19:08:14 <rtyler> which means we'll be getting proper automated offsite backups of that machine being done
19:08:22 <rtyler> instead of the ad-hoc crap I'm doing currently <_<
19:08:38 <kohsuke> yay
19:08:49 <rtyler> #info After backups are running, we need to perform another major downtime of cucumber.jenkins-ci.org to do an OS upgrade
19:09:11 <rtyler> we're currently using a version of Ubuntu that's not even under LTS anymore, which is bad news bears
19:09:48 <rtyler> #info I (rtyler) have started discussions with Contegix to spin off the hosting account for cucumber off of my personal account with Contegix
19:09:54 <rtyler> which would be owned by the SPI
19:10:11 <rtyler> I think that's it, any infra questions I can answer before we move on?
19:10:31 <imod> any more mirrors needed?
19:10:53 <rtyler> not as far as I can tell, if we need more it might be to increase the mix of european mirrors
19:11:02 <rtyler> we had some hiccups with our german mirror recently
19:11:12 <rtyler> not /pressing/, it fits under "nice to have" :)
19:11:22 <orrc> does anyone have an update on the infra-fundraiser?
19:11:33 <rtyler> kohsuke: want to speak to that?
19:11:37 <imod> ok, if so just screen :)
19:11:54 <kohsuke> orrc: let me check
19:12:09 <kohsuke> I don't think we've received any additional donation for a while
19:12:29 <kohsuke> So it's still more or less at $4040
19:12:32 <rtyler> #action rtyler to post a christmas donation beg-fest post to the blog
19:12:51 <rtyler> shall I continue?
19:13:01 <kohsuke> please
19:13:01 <rtyler> that fits somewhat with our next topic :)
19:13:09 <rtyler> #topic SCALE10x plans for Jenkins
19:13:31 <rtyler> #info Jenkins has been allowed to be an exhibitor at SCALE 10x on Jan 20-22 http://www.socallinuxexpo.org/scale10x/jenkins-ci
19:13:49 <rtyler> #info SCALE is the Southern California Linux Expo, it's a very large expo and conference in LA
19:14:04 <rtyler> we don't really have any "booth gear"
19:14:21 <rtyler> we will get a table though
19:14:29 <rtyler> so we can set up just about whatever to show off
19:14:43 <rtyler> oh
19:14:50 <rtyler> #info rtyler will be attending
19:14:52 <rtyler> :)
19:15:03 <kohsuke> #info I'll be attending too
19:15:09 <kohsuke> And I can bring stickers
19:15:25 <rtyler> I'm not sure if abayer or hare_brain will be able to attend
19:15:33 <rtyler> any other California Jenkins folks we can rope in?
19:15:46 <kohsuke> I guess we'll bring a computer as a demo machine?
19:16:07 <rtyler> well, if we road trip it, I have a couple extra computers I could bring and at least two extra monitors
19:16:21 <rtyler> a little demo cluster with maybe xfpanel plugin + builders would be neat :)
19:16:29 <kohsuke> sounds fun
19:16:42 <rtyler> last year connectivity to the booths was *good* but it'll be better to be prepared if it's not
19:16:44 <hare_brain> I cannot go that weekend.
19:17:12 <kohsuke> I think we need a blog post about this to solicit other so-cal people to join us
19:17:24 <rtyler> #action rtyler to work out potential road-trip/carpool plans for Bay Area people
19:17:29 <hokatichenci> will there be any jenkins talks?
19:17:47 <rtyler> hokatichenci: unfortunately not, the CFP ended shortly after they invited us :P
19:17:53 <Majost> Where in LA is this?
19:17:59 <rtyler> Majost: right outside of LAX
19:18:15 <rtyler> #action rtyler to write blog post to solicit California Jenkins people to join us at SCALE
19:18:22 <Majost> Nice! So it's right next to my offices!
19:18:34 <rtyler> #info Majost has been volunteered as well
19:18:50 <kohsuke> Maybe we can plan some get-together as well?
19:18:52 <Majost> haha
19:19:03 <rtyler> kohsuke: another CI Dinner? :)
19:19:07 <kohsuke> yeah
19:19:11 <rtyler> might be difficult, there's stuff going on all the nights really
19:19:17 <rtyler> saturday night is the keysigning party IIRC
19:19:17 <Majost> Count me in
19:19:19 <rtyler> and other drinks
19:19:32 <Majost> I know of some good places for beers too.
19:19:42 <rtyler> #action kohsuke to ponder a CI Dinner or something along those lines for SCALE
19:19:52 <kohsuke> great
19:19:57 <rtyler> may I move on?
19:20:01 <kohsuke> yeah
19:20:07 <rtyler> #topic Jenkins at FOSDEM 2012
19:20:21 <rtyler> #info FOSDEM is a big deal
19:20:42 <rtyler> #info Deadline to apply for a table at FOSDEM is Dec. 13th
19:20:52 <rtyler> #info Deadline for lightning talks at FOSDEM is Dec. 13th
19:21:21 <rtyler> #info Many of the devrooms are currently soliciting for speakers/presentations right now http://www.fosdem.org/2012/devrooms_for_2012
19:21:27 <rtyler> z00dax6: pipe up :)
19:21:37 <rtyler> aheritier: you're also going to FOSDEM yes? :)
19:21:45 <jenkinsci_builds> Project jenkins_main_trunk build #1,330: UNSTABLE in 1 hr 10 min: http://ci.jenkins-ci.org/job/jenkins_main_trunk/1330/
19:21:46 <jenkinsci_builds> Kohsuke Kawaguchi: [FIXED JENKINS-11714] Fixed the problem in the find command operator priority.
19:22:02 <jenkinsci_builds> Starting build 1,331 for job jenkins_main_trunk (previous build: UNSTABLE -- last SUCCESS #1329 17 hr ago)
19:22:06 <hare_brain> Ssh. We're in a meeting.
19:22:29 <rtyler> jenkinsci_builds and I are the only ones saying anything , does that count as a meeting? :)
19:22:42 <imod> I'll come too, if you think I'll be of any help
19:22:50 <orrc> I should be at FOSDEM
19:22:57 <kohsuke> I wonder if kutzi, drulli, gboissinot, etc might be interested in talking
19:23:05 <z00dax6> rtyler: Fosdem tends to be a good place to engage with people who are in turn doing development work on open source projects.
19:23:06 <kohsuke> or orrc :-)
19:23:08 <rtyler> imod: I think going to FOSDEM is it's own reward, regardless of whether we do anything :)
19:23:21 <rtyler> okay, how about this
19:23:27 <z00dax6> and there will be a fair few people there, it might actually be the largest open source centric, non commercial get together anywhere
19:23:38 <rtyler> I propose we apply for a Jenkins stand at FOSDEM
19:23:41 <drulli> I'm sorry, but I can't attend
19:23:48 <z00dax6> having a Jenkins specific talk would definitely be good
19:24:29 <imod> rtyler: ok, so count me in :)
19:24:45 * rtyler speaks up a bit
19:24:47 <rtyler> I propose we apply for a Jenkins stand at FOSDEM
19:24:48 <abayer> When/where is FOSDEM specifically?
19:24:58 <rtyler> abayer: 4-5 Feb. Brussels
19:25:13 <rtyler> #info FOSDEM 2012 is Feb 4-5th in Brussels, Belgium
19:25:31 <z00dax6> ( which is a weekend )
19:25:32 <abayer> 'k. I think I have coworkers going, but I'm probably traveled out. I'll check if I can get cloudera to pay, though. If so… =)
19:25:56 <rtyler> kohsuke: I think meetbot needs a #poll action
19:26:05 <rtyler> I PROPOSE WE APPLY FOR A JENKINS STAND AT FOSDEM
19:26:12 <z00dax6> rtyler: go for it :)
19:26:13 * rtyler pokes all the euros
19:26:28 <abayer> Sounds good to me, assuming we can get at least a few people willing to take turns manning it. =)
19:26:33 <rtyler> exactly
19:26:35 <kohsuke> Yeah, I think we need someone in Europe to drive it.
19:27:06 <rtyler> if I'm flying in, then I will only be able to bring one extra laptop for display purposes
19:27:23 <rtyler> which means having somebody local to help man the booth and set up demos would be valuable
19:27:37 <imod> sure I'll helpout
19:27:40 <rtyler> kohsuke: can you ping some of the cloudbees in europe to see if they'll join in?
19:27:47 <rtyler> ndeloof seems fun :)
19:27:59 <kohsuke> #action kohsuke to write to a few contacts to see if they'd be willing
19:28:04 <rtyler> #action rtyler to apply for a Jenkins stand at FOSDEM
19:28:27 <rtyler> alright, I give up, next topic :)
19:28:30 <rtyler> all you kohsuke
19:28:32 <kohsuke> I wonder if another call for help post for this is in order, similar to SCALE 10x
19:28:39 <kohsuke> aye
19:28:46 <rtyler> #action rtyler to write blog post for help with FOSDEM
19:28:55 * rtyler is racking up the action items :/
19:29:03 <kohsuke> #topic Jenkins CIA program
19:29:42 <kohsuke> So one of the lessons for me (and I've heard from others in the CB booth as well) during JavaOne is that there are many people still haven't heard about Jenkins
19:30:07 <kohsuke> So people suggested that we should do some evangelism effort
19:30:51 <kohsuke> And around the same time, I got the extra Jenkins stickers and people seem to like those
19:31:02 <abayer> ooo, I need those.
19:31:04 <imod> my daily business at work :)
19:31:04 <tbb> I would gladly help but I'm not exactly a Jenkins guru and therefore not really useful
19:31:05 <rtyler> heh
19:31:15 <rtyler> tbb: guru status not necessary
19:31:42 <kohsuke> So one of the idea that's tossed around is to help non-gurus in the community to spread the words by arming them with ...
19:32:05 <rtyler> guns
19:32:07 <rtyler> lots of guns
19:32:08 <tbb> STICKERS \o/
19:32:13 <kohsuke> some standard slide deck that they can use to introduce Jenkins, we'll send stickers so that they can hand them out, and
19:32:22 <kohsuke> maybe a T-shirt for the person himself
19:32:34 <rtyler> #info CIA == CI Ambassador
19:32:47 <kohsuke> rtyler said OpenSUSE does something like this and call it street teams
19:32:55 <imod> my company has about 3000 dev's and not too many know CI yet…. this would definitely help
19:32:57 <kohsuke> pelegri told me that OpenSolaris used to do this, too.
19:32:58 <rtyler> openSUSE actually calls them ambassadors
19:33:09 <kohsuke> Oh, then CIA is perfect
19:33:14 <rtyler> #info openSUSE has a very good model (IMHO) to check out for their Ambassador program
19:33:31 <rtyler> #info the openSUSE Greek Ambassador community is of particular interest
19:33:37 <kohsuke> Yeah, I thought CIA with a fake Central Intelligence Agency logo would be fun
19:33:49 <z00dax6> the ambassadors programs in various linux distro's has been a hit/miss situation - but it definitely gives people the sense of involvement, and they have a specific agenda and purpose
19:33:51 <b2jrock> A standard slide deck would also help for introducing Jenkins within a company.
19:33:53 <hare_brain> Put dark glasses and an earpiece on the butler.
19:33:54 <kohsuke> We can have a world map with pins showing which cities have been conquered
19:34:05 <rtyler> heh
19:34:18 <rtyler> the CIA name has certainly grown on me since you first pitched it kohsuke
19:34:21 <rtyler> hare_brain: I like that idea
19:34:28 <kohsuke> b2jrock: totally
19:34:46 <imod> the CIA logo is not as good known in europe though
19:34:55 <rtyler> #action a standard "intro to jenkins" slide deck should be created
19:35:04 <kohsuke> So I guess I was curious whether some people here would be willing to be our CIA agent if we do all those
19:35:20 <kohsuke> The idea is to go to some local meetups and present Jenkins, and we'll help
19:35:23 <rtyler> I'm willing to help organize such a program as part of my regular evangelism duties
19:35:32 <imod> sure I would
19:35:54 <rtyler> kohsuke: why don't we plan/prepare this stuff during Dec.
19:36:01 <rtyler> then try to launch the program in 2012 before SCALE
19:36:15 <kohsuke> sure
19:36:25 <rtyler> slide deck, X many stickers and blammo you're part of the CIA
19:36:33 <imod> keep us unto date and let us know if you need help
19:36:39 <hare_brain> No background check? ;)
19:36:41 <rtyler> maybe t-shirts for those who organize meetups or go speak at UGs?
19:36:53 <aheritier> @rtyler : not yet sure but I will try
19:37:35 <kohsuke> Yes, I'll check with the usual sponsor.  I think agent only T-shirts would be a great incentive
19:38:09 <kohsuke> #action rtyler, kohsuke, and imod to try to plan/prepare the program during Dec, before SCALE
19:38:14 <kohsuke> I think that's it on this.
19:38:21 <kohsuke> moving on
19:38:22 <rtyler> \o
19:38:31 <Majost> What help do you need for SCALE?
19:38:37 <rtyler> Majost: we'll discuss later
19:38:40 <Majost> np
19:38:45 <kohsuke> #topic LTS
19:38:53 * rtyler pokes vjuranek
19:38:57 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/LTS+1.424.x+RC+Testing
19:39:13 <vjuranek> so, from my point of view tests are done, we can release 1.424.1
19:39:31 <kohsuke> +1
19:39:39 <kohsuke> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/nMg36fR_QFA
19:39:42 <swankier> hi there.  I just setup a rather complex project that has many intermodule dependencies.  Often times downstream projects will fail to compile without any code changes in them.  No blame emails get sent, and the console (while it has the compile message) has no commit information.
19:39:47 <vjuranek> as I mentioned on dev list, other backports should IMHO go to 1.424.2
19:39:52 <hare_brain> +1
19:40:05 <imod> +1
19:40:13 <rtyler> swankier: we're right in the middle of a meeting, give us a few minuts to finish this off
19:40:40 <imod> ….if we get pull 316 into 1.424.2 :)
19:40:56 <kohsuke> OK, so I think we have a consensus for 1.424.1. It's a GO
19:41:18 <swankier> yessir
19:41:24 <kohsuke> Any objections?
19:41:44 <rtyler> FIRE ZE MISSILES!
19:41:56 <kohsuke> #agreed 1.424.1 will ship as it is now, and other fixes will be in 1.424.2
19:42:22 <kohsuke> I haven't really read pull #316 yet, but does it have security implications beyond m2release?
19:42:38 <imod> no, its only for the m2release
19:42:44 <kohsuke> maybe I should contact James offline to understand it better
19:43:05 <imod> although it opens other possibilities for plugins too
19:43:08 <kohsuke> Because I believe we've been refraining from adding new APIs in LTS intentionally
19:43:22 <kohsuke> Anyway, I think I'm probably side tracking
19:43:28 <imod> I understand, but this one is really a bummer
19:43:34 <kohsuke> OK
19:43:52 <teilo_> (james is kicking around)
19:44:40 <kohsuke> teilo_:  if you can hang around for 10 more minues, maybe we can wrap up this meeting first and then talk about it?
19:44:43 <hare_brain> Settle on next meeting and wrap?
19:44:44 <teilo_> (offline is good - As I will want you to change hat also)
19:44:59 <kohsuke> teilo_:  ok, will do.
19:45:09 <kohsuke> hare_brain: yes
19:45:14 <kohsuke> #topic next meeting
19:45:24 <rtyler> one more before the new year!
19:45:45 <hare_brain> 14th?
19:45:54 <kohsuke> +1
19:46:06 <rtyler> I'm down
19:46:33 <kohsuke> #agreed next meeting will be Dec 14th, same time as this week
19:46:44 <kohsuke> and I think that's it.
19:46:47 <hare_brain> Looking at next year, if we go back to our original biweekly schedule, the first meeting would be on the 4th. Not sure everyone would be back by then.
19:47:10 <hare_brain> So it seems like we're on a new two-week schedule following today and the 14th, then probably the 11th is the first meeting of the new year.
19:47:19 * rtyler nods
19:47:34 <kohsuke> sounds good
19:47:40 <hare_brain> Everyone reset their recurring meetings. ;)
19:47:41 <rtyler> bring us home kk
19:48:06 <kohsuke> OK, thanks for everyone (and in particular vjuranek for the hard work on LTS)
19:48:11 <kohsuke> #endmeeting