#jenkins Meeting

Meeting started by kohsuke at 18:00:56 UTC (full logs).

Meeting summary

  1. Plugin deprecations https://wiki.jenkins-ci.org/display/JENKINS/Proposed+Plugin+Deprecation (kohsuke, 18:02:31)
    1. Ok, this one's my baby. We've got a bunch of plugins that do more or less the same thing, and that's causing confusion, duplication of effort, etc. (abayer, 18:03:06)
    2. IDEA: I propose we comb the plugin list to find possible duplications and when possible, deprecate older plugins in favor of newer ones providing the same functionality and possibly more. (abayer, 18:03:45)
    3. e.g., the ones that prompted this - envfile and setenv have all their behavior incorporated into envinject. (abayer, 18:04:16)
    4. IIUC the migration implementation in envinject plugin is quite transparent and also backward compatible (kohsuke, 18:07:32)
    5. AGREED: (rtyler, 18:09:06)
    6. ACTION: abayer to write up his proposal for deprecated plugin behavior in the update center on the wiki (abayer, 18:14:29)
    7. IDEA: Review deprecation implementation ideas next meeting? (abayer, 18:16:28)
    8. AGREED: Plugin deprecation is good. Implementation ideas are also good. Write 'em on the wiki, review 'em next week. (abayer, 18:17:33)

  2. Jenkins User Conference http://jenkins-ci.org/content/jenkins-user-conference (kohsuke, 18:19:48)
    1. IDEA: If we have a bit of time, I'd love to hear what kind of talks people want to hear (kohsuke, 18:20:43)

  3. olamy_ as owner on jenkinsci on github question (kohsuke, 18:27:15)
    1. IDEA: olamy_ should be added as an owner. (abayer, 18:27:28)
    2. AGREED: (rtyler, 18:27:39)
    3. AGREED: olamy's an owner....now! (abayer, 18:32:08)

  4. Trademark Registration Status (kohsuke, 18:33:11)
    1. so the ball started rolling between SPI and us (kohsuke, 18:33:28)

  5. Kohsuke wanted to discuss this (JENKINS-9488 - align topbar colors): https://github.com/jenkinsci/jenkins/pull/179 (kohsuke, 18:35:23)
    1. so there's a pending request to change the color of the top bar of Jenkins UI (kohsuke, 18:35:45)
    2. one point I'd like to make is that the current color came from the same palette that's used for all the other icons (kohsuke, 18:36:41)
    3. screenshot: http://postimage.org/image/2u9iq9v0k/ (kohsuke, 18:44:02)

  6. : When is it time to release a new LTS release? (kohsuke, 18:47:05)
    1. ACTION: Kohsuke to run his script to identify tickets that are (1) marked as critical and (2) reported fixed in the trunk (kohsuke, 18:53:03)
    2. AGREED: aiming 1.409.2 in 3-4 weeks, and then move to rebumping to 1.42x after that. (kohsuke, 19:02:24)

  7. next meeting time (kohsuke, 19:02:41)


Meeting ended at 19:04:52 UTC (full logs).

Action items

  1. abayer to write up his proposal for deprecated plugin behavior in the update center on the wiki
  2. Kohsuke to run his script to identify tickets that are (1) marked as critical and (2) reported fixed in the trunk


Action items, by person

  1. abayer
    1. abayer to write up his proposal for deprecated plugin behavior in the update center on the wiki


People present (lines said)

  1. kohsuke (103)
  2. abayer (50)
  3. rtyler (38)
  4. aheritier (29)
  5. kutzi (15)
  6. bap2000 (15)
  7. jieryn (14)
  8. olamy (8)
  9. vjuranek (8)
  10. myusuf3 (5)
  11. jenkins-admin (3)
  12. sjakubowski (3)
  13. olamy_ (3)
  14. harpreet (3)
  15. robobutler (2)


Generated by MeetBot 0.1.4.