#jenkins Meeting

Meeting started by kohsuke at 18:02:29 UTC (full logs).

Meeting summary

  1. How do we handle pull requests which are pending for a long time (kohsuke, 18:03:08)
    1. AGREED: the pull request bot should tell contributors that they just need to ask in the dev list to get the push access. (kohsuke, 18:17:38)
    2. IDEA: the bot can and should also make other comments, like "hey, I noticed that you don't have any tests for this patch -- see this page for how to write one" (kohsuke, 18:18:02)
    3. IDEA: another obvious one is "does this have a ticket in issues.jenkins-ci.org?" (kohsuke, 18:18:33)

  2. What is the current state of the 'The new EMailer': https://wiki.jenkins-ci.org/display/JENKINS/The+new+EMailer (kohsuke, 18:19:48)
    1. Originally back in 2009 August (kohsuke, 18:20:46)
    2. ACTION: kutzi to update the wiki page with the roadmap/plan for email-ext -> email2core with lots of extension points (rtyler, 18:34:21)

  3. : Infra update from R. Tyler Croy regarding new machines at the OSUOSL (kohsuke, 18:35:44)
    1. ACTION: z00dax6 to help get lettuce set up with some basic puppet manifests (rtyler, 18:40:32)
    2. ACTION: rtyler to properly set up access to lettuce for kohsuke, abayer and aheriter (rtyler, 18:40:52)
    3. Throttling crawlers to JIRA http://www.theserverside.com/discussions/thread.tss?thread_id=62375 (rtyler, 18:42:43)
    4. ACTION: rtyler to get off his lazy ass and finally order that second NIC for cucumber (rtyler, 18:43:21)
    5. ACTION: Kohsuke to write to SPI what it means for them to own assets --- any processes, steps, etc. (kohsuke, 18:45:31)
    6. ACTION: rtyler to start a thread on -dev detailing access rights, usage policy, etc for hardware (rtyler, 18:46:19)

  4. CLA discussion (kohsuke, 18:46:31)
    1. So the current plan on the record is here: https://wiki.jenkins-ci.org/display/JENKINS/Copyright+on+source+code (kohsuke, 18:46:46)

  5. next meeting time (kohsuke, 19:02:34)
    1. AGREED: next meeting time is June 20th, same time --- 2 weeks from now (kohsuke, 19:04:05)


Meeting ended at 19:05:20 UTC (full logs).

Action items

  1. kutzi to update the wiki page with the roadmap/plan for email-ext -> email2core with lots of extension points
  2. z00dax6 to help get lettuce set up with some basic puppet manifests
  3. rtyler to properly set up access to lettuce for kohsuke, abayer and aheriter
  4. rtyler to get off his lazy ass and finally order that second NIC for cucumber
  5. Kohsuke to write to SPI what it means for them to own assets --- any processes, steps, etc.
  6. rtyler to start a thread on -dev detailing access rights, usage policy, etc for hardware


Action items, by person

  1. kohsuke
    1. rtyler to properly set up access to lettuce for kohsuke, abayer and aheriter
  2. kutzi
    1. kutzi to update the wiki page with the roadmap/plan for email-ext -> email2core with lots of extension points
  3. rtyler
    1. rtyler to properly set up access to lettuce for kohsuke, abayer and aheriter
    2. rtyler to get off his lazy ass and finally order that second NIC for cucumber
    3. rtyler to start a thread on -dev detailing access rights, usage policy, etc for hardware
  4. UNASSIGNED
    1. z00dax6 to help get lettuce set up with some basic puppet manifests
    2. Kohsuke to write to SPI what it means for them to own assets --- any processes, steps, etc.


People present (lines said)

  1. kohsuke (114)
  2. rtyler (75)
  3. kutzi (36)
  4. magnayn (21)
  5. hare_brain (11)
  6. rpetti (4)
  7. drulli (3)
  8. vjuranek (3)
  9. cowboyd (1)
  10. nigjo (1)
  11. robobutler (1)
  12. bap2000 (1)


Generated by MeetBot 0.1.4.