#jenkins Meeting

Meeting started by kohsuke at 18:02:27 UTC (full logs).

Meeting summary

  1. logo contest status (kohsuke, 18:03:56)
    1. Tyler gave me access to the Google doc that has the results (kohsuke, 18:04:29)
    2. ACTION: rtyler to tally the result and get the the run-off going starting next Monday (kohsuke, 18:07:21)

  2. Trademark registration status (kohsuke, 18:09:17)
  3. SFC response / umbrella org (kohsuke, 18:11:05)
  4. CLA discussion continued (kohsuke, 18:15:56)
    1. ACTION: kohsuke to ask hare_brain to see if he can ask his lawyers about the implications of optional voluntary CLAs. (kohsuke, 18:19:56)

  5. Discussion on the way we can strengthen plugins and avoid unnecessary duplication/forks (kohsuke, 18:20:57)
    1. IDEA: Crowdsourcing a review of all existing plugins, to understand their capabilities/overlaps/etc. (abayer, 18:29:31)
    2. ACTION: abayer to create a wiki page for tracking which plugins have been reviewed, and directions on what to do for reviewing (tagging/labeling, etc) (abayer, 18:30:50)
    3. IDEA: add the license information to the banner (kohsuke, 18:31:49)
    4. IDEA: write a Wiki page that focus on "how to modify an existing plugin and get your change integrated" (kohsuke, 18:34:20)
    5. IDEA: ask the three examples why they started a new one. (via FunkyFis1) (kohsuke, 18:35:04)
    6. IDEA: what about also adding keywords to plugins to better find them? (via rseguy) (kohsuke, 18:39:13)
    7. IDEA: easing the access to source code for those poor guys (me...) with no svn/git access from work, e.g. by bundling a zip when a plugin is released (actually, by putting it more in emphasis compared to today) (rseguy, 18:41:33)
    8. ACTION: Kohsuke to tweak the maven-hpi-plugin to create source assembly during the plugin release (kohsuke, 18:43:28)
    9. IDEA: Help find/organize plugins by generating a list of plugins dynamically from the same info the "Manage Plugin" does in Jenkins and putting it in the wiki or next to the wiki. This could also verify that wiki pages exist and are filled out right. (docwhat, 18:43:41)
    10. IDEA: Add a search engine based on labels for plugins (rseguy, 18:44:33)
    11. IDEA: Plugin Quickstart Utility -- a simple utility that helps either get an existing plugin or creates a skeleton plugin and verifies environment is ready for development. (docwhat, 18:44:56)
    12. ACTION: write some sort of reporting tool allowing compile/test every plugins declared in update-center.json over lastly released jenkins version (fcamblor, 18:45:40)
    13. IDEA: could we have an 'unstable' update-center.json generated from the jenkins CI instance? My impression is people get keen to release very often so some patch/change can become visible for users.. (magnayn, 18:46:14)
    14. IDEA: Adding "contribute to this plugin" links with information on the plugin pages would be helpful as well. (via docwhat) (kohsuke, 18:49:50)
    15. IDEA: how about on the "Extending" wiki page we suggest that before starting a plugin, put suggestion out to dev and users mailing list for comment? (via bap2000) (kohsuke, 18:49:54)
    16. IDEA: Would it be possible to leverage the same code that the Plugin Manager uses to generate the list and pages for the wiki? (via docwhat) (kohsuke, 18:49:57)
    17. ACTION: write a proposal on how about on the "Extending" wiki page we suggest that before starting a plugin, put suggestion out to dev and users mailing list for comment? (via bap2000) (rseguy, 18:53:14)
    18. ACTION: write a proposal on Adding "contribute to this plugin" links with information on the plugin pages would be helpful as well. (via docwhat) (rseguy, 18:53:37)

  6. When will be the next meeting? (kohsuke, 18:54:12)
    1. AGREED: next meeting will be in the same time, two weeks from now. (kohsuke, 18:57:36)


Meeting ended at 18:58:30 UTC (full logs).

Action items

  1. rtyler to tally the result and get the the run-off going starting next Monday
  2. kohsuke to ask hare_brain to see if he can ask his lawyers about the implications of optional voluntary CLAs.
  3. abayer to create a wiki page for tracking which plugins have been reviewed, and directions on what to do for reviewing (tagging/labeling, etc)
  4. Kohsuke to tweak the maven-hpi-plugin to create source assembly during the plugin release
  5. write some sort of reporting tool allowing compile/test every plugins declared in update-center.json over lastly released jenkins version
  6. write a proposal on how about on the "Extending" wiki page we suggest that before starting a plugin, put suggestion out to dev and users mailing list for comment? (via bap2000)
  7. write a proposal on Adding "contribute to this plugin" links with information on the plugin pages would be helpful as well. (via docwhat)


Action items, by person

  1. abayer
    1. abayer to create a wiki page for tracking which plugins have been reviewed, and directions on what to do for reviewing (tagging/labeling, etc)
  2. bap2000
    1. write a proposal on how about on the "Extending" wiki page we suggest that before starting a plugin, put suggestion out to dev and users mailing list for comment? (via bap2000)
  3. docwhat
    1. write a proposal on Adding "contribute to this plugin" links with information on the plugin pages would be helpful as well. (via docwhat)
  4. kohsuke
    1. kohsuke to ask hare_brain to see if he can ask his lawyers about the implications of optional voluntary CLAs.
  5. rtyler
    1. rtyler to tally the result and get the the run-off going starting next Monday
  6. UNASSIGNED
    1. Kohsuke to tweak the maven-hpi-plugin to create source assembly during the plugin release
    2. write some sort of reporting tool allowing compile/test every plugins declared in update-center.json over lastly released jenkins version


People present (lines said)

  1. kohsuke (106)
  2. rseguy (37)
  3. rtyler (20)
  4. fcamblor (13)
  5. kutzi (11)
  6. docwhat (10)
  7. abayer (8)
  8. magnayn (5)
  9. bap2000 (5)
  10. redsolo (3)
  11. mjmac_ (2)
  12. robobutler (2)
  13. FunkyFis1 (1)
  14. Creeture (1)
  15. jpederzolli (1)
  16. choas (1)


Generated by MeetBot 0.1.4.