#jenkins Meeting

Meeting started by abayer at 19:04:03 UTC (full logs).

Meeting summary

    1. we should really have an agenda :) (mwalling, 19:04:38)

  1. JIRA - project reorganization and bug triage? (abayer, 19:05:05)
    1. So a while back, I pushed the idea of separating plugins from core in JIRA, so that we could actually use fix versions on core at the very least. This never got done, because I, well, never did it. (abayer, 19:05:42)
    2. The subject has come up again on the mailing list and seems to have a lot of support. (abayer, 19:05:59)
    3. For starters, I think we're only talking about one project for Jenkins core, one project for Jenkins plugins, one project for Jenkins infrastructure. Eventually, a separate project for some individual plugins may make sense, but that's a *lot* of work to get going right off the bat. (abayer, 19:07:41)
    4. IDEA: Split into three projects to start (core, plugins, infra), see how that goes, and then review after a couple months to see if we want to start moving on plugins getting their own projects, etc. (abayer, 19:11:25)
    5. IDEA: addendum - SECURITY project remains as is. (abayer, 19:12:13)
    6. AGREED: Three-way split of JENKINS into core/plugins/infra, to be coordinated with volunteer help 'cos we have limited time. =) (abayer, 19:13:15)
    7. We have a verified status in JIRA. This is there basically just because java.net's Issuezilla setup had it, and so when I did the migration, I added verified so that we didn't have to mess with bug status. (abayer, 19:13:58)
    8. Verified is not really useful, and is in fact kind of confusing. (abayer, 19:14:30)
    9. That just makes the question of how to determine when a bug goes from resolved to closed even hairier. (abayer, 19:14:50)
    10. IDEA: Move all bugs in Verified -> Closed (automated process to do this) and nuke the Verified status. (abayer, 19:15:40)
    11. AGREED: Kill Verified. (abayer, 19:16:15)
    12. ACTION: abayer to kill verified. (abayer, 19:16:21)
    13. ACTION: abayer specifically to kill verified by next Monday. (abayer, 19:16:42)
    14. IDEA: There's ambiguity as to how/when a bug goes from resolved->verified. (abayer, 19:17:34)
    15. I am dumb. (abayer, 19:17:41)
    16. resolved->closed, info not idea. (abayer, 19:17:47)
    17. IDEA: A fairly simple workflow: when the developer fixes the bug (so far as they know), state goes to resolved. When the reporter verifies the bug is fixed, state goes to closed. (abayer, 19:20:24)
    18. IDEA: If the reporter finds the bug is still there, state->reopen. (abayer, 19:20:58)
    19. IDEA: When developer pushes code to fix the bug, state goes to resolved. When the code gets released, state goes to closed. If the bug persists, the state goes back to reopened. (abayer, 19:24:06)
    20. ACTION: abayer to make sure our JIRA setup allows reopening closed bugs. (abayer, 19:24:23)
    21. IDEA: addendum - [FIXED JENKINS-XYZ] in commit message will switch the state on build in ci.jenkins-ci.org to resolved, and will switch the state to closed on plugin release - will require tweaks to hpi plugin, but should be doable. (abayer, 19:25:34)
    22. IDEA: allow the [FIXED ... regex to also match [FIXES (mwalling, 19:27:18)
    23. ACTION: abayer to modify the ci.jenkins-ci.org JIRA integration to look for [FIXES …] or [FIXED …]. (abayer, 19:28:27)
    24. ACTION: addendum - or [FIX …] But that's it! (abayer, 19:29:05)
    25. IDEA: (clarification - auto resolved->closed to happen on core release as well) (abayer, 19:29:36)
    26. AGREED: The above idea on JIRA workflow going forward. (abayer, 19:32:06)
    27. IDEA: Mark all bugs in resolved state that entered resolved state at least 6 months ago as closed? (abayer, 19:32:31)
    28. AGREED: That thing I just said - closing all >6 months resolved bugs. (abayer, 19:34:15)
    29. ACTION: abayer to close all bugs resolved >6 months ago. (abayer, 19:34:28)
    30. IDEA: post these meetings on the website calendar (tom_huybrechts, 19:37:45)
    31. IDEA: and a preliminary agenda attached to it (redsolo, 19:38:17)
    32. AGREED: We just dropped the ball on the agenda again. =) (abayer, 19:38:43)
    33. ACTION: rtyler to do better on agenda. (abayer, 19:38:54)
    34. IDEA: Next meeting, 11am PST (7pm GMT, 8pm CET) next Wednesday (Feb 16)? (abayer, 19:41:53)


Meeting ended at 19:47:51 UTC (full logs).

Action items

  1. abayer to kill verified.
  2. abayer specifically to kill verified by next Monday.
  3. abayer to make sure our JIRA setup allows reopening closed bugs.
  4. abayer to modify the ci.jenkins-ci.org JIRA integration to look for [FIXES …] or [FIXED …].
  5. addendum - or [FIX …] But that's it!
  6. abayer to close all bugs resolved >6 months ago.
  7. rtyler to do better on agenda.


Action items, by person

  1. abayer
    1. abayer to kill verified.
    2. abayer specifically to kill verified by next Monday.
    3. abayer to make sure our JIRA setup allows reopening closed bugs.
    4. abayer to modify the ci.jenkins-ci.org JIRA integration to look for [FIXES …] or [FIXED …].
    5. abayer to close all bugs resolved >6 months ago.
  2. rtyler
    1. rtyler to do better on agenda.


People present (lines said)

  1. abayer (80)
  2. redsolo (22)
  3. jieryn-w (21)
  4. mwalling (16)
  5. hare_brain (12)
  6. larrys (9)
  7. rtyler (8)
  8. aheritier (6)
  9. wolfs (6)
  10. tom_huybrechts (5)
  11. fabrice31 (4)
  12. robobutler (2)
  13. hsoj (1)
  14. kutzi (1)
  15. banoss (1)
  16. freddy33 (1)


Generated by MeetBot 0.1.4.