18:03:46 <oleg-nenashev> #startmeeting
18:03:47 <robobutler> Let the Jenkins meeting commence!
18:04:00 <oleg-nenashev> #topic Jenkins Roadmap updates
18:04:24 <oleg-nenashev> #info Jenkins public roadmap JEP is published: https://github.com/jenkinsci/jep/tree/master/jep/14
18:04:42 <Slide-O-Mix> oleg-nenashev: Just want to mention what an awesome job you've done on the roadmap stuff, it looks really good
18:04:44 <oleg-nenashev> #info Roadmap draft: https://jenkins.io/project/roadmap/
18:04:56 <oleg-nenashev> Slide-O-Mix: thanks! A lot to add there though
18:05:22 <Slide-O-Mix> It's a great start and looks really nice. Your work is MUCH appreciated!
18:05:40 <oleg-nenashev> One bleeding weakness of the roadmap is a shallow "Jenkins jobs and integrations" category. Which is basically "Features for Jenkins end users"
18:06:25 <oleg-nenashev> If there is any SIG which have items for this category, it would be awesome. I am going to submit a few proposals to the developer mailing list soon
18:07:33 <oleg-nenashev> E.g., for [in]sanity check: (1) Tekton Pipelines support in Jenkins, (2) Container Steps support - native container steps without running Pipelines inside them
18:08:25 <oleg-nenashev> Slide-O-Mix: thanks for your feedback, much appreciated! I am also looking for a BDFL delegate for JEP-14. Would you be interested?
18:08:59 <Slide-O-Mix> I am not super up on the JEP process, so I am not sure what I would need to do, but I can review and be happy to help out in whatever way I can
18:09:07 <markewaite> I agree with slide that the roadmap is a great step forward.
18:09:08 <oleg-nenashev> It is probably a case when we need a board member as a BDFL delegate
18:09:32 <Slide-O-Mix> oleg-nenashev: I am more than happy to help out
18:09:42 <oleg-nenashev> #action oleg_nenashev to follow-up with Slide-O-Mix about being the JEP-14 delegate
18:10:20 <oleg-nenashev> #info Roadmap discussion in the Documentation SIG: https://groups.google.com/forum/#!topic/jenkinsci-docs/5kcPM82fn8Y
18:10:38 <oleg-nenashev> ^ we encourage all SIGs and subprojects to start such discussions
18:11:22 <oleg-nenashev> Slide-O-Mix markyjackson markewaite while we are here, are there any items you would like to add to "Future"?
18:12:01 <markewaite> Platform SIG will review roadmap topics tomorrow in meeting.  Docs SIG is trying a different approach with trying condorcet style voting on proposals.
18:12:13 <Slide-O-Mix> I can't think of anything right now
18:12:17 <markyjackson> Nothing from me
18:12:29 <oleg-nenashev> I think we should start official roadmap meetings soon as JEP-14 suggests, but it would be great to start discussing it earlier
18:12:51 <oleg-nenashev> Speaking of that, what if we convert the next Governance meeting into a roadmap meeting?
18:12:59 <Slide-O-Mix> I think for future, maybe Jenkins 3.0? ;) jk
18:13:08 <oleg-nenashev> .... or at least dedicate a chunk of time to that
18:13:43 <oleg-nenashev> Slide-O-Mix:  I am happy to discuss Jenkins 3.0, especially if we could break it down to some stories/area we would like to achieve
18:14:09 <markewaite> Yes, let's dedicate a significant portion of next governance meeting to roadmap.
18:14:12 <Slide-O-Mix> oleg-nenashev: I think for me, a big Jenkins 3.0 thing would be remove deprecated stuff and clean things up
18:14:15 <Slide-O-Mix> Sounds good to me
18:14:18 <oleg-nenashev> Not to even mention finding contributors to make it happen
18:14:22 <Slide-O-Mix> ja
18:14:54 <oleg-nenashev> #agreed we will use the next Governance meeting as a venue for the roadmap meeting as specified in JEP-14
18:15:07 <oleg-nenashev> Do we want to do it in a chat? Or a recordedcall?
18:15:25 <Slide-O-Mix> I think audio/video would be good
18:15:54 <oleg-nenashev> I am ready to try it. The chat format is not very popular
18:16:17 <oleg-nenashev> markewaite markyjackson  wdyt?
18:16:41 <markyjackson> Count me in
18:16:49 <markewaite> Recorded call is better for me.  I'm "in".
18:17:23 <oleg-nenashev> #agreed Next Jenkins Governance Meeting will be held as a recorded video call. We will still do meeting notes
18:17:38 <Slide-O-Mix> sounds good
18:17:42 <oleg-nenashev> OK, let's move on then. Thanks all for your feedback!
18:17:47 <oleg-nenashev> #topic Event updates
18:17:48 <markyjackson> +1
18:18:13 <oleg-nenashev> #info We are starting a series of Jenkins Online Meetups, and we are looking for speakers!
18:18:45 <oleg-nenashev> #info Main theme for April/May - Jenkins in Kubernetes. First meetup: https://www.meetup.com/Jenkins-online-meetup/events/269888701/
18:18:55 <oleg-nenashev> Thanks to markyjackson for stepping up!
18:19:00 <Slide-O-Mix> That sounds awesome!
18:19:10 <markyjackson> Most welcome!
18:19:15 <oleg-nenashev> I have 4 extra meetups in my pipeline now
18:19:22 <markyjackson> Wow!
18:20:24 <oleg-nenashev> With JAMs being impacted by COVID-19, this is something we could do to promote Jenkins. I will be sending announcements to JAM organizers one I have documentation about our online meetup platform
18:20:46 <markewaite> Docs SIG would like to add a roadmap item "Jenkins in Kubernetes".  Initially create a solutions page on jenkins.io, link to webinar recordings, etc.  Ultimately evolve to deeper docs
18:21:18 <oleg-nenashev> Currently we use CDF Zoom, and this is a big deal right now. My action item is to check our limits
18:21:27 <markyjackson> I would love to help there @markewaite
18:21:50 <oleg-nenashev> It is probable that we are limited to 100 users, and markyjackson is too popular to be limited by such small number
18:22:08 <markyjackson> Haha
18:22:09 <oleg-nenashev> Also on my plate
18:22:39 <markyjackson> I have a paid zoom account we can use which has a 500 user limit if that helps
18:22:57 <oleg-nenashev> markyjackson: great option as a plan B
18:23:05 <oleg-nenashev> CDF Zoom is a pain anyways
18:23:32 <oleg-nenashev> waiting for a dedicated Zoom account for Jenkins, tracymiranda and alyssat_ are on it
18:23:44 <markyjackson> Nice!
18:24:15 <oleg-nenashev> so let's see
18:24:29 <oleg-nenashev> Any questions or other topics?
18:24:45 <oleg-nenashev> markewaite: Thanks for the docs SIG update by the way
18:25:08 <oleg-nenashev> Everybody, get ready to our pings about documentation and blogposts about K8s :)
18:25:13 <oleg-nenashev> And anything else actually
18:25:43 * markyjackson can’t wait
18:25:50 <oleg-nenashev> :+1
18:25:57 <oleg-nenashev> #topic Next meeting
18:26:01 <oleg-nenashev> As usual?
18:26:15 <Slide-O-Mix> Yes, sounds good
18:26:23 <oleg-nenashev> It would be April 22, 6PM UTC
18:26:45 <oleg-nenashev> #info Next meeting - April 22, 6PM UTC . We will be doing a video call!
18:26:58 <oleg-nenashev> Thanks Slide-O-Mix markyjackson markewaite  !
18:27:04 <oleg-nenashev> #endmeeting