18:01:23 <oleg-nenashev> #startmeeting
18:01:24 <robobutler> Let the Jenkins meeting commence!
18:01:47 <oleg-nenashev> #info Agenda: #startmeeting
18:01:56 <oleg-nenashev> #info Agenda: https://docs.google.com/document/d/11Nr8QpqYgBiZjORplL_3Zkwys2qK1vEvK-NYyYa4rzg/edit#heading=h.vylsknw2s91m
18:02:10 <oleg-nenashev> #topic Recap of previous action items
18:02:28 <oleg-nenashev> do we have ones?
18:02:49 <oleg-nenashev> #info Previous meeting: http://meetings.jenkins-ci.org/jenkins-meeting/2019/jenkins-meeting.2019-12-18-18.02.html
18:02:56 <oleg-nenashev> no action items
18:03:20 <oleg-nenashev> #topic New meeting time
18:03:37 <oleg-nenashev> #info: Discussion: https://groups.google.com/forum/#!topic/jenkinsci-dev/RuWQ124gUsw
18:03:48 <oleg-nenashev> IIUC we still need to send out Doodle
18:04:03 <oleg-nenashev> Nope, it was sent
18:04:13 <oleg-nenashev> #info Doodle for the new meeting slot: https://doodle.com/poll/pq2g45anu92yz2b8
18:04:28 <oleg-nenashev> So far 2 votes
18:04:33 * oleg-nenashev did not vote
18:04:59 <drulli> I thought your initial times setup is your vote?
18:05:28 <oleg-nenashev> Not exactly
18:05:54 <oleg-nenashev> I just took common slots with good EMEA/APAC and Americas/EMEA overlap
18:06:05 <oleg-nenashev> But I will make any slot work if needed
18:06:42 <drulli> It looks like the current time is the best :-)
18:06:49 <oleg-nenashev> Basically the current options are 5PM UTC or 6PM UTC on Monday to Thursday
18:07:03 <oleg-nenashev> Unless somebody else votes, +1 for keeping the time
18:07:27 <oleg-nenashev> Should we postpone it till the next meeting (and keep the slot as is for now)?
18:07:42 <alyssat_> I think that's a good idea
18:08:10 <drulli> that means today is an excception?
18:08:23 <oleg-nenashev> Today is a regular slot drulli
18:08:27 <oleg-nenashev> 6PM UTC
18:08:41 <Slide-O-Mix> Who is asking for an update to the meeting time? Or, who is the current slot bad for?
18:09:21 <oleg-nenashev> Well, it was rather an attempt to have more people on the call
18:10:03 <oleg-nenashev> It is not ideal for Europe - right after the common working hours. So all School/shopping runs & Co. But not a big deal for me
18:10:32 <oleg-nenashev> drulli Slide-O-Mix : so, do we keep it for now?
18:10:51 <drulli> Well it is not ideal for me (kids are going to bed right now…) but we can handle
18:11:00 <drulli> it twice a month ;-)
18:11:21 <drulli> So let us keep it...
18:11:37 <oleg-nenashev> Or move 1h earlier?
18:11:57 <drulli> for me it would be better one hour later
18:12:17 <drulli> but as I said, it is not that often
18:12:30 <oleg-nenashev> #action oleg_nenashev to add a 7PM UTC option to the poll
18:12:48 <drulli> ok
18:12:50 <oleg-nenashev> Let's keep it as is for now, and keep the poll going
18:13:08 <oleg-nenashev> #agreed We keep 6PM UTC for now, please vote in the poll!
18:13:21 <oleg-nenashev> #topic Updates in the Governance Meeting tooling
18:13:55 <oleg-nenashev> #info Now we use Google Doc for the agenda. See the new Governance Board Meetings page here: https://jenkins.io/project/governance-meeting/
18:14:05 <oleg-nenashev> That's it, I;d guess
18:14:10 <drulli> This is ok for me
18:14:19 <oleg-nenashev> Is everyone comfortable with the new tooling?
18:14:29 <alyssat_> it's fine for me as well
18:14:50 <oleg-nenashev> It is a part of our Wiki migration/evacuation
18:15:21 <oleg-nenashev> Moving on in 30 sec if no comments
18:15:57 <oleg-nenashev> #topic Approval request: CommunityBridge funding page
18:16:02 <oleg-nenashev> It is by me
18:16:14 <oleg-nenashev> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/iLutO2X0bdg
18:16:37 <oleg-nenashev> I would like to get approval to setup a funding page prototype on CommunityBridge
18:17:07 <oleg-nenashev> #info Current page (for mentorship only): https://funding.communitybridge.org/projects/jenkins
18:17:38 <oleg-nenashev> The plan is to enable other categories and to reference the flow from jenkins.io/donate as an experimental one
18:18:02 <Slide-O-Mix> Sounds like a good plan to me
18:18:08 <drulli> I think it make sense to move everything to CDF
18:18:41 <oleg-nenashev> We will have to move, because SPI is expected to stop accepting donations sooner or later
18:18:53 <oleg-nenashev> They agreed to stop doing so in May 2019
18:19:02 <oleg-nenashev> But they still do that tho :)
18:19:26 <alyssat_> +1 for me as donations has been sent via email previously.  This is much better looking then sending an email to SPI
18:20:00 <oleg-nenashev> So far there was no negative feedback in the thread. Do we need any clarification? or should we just vote?
18:20:50 <oleg-nenashev> P.S: You may see a 3K USD self-donation. This is a stipend for our first CommunityBridge mentee (Sladyn Nunes)
18:21:06 <oleg-nenashev> VOTE: Approve beta testing of the CommunityBridge as a reference implementation
18:21:12 <Slide-O-Mix> +1
18:21:13 * oleg-nenashev abstains
18:21:19 <drulli> +1
18:21:19 <alyssat_> +1
18:21:32 <markewaite> +1
18:21:52 <oleg-nenashev> let's wait for 30 sec
18:22:31 <drulli> Would it be possible or does it make sense to show the totals of the donations somewhere on the web page? In the style of wikipedia? So that the people see how many income we have?
18:23:01 <oleg-nenashev> drulli: You mean donations from multiple channels? or just SPI?
18:23:12 <oleg-nenashev> uhm, just CommunityBridge
18:23:17 <drulli> From all channels
18:23:30 <drulli> ah ok, sorry
18:23:58 <oleg-nenashev> CommunityBridge publishes summary: https://usercontent.irccloud-cdn.com/file/lJSc9awR/image.png
18:24:24 <oleg-nenashev> For all channels we could do quarterly reports, but it would require manual actions
18:24:50 <oleg-nenashev> rtyler: used to do the treasury report for SPI
18:24:55 <drulli> I see, that link is already sufficient.
18:25:20 <oleg-nenashev> So we can improve it as we go
18:25:40 <oleg-nenashev> Linux Foundation also seeks feedback about improvements they could make on the portal
18:26:12 <oleg-nenashev> The payments backend for them is Expensify. We use it, and IMHO it's awesome
18:26:27 <oleg-nenashev> Especially being compared to other systems I used before
18:26:38 <oleg-nenashev> Any other questions?
18:27:22 <oleg-nenashev> ok, let's proceed
18:32:19 <oleg-nenashev> Hi all
18:32:26 <oleg-nenashev> IRCCloud went down
18:32:34 <oleg-nenashev> do I was dropped off
18:32:47 <oleg-nenashev> same for markewaite and lyssat
18:33:00 <oleg-nenashev> _alyssat
18:33:38 <oleg-nenashev> is everyone back?
18:33:52 <drulli> yes I am still here
18:33:58 <oleg-nenashev> lucky you
18:33:59 <Alyssat> i'm in
18:34:06 <Slide-O-Mix> I'm still here
18:34:13 <oleg-nenashev> I had to fallback to another IRC service
18:34:27 <oleg-nenashev> OK, let;s continue
18:34:42 <oleg-nenashev> #agreed Beta testing of CommunityBridge funding is approved
18:34:58 <oleg-nenashev> #action oleg_nenashev to setup a reference implementation and draft a JEP
18:37:28 <oleg-nenashev39> hmm
18:37:42 <oleg-nenashev39> this meeting becomes fun
18:37:56 <Alyssat> ;D
18:37:58 <Slide-O-Mix> so many oleg's!
18:38:05 <oleg-nenashev39> Did the "agreed" message arrive?
18:38:15 <Slide-O-Mix> No
18:38:42 <oleg-nenashev39> #agreed CommunityBridge Funding beta testing is approved
18:39:02 <oleg-nenashev39> #action oleg_nenashev to setup the reference implementation and draft a JEP
18:39:04 <oleg-nenashev39> uff
18:39:08 <rtyler> oof, sorry, I lost track of time
18:39:10 <rtyler> p/
18:39:28 <oleg-nenashev39> Slide-O-Mix drulli rtyler Could someone please take it over?
18:39:46 <rtyler> take what over?
18:39:50 <oleg-nenashev39> the meeting
18:39:56 <Slide-O-Mix> what is the doc link for the agenda?
18:39:57 <oleg-nenashev39> yey
18:40:29 <oleg-nenashev39> https://docs.google.com/document/d/11Nr8QpqYgBiZjORplL_3Zkwys2qK1vEvK-NYyYa4rzg/edit
18:40:54 <Slide-O-Mix> Ok, are we ready to move to the next topic?
18:40:56 <oleg-nenashev39> I am still here, just afraid of network issues
18:40:58 <rtyler> oleg-nenashev39: you need to #chair some people
18:41:07 <oleg-nenashev39> I think we are :(
18:41:35 <Slide-O-Mix> #topic Jenkins Evergreen Infra Status
18:41:47 <Slide-O-Mix> hmmm, need #chair oleg-nenashev39
18:41:48 <rtyler> oleg-nenashev39 needs to invoke the #chair command
18:42:00 <oleg-nenashev39> #chair Slide-O-Mix
18:42:07 <Slide-O-Mix> #topic Jenkins Evergreen Infra Status
18:42:15 <Slide-O-Mix> robobutler: are you alive?!
18:42:15 <robobutler> Slide-O-Mix: Error: "are" is not a valid command.
18:42:19 <rtyler> change your nick back oleg-nenashev39
18:42:20 <Slide-O-Mix> ineed
18:42:21 <Slide-O-Mix> indeed
18:42:27 <oleg-nenashev39> OK, I will try
18:42:31 <oleg-nenashev39> I am still the chair
18:42:45 <rtyler> `oleg-nenashev` is the chair
18:42:46 <oleg-nenashev39> Switch back fails, thanks IRC Cloud
18:42:50 <oleg-nenashev39> #topic Jenkins Evergreen Infra status. Do we shut down the Evergreen infra? (Olivier Vernin, Oleg Nenashev)
18:43:34 <oleg-nenashev39> Well, we can proceed without topic
18:43:36 <Slide-O-Mix> oleg-nenashev39: /msg nickserv ghost oleg-nenashev <password>
18:43:41 <oleg-nenashev39> The meetings will be a mess tho
18:43:55 <Slide-O-Mix> then change your nick
18:45:47 <oleg-nenashev39> wip
18:46:12 <oleg-nenashev> #chair Slide-O-Mix
18:46:12 <robobutler> Current chairs: Slide-O-Mix oleg-nenashev
18:46:16 <oleg-nenashev> #chair rtyler
18:46:16 <robobutler> Current chairs: Slide-O-Mix oleg-nenashev rtyler
18:46:20 <oleg-nenashev39> thanks
18:46:21 <rtyler> that was stupid
18:46:26 <rtyler> Slide-O-Mix: please continue :)
18:46:42 <oleg-nenashev39> My IRCfu is so rusty
18:46:52 <Slide-O-Mix> #topic Jenkins Evergreen Infra status. Do we shut down the Evergreen infra? (Olivier Vernin, Oleg Nenashev)
18:47:01 <rtyler> robobutler doesn't have real access controls, anybody could have changed nicks to yours and taken it over :)
18:47:01 <robobutler> rtyler: Error: "doesn't" is not a valid command.
18:47:39 <oleg-nenashev39> #info https://groups.google.com/forum/#!msg/jenkinsci-dev/OlG1IEFmSiQ/8RHA_urCBQAJ
18:47:47 <oleg-nenashev39> I am not sure whether olblak is around
18:47:55 <Slide-O-Mix> olblak: ping?
18:48:01 <rtyler> I'm in favor of shutting it down, and closing the Evergreen experiment down
18:48:08 <rtyler> I can/should write a blog post to that topic
18:48:13 <Slide-O-Mix> What's the current usage of it?
18:48:20 <Slide-O-Mix> Is it heavily used, or minimal usage?
18:48:23 <rtyler> broken :)
18:48:28 <rtyler> batmat and I haven't been pushing updates
18:48:31 <oleg-nenashev39> Long story short, we are migrating from ACS to AKS, and we need to either shut down the service or find maintainers
18:48:39 <rtyler> the service was already broken
18:48:46 <Slide-O-Mix> ok, so even if people are "using" it, it is not useful at all?
18:49:08 <oleg-nenashev39> I have heard a rumor of 8 users 1 year ago
18:49:11 <rtyler> shutting down evergreen servers doesn't do anything but return their Jenkins environments to what they otherwise are, stagnate and un-updating :p
18:49:27 <Slide-O-Mix> I'm in favor of shutting it down
18:49:35 <rtyler> the experiment taught me some good things at least, not sure what lessons others learned :)
18:49:36 <oleg-nenashev39> We will still need to somewhat announce the project shutdown
18:49:46 <oleg-nenashev39> Also, the code stays with us
18:50:04 <oleg-nenashev39> rtyler and batmat did everything-as-code IIRC
18:50:24 <rtyler> oleg-nenashev39: I think olblak should be free to disable the services, I will then write a blog post on the subject
18:50:32 <rtyler> we don't need to block decommissioning ACS
18:50:46 <oleg-nenashev39> rtyler I think we can send a notice in advance
18:51:04 <rtyler> oleg-nenashev39: I am not committing to that
18:51:05 <oleg-nenashev39> If we approve it, we can send a blog in few days and let the service die on Jan 31
18:51:09 <Slide-O-Mix> Is there a target for migrating to AKS?
18:51:24 <oleg-nenashev39> Jan 31 is a deadline
18:51:24 <rtyler> I don't think you're understanding the state of things
18:51:36 <rtyler> users are NOT getting updates right now, and haven't gotten them in many many months
18:51:40 <rtyler> the service is fundamentally broken
18:51:46 <rtyler> blocking olblak in any way is pointless and saves us nothing
18:51:59 <oleg-nenashev39> I agree
18:52:22 <oleg-nenashev39> If we want to sign-off immediate shutdown, I am also fine
18:52:42 <Slide-O-Mix> I say shut it down now
18:52:50 <rtyler> ditto\
18:52:51 <Slide-O-Mix> There is no point keeping it up if its broken right now
18:52:56 <oleg-nenashev39> sorry for confusion rtyler
18:53:41 <oleg-nenashev39> So, vote for "Sign-off immediate shutdown of Evergreen Infra OR any other decommission process preferred by the Infra Officer"
18:54:00 <oleg-nenashev39> Just to leave olblak option to "do nothing until it dies on its own"
18:54:14 <Slide-O-Mix> +1 Sign-off immediate shutdown
18:54:15 <drulli> +1
18:54:19 <oleg-nenashev39> +1
18:54:48 <rtyler> obvs +1
18:55:09 <rtyler> #action rtyler to archive evergreen repository
18:55:45 <oleg-nenashev39> #action oleg_nenashev to update jenkins.io projects (archive Evergreen there)
18:56:01 <oleg-nenashev39> rtyler do you take the blogpost?
18:56:37 <rtyler> #action rtyler to eventually write a blog post wrapping up the Evergreen experiment, updating the website too
18:57:20 <oleg-nenashev39> OK, I will just move Evergreen out of active projects
18:57:43 <oleg-nenashev39> so, next topic?
18:58:03 <Slide-O-Mix> sounds good
18:58:12 <oleg-nenashev39> uhm, also we need to stop Sentry accounts
18:58:25 <drulli> ?
18:58:31 <oleg-nenashev39> Or reuse them fo ci.jenkins.io like it was discussed on Tuesday
18:58:32 <rtyler> that's only used by Evergreen IIRC
18:58:57 <rtyler> we can definitely use it for other purposes, we have an open source gratis license with Sentry
18:59:00 <rtyler> drulli: sentry.io
18:59:08 <oleg-nenashev39> drulli Sentry is a event logging / reporting system which was used for Evergreen
18:59:23 <oleg-nenashev39> E.g. we caught some JEP-200 and Java 11 issues through it
18:59:39 <oleg-nenashev39> rtyler I would prefer to keep it for now if you are fine
18:59:46 <rtyler> yeah, no problem with that
18:59:49 <oleg-nenashev39> ty
18:59:53 <rtyler> I never turn away free stuff :)
19:00:13 <oleg-nenashev39> #agreed keep Sentry account for now (could be used for other systems)
19:00:25 <oleg-nenashev39> So we have a meetup topic
19:00:38 <oleg-nenashev39> Would be nice to vote there if everyone has few minutes
19:00:56 <oleg-nenashev39> Sorry for the IRC mess and delays it caused
19:01:22 <rtyler> let's keep rolling, Slide-O-Mix if you'll do the honors
19:01:31 <Slide-O-Mix> #topic Jenkins Area Meetup removal follow-up (Alyssa Tong, Oleg Nenashev)
19:01:46 <oleg-nenashev39> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/cviU5XUX8vQ
19:01:59 <oleg-nenashev39> The history summary is in the thread
19:02:10 <Alyssat> Thank you Oleg for writing out that email..very comprehensive :]
19:02:20 <oleg-nenashev39> happy to help
19:02:43 <oleg-nenashev39> We are following up on the fallout after the account removal together with Alyssat
19:03:06 <oleg-nenashev39> But it is a good time to start shutting down inactive accounts IMHO
19:03:10 <rtyler> I'm all for cleanup, and if Alyssat says it's good, then I'm +1 on whatever she wants :)
19:03:23 <oleg-nenashev39> So, 2 votes here
19:03:25 <oleg-nenashev39> VOTE: Approve the suggested process in general && delegate the final process decision to the event officer and Advocacy and Outreach SIG (immediate/short-term step down for meetups which never happened, grace period for stale ones)
19:03:25 <oleg-nenashev39> channels
19:03:41 <Slide-O-Mix> +1 on both from me
19:03:43 <Alyssat> The JAMS w/ data corruption is still being worked on by meetup.com..this may take them some time to recover
19:03:48 <drulli> +1
19:03:55 <oleg-nenashev39> The latter one is to just do some housekeeping and reduce the number of channels we have to maintain
19:04:22 <oleg-nenashev39> I am +1 for both, obviously
19:06:20 <Slide-O-Mix> good to go then?
19:06:26 <rtyler> I think so
19:06:33 <Alyssat> thank you all
19:06:39 <Slide-O-Mix> #topic FOSDEM updates (Oleg Nenashev)
19:06:47 <oleg-nenashev39> thank you too Alyssat
19:06:58 <rtyler> most importantly, I won't be able to join in FOSDEM :'(
19:06:59 <Alyssat> :]
19:07:19 <oleg-nenashev39> #info https://jenkins.io/blog/2020/01/10/fosdem-is-coming/
19:07:20 <Slide-O-Mix> I've never been to FOSDEM, I should look at attending in the future
19:07:30 <oleg-nenashev39> Slide-O-Mix yes you should!
19:07:37 <rtyler> it's a delightful chaos
19:07:55 <Slide-O-Mix> wouldn't be this year, but maybe next
19:08:02 <Alyssat> lots of good food and beer :]
19:08:10 <oleg-nenashev39> There is also Delirium. Best place to pay all the beer debts you accumulate over the year
19:08:50 <oleg-nenashev39> #info We have a small contributor summit on 31st. https://www.meetup.com/jenkinsmeetup/events/267684785/
19:08:58 <oleg-nenashev39> So it is not just about beers
19:09:13 <rtyler> is markewaite doing a pipeline training? I couldn't tell who might be running that
19:09:27 <oleg-nenashev39> rtyler Yes, it is Mark
19:09:40 <oleg-nenashev39> #info On the Thursday 30 of January, there will be two workshops one about Jenkins Pipelines lead by Mark Waite, and a second one about JenkinsX by Viktor Farcic.
19:09:50 <oleg-nenashev39> #info Finally the FOSDEM, the 01 and 02 of February, we’ll all be at FOSDEM. So come and say "hi" at the Jenkins/JenkinsX stand, inside the CICD Devroom.
19:10:16 <oleg-nenashev39> I like just copy-pasting olblak's post :)  thanks for writing it olblak!
19:10:29 <rtyler> IMHO we should definitely promote Marks' training from @jenkinsci (assuming it's relevant to Jenkins users and not CloudBees proprietary)
19:10:33 <oleg-nenashev39> So, is anyone going to SCALE?
19:10:46 <oleg-nenashev39> rtyler Yes, I have it in my list for Tweets
19:11:15 <oleg-nenashev39> We had CB posts few days ago, so I delayed jenkinsci tweets a bit
19:11:38 <Alyssat> I will be there to help out w/ the trainings and the booth..we'll have Jenkins socks =D
19:12:13 <oleg-nenashev39> rtyler Slide-O-Mix markewaite What about SCALE?
19:12:21 <rtyler> I will not be attending SCALE
19:12:38 <Alyssat> We will be at SCALE as well..at least Mark and I will
19:12:42 <Slide-O-Mix> I have not heard of SCALE...
19:12:50 <Alyssat> Mark will be doing he same training
19:12:59 <rtyler> Slide-O-Mix: in Pasadena, which is closeish for ya IIRC
19:13:03 <oleg-nenashev39> It's like FOSDEM, but less beers and Clubmate
19:13:13 <Slide-O-Mix> yeah, much closer than FOSDEM for sure
19:13:21 <Alyssat> and we have the usual Jenkins booth. We'd love to have more folks to help us with booth staff
19:13:29 <rtyler> it is also a great event
19:13:37 <rtyler> far more kid friendly than FOSDEM too
19:14:22 <oleg-nenashev39> I may go to SCALE this year, to be confirmed if timing for other trips is fine
19:14:32 <rtyler> any other details on this topic?
19:14:38 <rtyler> we're straying into advocacyland
19:14:39 <oleg-nenashev39> Will be happy to help if I am there
19:14:44 <Alyssat> (y)
19:14:53 <oleg-nenashev39> yup, nothing from me
19:14:56 <oleg-nenashev39> Thanks all!
19:15:32 <oleg-nenashev39> And thanks to Slide-O-Mix for taking it over... second time in a row :bow:
19:15:41 <Slide-O-Mix> glad to help
19:15:48 <rtyler> are we all done?
19:16:01 <Slide-O-Mix> Last thing on the agenda is Next meeting
19:16:05 <Slide-O-Mix> #topic Next meeting
19:16:13 <oleg-nenashev39> I;d guess we discussed it in the beginning
19:16:18 <Slide-O-Mix> true
19:16:21 <oleg-nenashev39> We agreed to keep 6PM UTC for now
19:16:30 <Slide-O-Mix> ok, we'll end meeting then
19:16:37 <Slide-O-Mix> #endmeeting