#jenkins-meeting Meeting

Meeting started by rtyler at 18:00:10 UTC (full logs).

Meeting summary

  1. Last meeting's actions (rtyler, 18:00:24)
  2. LTS status check (rtyler, 18:02:32)
    1. https://issues.jenkins-ci.org/browse/INFRA-960 is relevant to your interests then (rtyler, 18:04:28)
    2. ACTION: ogondza will push 2.32.3 RC tomorrow morning (ogondza, 18:06:19)
    3. in two weeks we'll select the next LTS baseline (danielbeck, 18:06:58)

  3. GSoC Update (rtyler, 18:07:56)
    1. the GSoC 2017 application has been submitted (rtyler, 18:09:28)
    2. https://jenkins.io/projects/gsoc for more details (rtyler, 18:09:36)

  4. Infrastructure update (rtyler, 18:15:14)
    1. Every monday we're having an infra hangout on https://jenkins.io/hangout at 20:00 UTC (rtyler, 18:15:40)
    2. rtyler will be pushing for better collaboration between core development changes and infrastructure changes where they are dependent (rtyler, 18:22:54)
    3. as per usual, interested parties are recommended to join #jenkins-infra and infra@lists.jenkins-ci.org (rtyler, 18:25:27)
    4. the wiki is perpetually on fire (rtyler, 18:26:30)
    5. danielbeck and rtyler have started doing some initial research into what systems depend on the wiki so we can reduce the wiki load and get it upgraded sooner rather than later (rtyler, 18:27:15)

  5. Should we host plugins with closed-source dependencies? (rtyler, 18:33:54)
    1. https://issues.jenkins-ci.org/browse/HOSTING-271 (rtyler, 18:35:39)
    2. https://jenkins.io/project/governance/#license (rtyler, 18:36:37)
    3. "But no such plugins will be hosted by the Jenkins project." (rtyler, 18:36:49)
    4. ACTION: rtyler and danielbeck to investigate whether we can ensure OSI-licensed code is being distributed "all the way down" for plugins to comply with governance document guidelines around proprietary code in plugins (rtyler, 18:47:07)
    5. to summarize, bits being packaged into an .hpi should be OSI-licensed (Open Source) to be published through the official Jenkins Update Center (rtyler, 18:49:03)

  6. Next meeting (rtyler, 18:49:48)
    1. Next meeting March 1st, 2017 (rtyler, 18:50:26)


Meeting ended at 18:50:31 UTC (full logs).

Action items

  1. ogondza will push 2.32.3 RC tomorrow morning
  2. rtyler and danielbeck to investigate whether we can ensure OSI-licensed code is being distributed "all the way down" for plugins to comply with governance document guidelines around proprietary code in plugins


Action items, by person

  1. danielbeck
    1. rtyler and danielbeck to investigate whether we can ensure OSI-licensed code is being distributed "all the way down" for plugins to comply with governance document guidelines around proprietary code in plugins
  2. ogondza
    1. ogondza will push 2.32.3 RC tomorrow morning
  3. rtyler
    1. rtyler and danielbeck to investigate whether we can ensure OSI-licensed code is being distributed "all the way down" for plugins to comply with governance document guidelines around proprietary code in plugins


People present (lines said)

  1. rtyler (115)
  2. danielbeck (46)
  3. ogondza (14)
  4. orrc (10)
  5. ageer (7)
  6. robobutler (2)
  7. autojack (1)
  8. schristouu88 (1)
  9. kohsuke (0)


Generated by MeetBot 0.1.4.