18:00:59 <kohsuke> #startmeeting
18:00:59 <robobutler> Let the Jenkins meeting commence!
18:01:13 <kohsuke> #chair hare_brain rtyler  danielbeck KostyaSha
18:01:13 <robobutler> Current chairs: KostyaSha danielbeck hare_brain kohsuke rtyler
18:01:15 <kohsuke> oops
18:01:22 <oleg-nenashev> :D
18:01:27 <kohsuke> I meant to type in myself but got KostyaSha instead
18:01:29 <kohsuke> oh well
18:01:41 <KostyaSha> two times yourself?!
18:01:42 <kohsuke> #topic Recap last meeting's actions
18:02:05 <danielbeck> The only action from last time was that I get some way to annotate the LTS changelog
18:02:11 <kohsuke> Aye
18:02:20 <kohsuke> And that's mine
18:02:26 <danielbeck> That hasn't happened AFAIK, so I'll just edit the file on the site
18:02:49 <kohsuke> It continues to be high on my TODO list FWIW
18:03:00 <danielbeck> From an earlier meeting, I had the list of infra admins, and it also includes Artifactory data now: https://wiki.jenkins-ci.org/display/JENKINS/Infrastructure+Admins
18:03:00 <kohsuke> #topic LTS status check
18:03:06 <kohsuke> Oops
18:03:18 <kohsuke> should I set the topic back?
18:03:19 * ogondza forgot to push on LTS rc release
18:03:38 <danielbeck> That's just FYI. Other than making Tyler an Artifactory admin when he's available, it's finish IMO.
18:03:45 * rtyler nods
18:03:52 <rtyler> thanks for that danielbeck
18:04:13 <danielbeck> I also noticed we never followed up on jenkinshosting.com, so we'll need to do that some time
18:04:28 <kohsuke> Yes, it's a good work towrad more transparency
18:04:46 <danielbeck> Would be interesting to see any past communication between the guy and KK, he wrote to the list once but that was it
18:04:48 <oleg-nenashev> Does Alan need permissions? He rarely appears in the community now IIRC
18:04:55 <kohsuke> danielbeck: I can forward it to you
18:05:06 <danielbeck> okay, then I'll follow up on that
18:05:06 <rtyler> I've not seen mindless in eons
18:05:07 <kohsuke> Basically he's very happy to go through the formality
18:05:33 <kohsuke> I communicated to him that for us to protect the mark we need it, but we aren't trying to shut you down.
18:05:45 <kohsuke> I mean shut him down
18:05:50 <danielbeck> Yes. I think we never intended to not grant that use.
18:06:00 <kohsuke> #action kohsuke to send danielbeck my correspondence with JenkinsHosting.com guys
18:06:05 <danielbeck> FWIW the wiki page on granted uses is outdated as well
18:06:18 <kohsuke> #action danielbeck to follow up with them
18:06:22 <danielbeck> #action danielbeck to update the granted trademark usage page
18:06:23 <rtyler> their site has hudson screenshots
18:06:25 <rtyler> lollz
18:06:27 <danielbeck> :-)
18:06:37 <danielbeck> Let's move on
18:06:45 <kohsuke> They did start as HudsonHosting.com
18:06:53 <kohsuke> OK, so now really LTS status
18:07:09 <kohsuke> I swear to god that I did produce & posted RC binaries
18:07:28 <kohsuke> So I need to chase down where the lapse is in automation
18:07:37 <danielbeck> no announcement to the list
18:07:38 <danielbeck> http://mirrors.jenkins-ci.org/war-stable-rc/1.625.1/
18:07:46 <danielbeck> and no wiki page for RC testing
18:08:01 <kohsuke> Right, no announcement to the list was my fault
18:08:11 <ogondza> I completely lost track, my apology
18:08:13 <kohsuke> oh I see, it didn't hit mirrors
18:08:26 <ogondza> anyway, we are ready
18:08:34 <kohsuke> I see that the calendar was adjusted already to mark today as 1.625.1 RC date
18:08:44 <danielbeck> yep, I did that yesterday when we noticed
18:08:46 <ogondza> I have backported one more issue and the revert what KostyaSha asked for
18:09:14 <ogondza> #action ogondza prepare the LTS testing wiki
18:09:16 <kohsuke> OK, then I should build 1.625.1 RC2 then
18:09:26 <oleg-nenashev> Do we merge any security stuff into 1.625.1 ?
18:10:07 <danielbeck> I think .2 is better in general for security unless it's urgent?
18:10:14 <oleg-nenashev> +1
18:10:25 <kohsuke> oleg-nenashev: historically, I believe we've done that right before the release, which means fixes skip RC soak tests
18:10:56 <kohsuke> I remember having that discussion with jglick when we started doing it
18:11:03 <danielbeck> with the exception of the master/slave system
18:11:43 <oleg-nenashev> kohsuke: I just want to make sure, because several PRs have been merged. I also vote for .2, but we need to make sure that the current fixes won't be taken into the release by the release bot
18:12:08 <kohsuke> Is it better to have this conversation in jenkinsci-cert list?
18:12:30 <kohsuke> I don't want to get too specific here about undisclosed issues or fixes we are planning to release in 1.625.1 if any.
18:12:43 <jglick> Yes we can take this to jenkinsci-cert.
18:12:46 <oleg-nenashev> agreed
18:12:47 <ogondza> ack, this is a process change
18:13:17 <kohsuke> ogondza: is what I just described a process change from what we've been doing? I was trying to explain the current process.
18:13:37 <danielbeck> So we're done with LTS discussion? KK will post RC 2 and make sure it gets distributed correctly.
18:13:50 <kohsuke> Yes
18:14:03 <kohsuke> #action kohsuke  to post 1.625.1 RC2
18:14:13 <danielbeck> ... and announce it
18:14:15 <ogondza> No, though preferring .2 for security fixes was proposed several times though not sure if sainted on meeting so I assume it is not a process
18:14:25 <ogondza> kohsuke: ^
18:14:37 <kohsuke> Yeah, indeed that's new
18:14:47 <kohsuke> I have some concerns about that, but I will take it to jenkinsci-cert
18:14:49 <danielbeck> Let's continue that discussion on the cert list
18:14:51 <kohsuke> #topic Q4 patron program
18:15:18 <kohsuke> danielbeck: yours
18:15:21 <danielbeck> No changes to Q3. I've never received the final second CloudBees message, but apparently I will soon
18:15:49 <danielbeck> I think we can just agree to continue to run the same messages.
18:15:56 <danielbeck> https://github.com/jenkinsci/patron/pull/4/files
18:16:18 <kohsuke> +1
18:16:57 <kohsuke> Shall we move on?
18:17:02 <danielbeck> anyone else ±1?
18:17:05 <oleg-nenashev> +1
18:17:09 * rtyler shrugs
18:17:10 <rtyler> sure
18:17:36 <danielbeck> Looks like nobody's opposed at least
18:18:09 <rtyler> Kif, what makes a man turn neutral
18:18:16 <KostyaSha> only if it not a huge unclosable banner
18:18:16 <danielbeck> #agreed same patron messages in Q4 as in Q3
18:18:32 <danielbeck> KostyaSha Same message format as always
18:19:26 <kohsuke> FWIW I believe the document only says new blessing needed for new messages
18:19:40 <kohsuke> Anyway, shall we move on?
18:19:54 <oleg-nenashev> yep
18:20:00 <kohsuke> #topic Time to think about Jenkins board elections?
18:20:09 <kohsuke> ... from orrc:
18:20:53 <kohsuke> #info the 2-year old "latest" proposal is here: https://wiki.jenkins-ci.org/display/JENKINS/Board+Election+Process+Proposal
18:21:20 <batmat> Is this page still relevant? https://wiki.jenkins-ci.org/display/JENKINS/Governance+Board
18:21:45 <batmat> *relevant/up-to-date I mean.
18:21:45 <rtyler> uh, I think s/abayer/rtyler and yes
18:21:57 <kohsuke> So far I've been failing to implement the account app change, but I agree we need to do it sooner
18:21:58 <KostyaSha> what will happen if CB hire newly elected non CB person?
18:22:12 <oleg-nenashev> I'm still +1 on proposals, btw orrc's concern must be addressed
18:22:30 <kohsuke> batmat: right, abayer has transitioned a seat to rtyler
18:22:34 <kohsuke> recorded live on 100K podcast
18:22:42 <rtyler> very official like :P
18:22:55 <KostyaSha> so, 2 CB and hare_brain ?
18:22:56 <kohsuke> We should announce that more formally too
18:23:52 <batmat> Ok, updated the page, is is OK now?
18:24:13 <oleg-nenashev> "Any company must have <50% of board members" seems to be a reasonable addition
18:24:34 <fredg02> +1
18:24:38 <rtyler> I'm not sure it does though
18:24:41 <kohsuke> oleg-nenashev: orrc: I wanted to actually discuss if it's so inherently bad that CB employees have majority
18:24:50 <KostyaSha> it also seems to me that now nobody from board really uses/supports jenkins for some projects
18:25:00 <rtyler> kohsuke's clearly involved with how CB policy is made
18:25:12 <KostyaSha> * i mean practise
18:25:22 <rtyler> but if you take somebody like danielbeck, I'm less convinced that his CB involvement "taints" his ability to act as a board member
18:25:52 <rtyler> I think we should look to how something like Ubuntu is operated here
18:26:06 <rtyler> or openSUSE
18:26:19 <hare_brain> KostyaSha, not sure what you mean
18:26:26 <rtyler> if CB hires all the people who are passionate and spend lots of time on jenkins, we can't just *not* have a board
18:26:31 <oleg-nenashev> kohsuke: I think that it's pretty important. It will prevent formal complains that a company may dominate in the community and push any decision
18:26:48 <kohsuke> I guess my concern is that people who are getting stuff done, like danielbeck, gets necessary authority to act.
18:26:54 <KostyaSha> hare_brain, i mean that abayer configures and supports apache's jenkins and infra. Do you support any jenkins installation as user?
18:27:11 <kohsuke> oleg-nenashev: Yes, I totally understand the motivation behind "no majority" rule
18:27:37 <hare_brain> Of course I do.
18:27:52 <hare_brain> My team runs Shutterfly's release infrastructure, which is based on Jenkins.
18:27:57 <rtyler> the purpose of this topic is not to elect board members right now
18:28:08 <KostyaSha> hare_brain, good
18:28:18 <rtyler> can we not compare jenkins credentials and discuss the topic at hand
18:28:56 <kohsuke> It's a bummer orrc is not here
18:29:00 <rtyler> it is
18:29:02 <batmat> How are we to go forward with this one? A thread on the ML about the different models?
18:29:16 <batmat> maybe orrc will be able to express more things in async?
18:29:25 <batmat> and others btw
18:29:26 <rtyler> so there's a qualifying question that I'd like to ask about that
18:29:42 <hare_brain> Is there a public record if orrc's concerns?
18:29:43 <rtyler> there's a definite bias we're going to get by keeping topics like this, and the Jenkins 2.0 discussion, on the -dev mailing list
18:29:53 <danielbeck> hare_brain Only the meeting topic I think
18:30:19 <rtyler> there are plenty of users on the mailing list, are their opinions not important to weigh in here?
18:30:47 <fredg02> @rtyler: I think it's perfectly fine to have Kohsuke on the board, but CB should not have a 2/3 majority on the board. For the sake of "could look a bit shady" for people that don't know the motivation of each board member.
18:31:03 <batmat> rtyler: sure, I suppose kohsuke just thought it was more something technical first, before visible/user changes. That's my understanding
18:31:10 <rtyler> fredg02: I understand that bit I'd like to quantify it more than "looks shady"
18:31:19 <rtyler> but*
18:31:50 <kohsuke> Maybe we can go the UK monarchy route and define a separate body under board that has additional authority delegated to act
18:31:52 <rtyler> if in a year, all the highly active particpants in the project work for CB, does that mean we have no government? :P
18:32:12 * rtyler doesn't want to become belgium
18:32:13 * rtyler ducks
18:32:20 <teilo> So KK becomes KKK (king KK?)
18:32:20 <fredg02> let's add oleg-nenashev's addition "Any company must have <50% of board members" to the proposal
18:32:41 <KostyaSha> so 2/3 or <50%?
18:32:57 <fredg02> less than the majority ;)
18:32:57 <rtyler> I would also like us to consider as a community some other projects which have similarly influential corporate participants
18:32:59 <hare_brain> Well the proposal was to expand the board to 5 members.
18:33:08 <batmat> well, if we add that then IIUC there's then an immediate issue?
18:33:13 <batmat> hare_brain: ok, I see.
18:33:32 <danielbeck> fredg02 So skip whoever wold get elected if they'd push it over 50%? Or have only one candidate per company?
18:34:05 <batmat> rtyler: that was my thought to give us time to discuss that on the ML, with people having a bit more time to explain (and maybe push towards) some other examples.
18:34:09 <oleg-nenashev> danielbeck: +KKK as an obvious exception?
18:34:10 <rtyler> what if I have a ceritifed letter from Sacha saying CB does not tell me how to act on the board? :P
18:34:13 <fredg02> I don't mind having 2 CB ppl on the board if the board has 5 members.
18:34:28 <kohsuke> Oh boy, I hope this KKK thing won't stick.
18:34:31 <rtyler> haha
18:34:35 <KostyaSha> oleg-nenashev, diods?!
18:34:39 <kohsuke> We already got slave s and executors going around.
18:34:47 <fredg02> hehe
18:34:59 <batmat> lol
18:35:02 <rtyler> if a board member accepts a job at CB, do they then lose their seat
18:35:16 <batmat> rtyler: right. Or FIFO ?
18:35:18 <batmat> :)
18:35:20 <rtyler> hah
18:35:20 <teilo> rtyler: I would prefer it to be "at the time of an election"
18:35:28 <danielbeck> FWIW I'm for ogondza and vjuranek in a three person board so it's for once not CB that's considered a problem :-)
18:35:51 <rtyler> hah, ETOOMANYFEDORAS
18:36:19 <oleg-nenashev> teilo: I would prefer "any time", but I'm not sure how democracy should work here
18:36:19 <rtyler> danielbeck: I think that is a good point, does the rule apply to all corporate entities or just CB
18:36:33 <fredg02> same rules for everyone!
18:36:37 <rtyler> what if I work for Hive Holdings, and KK works for CloudBees and we both work for Sacha Enterprises
18:36:40 <rtyler> does that count?
18:36:53 <rtyler> (redhat's not quite like that, but amazon and google are definitely fragmented like that)
18:37:09 <fredg02> alphabet... you mean
18:37:29 <kohsuke> I'd think if we embrace a rule like that, then I think it's the spirit that counts
18:37:31 <rtyler> I'm saying this not to be annoying (which I'm sure I am) but that whatever structure if there's going to be a guard against undue corporate influence that it's structured properly
18:37:44 <oleg-nenashev> rtyler: I don't think there is a need to be so formal. WEANAL
18:38:12 <oleg-nenashev> this acronyme is even more crappy
18:38:15 <rtyler> heh
18:38:31 <kohsuke> Board not having enough bandwidth has been a problem and it is still a problem today
18:38:39 <KostyaSha> rtyler, it easy define! all guys that pushing workflow are CB :)
18:38:47 <rtyler> I think my problem is that if it's hard to quanitfy ('looks shady') and there aren't strict guidelines in place
18:38:55 <rtyler> then "looks shady" can be used as a weapon against the board in the future
18:39:19 <rtyler> depending on where one is in the community, one will perceive shadiness differently
18:39:25 <mmars> rtyler: then there should be a disclosure policy and recusal in event of conflict of interest
18:39:38 <kohsuke> As I said, my concern in having the proposed rule is that it excludes lots of people who can spend time on the project, which is somewhat anti-meritocratic
18:39:54 <rtyler> mmars: aha, now you're getting to the heart of it I think!
18:40:00 <kohsuke> So if we are to adopt the proposed rule, I want us to spend some time thinking about it.
18:40:14 <oleg-nenashev> kohsuke: IIRC Jenkins contribution does not require the board membership
18:40:17 <rtyler> so let's say danielbeck's job description is "work on Jenkins FOSS full time", does that present a conflict of interest?
18:40:26 <fredg02> @kohsuke: so you think we run out of candidates if we enforce the <50% ruleß
18:40:27 <fredg02> ?
18:40:52 <rtyler> kohsuke as a CB investor and executive obviously *does* have a conflict of interest
18:41:06 <kohsuke> oleg-nenashev: for code commits, yes, but when you interact with outside, being able to represent the community does help
18:41:21 <fredg02> @rtyler: yes, but it's ok as long as he does not have majority
18:41:26 <kohsuke> e.g., talking to SPI, ffis, or driving code of conduct investigation
18:41:36 <hare_brain> It seems there is a question of scope of the governance board. For example, the board has nothing to do with workflow as a feature of Jenkins, other than overlapping people.
18:41:48 <oleg-nenashev> It's just a "Board of Directors", which gives advices and acts as arbitrator. That's why it's important to keep it independent from both formal and informal POVs
18:42:10 <kohsuke> fredg02: I wouldn't say we run out of candidates, but the pool will be smaller for sure
18:42:39 <rtyler> I actually think that could potentially have the opposite effect
18:42:41 <fredg02> @kohsuke: but that's the lesser evil, I think
18:42:57 <rtyler> since now CB as a company would have an interest in putting a few candidates forward that are in their interests
18:43:03 <rtyler> as opposed to people volunteering themselves
18:43:31 <kohsuke> hare_brain: oleg-nenashev: right, that line of thoughts leads to the board delegating some more exectuive abilities to another group
18:43:45 <rtyler> anyways, I agree with your point about there being some overlapping issues here hare_brain
18:44:47 <rtyler> just a time check, we've got 15 minutes left here
18:45:01 <rtyler> so let's nail down some actions to take between here and the next meeting to get this moving forward
18:45:12 <rtyler> fredg02: did you add the 50% thing to that proposal?
18:45:25 <oleg-nenashev> we have not voted yet
18:45:37 <hare_brain> IMO, the board should not be involved in deciding feature roadmap, technical decisions, things about Jenkins-as-a-product. It's scope should be Jenkins-as-a-community. I can pretty clearly separate the two concepts. Not sure if that's how people generally feel.
18:45:39 <oleg-nenashev> There's also a question raised by teilo in such case
18:45:52 <fredg02> the goal is to prevent the board from agreeing to thinks like "let's show advertisment of <company> on every Jenkins installation" while <company> has majority in the board
18:45:52 <kohsuke> hare_brain: +1
18:46:10 <rtyler> #action hare_brain to write out a revised proposal for the scope of the jenkins board
18:46:13 <rtyler> :)
18:46:37 <fredg02> s/thinks/things
18:46:54 <hare_brain> fredg02 exactly right
18:47:24 * teilo notices I never did move the servlet 3.0
18:47:43 <hare_brain> rtyler, the current Governance document describes it pretty succinctly and accurately. https://wiki.jenkins-ci.org/display/JENKINS/Governance+Document#GovernanceDocument-board
18:48:17 <hare_brain> We can stick in an explicit "The board's authority does not extend to features or roadmap."
18:48:17 <rtyler> hare_brain: I think what's more important, to what you wrote earlier, is to write what the board doesn't do
18:48:25 <rtyler> saying we're queens doesn't really explain much :P
18:48:45 <kohsuke> It does for me, so I must have written that part
18:48:57 <teilo> some Queens have been dictators as well :-)
18:48:58 <rtyler> heh
18:49:19 <kohsuke> hare_brain: should I take that AI?
18:49:29 <oleg-nenashev> rtyler: It means that the goverment can reduce your fundings :)
18:49:37 <rtyler> heh
18:49:49 <hare_brain> Take work off my plate? Sure. :)
18:49:54 <rtyler> well, right now the project technically owes me money, so I don't think my funding can be removed any more
18:50:35 <kohsuke> rtyler: sorry I didn't follow up on that one, let's follow up and fix that
18:50:42 <rtyler> heh
18:50:53 <rtyler> I should declare jenkins as a dependent on my taxes
18:51:03 <hare_brain> #action kohsuke to take previous action from hare_brain
18:51:06 <rtyler> other action items from this?
18:51:11 <kohsuke> Too late, it's already in my tax return
18:51:40 <fredg02> @rtyler re-election sometime soon?
18:51:43 <rtyler> if oleg-nenashev or fredg02 can update or append their corporate influence proposal to the doc that'd be good
18:51:51 <rtyler> see https://wiki.jenkins-ci.org/display/JENKINS/Board+Election+Process+Proposal
18:52:09 <kohsuke> I think we are mostly saying very similar thing, so hopefully a clarifiying the role of the board and adding that rule would let us bless it
18:52:22 <kohsuke> We need someone to implement the change to accountapp
18:52:36 <rtyler> fredg02: maybe? I think it makes sense to do it next february on Jenkins' birthday
18:52:46 <rtyler> that way we can keep the number of dates we all have to remember down :P
18:53:11 <fredg02> rtyler: sounds good
18:53:14 <kohsuke> That's a great idea
18:53:26 <rtyler> I think that would also help get us into a rhythm
18:53:43 <kohsuke> Any volunteer to help the accountapp code change?
18:53:46 <danielbeck> wasn't that just the 100k?
18:54:01 <rtyler> #action rtyler to put proposal for board elections on feb 2nd annually
18:54:15 <rtyler> kohsuke: what's the scope of the code change?
18:54:25 <rtyler> kohsuke: I've been pondering updating that app anyways :p
18:54:30 <rtyler> such a PITA for management
18:54:38 <kohsuke> hopefully not that much
18:54:40 <rtyler> heh
18:54:43 <rtyler> got JIRA?
18:54:43 <kohsuke> I talked about that briefly with danielbeck
18:54:51 <hare_brain> *where* is the code?
18:54:52 <danielbeck> rtyler Adding a page for voting, select which of the candidates record the choice, and export into a format that can be fed into an STV tool
18:54:52 <oleg-nenashev> #action oleg-nenashev to update proposals regarding the per-company limit of board members
18:55:13 <rtyler> #action kohsuke to file a JIRA on what needs to change in the accountapp to make board elections viable
18:55:24 <kohsuke> #info code is https://github.com/jenkins-infra/account-app
18:55:40 <rtyler> mabye I can get gus to help pretty it up a bit ;)
18:56:00 <danielbeck> Clearly the highest priority
18:56:11 <rtyler> heh
18:56:18 <kohsuke> Line up in the queue behind me, rtyler. I got a long list of things for him
18:56:41 <rtyler> kohsuke: drinking contest? :P
18:56:41 <kohsuke> OK, I think it's good enough for this topic for today
18:57:08 <danielbeck> kohsuke Maybe start a thread on the list about this? This is a pretty small group after all
18:57:10 <rtyler> shall we cover the servlet 3.1 topic?
18:57:15 <rtyler> agreed!
18:57:17 <kohsuke> Yes, and yes
18:57:24 <rtyler> very US timezone biased
18:57:26 <kohsuke> #topic time to move to Java 8 and servlet 3.1
18:57:43 <kohsuke> teilo: does that you mean you didn't read the Jenkins 2.0 post or you cannot wait for that?
18:58:30 <danielbeck> Are there good solutions for the Maven Project Plugin to build with older JDKs? People complain about the recent Java 7 requirement already, and I expect it to not get better once LTS has it as well.
18:58:37 <teilo> kohsuke: 1 do it now not later.  2 the propsal said servlet 3.0 not 3.1
18:58:48 <kohsuke> oh
18:58:55 <kohsuke> what's new in servlet 3.1?
18:59:15 <teilo> non blocking io
18:59:20 <kohsuke> danielbeck: I think it's the fundamental limitation of that plugin
18:59:33 <kohsuke> but some of non-blocking I/O was a part of 3.0
19:00:03 <teilo> Servlet 3.0 allowed asynchronous request processing but only traditional I/O was permitted.
19:00:05 <kohsuke> #info https://blogs.oracle.com/arungupta/entry/what_s_new_in_servlet
19:00:08 <danielbeck> kohsuke Yes, but with almost 1M jobs out there we should consider the impact of moving to Java 8.
19:00:23 <danielbeck> Because "It's just master, you can build what you want" is a load of shit
19:00:45 <rtyler> i'm out of time, catch you folks after lunch
19:00:47 <danielbeck> s/build/build with
19:00:49 <rtyler> o/
19:01:12 <kohsuke> Yes
19:01:40 <kohsuke> Servlet 3.1 part doesn't feel like a problem
19:02:09 <kohsuke> I think this conversation is probably better suited for the ML
19:02:22 <kohsuke> Especially given that we are running out of time
19:02:42 <danielbeck> Right. There's not going to be a decision today.
19:03:12 <kohsuke> teilo: if you want to propose this before 2.0 you should send a proposal to the ML
19:03:22 <kohsuke> #topic next meeting
19:03:48 <kohsuke> #info the next meeting will be Oct 14th the same time
19:03:55 <kohsuke> When does DST end?
19:04:07 <danielbeck> end of oct
19:04:14 <kohsuke> OK, so we are still safe
19:04:18 <kohsuke> #endmeeting