18:00:52 <kohsuke> #startmeeting
18:00:52 <robobutler> Let the Jenkins meeting commence!
18:01:05 <danielbeck> cburroughs (meeting now, please wait a bit with followup questions)
18:01:11 <kohsuke> #chairs rtyler danielbeck kohsuke
18:01:43 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:01:56 <kohsuke> I'm going to sneak in one more topic about rebundling plugins
18:02:27 <kohsuke> #topic Recap last meeting's actions
18:02:42 <danielbeck> there were none.
18:02:57 <fredg> any news about #jenkins-meeting?
18:03:09 <KostyaSha> fredg, wait for 10years
18:03:11 <danielbeck> fredg Still on my list of things to do
18:03:31 <fredg> ok:)
18:03:47 <kohsuke> #topic Jenkins certification
18:04:20 <KostyaSha> no recap?
18:04:44 <kohsuke> KostyaSha: I thought danielbeck said there's none, because the last week we only talked about LTS RC status check
18:04:54 <danielbeck> KostyaSha http://meetings.jenkins-ci.org/jenkins/2015/jenkins.2015-07-22-18.01.html action items: (none)
18:05:03 <kohsuke> We'd like to come up with a certification program for Jenkins users and admins
18:05:17 <kohsuke> Something people can put on their resumes to show off
18:05:20 <KostyaSha> for example kohsuke didn't contact bot owner that was planned for backup channel logging
18:05:54 <kohsuke> I'm afraid there's no progress to report on that one
18:06:00 <KostyaSha> either give op to danielbeck so he can confirm it instead of you
18:06:21 <orrc> maybe such actions can be added to MEETING, as people remember them
18:06:21 <kohsuke> #action kohsuke to give channel ops to danielbeck
18:06:39 <kohsuke> (if you know the command that I need to run please let me know)
18:06:45 <KostyaSha> one sec
18:07:01 <danielbeck> I propose we move discussions of past meetings (before the previous one) to the end. Otherwise we'll never get to discuss anything.
18:07:15 <kohsuke> Can I resume the certification stuff?
18:07:28 <danielbeck> please
18:07:53 <kohsuke> Right, and certification is also useful for employeers to filter applicants
18:08:55 <ogondza> kohsuke: will this be a source of income for the project?
18:09:09 <ogondza> or why does upstream getting involved?
18:09:10 <kohsuke> I was told that CB is happy to pay the bill to get that certificate test developed, but I want to make it the community's thing
18:09:41 <KostyaSha> and what do you want certify?
18:09:50 <fredg> So the certification should be something like LPIC for Linux?
18:09:53 <KostyaSha> button clicking? workflow?
18:10:05 <kohsuke> I need to check on whether this is supposed to be money-making thing or not, but I don't think it is.
18:10:19 <kohsuke> IOW this will not be a source of income for anyone
18:10:26 <aheritier> kohsuke: How a customer could know choose between several certifications ? (if one day several company offer it)
18:10:43 <KostyaSha> https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue good point for certification :)
18:11:33 <aheritier> I suppose that anyone could propose some trainings and certifications about Jenkins. How could we control this ? (at list be aware of them?)
18:11:43 <danielbeck> trademark usage?
18:11:57 <aheritier> danielbeck good point
18:12:07 <kohsuke> At this point, there's a small committee being launched to discuss how to do this, and I'm looking for someone from the community in there to provide supervision
18:12:16 <kohsuke> ... plus report it back to the broader community
18:12:18 <KostyaSha> kohsuke, maybe you can try with CB Jenkins Enterprise certification and then share results?
18:12:39 <KostyaSha> i think you already have some docs and trainings for it
18:13:19 <kohsuke> I believe that's also in the works, but if that's the only certification I think it's a weak story
18:13:45 <kohsuke> ... for obviously a lot more people care about being a Certified Jenkins Administrator than being a Certified CloudBees Jenkins Platform Administrator
18:13:57 <KostyaSha> kohsuke, well jenkins "community" has pure documentation
18:14:19 <kohsuke> And I truly believe something like this helps lift the tide for the whole community
18:14:22 <KostyaSha> for passing certificaiton you of course need materials and documentation and only CBJE has good docs
18:14:42 <kohsuke> Not really, training and certification are decoupled.
18:15:16 <kohsuke> IOW, I expect people here will be able to take a certificaion test and get certified without any extra training.
18:15:16 <KostyaSha> kohsuke, my suggestion was to revert steps, CBJE first (as you already has good docs/trainings and resources) and then cut some FOSS part into Jenkins Certification
18:15:36 <fredg> Training and certification could be good motiviation to improve the documentation
18:16:02 <KostyaSha> kohsuke, how i will certify newbies or people that think that they know jenkins? After they fail on the first question they will need docs that still in very bad state (confluence;)
18:17:09 <KostyaSha> kohsuke, and on this talk i'm alone from FOSS side? :)
18:17:29 <kohsuke> We don't need to talk about how we develop materials & tests here --- the whole point of having someone from the community in that committee is so that s/he can participate in that discussion
18:17:57 <ogondza> kohsuke: I am opened to have that discussion
18:18:20 <kohsuke> (like I said training & certification are decoupled and the existing training material does not translate to tests)
18:18:30 <ogondza> though, I still wonder what is the motivation for community? why are we doing this?
18:19:01 <KostyaSha> ogondza, like any other certificate - for MANAGERS
18:19:07 <KostyaSha> and $$
18:19:23 * KostyaSha IMHO
18:19:42 <kohsuke> I think there are multiple reasons, but I agree with KostyaSha that it is ultimately the same reason why everyone else does it.
18:20:06 <kohsuke> It gives a bit more recognition to the people who knows Jenkins
18:20:24 <kohsuke> It makes it more than something you claim --- it adds some degree of objective validation
18:21:15 <KostyaSha> 1 level: jenkins slave, 2 level jenkins master :D
18:21:24 <kohsuke> I'm also hoping that it will help build a network among us
18:22:11 <KostyaSha> imho everything in jenkins ends into bugs&development :( jenkins needs more experienced developers :(
18:22:21 <orrc> the idea seems ok. though I think there's a lot of upkeep required for a certification program: making sure it's hard enough so that it's worth something, making sure the test doesn't get stale over time, administration...
18:22:23 <kohsuke> Or it will allow Joe in Acme Corp to add this to his employee development program for this quarter.
18:22:38 <danielbeck> It's not difficult to imagine how enabling managers to easily hire Jenkins experts can help the community grow.
18:23:09 <KostyaSha> danielbeck, define "jenkins expert" :)
18:23:09 <kohsuke> orrc: right, we brought the consultants to lead the effort --- they've done something similar for PHP in the past, so they are experienced.
18:23:39 <danielbeck> KostyaSha Using it in large scale projects is difficult enough. Details will need to be hashed out of course.
18:23:45 <kohsuke> they need what they call "subject matter experts" to come up with tests, but they have methodology to statistically narrow them down to the right set of questions, etc.
18:24:03 <KostyaSha> danielbeck, even small installation may have difficulties :(
18:24:56 <orrc> ok. so is the idea is that the community funds the ongoing costs of the certification scheme, but breaks even via licensing / certification fees?
18:25:32 <kohsuke> I need to double-check on the cost & revenue structure. My apologies that I haven't done that homework.
18:25:51 <kohsuke> I don't have a good insight into the level of ongoing maintenance cost of such scheme.
18:26:17 <KostyaSha> danielbeck, if you have large jenkins installation, then you are already jenkins developer :)
18:26:18 <kohsuke> But a part of the reasons I'm looking for somebody on that "certification advisory board" is to find out about those things and report back to us for final Y/N
18:26:56 <KostyaSha> ogondza, ? :)
18:27:06 <kohsuke> In terms of the commitment, ot
18:27:27 <kohsuke> In terms of the commitment, we are looking for 3 or 4 more meetings with 1-2hr each
18:27:59 <ogondza> I see this as an opportunity to make Jenkins look more established and to improve the documentation we have
18:28:13 <kohsuke> And I think we really need this person to be unrelated to CB.
18:28:13 <KostyaSha> and update confluence! /o/
18:28:22 <kohsuke> ogondza: yeah
18:28:53 <ogondza> kohsuke: sign me in
18:29:11 <kohsuke> great
18:29:22 <kohsuke> is the outlook so far good for us as a whole?
18:30:01 <kohsuke> I'd think if it worked for PHP it'll work for us.
18:30:09 <danielbeck> looks like there are some concerns about contents and cost, but no opposition to the idea
18:30:20 <orrc> I wonder about who will administer the training, and the general flow of money. but the idea is fine
18:30:29 <fredg> +1 for the general idea
18:30:30 <ogondza> orrc: +1
18:30:43 <kohsuke> Let's make sure we cover those grounds for sure
18:31:08 <kohsuke> #agreed ogondza will be on the certification advisory board
18:31:17 <kohsuke> shall we move on to the next topic?
18:31:42 <kohsuke> #topic Approval of new Patron program messages
18:31:49 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/Patron+of+Jenkins+program
18:31:51 <KostyaSha> kohsuke, /msg ChanServ FLAGS #jenkins danielbeck +O
18:32:07 <kohsuke> KostyaSha: thanks, done
18:32:14 <danielbeck> thanks
18:32:39 <danielbeck> we started this program last year and it went well enough
18:32:49 <danielbeck> so the project got quite a bit of money from it
18:32:54 <danielbeck> ~3k per quarter
18:33:20 <kohsuke> danielbeck: what's the new messages to approve? I don't see them in https://github.com/jenkinsci/patron
18:33:32 <danielbeck> unfortunately it wasn't passed on properly due to a change of role, and we're reviving it now
18:34:13 <danielbeck> Turns out we got donations and didn't put up the messages they paid for, including the current quarter
18:34:16 <kohsuke> right, the last one is 2014Q4
18:34:44 <danielbeck> We're currently working this out with the donors so they get extra message time for their back donations
18:34:59 <danielbeck> and I'd like to get approval for the 2015Q3 messages by CloudBees today.
18:35:05 <danielbeck> http://jenkinsci.github.io/patron/tester.html?caption=Ensure+Optimal+Configurability&link=https%3A%2F%2Fpages.cloudbees.com%2FWebsite_7WaysOptimizeJenkins.html&blurb=Is+your+Jenkins+Continuous+Integration+Environment+Optimally+Configured+%3F&logo=http%3A%2F%2Fwww.cloudbees.com%2Fsites%2Fdefault%2Ffiles%2Fcb-logo-clr.r-square78x78.png
18:35:11 <danielbeck> http://jenkinsci.github.io/patron/tester.html?caption=Jenkins+At+Scale+is+Easier+Than+You+Think&link=https%3A%2F%2Fpages.cloudbees.com%2Frs%2Fcloudbees%2Fimages%2FCloudBees-Jenkins-Enterprise-Plugins-Ebook.pdf&blurb=Get+OSS+Jenkins+Plus+Some+Enterprise+Robustness&logo=http%3A%2F%2Fwww.cloudbees.com%2Fsites%2Fdefault%2Ffiles%2Fcb-logo-clr.r-square78x78.png
18:35:54 <danielbeck> One of them links to a PDF and the link is too long, I asked for a different URL and/or a landing page, but otherwise I'd like to get approval for these messages for the current quarter.
18:36:14 <danielbeck> I hope changing the URL afterwards is not a problem with you.
18:36:35 <kohsuke> Yeah I think it's OK
18:36:40 <kohsuke> changing URL, that is
18:37:05 <kohsuke> I'll refrain from commenting on messages, though I think it's in line with the tones of the past messages
18:37:13 <kohsuke> #info https://github.com/jenkinsci/patron/blob/gh-pages/messages.xml for the past messages
18:38:20 <kohsuke> any +1, -1, etc?
18:38:29 <fredg> looks ok, I guess
18:38:30 <orrc> those are fine. what's the general approval process again? each request comes to this meeting, or to the board members via jenkinsci-patrons, etc?
18:38:48 <ogondza> lgtm
18:38:52 <danielbeck> the project meeting approves the messages
18:39:25 <danielbeck> we broke the process a bit this time because due to a miscommunication CB sent the donation early
18:39:40 <orrc> ok, done, close INFRA-315 ;)
18:39:43 <jenkins-admin> INFRA-315:wiki advertising is showing blank adverts (Open) https://issues.jenkins-ci.org/browse/INFRA-315
18:39:53 <KostyaSha> lgtm if it not for jira/wiki
18:39:57 <kohsuke> #agreed proposed CB messages are OK
18:40:32 <kohsuke> closed
18:40:51 <kohsuke> shall we move on to next topic?
18:41:09 <orrc> yes
18:41:11 <kohsuke> Should we put Xebia's current message for now until they come up with a new one?
18:41:26 <kohsuke> I guess we don't have to re-approve that one
18:41:39 <kohsuke> #topic JUC travel grant
18:41:47 <danielbeck> kohsuke Haven't heard back from them what message they want... wouldn't want to put up a year old message...
18:41:53 <danielbeck> https://groups.google.com/forum/#!topic/jenkinsci-dev/LiqsANj4Lvc
18:41:59 <kohsuke> np
18:42:13 <danielbeck> We had this topic in the past
18:42:19 <danielbeck> but nothing came from it
18:42:32 <danielbeck> supporting community members' travel to Jenkins conferences
18:43:13 <danielbeck> so now I was asked whether we could support Pradeepto Bhattacharya's travel to the US JUC
18:43:34 <danielbeck> since we considered this in the past I brought it up on the dev list
18:43:42 <KostyaSha> be careful, we have experience that some persons sending such requests to leave their country forever
18:44:25 <danielbeck> who's "we"?
18:44:44 <KostyaSha> was in org members in http://lvee.org
18:45:21 <kohsuke> My recollection of earlier conversations is that the general idea of sponsoring a travel for up to a specific budget / year has a good support
18:45:28 <danielbeck> note that he attended JUC London already, and will attend JUC US West -- but it's a major expense for him.
18:45:46 <KostyaSha> for me expensive attending any JUC, but i'm ok ;)
18:46:20 <kohsuke> Where we are unclear is what bar would a proposal needs to pass to be considered benefitial to the community.
18:46:48 <danielbeck> right, we stopped the previous discussion around the topic of community benefit
18:47:17 <danielbeck> in this case, he's a repeat speaker, but not active in the community beyond local meetups.
18:47:35 <danielbeck> Pradeepto's profile is available at e.g. https://www.cloudbees.com/jenkins/juc-2015/abstracts/europe/02-02-1400-bhattacharya
18:47:58 <KostyaSha> Director of Engineering  can't travel?
18:48:19 <kohsuke> And I thought sponsoring a visit to a conference seems to be generally accepted practice
18:48:24 <kohsuke> Here's one for FreeBSD: https://forums.freebsd.org/threads/accepting-travel-grant-applications-for-eurobsdcon-2013.40910/
18:48:57 <KostyaSha> kohsuke, yes, idea is good, but criterias unclear. Maybe do it as random lottery?
18:49:17 <kohsuke> (then there's a related separate issue about JUC being described as a commercial conference, which I want to discuss further)
18:49:39 <KostyaSha> grep contributors from last 3 months | sort | unique | grep -v CB-employees
18:49:47 <kohsuke> KostyaSha: I don't want loterry
18:50:38 <orrc> like was said last time, it's hard to judge return on investment
18:50:51 <orrc> but I agree with the allocation of a budget per quarter, as hare_brain mentioned
18:51:11 <kohsuke> I think we need to start somewhere and adjust over time
18:52:24 <kohsuke> I liked that Pradeepto is passionate enough about Jenkins that he's paying out of his own pocket to come to these events
18:52:58 <KostyaSha> Is JUC free for speakers?
18:53:12 <kohsuke> wrt budget, IIRC the number floated was to set aside $2K/year and use it to support 2 people for $1K each
18:53:37 <kohsuke> KostyaSha: I'm pretty sure, yes. And for people in the "ask the experts" community room.
18:53:57 * orrc checks flight prices from Frankfurt to California in September
18:54:04 <orrc> yeah, JUC speakers get in free
18:54:23 <kohsuke> orrc: I'd love to have you over, too
18:54:24 <KostyaSha> orrc, do you need visas?
18:55:15 <orrc> I think $2k/year is a good starting point, though maybe with max $500 per visit?
18:55:40 <orrc> that could help cover more shorter distance trips, e.g. people to FOSDEM?
18:55:52 <KostyaSha> kohsuke, freebsd firstly targeted to developers
18:55:57 <kohsuke> OK, so you want to go for more people
18:56:27 <kohsuke> I'm fine with that.
18:56:31 <orrc> for this particular case, I don't really see the benefit as it's a repeat talk, but we need to start somewhere. and I know, from talking to Alyssa in 2013 about sponsoring me to JUC West, she mentioned some budget could come from sponsors
18:56:45 <KostyaSha> such benefit may attract more jenkins devs imho
18:56:50 <orrc> so I think sponsoring this guy could work, just not all from the OSS side perhaps
18:57:01 <fredg> orrc: +1
18:57:48 <kohsuke> JUC is a big money loser so I don't want people to think that we have other funding sources readily available
18:58:13 <kohsuke> but anyway,  I think we have a consensus
18:58:46 <kohsuke> If this being a repeat talk is a problem, perhaps we can think of this as retroactively sponsoring his JUC Europe visit that has already happened.
18:58:53 <orrc> :)
18:59:20 <kohsuke> danielbeck: is this good with you?
18:59:48 <danielbeck> consensus is up to 500 USD per person so we get to sponsor more?
18:59:51 <kohsuke> Let's make sure we'll interview him and post it as a blog. Give visibility to the program and him
18:59:56 <danielbeck> from the total of 2k per year
19:00:00 <kohsuke> Right
19:00:21 <KostyaSha> oleg-nenashev, how much cost you to travel from Russia?
19:00:24 <kohsuke> Let's also aim for bringing someone to FOSDEM
19:00:34 <danielbeck> and we're going to sponsor Pradeepto as an experiment, and milk him for a blog post and travel report?
19:00:36 <kohsuke> And SCALE14x
19:00:47 <kohsuke> danielbeck: yes
19:00:48 <KostyaSha> danielbeck, and twitter spamming :)
19:00:52 <fredg> +1 for bringing ppl to FOSDEM
19:01:21 <fredg> and encourage them to give a Jenkins related talk ;)
19:01:33 <kohsuke> fredg: right
19:01:44 <KostyaSha> maybe better ask him upgrade confluence?
19:01:57 <danielbeck> sounds great. I'll work with Pradeepto on writing about this.
19:02:19 <danielbeck> Should we establish a formal process for applying in the future?
19:02:30 <danielbeck> since it's now a real thing
19:02:33 <fredg> yes, please
19:02:38 <orrc> yes, at least having a wiki page with this stuff would be great
19:02:45 <kohsuke> yeah
19:02:52 <danielbeck> Alright, I'll work out a draft
19:02:58 <KostyaSha> orrc, ro page?)
19:03:12 <kohsuke> I need to go now, I hoped to talk about plugin rebundling but I guess I'm not going to get time
19:03:14 <danielbeck> #action danielbeck to work with Pradeepto on blog post and travel report
19:03:27 <danielbeck> #action danielbeck to write draft wiki page on new travel grant program
19:03:48 <kohsuke> #topic next meeting
19:04:03 <kohsuke> 8/19, same time
19:04:14 <kohsuke> #info and please see https://groups.google.com/forum/#!topic/jenkinsci-dev/kRobm-cxFw8
19:04:22 <kohsuke> #endmeeting