18:02:31 <kohsuke> #startmeeting
18:02:31 <robobutler> Let the Jenkins meeting commence!
18:02:38 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:02:47 <kohsuke> #topic recap of actions
18:03:04 <kohsuke> #info https://issues.jenkins-ci.org/browse/MEETING
18:03:25 <kohsuke> Hmm, I guess I haven't kept that up to date for a while
18:03:38 <kohsuke> Any specific AIs that we want to review?
18:04:00 <danielbeck> kohsuke patron program progress?
18:04:04 <Kamran> hey kohsuke :)
18:04:12 <kohsuke> Ah
18:04:22 <kohsuke> I'm afraid no progress to report
18:04:34 <kohsuke> I need to follow up that one
18:04:40 <Kamran> kohsuke: Did you happen to take a look at my ICLA yet? :D
18:04:50 <kohsuke> #action kohsuke to write to christina
18:04:52 <danielbeck> Kamran Meeting right now, please wait a bit
18:05:02 <Kamran> danielbeck: Okay.
18:05:15 <kohsuke> shall we move on to other topics, sinec we have a lot of them?
18:05:36 <danielbeck> +1
18:05:42 <Kamran> +3
18:05:45 <kohsuke> #topic JUC 2015 - obtain approval for a Mobile Morning mini-track that focus on Jenkins mobile development (Alyssa)
18:06:26 <kohsuke> Some sponsors are interested in having a clump of mobile related sessions & panel in JUC
18:06:45 <kohsuke> And so alyssa wanted to socialize that idea & see how people feel
18:07:39 <kohsuke> (All the usual caveats about no product pitch etc still applies.)
18:07:59 <danielbeck> would that be in parallel to other tracks?
18:08:59 <kohsuke> I don't think so, it's just putting all the mobile related talks back to back in one of the existing tracks
18:09:21 <kohsuke> So it's really just a grouping with a little bit of extra visibility
18:09:49 <kohsuke> All right, I take silence as "it's OK"
18:09:51 <kohsuke> going once...
18:09:52 <aheritier> mobile developments. Oh my god, I had to fight with xcode and ios build all the day…
18:10:16 <kohsuke> Yeah, I'm sure there are a lot of battle scar stories to share
18:10:22 <danielbeck> should be fine if attendees have other things to do if not interested.
18:10:27 <aheritier> I’m sure too
18:10:34 <kohsuke> Right, it's one of the two tracks
18:10:43 <kohsuke> OK, moving on...
18:10:51 <kohsuke> #topic Build/publisher steps & AbortException handling
18:11:17 <kohsuke> oh but kostyasha is not here
18:11:23 <danielbeck> I added the two supplementary links in the wiki but Kostya indicated they we're really what this is about. Sorry about that!
18:11:40 <kohsuke> #topic Defining guidelines on expected behavior and/or structure for plugins? If so, should we enforce them?
18:12:20 <danielbeck> Let's skip this, I added this as it's somewhat related to Kostya's topic
18:12:29 <kohsuke> all right
18:12:37 <danielbeck> We already discussed it in October, it's recently come up again
18:12:43 <kohsuke> #topic Would changing the meeting time to 10 AM PST/PDT allow overruns?
18:13:00 <danielbeck> Basically what it says on the tin. WDYT?
18:13:04 <kohsuke> would changing the time allow overrun?
18:13:38 <danielbeck> we've had several meeting we had to abort or hurry through, so the question is whether the problem is duration or time
18:13:52 <danielbeck> and if it's the latter, would moving the meeting time help?
18:13:58 <kohsuke> or frequency.
18:14:16 <danielbeck> I think it would also help eastern europe (e.g. Oleg, Kostya) if it was earlier
18:14:31 <kohsuke> Personally, if we really need to overrun, I can stay around even in the current time
18:14:46 <kohsuke> And likewise, even if we change the time, I'll still be just as likely to want to wrap this up in an hour
18:15:25 <danielbeck> alright, so the meeting time is not actually a problem (unless others want it to end earlier due to TZ issues)
18:15:28 <kohsuke> If this is to accomodate oleg, kostyasha, etc., I want to hear from them
18:15:45 <danielbeck> agreed
18:15:56 <kohsuke> I'm open to changing time, but there's certain inertia for things like this
18:16:17 <kohsuke> so in the absense of people saying "I can make it if the time moves", I'm inclined to keep it as is
18:16:28 <aheritier> +1
18:16:33 <kohsuke> and obviously, my apologies for blowing the previous one
18:16:43 <Kamran> +2
18:16:48 <danielbeck> As I wrote, from past meetings I got the impression that end time was a rather hard limit, hence the suggestion.
18:17:08 <danielbeck> let's move on
18:17:16 <kohsuke> #agreed if oleg, kostyasha or anyone else really want to change the time, we'll reconsider, but for now we keep the time as is.
18:17:25 <kohsuke> #topic Who gets voice on IRC? "Committers"... to any plugin? To core?
18:17:36 <danielbeck> I couldn't find any info on that.
18:17:48 <kohsuke> So the intent of the voice was to (1) give some visibility to active people in the community and
18:17:55 <kohsuke> (2) grant access to ircbot
18:18:20 <kohsuke> So to me, it is open to any plugin developers
18:18:38 <kohsuke> I guess your point is that it should be written down somewhere
18:18:43 <aheritier> AFAIR it was the case. For any developer who asked to have it
18:18:47 <danielbeck> we've recently added destructive commands to the bot.
18:18:56 <kohsuke> hm
18:19:00 <danielbeck> so "any plugin dev" seems to be too permissive
18:19:17 <jenkins-builds> Starting build #4061 for job jenkins_main_trunk (previous build: SUCCESS)
18:19:40 <kohsuke> maybe we limit who can run those destructive commands?
18:20:01 <kohsuke> we can just hard-code them in the bot, or maybe limit that to ops?
18:20:07 <Kamran> probably.
18:20:08 <danielbeck> too few ops
18:20:19 <Kamran> ^
18:20:48 <danielbeck> just seems weird to have someone request a fork of the 1010th plugin and give them control over all the repos and Jira.
18:20:50 <aheritier> there are few ops, thus +1 to allow them to do launch that destructive commands instead of people with only voice
18:21:31 <kohsuke> what if we use +v in jenkins-infra for more delicate commands?
18:21:31 <danielbeck> then I'll need to finish the jira component refatoring before that goes live :-)
18:21:53 <Kamran> jira component refactoring?
18:21:55 <danielbeck> kohsuke would reduced visibility be a problem?
18:22:18 <kohsuke> No, it's still the same bot, just that some commands you need to ask from #jenkins-infra
18:22:28 <kohsuke> And really, how many times do you need to remove components?
18:22:36 <danielbeck> kohsuke Visibility as in the community seems what's going on
18:22:48 <danielbeck> kohsuke A few dozen times or so still, but that's still part of https://wiki.jenkins-ci.org/display/JENKINS/2014+JIRA+Components+Refactoring so ... rarely
18:23:40 <kohsuke> if we log #jenkins-infra I think the visibility concern should be addressed
18:23:58 <danielbeck> right
18:24:11 <kohsuke> (and perhaps that way we can make the bot even more capable, like restarting jira)
18:24:17 <Kamran> yeah
18:25:04 <kohsuke> danielbeck: is that good enough in your opinion?
18:25:23 <danielbeck> still a bit too permissive for my taste, but that's the nature of the project I guess.
18:25:36 <kohsuke> yes
18:25:40 <danielbeck> so yeah, should at least prevent abuse.
18:26:13 <kohsuke> #action kohsuke to log #jenkins-infra
18:26:25 <kohsuke> can somebody volunteer to update ircbot for this new permission scheme?
18:26:40 <kohsuke> I think oleg hacks on ircbot
18:26:51 <danielbeck> he's not here, but we can ask
18:26:56 <Kamran> Doesn't jenkins-admin use PircBotX?
18:27:03 <kohsuke> Kamran: yeah
18:27:13 <kohsuke> Do you want to take this on?
18:27:26 <kohsuke> It's a small Java program: https://github.com/jenkins-infra/ircbot
18:27:59 <kohsuke> #agreed we'll run jenkins-admin bot also in #jenkins-infra and restrict destructive commands to people with +v on #jenkins-infra
18:28:13 <kohsuke> #action danielbeck to ask oleg if he can hack ircbot to do this
18:28:30 <kohsuke> if that fails I guess it'll be on me
18:28:40 <kohsuke> shall we move on?
18:28:45 <danielbeck> yes
18:28:50 <kohsuke> #topic JENKINS-27268
18:28:53 <jenkins-admin> JENKINS-27268:"dumb" slave? (Open) https://issues.jenkins-ci.org/browse/JENKINS-27268
18:29:12 <danielbeck> A user brought up the terminology issue in Jenkins
18:29:31 <danielbeck> similar issue in Django a while back: https://github.com/django/django/pull/2692
18:29:51 <kohsuke> OK, I thought for a moment he has a trouble with "dumb" part
18:30:00 <kohsuke> but IIUC he's complaining about the "slave" part
18:30:01 <danielbeck> So I wanted to raise awareness of this issue and discuss whether it needs to change
18:30:11 <danielbeck> It's worse in combination I think
18:30:12 <ogondza> we have enough ambiguity in terminology, imo. I do not feel master/slave to be that problematic personally
18:30:28 <ogondza> the "dump" part worries me more, too
18:31:10 <kohsuke> I originally named it "dumb slave" in anticipation of newer smarter slave types, but that never really materialized
18:31:53 <kohsuke> So I can definitely change it to "Build slave" or something by just a few changes in the core
18:32:07 <Kamran> I could take that on, since it seems quite easy.
18:32:20 <kohsuke> Renaming "slave" to another word that's more politically correct word would be a bit more work
18:32:42 <kohsuke> but if some people are offended by it, I suppose we need to do it
18:33:05 <kohsuke> Being an immigrant, I don't have the proper American sensibilities to that issue.
18:33:36 <Kamran> I think we should keep slave, but at least change it to build slave like you mentioned.
18:34:05 <kohsuke> Is that good enough for the submitter of JENKINS-27268?
18:34:08 <jenkins-admin> JENKINS-27268:"dumb" slave? (Open) https://issues.jenkins-ci.org/browse/JENKINS-27268
18:34:24 <danielbeck> I don't know. I can ask.
18:34:33 <kohsuke> And looking at that django issue, looks like they have rejected it
18:34:46 <kohsuke> or not
18:34:50 <danielbeck> kohsuke I think only this particular solution
18:35:00 <danielbeck> and implemented another
18:35:12 <ogondza> I suggest "static slave" or "permanent slave"
18:35:12 <bookwar> or please tell me this is the april's joke..
18:35:30 <danielbeck> bookwar Sorry, no.
18:35:33 <Kamran> danielbeck: What about "build node"?
18:35:39 <danielbeck> master is also a node
18:35:48 <danielbeck> "standalone slave"? "simple slave"?
18:35:55 <kohsuke> Wow, that PR quickly turned into a PR circus
18:36:18 <danielbeck> kohsuke The reason I wanted to bring this up here, so we don't get caught in the same mess
18:36:40 <kohsuke> Yeah, I'm more inclined to fix this now that I see that shit storm
18:36:48 <kohsuke> Unwanted attention
18:37:16 <Kamran> kohsuke: What would you guys change "dumb slave" to though?
18:37:16 <kohsuke> Kamran: yeah "build node" would work
18:37:22 <Kamran> yay :D
18:37:30 <kohsuke> It's close to internal name, too
18:37:41 <kohsuke> class Slave extends from Node
18:37:54 <kohsuke> Other tools call them agents
18:37:55 <jglick> Dunno, “slave” term appears throughout documentation and UI.
18:37:56 <kohsuke> So that's another option
18:37:57 <danielbeck> kohsuke so then there's node-to-master access control? huh?
18:38:11 <jglick> Changing the basic term now seems ill advised.
18:38:36 <Kamran> jglick: It wouldn't take that much work to change "slave" from "node" on Jenkins' wiki I don't think.
18:38:39 <kohsuke> jglick:  you have proper American sensibilities!
18:38:51 <jglick> “Dumb” was never a useful adjective in this context, though. “Static” or “permanent” or “manual” etc. would be more helpful.
18:39:24 <Kamran> jglick: yeah, but i don't think the submitter of that issue likes "slave" either.
18:40:25 <kohsuke> I just don't want to see HN/reddit thead like "Jenkins developers insists of using racial terms"
18:40:41 <kohsuke> Guaranteed frontpage hitter with charged comments from both sides
18:41:03 <Kamran> yeah, that would really suck to have to deal with that crap.
18:41:28 <jieryn> leader/follower
18:41:41 <kohsuke> jglick: you can correct me, but my impression of US of A is that you don't want to be seen defending those things
18:41:53 <danielbeck> It's worse with the 'dumb' anthropomorphizing the term, but it seems Django blew up without that anyway
18:41:57 <Kamran> lol, "US of A" :D
18:42:05 <jglick> I think there is precedent for using “slave” in a purely technical sense. http://en.wikipedia.org/wiki/Master_cylinder for example.
18:42:42 <kohsuke> Yeah, I was thinking about master/slave disks in IDE interfaces
18:42:56 <ogondza> "Is it at all ironic that this got merged into  master ?"
18:42:58 <Kamran> jglick: I still think we should change "slave" to "node", and change "dumb" to "standalone" or "build" like I mentioned earlier.
18:43:29 <Kamran> however jglick, "static" seems like another good one.
18:43:32 <danielbeck> master is also a 'node', so that doesn't help
18:43:38 <jglick> -0 on using “node” which also encompasses the master.
18:43:54 <kohsuke> "static build agent"?
18:43:54 <jglick> “Slave” is the only term which unambiguously excludes the master node.
18:44:02 <Kamran> kohsuke: yeah, i like that
18:44:20 <danielbeck> kohsuke master and agents?
18:44:49 <kohsuke> yeah, I'm too lazy to change that. I don't think people would be complaining about master
18:44:54 <microm> Does Jenkins support junitparams ?
18:45:06 <danielbeck> microm Meeting right now, please ask later.
18:45:26 <jglick> http://en.wikipedia.org/wiki/Master/slave_%28technology%29 generally
18:45:42 <Kamran> kohsuke: How many files would one need to edit in order to change slave to agent?
18:45:50 <danielbeck> jglick "Due to the controversy, the term was selected as the most politically incorrect word in 2004 by Global Language Monitor"
18:45:50 <jglick> So as long as we do not sell products in LA we are fine!
18:46:12 <danielbeck> Oh, Drupal was also changed
18:46:26 <kohsuke> I'm trying to see if I can get at least -0 from jglick about "static build agent"
18:46:43 <Kamran> i'll do a search through the Jenkins repo, see how many source files refers to "slave", since GitHub has that ability
18:46:49 <kohsuke> I don't want to waste too much on this
18:46:59 <danielbeck> Kamran We cannot change classes due to plugin compatibility
18:47:04 <Kamran> oh
18:47:05 <Kamran> dang
18:47:15 <jglick> Will possibly confuse existing Jenkins users. New users probably would not notice, though the continued use of the term “master” is then just weird.
18:47:17 <danielbeck> (which adds an unfortunately layer of terminology confusion for any devs)
18:48:03 <Kamran> jglick: Master could possibly be called "Master build agent", but that would require changing the classes.
18:48:07 <danielbeck> as we cannot just get rid of it cleanly
18:48:21 <danielbeck> I wonder whether consistent use of "slave node" would be sufficinet
18:48:24 <kohsuke> I think existing users will understand what they mean, especially because they see it in the place where they used to see "dumb slave"
18:49:40 <Kamran> kohsuke: yeah.
18:49:42 <kohsuke> danielbeck: not if I'm reading JENKINS-27268 right
18:49:44 <jenkins-admin> JENKINS-27268:"dumb" slave? (Open) https://issues.jenkins-ci.org/browse/JENKINS-27268
18:50:41 <ogondza> lets get rid of "dumb" part and see if the requestor is satisfied
18:50:59 <danielbeck> kohsuke Given how extensively 'slave' is used it going to be really difficult
18:51:02 <bookwar> "I just don't want to see HN/reddit thead like "Jenkins developers insists of using racial terms" i would be really surprised if the change(if it will be performed) doesn't hit the reddit . Don't do changes because of shitstorm blackmailing please, do it because they are reasonable. if they are.
18:51:27 <danielbeck> I mean, agent.jar alone is going to be fun
18:51:36 <Kamran> ogondza: That wouldn't require modifying classes right? Because that would break plugin compatability, like kohsuke just mentioned a few minutes ago.
18:51:49 <Kamran> *changing
18:51:57 <jglick> -1 on changes to filenames. Much too risky.
18:52:15 <ogondza> I have never considered actually renaming classes, only UI labels
18:52:24 <danielbeck> jglick "Want to connect your machine as an agent? Run slave.jar" o_O
18:52:40 <kohsuke> I think this is one of the rare moments in which I wave the BDFL flag
18:52:51 <Kamran> BDFL flag?
18:53:00 <jglick> Benevolent Dictator For Life
18:53:12 <Kamran> Oh, lol.
18:53:18 <kohsuke> Basically "let's not argue, please let me have it my way" plea
18:53:21 <sjmikem> For "Copy artifacts from another project", do I have to specify project name?  Or can it be any upstream project?
18:53:29 <danielbeck> sjmikem Meeting right now, please wait a bit
18:53:40 <kohsuke> I think we are all on the same page about not upsetting the compatibility requirements
18:53:54 <kohsuke> So I feel comfortable getting the changes mostly right
18:54:00 <danielbeck> user confusion!
18:54:13 <kohsuke> That's mangeable.
18:54:54 <Kamran> kohsuke: We might be able to just change the UI labels, but if we were to get rid of "dumb" what would we rename that to in the UI?
18:55:04 <kohsuke> Can we move on?
18:55:15 <Kamran> yes
18:55:17 <kohsuke> I feel like we can keep talking about this forever, and there's really more important things
18:55:19 <batmat> FWIW I'm french and I never had an issue with this. Though I see some ppl in other parts of the world that may see those words carrying strong meaning...
18:55:28 <batmat> kohsuke: yes, agreed.
18:55:35 <kohsuke> #topic Bug bounties/rewards for security issues
18:55:54 <danielbeck> A reporter of a security issue brought this up
18:56:12 <danielbeck> Basically asking for a reward of some kind
18:56:23 <kohsuke> our pockets aren't deep enough to offer anything significant, but I thought perhaps some token gifts would be doable
18:56:44 <Kamran> kohsuke: agreed
18:56:45 <danielbeck> we don't have money, but something like a mug or t-shirt maybe?
18:57:05 <Kamran> Ooh, I like the mugs idea Daniel.
18:57:06 <kohsuke> Right, maybe a gift card for cafepress.com/jenkinsci
18:57:35 <kohsuke> something easy administration wise would be nice, too
18:57:42 <kohsuke> something that can be sent over email
18:57:46 <Kamran> yeah
18:58:01 <danielbeck> kohsuke Would it be feasible to have exclusive designs?
18:58:24 <kohsuke> we need to find someone who can do the artwork
18:59:04 <Kamran> yeah
18:59:04 <kohsuke> I can ask to some CB folks, but I've always felt their illustrator creates pictures that feel different
18:59:17 <kohsuke> see http://jenkins-ci.org/content/jenkins-100k-celebration-pictures
18:59:20 <jenkins-admin> JENKINS-100:tag this build icon has bad name (Closed) https://issues.jenkins-ci.org/browse/JENKINS-100
19:00:04 <kohsuke> shapeway $25 gift card can do for https://www.shapeways.com/model/upload-and-buy/2183445
19:00:04 <danielbeck> http://blog.cloudbees.com/2015/01/breakingbuilds-twitter-contest-results.html
19:00:29 <Kamran> (off-topic) odd, i just noticed, jenkins-admin doesn't have the ability to connect to IRC using SSL.
19:00:49 <danielbeck> kohsuke non-public link
19:00:55 <kohsuke> oh
19:01:20 <kohsuke> https://www.shapeways.com/product/NZAN5AGUS/mr-jenkins-v2
19:01:52 <Kamran> Hmm, those look nice, I quite like the 4th one actually
19:02:04 <Kamran> oh wait, you made those
19:02:05 <Kamran> :D
19:02:05 <kohsuke> The other part of the program is to limit this to one per person
19:02:11 <danielbeck> kohsuke Definitely.
19:02:12 <kohsuke> Sorry, danielbeck & jglick you'll only get one
19:02:41 <jglick> I would just say to disqualify committers.
19:03:01 <jglick> (Or their families!)
19:03:04 <Kamran> jglick: Why?
19:03:16 <danielbeck> Kamran It costs money.
19:03:34 <kohsuke> I'm afraid I'm running out of time today
19:03:37 <Kamran> danielbeck: Yeah, true
19:03:39 <kohsuke> I want to hear from hare_brain on this one
19:03:43 <jglick> It is just part of our job. Anyway what if I tried to illicitly build my coffee mug collection by *introducing* vulnerabilities and then reporting them?
19:04:05 <danielbeck> kohsuke I think mug/shirt, possibly with exclusive design (if it's just the Jenkins logo +  "security team" below, doesn't have to be super elaborate IMO) would be fine.
19:04:07 <kohsuke> #chair danielbeck jglick
19:04:07 <robobutler> Current chairs: danielbeck jglick kohsuke
19:04:21 <kohsuke> OK, I'll ask CB folks to see if they can do an artwork
19:04:23 <hare_brain> I’m sorry.
19:04:29 <hare_brain> I’ve been in meetings and not paying attention.
19:04:32 <kohsuke> #chair hare_brain
19:04:32 <robobutler> Current chairs: danielbeck hare_brain jglick kohsuke
19:04:46 <kohsuke> I need to run now, I'm really sorry
19:04:59 <kohsuke> hare_brain: bounty / thank you gift for security vulnerabilities
19:05:05 <danielbeck> hare_brain Can we afford t-shirts or mugs for security issue reporters as a token gift?
19:05:31 <hare_brain> Seems like we should be able to.
19:05:49 <hare_brain> We’re not getting these reports every day are we
19:06:17 <Kamran> kohsuke: Would you please be able to take a look at my ICLA before you run off?
19:06:30 <danielbeck> Fairly few, and most are from regular devs, see the recent advisories
19:07:46 <jglick> So can we agree on (a) token non-cash gifts, (b) not for committers, (c) accepted (or fixed?) issues only?
19:08:08 <danielbeck> d) no repeats
19:08:28 <hare_brain> +1
19:08:41 <danielbeck> Published fixes should be fine
19:08:54 <danielbeck> e) must be exploitable, no hardening
19:09:32 <Kamran> agreed
19:09:46 <jglick> #agreed non-cash gifts to be provided to reporters of SECURITY issues if and when the issue is accepted as a vulnerability (not merely security hardening) and a fix published. Maximum one gift per reporter and Jenkins committers are excluded.
19:10:30 <danielbeck> great
19:10:34 <jglick> Whether we retroactively offer gifts to historical reporters is another question I would leave for now unless anyone feels strongly.
19:11:09 <danielbeck> let's move on
19:11:13 <Kamran> agreed
19:11:23 <jglick> danielbeck do you want to take the other agenda items? Most are from you.
19:11:45 <danielbeck> #topic Resurrecting the MEETING Jira project (maybe even have the bot create issues for action items automatically)
19:12:15 <danielbeck> Just as kohsuke discovered a few minutes ago, this Jira project is basically dead
19:12:40 <danielbeck> I think it would be a great tool for tracking meeting action items, if we can manage to have the bot create issues
19:12:48 <danielbeck> or we just shut it down.
19:13:08 <danielbeck> any opinions on this?
19:13:16 <jglick> Never heard of it before.
19:13:21 <danielbeck> https://issues.jenkins-ci.org/browse/MEETING
19:13:46 <jglick> #info https://issues.jenkins-ci.org/browse/MEETING
19:14:12 <jglick> No opinion from me.
19:14:13 <Kamran> Maybe we could try figuring out how to make the bot create issues?
19:14:48 <jglick> May be tricky since in general IRC nick != jenkins-ci.org username.
19:15:01 <Kamran> jglick: yeah, true.
19:15:50 <Kamran> danielbeck: What's your opinion on this?
19:15:59 <danielbeck> I don't know where the bot source is, unfortunately.
19:16:11 <danielbeck> I'd love to get MEETING revived
19:16:15 <Kamran> danielbeck: https://github.com/jenkins-infra/ircbot
19:16:33 <danielbeck> I've forgotten probably half the action items assigned to me
19:16:40 <danielbeck> Proper tracking would be great
19:16:45 <Kamran> That's the bot source, daniel.
19:16:57 <danielbeck> Kamran Isn't that jenkins-admin? This is about robobutler
19:17:01 <Kamran> no
19:17:03 <Kamran> *oh
19:17:15 <Kamran> you guys have two bots in here, totally forgot about that
19:17:24 <danielbeck> there's also jenkins-builds
19:17:40 <danielbeck> So yeah, not something we can manage without input from kohsuke I'm afraif
19:17:50 <jenkins-builds> Project jenkins_main_trunk build #4061: SUCCESS in 58 min: http://ci.jenkins-ci.org/job/jenkins_main_trunk/4061/
19:17:50 <jenkins-builds> Jesse Glick: [JENKINS-27700] Noting that JENKINS-27565 changed settings format.
19:17:53 <jenkins-admin> JENKINS-27700:Node configuration missing after downgrading from 1.607 to 1.606 (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-27700
19:17:55 <jenkins-admin> JENKINS-27565:Nodes can be removed as idle before the assigned tasks have started (Resolved) https://issues.jenkins-ci.org/browse/JENKINS-27565
19:18:05 <danielbeck> so I think we should just move on
19:18:10 <Kamran> Alright.
19:18:10 <danielbeck> and postpone this
19:18:47 <Kamran> uh, danielbeck: https://github.com/jenkins-infra/robobutler
19:19:03 <danielbeck> Kamran Nice
19:19:16 <Kamran> :D
19:19:51 <danielbeck> still, doesn't look like there's a lot of interest in this topic?
19:20:35 <Kamran> I still think we could at least try and figure out how to make the bot create issues, but not sure how much work that would take, however, I do have an IRC bot coded in python as well, which is what robobutler is coded in
19:20:35 <schristou> cccccceefndcngbdvrbjrkvgkjjbfdfdherdcjhbfnkg
19:20:47 <schristou> ops sorry
19:21:01 <Kamran> schristou: were you sleeping on your keyboard? :D
19:21:05 <danielbeck> Kamran Could you maybe take a shot to see whether this would be feasible?
19:21:28 <schristou> Kamran: SHH! ;)
19:22:11 <Kamran> danielbeck: I'll give it a shot. :D
19:23:00 <danielbeck> #action Kamran to look into adding MEETING issue creation to robobutler
19:23:06 <danielbeck> great!
19:23:09 <Kamran> :)
19:23:29 <danielbeck> #topic The important content of the Wiki is difficult to find (between outdated or even empty pages), and there's no real introduction to Jenkins – What can we do about it?
19:23:41 <danielbeck> This also includes the web site.
19:24:06 <danielbeck> It seems to be unnecessarily difficult to find anything in the wiki
19:24:36 <danielbeck> Even the wiki home page is outdated and borderline wrong
19:24:59 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/Meet+Jenkins
19:25:16 <Kamran> (kinda un-related, but kinda related) Maybe updating the atlassian software (Confluence, JIRA, etc) might make the wiki easier to navigate? Because right now, the Jenkins Wiki is stuck at Confluence version 3.4.7, which is really out of date now. Same applies to JIRA as well.
19:25:30 <danielbeck> The second most important function of Jenkins is 'monitor external job'
19:26:21 <danielbeck> so I'd really like to clean and/or restructure up the wiki, or anything else that makes the important bits easier to find
19:27:24 <danielbeck> maybe having a wiki isn't the best approach to begin with, and something more like a knowledge base site with specific questions/answers might work better for some of the content?
19:27:36 <ogondza> I agree, though have no idea where to start or a vision of the future
19:27:47 <Kamran> danielbeck: I think we should keep the wiki.
19:28:06 <Kamran> Because to be honest, I find wikis to be easier to navigate than knowledge bases.
19:28:57 <hare_brain> If you were to restructure the wiki, would you want to move it to GitHub wiki?
19:29:02 <danielbeck> Kamran To clarify, 'having _only_ a wiki'
19:29:17 <danielbeck> hare_brain That's per repo, right?
19:29:21 <Kamran> danielbeck: yes.
19:29:37 <Kamran> each github wiki is per repository.
19:29:39 <danielbeck> that makes as little sense for Jenkins as per-repo issue trackers.
19:29:45 <Kamran> yeah
19:30:02 <Kamran> However, the Jenkins wiki being stuck at Confluence 3.4.7 is kind of a bad thing, especially since that's a really old version.
19:30:45 <danielbeck> Kamran I think an update is planned
19:31:00 <Kamran> Really? :D
19:31:16 <ogondza> danielbeck: I am afraid that using knowledgebase would suffer from outdated content as well
19:31:19 <danielbeck> But I doubt the wiki version will help a lot with making the content more accessible
19:32:38 <Kamran> danielbeck: It might actually, because Confluence was given a revamp in version 5.x.
19:32:55 <Kamran> and that revamp made Confluence a lot easier to navigate
19:33:02 <jglick> Maybe we should link more prominently to http://stackoverflow.com/questions/tagged/jenkins ?
19:33:10 <Kamran> in my opinion, anyway
19:33:16 <danielbeck> ogondza It would help if we could have a better overview of the content we have, so if something changes, we can actually find the wiki pages to change
19:33:54 <danielbeck> jglick Looks more like a mailing list alternative to be honest
19:34:24 <Kamran> danielbeck: the images on the wiki also need to be updated, such as wiki pages with Jenkins screenshots
19:34:25 <jglick> Well you talked about a “knowledge base” and that is what I think of as the modern version of KBs.
19:34:58 <danielbeck> right
19:35:36 <danielbeck> As I wrote, for some of the content
19:36:00 <danielbeck> that would allow us to focus the wiki more on general documentation
19:36:14 <Kamran> danielbeck: yeah
19:37:24 <danielbeck> Should we continue this to the dev list to get more ideas?
19:37:32 <danielbeck> *on
19:37:42 <ogondza> +1
19:37:47 <Kamran> danielbeck: yeah
19:37:50 <Kamran> *sure
19:38:33 <danielbeck> #action danielbeck to ask for ideas on improving the documentation on the dev list
19:38:49 <Kamran> shall we move on?
19:38:50 <Kamran> :D
19:39:09 <danielbeck> #topic Proposal: move Jenkins official image repo to jenkinsci org so enhancement / version updates can be managed by the community
19:39:23 <danielbeck> ndeloof isn't here
19:39:25 <Kamran> +1
19:39:37 <danielbeck> jglick Can you contact him?
19:39:52 <jglick> danielbeck: he said he could not make the meeting.
19:40:01 <jglick> But I think he is not necessary for the topic.
19:40:08 <jglick> Seems like a reasonable proposal to me.
19:40:18 <Kamran> Yeah, i agree with jglick.
19:40:18 <jglick> Right now there are several open issues and PRs.
19:40:38 <jglick> I think it is just for historical reasons that it landed in @cloudbees.
19:40:55 <jglick> #info https://github.com/cloudbees/jenkins-ci.org-docker
19:41:01 <Kamran> jglick: Doesn't all issues & PRs stay in the repo even when you move it to an organization?
19:41:17 <jglick> Yes, if you *move* rather than clone.
19:42:07 <danielbeck> Should the repo be renamed as well, or is this an established docker naming convention?
19:42:23 <danielbeck> From the name it looks more like part of jenkins-infra to me
19:42:23 <jglick> Not sure if there is any particular convention.
19:42:49 <jglick> Is that a GH org?
19:42:55 <Kamran> jglick: yes
19:43:04 <jglick> https://github.com/jenkins-infra
19:43:16 <Kamran> dang it, you beat me to it
19:43:44 <jglick> Not sure. This is not part of jenkins-ci.org.
19:43:49 <jglick> That is, the site.
19:43:50 <danielbeck> jglick Would be wrong in jenkins-infra, but that's why I wrote that the name confuses. Looks like the docker container driving www.jenkins-ci.org
19:44:15 <Kamran> Odd, how is github at "Everything operating normally", when the avatar server is still having problems?
19:44:15 <danielbeck> based on name only
19:44:35 <arminius> so i decided to make my jenkins look a bit more awesome: http://arminius.org/shot.png - anyone an idea why this seems to be only present when accessing jenkins from my desktop machine but not from my thinkpad?
19:44:36 <jglick> Oh, yes, I see your point. Agreed, the name should change.
19:44:58 <danielbeck> arminius Meeting ongoing, please wait a bit
19:45:26 <jglick> Maybe @jenkinsci/jenkins-docker-image?
19:45:38 <danielbeck> much better
19:46:13 <Kamran> arminius: dang, that theme looks awesome. Would you consider making it public? I would love to use it. Also yeah, danielbeck is right, there is a meeting going on right now :D
19:46:50 <Kamran> jglick: yeah, i like that
19:46:53 <arminius> Kamran: it's just a css modification of a theme i downloaded, will try to tar/gz that, sure. :)
19:47:25 <Kamran> Okay, PM me it once you do, since I don't want to disturb the meeting :D
19:47:28 <jglick> #info https://registry.hub.docker.com/_/jenkins/
19:47:47 <Kamran> *when you do
19:47:56 <jglick> https://registry.hub.docker.com/search?q=library&f=official
19:47:59 <Kamran> jglick: Where does that even go when you do #info?
19:48:11 <danielbeck> Kamran Meeting minutes
19:48:17 <jglick> Kamran: meeting notes http://meetbot.debian.net/Manual.html#commands
19:48:32 <Kamran> Ah, okay.
19:48:55 <jglick> I can find no solid convention but docker-jenkins looks most conventional.
19:49:07 <jglick> So revised proposal: @jenkinsci/docker-jenkins
19:49:35 <Kamran> jglick: I do see a lot of repos going by projectname-docker-container
19:49:51 <jglick> Also some at: https://github.com/docker-library
19:49:53 <Kamran> or am i being a derp?
19:50:05 <danielbeck> would also help disambiguate from the plugin
19:50:12 <Kamran> yeah
19:50:14 <jglick> But I think we want to keep it in @jenkinsci.
19:50:32 <Kamran> jglick: no, i mean as the repository name :D
19:50:35 <danielbeck> docker-jenkins could be the plugin with a bad repo name as well. jenkins-docker-container, not so much
19:50:51 <jglick> Yeah I suppose so. (In fact it is docker-plugin.)
19:51:05 <jglick> (And we do try to enforce repo names when cloning into @jenkinsci.)
19:51:18 <jglick> But jenkins-docker-container is fine with me too.
19:51:23 <Kamran> yay :D
19:51:38 <arminius> Kamran: wget arminius.org/jenkins-theme.tar.gz
19:52:14 <Kamran> arminius: Alright, thanks! :D
19:52:19 <danielbeck> So #agreed? Or are you looking for more opinions?
19:52:27 <Kamran> #agreed.
19:52:31 <arminius> Kamran: much welcome. if it works for you i would be very happy to know. :)
19:52:33 <jglick> Yes.
19:53:30 <danielbeck> #agreed move Jenkins docker repo from @cloudbees into @jenkinsci, rename to jenkins-docker-container
19:53:53 <jglick> #action ndeloof to do the move
19:53:53 <danielbeck> Who's doing that? jglick? ndeloof?
19:53:56 <danielbeck> ok
19:53:56 <Kamran> shall we move on?
19:53:58 <danielbeck> yes
19:54:16 <danielbeck> #topic Disabling "Clone" feature in JIRA
19:54:24 <danielbeck> Is there any legitimate use case for this?
19:54:32 <Kamran> No there isn't.
19:55:17 <danielbeck> I've only ever seen it to improve visibility by ... fragmenting... things, or to create new issues that then still carry around a half broken issue description
19:55:33 <orrc_> yeah, in any JIRA I've seen, nobody ever clones issues properly
19:55:36 <danielbeck> so if that's possible, I'd like to see this removed/disabled
19:55:49 <Kamran> danielbeck: Not sure if it's a thing you can actually disable
19:55:58 <danielbeck> take away permissions?
19:56:07 <Kamran> Is there a permission node for that?
19:56:28 <danielbeck> Would need to look this up
19:56:38 <danielbeck> but is there anyone who thinks it's useful?
19:56:48 <Kamran> danielbeck: nope, not useful to me
19:56:53 <orrc_> a DDG search for "jira disable clone" suggests that feature was implemented a while ago
19:57:15 <danielbeck> IOW, we urgently need a Jira update now :-)
19:57:34 <Kamran> danielbeck: yup, same goes for confluence :D
19:57:57 <orrc_> we're on JIRA 5, it was implemented in JIRA 3.7 :)
19:58:12 <orrc_> Kamran: kk has been working on updating Confluence too
19:58:27 <danielbeck> so, can we agree on removing this?
19:58:34 <Kamran> Yes.
19:58:38 <Kamran> #agreed
19:58:41 <ogondza> +1
19:59:05 <danielbeck> #agreed Remove/disable clone action in Jira
19:59:07 <orrc_> kill it. nobody wants it. in the super rare case that somebody has a real reason to use it, we can just flip the switch again
19:59:38 <danielbeck> #action danielbeck to figure out how to get rid of clone in Jira
19:59:49 <danielbeck> #topic The Chinese mirror is a mess
19:59:58 <danielbeck> #info http://mirrors.jenkins-ci.org/status.html
20:00:10 <danielbeck> great timing: that was at 100+ days age just a few days ago
20:00:44 <Kamran> wow, all them red indicators under the chinese mirror though
20:00:49 <danielbeck> resulting in some users getting broken updates due to INFRA-260
20:00:52 <jenkins-admin> INFRA-260:The Chinese mirror is outdated (Open) https://issues.jenkins-ci.org/browse/INFRA-260
20:01:41 <danielbeck> Unfortunately I have no idea who's running the mirrors, and if there's any way to get a better mirror in that region
20:02:13 <orrc_> there was an offer on the mailing list a few days ago from someone who has US, GB, RU and AU mirrors (I think)
20:02:31 <orrc_> it would be nice if the mirror management stuff was in puppet, but it doesn't seem to be at all
20:02:37 <danielbeck> orrc_ Nothing near China though?
20:02:46 <danielbeck> rtyler?
20:03:01 <kohsuke> I'm back and hey this is still going!
20:03:08 <Kamran> kohsuke: welcome back!
20:03:34 <kohsuke> Maybe I should read backlog, but should we just remove that mirror from the list?
20:03:47 <danielbeck> I don't know how useful/essential it is
20:03:49 <orrc_> danielbeck: not that I remember. we still have two mirrors in JP
20:04:01 <Kamran> kohsuke: yes, because there's no point in having a mirror that's so outdated.
20:04:20 <danielbeck> a few days aren't that bad, but 100+? that's completely useless
20:04:22 <kohsuke> mirrorbrain only redirects traffic to a mirror when it knows the mirror has up-to-date file
20:04:36 <rtyler> is it meeting time?
20:04:37 <kohsuke> So it's probably not doing any real harm
20:04:39 <rtyler> damnit
20:04:40 <danielbeck> kohsuke Any explanation for INFRA-260 then?
20:04:43 <jenkins-admin> INFRA-260:The Chinese mirror is outdated (Open) https://issues.jenkins-ci.org/browse/INFRA-260
20:04:50 <Kamran> rtyler: yes, it's been going on for over 2 hours now :D
20:04:51 <rtyler> kohsuke: do you know how to disable a mirror in mb?
20:05:00 <kohsuke> yeah, I think I do
20:05:01 <rtyler> east coast time is really messing with me
20:05:02 <danielbeck> I rewrote it a bit but the original error is in there
20:05:10 <rtyler> kohsuke: alright, let's do that later then?
20:05:20 <kohsuke> I see, so it is actually causing harm
20:05:28 <orrc_> kohsuke: rtyler: can the mirror management be puppetised or automated somehow?
20:05:32 <rtyler> I dropped the ball on that, there's unread infra emails that I deprioritized in favor of reviewing those PRs
20:05:42 <orrc_> also, the guy wrote back today: http://lists.jenkins-ci.org/pipermail/jenkins-infra/2015-April/000284.html
20:05:45 <rtyler> orrc_: it can, that's one of the oldest INFRA tickets :P
20:05:58 <danielbeck> kohsuke Also, see comments from someone in India who solved it by using the German mirror
20:06:03 <orrc_> jolly good
20:06:48 <rtyler> kohsuke: considering the recent work you've done I think we should get the mirrors into functional state so users aren't affected but continue to focus on the jira stuff
20:07:25 <kohsuke> so IIUC, the action is to remove the mirror now, then puppetizing mirrorbrain in a not-so-long term?
20:07:41 <rtyler> depending on how you define not-so-long term, sure
20:07:44 <kohsuke> I assume Ray Sison from Go-Parts is a different conversation, right?
20:07:50 <rtyler> oh yeah
20:08:10 <rtyler> mirrorbrain is very database driven, and tohse types of applications tend to be more challenging to properly puppetize
20:08:13 <kohsuke> #action kohsuke to disable mirror.bit.edu.cn
20:08:33 <orrc_> kohsuke: related: INFRA-225 is back
20:08:36 <jenkins-admin> INFRA-225:Appears backend crawler hasn't run since Oct 2014 (Reopened) https://issues.jenkins-ci.org/browse/INFRA-225
20:08:44 <kohsuke> #action somebody needs to file INFRA ticket to puppetize mirrobrain
20:08:55 <rtyler> it's there
20:08:58 <rtyler> it's like INFRA-4
20:08:59 <kohsuke> orrc_:  aye, I meant to get to it over the weekend and got carried away with JIRA/Confluence hacking
20:08:59 <rtyler> :P
20:09:00 <jenkins-admin> INFRA-4:Upgrade spinach from 10.10 to 12.04 LTS (Resolved) https://issues.jenkins-ci.org/browse/INFRA-4
20:09:39 <kohsuke> Nope, I'm not seeing a ticket for that
20:10:08 * rtyler fetches
20:10:32 <kohsuke> Anything else on this topic?
20:10:43 <danielbeck> done with disabling the mirror
20:10:54 <kohsuke> that was fast!
20:10:55 <orrc_> kohsuke: cool. that JIRA/Confluence stuff is really nice
20:11:05 <kohsuke> Thanks
20:11:23 <kohsuke> Turns out that JIRA license has expired, so we need to get a new license issued before we can upgrade
20:11:38 <Kamran> And Confluence?
20:11:40 <kohsuke> So I'm thinking maybe I should postpone migration until that
20:12:10 <kohsuke> The thing is, usually the license renewal is automatic, but Atlassian has abandone the unlimited JIRA user license
20:12:21 <kohsuke> so it looks like we need to be transferred to a different kind of license
20:12:30 <danielbeck> kohsuke next meeting / end meeting? Or is this for the meeting?
20:12:33 <kohsuke> I've already applied for it, but it says it'll take multiple business days
20:12:38 <kohsuke> sorry, you are right
20:12:49 <kohsuke> let's wrap this up and I can update outside the meeting
20:12:56 <kohsuke> #topic next meeting
20:13:12 <kohsuke> Next meeting will be April 15th
20:13:17 <kohsuke> same time as always
20:13:22 <kohsuke> #endmeeting