19:04:59 <kohsuke__> #startmeeting
19:04:59 <robobutler> Let the Jenkins meeting commence!
19:05:10 <kohsuke__> I think my network is unstable
19:05:15 <kohsuke__> (I'm in a conference)
19:05:24 <autojack> aha
19:05:33 <kohsuke__> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
19:05:48 <kohsuke__> #topic Decision on further component renames in Jira
19:06:00 <autojack> I would like to talk about https://issues.jenkins-ci.org/browse/JENKINS-23431
19:06:02 <jenkins-admin> JENKINS-23431:Google is phasing out OpenID endpoint. Need to move on to G+ sign-in (Open) https://issues.jenkins-ci.org/browse/JENKINS-23431
19:06:17 <kohsuke__> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/T_V9Z71rbPk
19:06:23 <kohsuke__> autojack: OK, let's add to the end
19:06:25 <oleg-nenashev> kohsuke: Don't forget to push F5  next time ;)
19:06:27 <autojack> np
19:06:56 <oleg-nenashev> I reordered topics to keep INFRA together. BTW, no difference
19:08:05 <oleg-nenashev> danielbe_: Are you online?
19:08:16 <kohsuke__> FWIW, the list looks good to me
19:08:45 <kohsuke__> I thought we did have jmeter plugin but maybe that got renamed
19:08:59 <oleg-nenashev> It's performance-plugin nopw
19:09:06 <kohsuke__> https://wiki.jenkins-ci.org/display/JENKINS/JMeter+Plugin
19:09:35 <oleg-nenashev> No need to keep the component IMO
19:09:44 <kohsuke__> I agree
19:11:02 <kohsuke__> jenkins-reviewbot is the actual artifactId of the plugin, huh
19:11:19 <oleg-nenashev> There're plenty of other changes proposed, but they LGTM. We can revise/revert particular changes at any moment
19:11:45 <kohsuke__> #agreed the list he has looks good to us. Fire away
19:12:06 <oleg-nenashev> I would also propose to slightly update plugin-info macro to explicitly show jiraComponent
19:12:43 <oleg-nenashev> In such case we would avoid possible confusions
19:12:51 <kohsuke__> OK, why is that?
19:13:44 <kohsuke__> Since danielbe_ isn't here, let's talk about other stuff
19:13:49 <oleg-nenashev> Currently, there's only a hyperlink to open issues. BTW, a user won't notice if the jraComponent is invalid
19:14:03 <oleg-nenashev> JIRA just returns an empty list
19:14:23 <kohsuke__> Ah
19:14:37 <oleg-nenashev> An additional info row with an embedded validadion would be great
19:14:38 <kohsuke__> so you want to have it jump to the component page, like https://issues.jenkins-ci.org/browse/JENKINS/component/15803
19:14:54 <oleg-nenashev> Yes, it makes sense as well
19:15:13 <kohsuke__> OK, I think I understand now
19:15:17 <kohsuke__> sounds like another INFRA issue
19:15:23 <oleg-nenashev> yep
19:15:31 <oleg-nenashev> I haven't submitted it yet
19:16:00 <kohsuke__> #idea Plugin masthead in Wiki should land to the component page like https://issues.jenkins-ci.org/browse/JENKINS/component/15803#selectedTab=com.atlassian.jira.plugin.system.project%3Acomponent-issues-panel
19:16:04 <kohsuke__> oops
19:16:22 <oleg-nenashev> I can easily implement it, but a test environment would be useful. A support from INFRA owners is required to update the plugin as well
19:16:53 <kohsuke__> I thinke the challenge in linking to the component page is to figure out the component ID from the component name
19:16:57 <oleg-nenashev> kohsuke: How long did it take to update the plugin?
19:17:36 <kohsuke__> Something has to run elsewhere asynchronously to generate such mapping as redirector
19:17:55 <oleg-nenashev> kohsuke: AFAIK JIRA REST API has such command
19:17:56 <kohsuke__> Deploying the Confluence plugin itself is very quick. Cache regeneration will then take some more time
19:18:34 <kohsuke__> But all in all, deploying a new version is an easy process
19:18:42 <kohsuke__> Can we move on to the next topic?
19:18:59 <oleg-nenashev> yes. This one seems to be 1x1
19:19:21 <kohsuke__> #topic Mark usage request from CloudBees
19:19:33 <kohsuke__> #info https://groups.google.com/forum/#!searchin/jenkinsci-dev/mark$20usage/jenkinsci-dev/rzNetnrhPRI/7rRfyshG9bEJ
19:20:07 <kohsuke__> The conversation didn't go further beyond the initial round, so I am hoping to hear from more of you
19:20:17 <kohsuke__> hare_brain: abayer: I hope you guys are here
19:20:23 <hare_brain> I’m here
19:21:10 <kohsuke__> Or is this something not too many people just don't care about?
19:21:33 <kohsuke__> I meant "most people just don't care about"
19:22:09 <kohsuke__> I'm sort of between a rock and a hard place.
19:22:10 <hare_brain> I hope *some* people care about it. Because we could really use other opinions.
19:22:24 <kohsuke__> Exactly
19:23:34 <oleg-nenashev> kohsuke__: I have not a strong opinion on the naming pattern. But it definitely makes sense to define a common standard [post-factum?]
19:25:08 <kohsuke_> Yes, I tried to phrase it as much about approving a pattern as these specific names
19:25:29 <oleg-nenashev> It also makes sense to agree on names for non-commercial solutions. There're plenty of "MyMegaJenkins" names on presentations. It's not bad, but it seems to be a grey zone as well
19:27:05 <kohsuke_> Technically, I don't think the commercial / non-commercial nature of the mark usage affects the policy --- for example Apache rules about their trademarks do not distinguish commercial/non-commercial
19:27:24 <hare_brain> I would say that it’s actually *less* about the pattern and *more* about protecting the trademark, and ensuring that it continues to be associated with the project first.
19:28:51 <kohsuke_> OK. I thought you are for guidelines that help deciding on these things more smoothly as opposed to look at individual cases individually.
19:30:12 <hare_brain> Well, guidelines may help decide, but the criteria, IMO, should always be, what effect does a request have on the trademark?
19:30:54 <kohsuke_> Did my response to you about which way the confusion goes score any points?
19:31:18 <autojack> hi
19:31:20 <autojack> I am reading.
19:31:39 <hare_brain> No, not really. :) I had considered and acknowledged the reverse meritocracy point before. It *is* unfair to CloudBees.
19:32:06 <kohsuke_> ... that the question at hand is whether proposed "AcmeCorp Jenkins Enterprise" confuses people whether it is from AcmeCorp or Jenkins
19:32:08 <hare_brain> And to be clear, my position has always been one of concern, not objection.
19:32:32 <hare_brain> If no one else is worried about it, then I wouldn’t object to the specific request from CloudBees.
19:32:50 <kohsuke_> It is not about whether people get confused about where Jenkins effort is from, which I sense is your main concern.
19:33:39 <oleg-nenashev> I'd say "CloudBees Jenkins ..." is the only one real confusion now. I know many people, who have been confused by it
19:34:05 <oleg-nenashev> BTW, in case of CB it's fair to leave things as is
19:34:35 <kohsuke_> oleg-nenashev: you know many people who have been confused what with what?
19:35:21 <oleg-nenashev> kohsuke_: Many my previous colleagues and contacts thought that Jenkins is a product from Cloudbees
19:35:30 <kohsuke_> Do I get it right that you feel the same as hare_brain , that "AcmeCorp Jenkins FooBarZot" is OK for general AcmeCorp but not for CloudBees?
19:35:39 <kohsuke_> OK
19:35:45 <oleg-nenashev> kohsuke_: No
19:36:10 <oleg-nenashev> kohsuke: In my opinion, there's no problem with Cloudbees. I'm OK with current names
19:36:26 <kohsuke_> Just to make sure, current names are "Jenkins Enterprise by CloudBees"
19:36:37 <kohsuke_> The new name being requested is "CloudBees Jenkins Enterprise"
19:36:51 <kohsuke_> (there are a few more requests here but they all follow the same pattern)
19:37:26 <oleg-nenashev> People will invert words in any case :(
19:38:01 <kohsuke_> Sorry for being slow, but I'm just trying to understand what you are OK with
19:38:30 <oleg-nenashev> No problem, it's probably caused by my English
19:38:56 <oleg-nenashev> I'm OK with both namings
19:39:10 <hare_brain> “…that "AcmeCorp Jenkins FooBarZot" is OK for general AcmeCorp but not for CloudBees?”
19:39:11 <autojack> my two cents: purely from the perspective of readability, limiting confusion, and so on, I think I prefer the 'Jenkins Foo by SomeCompany' convention over 'SomeCompany Jenkins Foo.'
19:39:15 <hare_brain> Oops
19:39:41 <autojack> I like that it makes it clear that this is a Jenkins improvement brought to you by SomeCompany.
19:39:51 <hare_brain> What I mean to continue with, is that “AcmeCorp Jenkins FooBarZot” is more likely to dilute the mark than the currently approved pattern.
19:39:53 <oleg-nenashev> Yes! I found it: http://docs.pivotal.io/cloudbees/Jenkins.html
19:40:25 <kohsuke_> All right, is it fair if I send another email to that thread saying the board will approve the request in 2 weeks unless we hear from people?
19:40:39 <hare_brain> When it’s CloudBees instead the place of AcmeCorp, the likelihood of trademark dilution is higher.
19:41:01 <kohsuke_> I take it back. I didn't notice there are more messages to scroll
19:41:52 <kohsuke_> grr, I'll ask Pivotal doc to be updated
19:42:07 <oleg-nenashev> Example #2: https://opensourcearchitect.co/education/cloudbees/jenkins-2-day
19:42:34 <oleg-nenashev> I'd say the logo could be updated as well :)
19:43:08 <oleg-nenashev> BTW, it is not very related to the discussion
19:43:44 <kohsuke_> autojack: it's kind of ironic that a part of the motivation for the new name request, as I believe, is to put more emphasis on CloudBees
19:44:10 <hare_brain> Which is a valid motivation for CloudBees.:)
19:44:17 <oleg-nenashev> Definitely
19:44:23 <autojack> yeah. well I think that's what hare_brain is hesitant about.
19:44:53 <autojack> the open question I guess is whether we think that impacts the Jenkins brand and mark negatively or positively.
19:45:17 <hare_brain> The *independence* of the brand and mark.
19:45:37 <autojack> I don't have a burning desk-pounding opinion about it, but I'm glad we're being sensitive to it.
19:45:56 <hare_brain> Where is rtyler?
19:46:02 <autojack> (I would also hesitate to put much weight in my opinion because I'm not some heroic longtime contributor :)
19:46:25 <hare_brain> autojack, I think that’s why opinions like yours matter actually
19:46:33 <autojack> heh
19:47:22 <oleg-nenashev> Does CloudBess consider convenient solutions?
19:47:25 <autojack> asking myself: what's the difference I perceive between 'Jenkins Enterprise by CloudBees' and 'CloudBees Jenkins Enterprise?'
19:48:17 <autojack> my gut says the first is CloudBees improvements to an OSS project, the second is CB contributing the lion's share of the improvements.
19:48:26 <autojack> just based on reading it.
19:48:46 <autojack> to me it's a question of what these names communicate to the community at large.
19:49:12 <autojack> would people start wondering, is CloudBees Jenkins a fork like Jenkins/Hudson?
19:50:19 <kohsuke_> autojack: So I think you are saying that you actually like Jenkins is the front & center of the focus in the name
19:50:39 <autojack> yes.
19:50:59 <kohsuke_> In that line of rasoning, if CloudBees decided to drop the reference of Jenkins altogether and just call it something else completely, like just "FooBarZot", then you wouldn't like it either
19:51:00 <roac> Hi. I manually put in a locally compiled version of junit plugin. Everything works fine. But in the Job's home page I see that there are 2 links to "Latest Test Result" with 2 corresponding graphs.
19:51:06 <roac> Did i miss something.
19:51:13 <autojack> but I can imagine CB saying, hey, we have contributed a LOT to make Enterprise different, we should get first billing.
19:51:29 <kohsuke_> As in, the question of "is FooBarZot a fork like Jenkins/Hudson?" would be still valid, no?
19:51:30 <oleg-nenashev> Jenkins can be at the end
19:51:30 <autojack> roac: community meeting in progress, can you wait a few minutes?
19:51:44 <roac> Sorry. Sure.
19:51:48 <autojack> roac: thanks :)
19:52:00 <danielbe_> oleg-nenashev kohsuke_  My apologies for missing the meeting
19:52:08 <kohsuke_> no problem
19:52:17 <kohsuke_> Do you have any thoughts on this name topic?
19:52:41 <oleg-nenashev> The mixing is a real topic. "Cloudbees CI Enterprise. Powered by Jenkins" would be ok
19:53:06 <danielbe_> sorry need to catch up the last 30 minutes
19:53:11 <autojack> kohsuke_: well, if they dropped the reference to Jenkins I might wonder, is this even a Jenkins plugin/product or some stand-alone thing?
19:55:15 <kohsuke_> I do want to have "Jenkins" in the name because JEbC *is* Jenkins.
19:55:32 <autojack> right
19:55:47 <autojack> I guess if we take your Linux example, we have Red Hat Linux, Ubuntu Linux, Debian GNU/Linux...
19:56:26 <hare_brain> Which one do you think of first, when someone says just “Linux”?
19:56:40 <kohsuke_> And I do appreciate the concern that there might be a growing confusion out there that Jenkins is a CloudBees effort instead of the community effort, to me that's an independent problem, because I honestly don't see how CJE would be any more confusing than JEbC
19:56:44 <autojack> duh, TurboLinux of course...
19:56:45 <autojack> ;)
19:56:59 <autojack> kohsuke_: yeah your point is valid.
19:58:00 <kohsuke_> In Linux example, if none of those vendors are allowed to use the mark Linux to refer to their Linux distros, I think it would have had a negative impact over all.
19:58:10 <autojack> hare_brain: I tend to make the distinction between Linux, the kernel, and e.g. Red Hat Linux the distro.
19:58:17 <autojack> agreed.
19:58:22 <danielbe_> kohsuke_ It's easier to interpet CJE as CJ...E, as in, there's also a "CloudBees Jenkins (regular)"
19:58:32 <autojack> ALTHOUGH THEY SHOULD ALL BE CALLING IT GNU/LINUX </rms>
19:59:45 <kohsuke_> danielbe_: I see, I didn't think of that way, but I get that
20:00:33 <autojack> maybe we should just poll everyone here now that we've kicked this back and forth.
20:00:50 <hare_brain> That’s sort of what we were hoping for!
20:01:08 <hare_brain> And I encourage people to speak up.
20:01:18 <autojack> the proposal is to generally allow uses that fit the pattern 'SomeCo Jenkins Product' in addition to 'Jenkins Product by SomeCo.'
20:01:29 <autojack> (still subject to vote, right?)
20:01:49 <kohsuke_> Yes, each usage needs to be requested and approved
20:01:52 <autojack> (so I can't release Jenkins Sucks by Oracle [SECRETLY INSTALLS HUDSON])
20:02:01 <hare_brain> We could always say that we’re giving CloudBees special dispensation for that format, and not approve the pattern for general usage.
20:02:10 <autojack> I think that's a slippery slope.
20:02:10 <kohsuke_> ha!
20:02:31 <autojack> my instinct is that the same policy should apply to any user.
20:03:06 <hare_brain> I put that on the table to acknowledge the overweight contributions that CloudBees is now making to the community
20:03:11 <autojack> right now I still feel like I prefer not to approve the new proposal. but I still don't have a strong fiery opinion.
20:03:49 <autojack> yeah, I would just worry about having to approve further special exceptions for other big contributors down the line or something. I dunno.
20:05:50 <kohsuke_> Hmm
20:05:51 <hare_brain> I think this would actually be an easier decision if there *were* other big contributors.
20:06:03 <autojack> I was just thinking that.
20:06:48 <danielbe_> are these product names reserved for contributors to the community?
20:07:13 <hare_brain> danielbe_ that’s an interesting question!
20:07:51 <kohsuke_> It's dificult to imagine how anyone serious enough to put a product name like that out there can do it without being a contribuor
20:08:13 <danielbe_> kohsuke_ Just don't push fixes upstream. It's MIT.
20:08:28 <hare_brain> Yep
20:08:55 <kohsuke_> That's called forking and those people will not want to use the same name
20:08:56 <hare_brain> The fact that the community owns the trademark gives us a lot of leverage about that.
20:09:59 <kohsuke_> Right
20:10:23 <kohsuke_> If we feel that someone is using the name Jenkins to refer to something not quite Jenkins in ways that create confusion, we can stop that
20:10:43 <hare_brain> I guess in all likelihood, if some organization tried to create a product based on Jenkins and there were no contributions, we would not grant them the right to use the trademark.
20:11:04 <kohsuke_> That's the canonical use case for marks, IIUC.
20:11:24 <hare_brain> Perhaps. I just hadn’t considered that angle before.
20:12:07 <hare_brain> I just assumed that the requests would all come from someone who participates in the community.
20:12:25 <oleg-nenashev> Does Jenkins have a registered trademark BTW?
20:13:05 <kohsuke_> I need to look at the exact status with SPI, but the application is being processed
20:13:19 <kohsuke_> I've seen some email back and forth that has been going on for years now
20:15:02 <hare_brain> It’s 12:15 (PST). Poll?
20:15:19 <kohsuke_> Yes, let's try to bring this to some kind of conclusion
20:15:24 <danielbe_> what specifically? CloudBees' use of the specific CJE name?
20:15:28 <hare_brain> I am sure that kosuke_ wants resolution. It’s dragged on for long enough.
20:15:50 <autojack> agreed. my instinct still says to stick with the existing scheme only, not the proposed.
20:16:21 <autojack> so that's my vote.
20:16:38 <kohsuke_> The question for poll is, should the project approve "CloudBees Jenkins Enterprise" (and 2 other variants)
20:16:39 <autojack> do I get a vote? heh.
20:17:09 <kohsuke_> CloudBees Jenkins Operations Center and CloudBees Jenkins Analytics, to be exact
20:17:59 <hare_brain> autojack is -1
20:18:10 <abayer> …I've been AFK, but I'm +1, fwiw.
20:18:44 <kohsuke_> danielbe_: oleg-nenashev ?
20:18:53 <oleg-nenashev> -0.5
20:19:02 <hare_brain> #info autojack -1 for CloudBees Jenkins Enterprise, et al
20:19:05 <hare_brain> #info abayer +1 for same
20:19:15 <hare_brain> #info oleg-nenashev -0.5 for same
20:19:52 <danielbe_> +1
20:20:04 <hare_brain> #info danielbe +1 for same
20:20:24 <hare_brain> #info hare_brain is -0.5 for same
20:20:36 <hare_brain> kohsuke you have to abstain. :)
20:20:51 <kohsuke_> Can my daughter vote? :-)
20:20:59 <hare_brain> What has she contributed? :)
20:21:01 <autojack> I didn't know I could be down half :)
20:21:11 <kohsuke_> She has helped the Jenkins booth at SCALE!
20:21:37 <kohsuke_> But on more serious note, what now?
20:21:45 <hare_brain> I wish we had more votes
20:21:53 <autojack> me too.
20:21:56 <oleg-nenashev> kohsuke_: Not enough paticipants IMO
20:22:03 <danielbe_> yes. Even without hare_brain it would be too close to 0 IMO
20:22:11 <autojack> it feels like we need to defer for 2 weeks, rally some more people, etc.
20:22:30 <kohsuke_> OK
20:22:32 <autojack> I can think about it a little more and write up my thoughts on the mailing list too.
20:22:53 <hare_brain> 😞 that’s unfortunate. I don’t want to slow down CloudBee’s business efforts around this.
20:22:59 <kohsuke_> I'll send another email to the thread to udate this conversation today and that we need more inputs & votes from people
20:23:25 <hare_brain> Maybe to -users instead of just -dev?
20:23:42 <autojack> I wouldn't do that.
20:23:49 <autojack> I don't think.
20:23:58 <autojack> seems like you would get a lot of noise.
20:24:13 <hare_brain> That’s the population that we are talking about whether they would be confused or not...
20:24:28 <autojack> mm, good point.
20:24:37 <danielbe_> input yes, votes no?
20:24:52 <kohsuke_> Let's see if a passionate plea for more votes & inputs would result in more people chiming in
20:25:01 <hare_brain> What did we do for other votes? Had to be on the -users mailing list for a certain period of time to be granted the right to vote? (I don’t recall)
20:25:11 <hare_brain> Or was it -dev?
20:25:28 <kohsuke_> The only open vote we ever had was for renaming, and users were a very much a part of it
20:25:55 <hare_brain> I guess we still haven’t gotten around to votes for more board members. :/
20:26:03 <abayer> heh
20:26:17 <danielbe_> would be nice if the board members were listed anywhere
20:26:31 <kohsuke_> Let's keep the conversation in that thread, and we can post a note to the users list saying there's this discussion going on and we could use more inputs
20:26:40 <kohsuke_> ... in that dev thread, I mean.
20:26:55 <hare_brain> OK
20:26:58 <kohsuke_> cross-list conversation is messy and neither list accepts non-members to post
20:27:30 <oleg-nenashev> anyone can join dev list if he wants
20:27:54 <danielbe_> oleg-nenashev Like we need more user topics on the dev list
20:28:34 <oleg-nenashev> If you write a blog post, active users will be able to provide their input... just fot he sake of meritocracy
20:28:56 <kohsuke_> All right, I think this has to be good enough for the day
20:29:11 <oleg-nenashev> danielbe_: We need less plugin requests and more plugin maintainers
20:29:12 <kohsuke_> I really appreciate all the thoughts and opinions about this.
20:29:14 <autojack> rats, I did want to talk about https://issues.jenkins-ci.org/browse/JENKINS-23431 :)
20:29:16 <jenkins-admin> JENKINS-23431:Google is phasing out OpenID endpoint. Need to move on to G+ sign-in (Open) https://issues.jenkins-ci.org/browse/JENKINS-23431
20:29:41 <hare_brain> Yes, I appreciate the discussion too! I’m just sorry to CloudBees that we haven’t reached consensus yet.
20:30:11 <kohsuke_> autojack: can we talk about that in the next time?
20:30:17 <kohsuke_> #topic next meeting
20:30:17 <autojack> sounds good
20:30:34 <kohsuke_> #info next meeting will be 2 weeks from now
20:30:54 <oleg-nenashev> kohsuke_: I've collected a list of messy names on CloudBees sites. If you want, I can send it to you
20:30:55 <kohsuke_> The day before Thanksviging
20:30:56 <hare_brain> koshuke_ do you want to do a one-time extra meeting next week so we don’t have to wait 2 weeks to talk about this again?
20:31:04 <kohsuke_> oleg-nenashev: yes please
20:31:10 <danielbe_> component renames were approved? Or is there further need for discussion? jglick had concerns
20:31:25 <kohsuke_> hare_brain: I need to check if I can make it
20:31:29 <kohsuke_> I'll be traveling on that day
20:31:46 <hare_brain> I hope we have quorum for the 26ht.
20:31:59 <oleg-nenashev> danielbe_: Yes. jglick has not participated in the discussion
20:32:02 <hare_brain> (Yes, that’s a U.S. centric view)
20:32:06 <autojack> I can do 26th.
20:32:18 <kohsuke_> All right, talk to you on 26th
20:32:37 <kohsuke_> #endmeeting
20:32:52 <kohsuke_> robobutler?
20:32:52 <autojack> hare_brain: are you still at Yahoo?
20:33:07 <kohsuke_> #charis
20:33:08 <hare_brain> No, haven’t been there for over two years. Shutterfly.
20:33:10 <kohsuke_> #chairs
20:33:25 <autojack> ah OK. well, they just acquired my company :)
20:33:31 <autojack> rats, I almost got to work with you.
20:33:45 <hare_brain> You know, I was wondering where I heard BrightRoll before that announcement!
20:33:50 <autojack> haha
20:33:58 <hare_brain> I’m hiring. You could still work with me. ;)
20:34:02 <autojack> heh
20:34:07 <autojack> do you have an office in Melbourne, Australia?
20:34:10 <kohsuke__> #endmeeting