18:00:46 <kohsuke> #startmeeting
18:00:46 <robobutler> Let the Jenkins meeting commence!
18:00:50 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:00:59 <kohsuke> Lot to cover
18:01:10 <kohsuke> #topic Travel grant for JUC Tokyo 2015
18:01:33 <kohsuke> So the user group over there is organizing the 2nd JUC Tokyo
18:02:01 <kohsuke> This one is unique JUC compared to other JUCs, in that it's all volunteer based
18:02:20 <kohsuke> In fact the plan is not to take any sponsors this year
18:03:04 <kohsuke> The last time they (or we, since I'm personally involved) got sponsors and spend $4K bringing 2 people from abroad
18:03:22 <kohsuke> This time they've got $2K left over from other activities to cover one person,
18:03:43 <kohsuke> ... but I wonder if we can match that with another $2K from the main project budget to fly another person
18:04:25 <kohsuke> The project currently has $14K+ in the bank, so we could certainly afford it
18:04:33 <kohsuke> and IMO money sitting in the bank does no good
18:04:39 <danielbeck> what else would project money be used for usually?
18:04:57 <kohsuke> the operational cost --- SSL certs, servers, stickers to give away
18:05:23 <kohsuke> Those are the important ones, and that costs $1K-$3K / yr, IIRC
18:05:35 <kohsuke> stickers are the most expensive ones
18:06:31 <danielbeck> how well does the wiki sponsorship work?
18:06:47 <danielbeck> (asking just to get an idea how large of an expense this would be)
18:06:48 <kohsuke> The last time the conversation of travel grant came up in absence of specific event, people felt that we need to see some concrete proposal on the table to be able to judge, so here we are.
18:07:13 <kohsuke> We continue to get unsteady stream of small donations
18:07:20 <kohsuke> Let me check recent one
18:07:39 <kohsuke> Sep so far, $20
18:07:45 <kohsuke> Aug is $3200
18:07:54 <kohsuke> Jul, Jun, $0
18:08:13 <kohsuke> That Aug figure is because one donation of $3K --- I should write a thank you letter
18:08:27 <kohsuke> The "steady" part of the stream in this year is the new patron program
18:08:37 <kohsuke> Consistent $2250 per quarter
18:09:08 <kohsuke> hare_brain, rtyler, any thoughts?
18:09:34 <hare_brain> Sorry, I lost track of time. Wasn’t paying attention at all.
18:10:03 <kohsuke> travel grant for JUC in Tokyo to bring one person from somewhere in the world to speak over there. $2000.
18:11:10 <hare_brain> Are there candidates for the travel grant?
18:11:29 <kohsuke> Yes, there are a few conversations in private
18:11:59 <kohsuke> No one committed yet partly due to schedule, partly due to this
18:13:20 <hare_brain> What’s the ROI for the community on a travel grant?
18:14:01 <kohsuke> I think it's partly to prop up the user base over there
18:14:20 <kohsuke> Bigger user base, more adoption, etc. To grow the community there.
18:14:39 <kohsuke> It's also partly to connect people involved in the project
18:15:34 <hare_brain> Can you give some examples of the types of contributions the user base over there has made to Jenkins?
18:16:00 <kohsuke> ssogabe on various parts of the core bug fixes
18:16:17 <kohsuke> then ohtake for the bootstrap integration work, though it didn't get merged
18:16:55 <kohsuke> Then there's masanobuimai who did the angry Jenkins and other logo work
18:17:15 <kohsuke> Then the rest is all sorts of misc plugins
18:17:59 <kohsuke> It's actually a sizable community, except that it tends to be visible
18:18:16 <kohsuke> The last JUC had 1000 people registered and 700 people came, which still made it the biggest JUC
18:18:17 <hare_brain> visible or invisible?
18:18:23 <kohsuke> sorry, invisible.
18:19:04 <hare_brain> :)
18:19:08 <oleg-nenashev> Offtopic: Are there any plans on other JUC15 conferences (dates, venues, etc.)?
18:19:35 <kohsuke> oleg-nenashev: I'm sure there will be, but none has any detailed plans yet
18:19:51 <hare_brain> Would you say that the Japanese Jenkins community is fairly separated from the rest of us?
18:20:09 <kohsuke> Yes, I think so.
18:20:25 <kohsuke> It's partly due to the language, and partly due to the time zone.
18:20:47 <kohsuke> rtyler and abayer was there the last time, so they can tell us if they are around
18:21:28 <hare_brain> Do you feel it’s important to try to get them to join/be more involved the main community?
18:22:27 <kohsuke> Yes, but these things often take a specific person (or a company) to act as a bridge, and we just don't have that one person
18:23:07 <hare_brain> Where I’m going with this line of questioning, is if someone going over there on a travel grant helps towards building that bridge.
18:24:44 <kohsuke> I don't think one travel will do it, but I think hooking people up with others would help.
18:25:05 <kohsuke> On that point I'd love to hear from abayer and rtyler if the visit helped them
18:25:08 <oleg-nenashev> Remote communications could be useful as well. Currently, all rpject meetings and webinars do not fit East Asian timezones
18:25:26 <kohsuke> (We also did the other way around --- ohtake came to FOSDEM in Brussels)
18:26:14 <kohsuke> oleg-nenashev: yes, but there's no time that works for everyone.
18:26:33 <danielbeck> oleg-nenashev: Which region of the world would you like to exclude in the future?
18:27:09 <kohsuke> And when I asked them whether the time is the main obstacle, most of them felt fixing that alone would do it
18:27:20 <kohsuke> sorry, would NOT do it
18:27:46 <hare_brain> I don’t have a problem the concept of a travel grant. I just want to make sure it’s money well spent.
18:28:38 <kohsuke> My general feeling is that there's only so many ways we can spend the money, and I think this would be one of them.
18:29:27 <kohsuke> And it's hard to measure ROI on these things
18:30:13 <hare_brain> I’d like to generalize the discussion above this specific instance.
18:30:37 <hare_brain> If you are proposing that we should budget X dollars for travel grants every year, that’s a good generalization.
18:31:02 <hare_brain> It just feels these requests are rather ad hoc.
18:32:00 <kohsuke> All right, I don't want this topic to take up the whole time, so maybe I'll start a thread and ask abayer, rtyler, ohtake, etc to share their experience
18:32:39 <kohsuke> We are doing this for the first time, so I think it being ad hoc is inevitable
18:33:14 <kohsuke> But if it makes more sense to budget some allotment upfront, I'm all for it
18:33:45 <kohsuke> #topic Cease support for native Solaris packages
18:33:56 <hare_brain> Right: it’s not the first time it’s come up. So rather than discuss each request, I’d like to just have the discussion about what’s a good amount of money to set aside each year for travel grants (if any), and then if a request comes in, we can just see if there’s budget left for each request.
18:34:45 <kohsuke> would that favor the event earlier in the year?
18:35:38 <kohsuke> rtyler doesn't seem to be around, so let's talk about other things first
18:35:44 <kohsuke> #topic Improvements to JENKINS project in JIRA
18:35:45 <hare_brain> Break up the budget by quarter to avoid that
18:36:23 <danielbeck> I'm proposing a few changes to the Jira project that would make working with it easier.
18:36:53 <danielbeck> Due to some miscommunication, some were already implemented: Hiding Due Date, Affects Version, and Fix Version fields
18:37:10 <danielbeck> These can be reverted at any time though.
18:37:12 <kohsuke> I don't think that's a problem
18:37:26 <kohsuke> I don't know how to make those changes but I assume you do?
18:37:41 <danielbeck> rtyler basically said all were possible
18:37:55 <danielbeck> But he's waiting for a decision on them because some are a bit more effort
18:38:05 <danielbeck> So, still unimplemented are:
18:38:07 <kohsuke> TIL rtyler is a JIRA expert
18:38:51 <kohsuke> It all looks good to me. So my +1
18:39:03 <danielbeck> Set default priority to Minor -- subjectively, this is a better default as it seems to be true more often, plus it may reduce the number of Critical/Blocker issues just because someone wants to step a level up
18:39:10 <danielbeck> Remove Patch, because Github
18:39:28 <danielbeck> Making closed issues editable would allow fixing things like labels without clicking a dozen times
18:39:42 <ogondza> editable closed issues: +1
18:40:43 <kohsuke> jglick: do you care one way or the other?
18:40:50 <danielbeck> Does anyone have concerns about any of these?
18:41:07 <autojack> crap in a hat. I didn't put the JUC SF date in my calendar, so I bought tickets to go to Australia over that time.
18:41:13 <autojack> and I already have a JUC ticket. rar.
18:41:21 <hare_brain> The only thing I have reservations about is the default priority change.
18:41:24 <autojack> plus I was really looking forward to the conf!
18:41:28 <jglick> Making closed issues editable would be great.
18:41:52 <jglick> And +1 on default priority of Minor.
18:41:58 <hare_brain> We made the same change recently, and now the problem is that critical issues stop showing up on people’s dashboards because filers don’t realize the default priority is different.
18:42:20 <hare_brain> Is there anyway to leave priority with no default?
18:42:43 <jglick> (That would be better still.)
18:42:57 <kohsuke> I guess that would be by adding new priority that is "undecided"?
18:43:06 <hare_brain> That would work.
18:43:38 <danielbeck> wouldn't that have the same problem?
18:44:06 <danielbeck> Why would minor issues be hidden? Is the default Dashboard "Major and up"?
18:44:53 <hare_brain> It does, but it’s easier to search for those, and it’s then possible to distinguish between “really minor” and “minor because someone didn’t set it”
18:44:56 <jglick> kohsuke: that does not sound like it would help. Would want Priority to be a mandatory field w/o which you could not submit.
18:45:10 <hare_brain> jglick +1 to that. That’s even better.
18:45:59 <kohsuke> I don't know if that's doable
18:46:05 <kohsuke> Someone with more JIRA-fu needed
18:47:15 <danielbeck> just tested on my Jira, seems if no explicit default is set, Major is the default in the form
18:47:39 <kohsuke> https://jira.atlassian.com/browse/JRA-13048
18:47:46 <kohsuke> Still an RFE in the upstream
18:48:12 <danielbeck> Comment has a solution involving a modified workflow
18:48:49 <danielbeck> Basically, reject any issue with the default 'Unspecified' priority
18:49:12 <kohsuke> OK, so I guess I wasn't too far off, it turns out
18:50:25 <kohsuke> #agreed instead of changing the default priority to minor, we'll try forcing the user to select it
18:50:43 <kohsuke> #agreed other proposals are blessed
18:50:53 <kohsuke> #topic Can we improve the Jenkins release process?
18:51:18 <danielbeck> Over the last year, six RCs have been released, and nobody seems to have noticed.
18:51:22 <danielbeck> The year before, 14 RCs
18:51:30 <danielbeck> http://mirrors.jenkins-ci.org/war-rc/
18:51:53 <kohsuke> Right, it's been inconsistently done
18:52:16 <danielbeck> The downside is that any fix takes ~1.5 weeks until released unless we patch the rc branch
18:53:06 <kohsuke> Oh, so you want to get rid of the RC completely?
18:53:10 <danielbeck> I have no concrete proposals here, but it seems this is something that could be improved
18:53:44 <ogondza> IIRC jglick suggested the same thing in the past
18:53:48 <jglick> Yes.
18:54:07 <kohsuke> I want to fix it in the other way --- issue RC more consistently, as part of it is to run https://ci.jenkins-ci.org/ on RC
18:55:31 <ogondza> Do we have some feedback from RC branch adopters?
18:55:33 <jglick> Would it not suffice to discourage people from updating to a new weekly until a few days after its release when no showstopper regressions have been identified?
18:55:55 <danielbeck> who's going to identify them?
18:56:15 <jglick> Who identifies showstopper issues in RCs?
18:56:20 <OEP> So, Jenkins pretty aggressively manages my config.xml (making it world readable). I want to lock it down so my local slaves can't read that file. Is there a way to do this?
18:56:31 <jglick> OEP: meeting in progress, please ask later
18:56:46 <kohsuke> jglick: we use ci.jenkins-ci.org
18:57:06 <danielbeck> so you'll try to deploy more regularly to JonJ?
18:57:21 <jglick> Why not just deploy snapshots every night?
18:57:25 <oleg-nenashev> kohsuke: As I remember, rtyler vetoed such approach after regular outages of the service
18:57:37 <kohsuke> oleg-nenashev: That's true
18:57:47 <danielbeck> jglick: Because some jobs take forever (infra-statistics)
18:57:48 <kohsuke> jglick: I feel like a part of the point is to run it "for a while"
18:58:13 <ScottHebertErics> I currently run a couple of select ATH tests when a new RC comes out.
18:58:28 <kohsuke> oleg-nenashev: but I think if we fix that one bug that's causing CPU 100% problem, I think he's OK
18:58:32 <danielbeck> ScottHebertErics: Weekly RC or LTS RC?
18:58:47 <ScottHebertErics> sorry. LTS RC.
18:59:00 <jglick> We are discussing weekly RCs.
18:59:21 <ScottHebertErics> sorry about that
18:59:49 <oleg-nenashev> Do we have enough resources to run a "latest and greatest" mirror pof ci.jenkins-ci.org?
19:00:15 <jglick> If they are actually contributing something tangible to stability, fine. My experience has mostly been that people notice regressions after the weekly has been released, and then we just waste a week waiting for changes to filter through the rc branch, which also confuses everyone who comes across it.
19:00:17 <oleg-nenashev> Probably, a mirror server with a reference one would be a best solution for the troubleshooting
19:00:49 <danielbeck> most of it is infra, cannot really do that in parallel
19:01:07 <danielbeck> unless setting up mirror everything
19:01:18 <rtyler> kohsuke: sorry for the delay
19:01:27 <kohsuke> np
19:01:28 <rtyler> got pulled into a meeting
19:02:06 <danielbeck> Move on to rtyler's topic?
19:02:16 <danielbeck> I doubt we'll find a solution to RC process now
19:02:21 <kohsuke> OK
19:02:21 * rtyler prepares his cannon
19:02:27 <kohsuke> #topic kill solaris packages
19:02:34 <rtyler> ALRIGHTY!
19:02:49 <rtyler> so as some of you know we've been upgrading and modernizing some of the project infrastructure
19:03:00 <rtyler> most of that work is here: https://github.com/jenkins-infra
19:03:31 <rtyler> the Solaris packages in particular present a frustrating problem
19:03:43 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/2014+Jenkins+Infrastructure+Roadmap#2014JenkinsInfrastructureRoadmap-MigrationtoamodernPuppetinfrastructure ?
19:03:54 <rtyler> yeah
19:04:02 <rtyler> #info INFRA-20
19:04:07 <jenkins-admin> INFRA-20:Port the IPS module over to jenkins-infra (Open) https://issues.jenkins-ci.org/browse/INFRA-20
19:04:17 <rtyler> Solaris packages require a specialized package repository server
19:04:35 <rtyler> which is not maintained for Linux, and will require an inordinate amount of infrastructure work to continue to support
19:04:46 <rtyler> INFRA-20 is blocking INFRA-21
19:04:47 <jenkins-admin> INFRA-21:Deploy puppet agent onto lettuce (Open) https://issues.jenkins-ci.org/browse/INFRA-21
19:05:07 <rtyler> what I would like are one of two things:
19:06:07 <kohsuke> All right, I accept the defeat. We can kill it to unblock infra, and when I managed to run IPS depotd in Docker I'll send in a pull request to resurrect it
19:06:08 <rtyler> rats, danielbeck I can't find that ticket you added all those links to
19:06:17 <danielbeck> JENKINS-11729 JENKINS-13905 JENKINS-12197 JENKINS-15148
19:06:25 <jenkins-admin> JENKINS-11729:Cannot install Jenkins on a fresh copy of Solaris 11 (Open) https://issues.jenkins-ci.org/browse/JENKINS-11729
19:06:29 <jenkins-admin> JENKINS-13905:install IPS jenkins package failed (Reopened) https://issues.jenkins-ci.org/browse/JENKINS-13905
19:06:30 <rtyler> kohsuke: I don't think that's the important thing to do in this meeting
19:06:32 <jenkins-admin> JENKINS-12197:Security hole when using IPS distribution on Solaris (Open) https://issues.jenkins-ci.org/browse/JENKINS-12197
19:06:38 <jenkins-admin> JENKINS-15148:OpenIndiana IPS package has permissions conflict with oi_151a6 (Open) https://issues.jenkins-ci.org/browse/JENKINS-15148
19:07:05 <rtyler> I actually think we should determine how to evaluate cost vs. benefit of operating these native packages for lesser-used-platforms
19:07:30 <rtyler> then if solaris meets some criteria that we' apply across the board, then kill it with fire
19:07:45 <rtyler> I don't know enough about the solaris user base to rightfully say "it's not worth it"
19:08:20 <jglick> I think the only commonly uses platforms are Linux and Windows Server.
19:08:23 <rtyler> it's different than the *BSD ports or gentoo recipe too, since we're hosting binaries
19:08:24 <jglick> [used]
19:08:59 <oleg-nenashev> Solaris and OpenIndiana are not very popular now. Probably, the support of their repos could handed over to interested persons (if available)
19:09:00 <kohsuke> http://ips.jenkins-ci.org/ips-stable/en/stats.shtml says in the past 2 weeks no one has installed anything from this repo
19:09:01 <danielbeck> 43.6k Linux masters, 33.4 Windows, 6.6k OS X, 925 SunOS, 285 AIX, 370 various
19:09:01 <jglick> (By Linux I mean CentOS/RHEL and Debian/Ubuntu mainly.)
19:09:43 <jglick> That many people run on OS X? I wonder if they use the app package.
19:09:49 <rtyler> kohsuke: perhaps we could vote to suspend IPS for now, and then I can take an action to write a proposal for "package hosting criteria?"
19:09:52 <jglick> Or if this is people installing on a laptop.
19:09:59 <rtyler> this would also mean we could remove IPS packages from the release process too
19:10:31 <kohsuke> I have no objection to suspend IPS for now
19:10:34 <gazarsgo> i'm trying to put jenkins behind https://github.com/bitly/google_auth_proxy/ but i am getting weird authentication errors for Unexpected authentication type: org.acegisecurity.providers.UsernamePasswordAuthenticationToken ...
19:10:36 <jenkins-builds> Starting build #3688 for job jenkins_main_trunk (previous build: SUCCESS)
19:10:39 <gazarsgo> how can i disable authentication there ?
19:10:48 <rtyler> gazarsgo: give us a bit, we're still in a project meeting
19:11:02 <rtyler> #action rtyler to suspend service to the IPS repository for now
19:11:19 <kohsuke> ... and if you'd want to clarify the criteria for us to accept future package hosting, that's great
19:11:27 <rtyler> kohsuke: should you take an action to remove it from the release process? since I'll take IPS off lettuce asap
19:11:35 <kohsuke> Yes, will do.
19:11:46 <rtyler> #action rtyler to propose criteria for hosting native packages on jenkins-infra
19:11:59 <rtyler> I'll try to get that second one done before next meeting
19:12:05 <danielbeck> also post notice to users list?
19:12:05 <kohsuke> thanks
19:12:18 <rtyler> #action rtyler to notify users@ of IPS termination
19:12:25 <danielbeck> change jenkins-ci.org as well
19:12:34 <rtyler> #action rtyler to change jenkins-ci.org as well
19:12:35 <rtyler> xD
19:12:47 * kohsuke sobs in the corner
19:12:51 <rtyler> heh
19:13:03 <rtyler> I think that covers it from my side, did we finish all the other agenda items?
19:13:10 <kohsuke> #topic next meeting
19:13:25 <kohsuke> #info next meeting will be in Oct 1st
19:13:27 <rtyler> two weeks from today is smack in the
19:13:31 <rtyler> middle of JavaOne
19:13:31 <kohsuke> JavaOne week
19:13:35 <rtyler> perhaps three weeks then?
19:13:38 <rtyler> Oct 8th?
19:13:51 <kohsuke> Nah, I think it's OK
19:14:01 * rtyler will be at JavaOne
19:14:05 <kohsuke> It messes up the calendar to change it
19:14:08 <rtyler> heh
19:14:10 <kohsuke> O RLY?
19:14:13 <rtyler> YA RLY
19:14:24 <rtyler> <-- Mr. Big Shot
19:14:45 <kohsuke> No worries. They've got WiFi. So you can still join
19:14:53 <kohsuke> I bet you'll need some distraction from talks
19:15:17 <kohsuke> #endmeeting