19:01:46 <kohsuke> #startmeeting
19:01:46 <robobutler> Let the Jenkins meeting commence!
19:01:51 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
19:02:02 <kohsuke> #topic recap of actions
19:02:39 <kohsuke> #info https://issues.jenkins-ci.org/browse/MEETING
19:03:00 <kohsuke> MEETING-8 is complete
19:03:13 <kohsuke> except rtyler hasn't sent in the reimbursement form
19:03:21 <kohsuke> please do
19:03:55 <kohsuke> orrc:  I'm not sure if I heared back from FFI
19:04:00 <kohsuke> (wrt MEETING-9)
19:04:16 <orrc> I haven't heard anything
19:04:47 <kohsuke> trying to locate the e-mail
19:05:27 <kohsuke> I guess I'll write to Martin Schulze
19:05:42 <kohsuke> is he a member of ffis?
19:05:52 <kohsuke> or someone whose project is affilated with ffis?
19:06:16 <kohsuke> action: kohsuke to ping ffis again
19:06:21 <kohsuke> #action kohsuke to ping ffis again
19:06:32 <orrc> He replied to my first ffis email, so I guess he's involved
19:06:53 <kohsuke> other AIs still incomplete
19:07:10 <kohsuke> #topic Balancing personal information of JUC attendees vs cost
19:07:42 <kohsuke> so I asked Alyssa to produce a summary of the income/expense of JUCs
19:07:44 <kohsuke> #info https://docs.google.com/spreadsheet/ccc?key=0ApE2WVyiXL0hdGZSRTZVQmdTN2VnVWdJMWZCNEJqa1E
19:08:24 <kohsuke> The context here is that we've been passing attendee contact information to sponsors, and we haven't been explicit about it
19:09:21 <kohsuke> So we want to fix this
19:09:26 <LisaWells> On that note, we want to apologize that you felt like you were being harassed by JUC sponsors because we shared lead information. You should know that both when sponsors signed up originally, and when we sent attendee details to them, sponsors were urged to “please treat the list gently, maybe send only one follow-up email with useful assets and an Opt In capability, and not to merge people into their main databases.”
19:10:05 <kohsuke> OTOH, people talking to sponsors said without those "lead" information, it'd be very difficult to get sponsors at all
19:10:37 <LisaWells> Gold sponsors paid $5000 for the privilege of getting contact information – which is $2000 more than Silver sponsors paid, and the contact info is the only difference. I signed these guys up myself, and it was the names they wanted.
19:11:19 <kohsuke> The "eventbrite" line is the income from ticket sales
19:11:37 <kohsuke> if you compare that with the total expense, it's pretty clear that they don't match up
19:12:10 <kohsuke> I believe "F&B" is food&beverages and that actually includes room fee
19:12:44 <LisaWells> in case you're not on the Gdoc: $28k of EventBrite income vs $45k of expenses
19:12:52 <kohsuke> Alyssa told me that the way it works with these venues is that hotels bundle them into one to make you pay more
19:13:48 <LisaWells> So how can we make this better next year?
19:14:06 <kohsuke> I think we continue to try to find a venue that's free/cheap like we did in JUC Tokyo, but we haven't found one in San Francisco.
19:14:08 <LisaWells> We want to make sure not to upset people in future. Going forward, we’d like the community to agree on what sponsors receive and on how to share (or not share) information. We are also looking into options where people could Opt Out of contact sharing upon registration and also looking into Badge Scanning options for next year (maybe individual QR codes as suggested) .
19:14:36 <kohsuke> rtyler: any thoughts?
19:15:08 <kohsuke> hare_brain: ?
19:15:21 <hare_brain> For me, I understand that I'm probably going to receive solicitations when I register for something. What annoyed me was a particular vendor emailed me several times, *and* called me on my personal phone. Worse, the way they presented themselves was that we had had a conversation at JUC which I absolutely did not.
19:15:50 <abayer> Yeah, that was my only issue.
19:15:55 <quidryan> Am I reading the spreadsheet correctly, even without Gold Sponsors, SF JUC would have been in the black?
19:15:58 <abayer> Spam is one thing - cold-calling is another.
19:16:10 <hare_brain> So one thing I would suggest is a clearer disclosure about what information would be disclosed.
19:16:18 <LisaWells> So next year we definitely want to have an "Opt Out" checkbox when you register (if EventBrite will let us) - with the plea to please understand that sponsors really help out and the contact info makes it worth their while
19:16:29 <LisaWells> also we were thinking next year we don't share phone at all?
19:16:36 <hare_brain> I gave my personal number under the assumption that it would have been used to contact me about problems with the event. I did not expect that it would be given to a vendor.
19:16:54 <kohsuke> quidryan: Yes, I think JUC SF 2012 was in black
19:16:58 <LisaWells> our apologies for not being clear aobugt that.
19:17:23 * rtyler shows up
19:17:32 <kohsuke> quidryan: but there were 6 gold sponsors so I don't think it was in black if we didn't have any of them
19:17:37 <hare_brain> At the end of the day, it's an annoyance, and not a travesty. I wouldn't NOT come to JUC because of this. :)
19:18:08 <kohsuke> rtyler: https://docs.google.com/spreadsheet/ccc?key=0ApE2WVyiXL0hdGZSRTZVQmdTN2VnVWdJMWZCNEJqa1E#gid=0
19:18:35 <quidryan> kohsuke, I see line 11, line 13 and maybe line 12 as Gold Sponsors. I don't see 6.
19:18:48 <rtyler> bad url
19:19:07 <kohsuke> rtyler: how about https://docs.google.com/spreadsheet/ccc?key=0ApE2WVyiXL0hdGZSRTZVQmdTN2VnVWdJMWZCNEJqa1E
19:19:14 <kohsuke> oh the same thing
19:19:19 <LisaWells> We did have 6 Gold sponsors. Some we had to negotiate more heavily with than others.
19:19:33 <kohsuke> #info http://www.cloudbees.com/jenkins-user-conference-2012-san-francisco.cb for sponsor list
19:19:35 <LisaWells> HP, for example, would not have sponsored if we hadn't given them Gold at half price.
19:20:06 * rtyler boggles at NY and Paris
19:20:36 <jenkins-builds> Starting build #2077 for job jenkins_main_trunk (previous build: SUCCESS)
19:21:32 <kohsuke> I guess I'm hoping that opt-out + being more explicit about this would be acceptable for future events of this sort
19:21:32 <rtyler> hare_brain: if every company called me like sonatype did, I wouldn't attend
19:22:13 <kohsuke> and I guess I'll personally ask LisaWells to tell this episode to future sponsors
19:22:16 <hare_brain> rtyler Fair enough. I'll rephrase as "What happened after JUC SF 2012 wouldn't stop me from attending."
19:22:55 <kohsuke> I don't think it's in anyone's interest to be perceived like sonatype
19:23:15 <hare_brain> Heh. So much for my attempt to keep things anonymous.
19:24:03 <kohsuke> Let me move on to the next topic as it's kind of related
19:24:15 <kohsuke> #topic Forming the Events subgroup in the community for the purpose of coordinating and running event
19:24:50 <kohsuke> there's a couple of related efforts here
19:24:53 <LisaWells_> so... how do we do this better next year?
19:25:48 <kohsuke> LisaWells_: my sense is that opt-out + transparent about what happens to your contact info received reasonable acceptance
19:26:04 <LisaWells_> what does everyone else think about that?
19:26:13 <hare_brain> Not requiring/not sharing phone numbers would be welcome.
19:26:13 * rtyler nods
19:26:56 <LisaWells_> i don't think Phone was a Required field during registration, fwiw. but next year we won't share that even if provided
19:27:14 <kohsuke> Yes, I like that
19:27:20 * kohsuke is phone phobia
19:27:48 <kohsuke> LisaWells_:  Can I resume talking about the next topic?
19:28:13 <kohsuke> I take it as yes
19:28:14 <LisaWells_> Please :)
19:28:34 <kohsuke> kinow is trying to bootstrap the brazilian user community
19:28:53 <kohsuke> and independently I'm working with Samsung folks to get one going in Korea as well
19:29:32 <kohsuke> I'm also trying to bring more JUC conversations in public, which requires a channel for communication for folks like LisaWells_ and alyssa
19:29:57 <kohsuke> so I mentioned this to rtyler a bit but I finally got events@lists.jenkins-ci.org created
19:30:11 <kohsuke> http://lists.jenkins-ci.org/mailman/listinfo/jenkins-events
19:30:27 <kohsuke> in the past we had event specific list like http://lists.jenkins-ci.org/mailman/listinfo
19:31:03 <LisaWells_> we are hoping to help the community drive a lot of events, so having a streamlined comm link will be most excellent
19:31:16 <kohsuke> but for smaller events and for cross-pollination between different local community, I wanted the project meeting to bless the new list for event related stuff
19:31:29 <rtyler> I think it's a good idea
19:32:13 <kohsuke> There are a few more things I thought this list would be a good fir for in https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-November14thMeeting
19:32:49 <kohsuke> like doing the CIA program bookkeeping
19:32:51 <rtyler> I think getting the right people on the list that can help new organizers will be useful too
19:33:00 <rtyler> offering advice, etc
19:33:02 <kohsuke> exactly
19:33:37 <kohsuke> rtyler: who should we invite, aside from you?
19:33:38 <LisaWells_> Alyssa & I are hoping we can help share knowledge, give ideas, suggest structure that has worked (and not worked :) ), etc
19:33:51 <rtyler> kinow, ndeloof
19:34:03 <kohsuke> and some folks from Tokyo
19:34:03 <rtyler> the israeli guys, copenhagen guys
19:34:31 <kohsuke> israeli guys = I'll check with JFrog, copenhagen guys = rsandell and Knud
19:35:15 <kohsuke> action: kohsuke to write to kinow, ndeloof, JFrog, ikikko, cactusman et al, rsandll and Knud Poulsen to join events (and encourage others they think of to do so the same)
19:35:36 <kohsuke> should I do a post about it on jenkins-ci.org?
19:35:52 <alyssa_> I think bruno kinoshita would like to join as well
19:35:53 <LisaWells_> +1
19:36:00 <kohsuke> alyssa_: that's kinow
19:36:12 <LisaWells_> with the encouragement for people to sign up for the list AND start thinking about events for next year
19:36:12 <rtyler> kohsuke: yes
19:36:14 <rtyler> I think so
19:36:20 <rtyler> yes to what LisaWells_ said too
19:36:27 <kohsuke> action: kohsuke to announce it on jenkins-ci.org post
19:36:41 <rtyler> I'm going to be swamped with fosdem, but we should start trying to get more things organically organized in 2013
19:36:51 <kohsuke> Yes
19:37:26 <LisaWells_> we've been talking about what we can do to encourage meetups, Jenkins events, etc. any thoughts?
19:37:42 <kohsuke> rtyler:  wrt FOSDEM, one of the Tokyo people might after all be able to come with your grant
19:37:47 <orrc> So the aim is to help people organise any sort of Jenkins-related event or talk?
19:37:53 <rtyler> kohsuke: let's chat more about that after :)
19:37:54 <LisaWells_> yes
19:38:00 <rtyler> orrc: more the event stuff I think
19:38:28 <LisaWells_> talks too - CIA is another thing that could use some TLC
19:38:47 <LisaWells_> and could maybe be addressed by Events subgroup?
19:38:47 <kohsuke> although a part of the original Jenkins CIA idea was to come up with some reusable slides, so if anyone wants to take it on, I think it'd fit, too
19:40:00 <kohsuke> #agreed events@lists.jenkins-ci.org is blessed
19:40:24 <kohsuke> shall we move on?
19:40:37 <kohsuke> #topic Status of moving Jenkins to java 6 as minimal runtime
19:40:48 <rtyler> I thought we already did this? or was it just for development
19:41:09 <kohsuke> No, we haven't done this
19:41:28 <rtyler> ah
19:41:33 * rtyler backs away
19:41:50 <kohsuke> My suggestion is to start producing releases with Java6 but without adding tons of Java6 dependencies right away
19:42:10 <kohsuke> That gives a chance  to anyone not tuning into the last round of e-mail conversations
19:42:16 <imod> I'd love to see this happen - but what was the issue olamy was mentioning?
19:42:26 <rtyler> jorgenpt: ^
19:42:37 <jorgenpt> What am I looking at?
19:42:45 <rtyler> jorgenpt: /topic
19:42:52 <kohsuke> requiring Java6 to run Jenkins master, slave, and Maven builds
19:42:55 <rtyler> wanted to make sure you were in on this to some extent
19:42:58 <jorgenpt> Okay
19:43:11 <jorgenpt> Sounds good to me - I'm all for it. :-)
19:43:24 <kohsuke> imod: the only issue I'm aware of is that Maven builds now need to run with Java6
19:43:43 <imod> ok, so lets do it
19:44:10 <kohsuke> yeah, my proposal is to start producing releases with Java6 class files but without adding new dependencies
19:44:38 <imod> what kind of dependencies are you thinking about?
19:44:39 <kohsuke> if by 1.500 or so we don't hear any major backlash, all Java6 dependencies are good to go
19:44:53 <kohsuke> imod: calls to java.util.*, etc
19:45:03 <imod> ok
19:45:26 <kohsuke> IOW, for a while I think we should be able to back off from Java6 requirement easily
19:46:14 <kohsuke> action: kohsuke to send an e-mail to the dev list about the above plan and start acting accordingly
19:46:23 <kohsuke> #action kohsuke to send an e-mail to the dev list about the above plan and start acting accordingly
19:46:43 <rtyler> users list as well
19:46:58 <kohsuke> #action CC to the users list as well
19:47:00 <kohsuke> Yes, one more heads up
19:47:11 <kohsuke> I think that's it for today
19:47:15 <kohsuke> #topic next meeting
19:47:47 <rtyler> just before xmas?
19:47:48 <kohsuke> 11/28
19:47:55 <kohsuke> wait, what?
19:47:58 <hare_brain> Would we call that the last one for the year?
19:48:00 <rtyler> will that be the last of the year?
19:48:00 <hare_brain> 11/28
19:48:04 <rtyler> heh
19:48:27 <rtyler> I wouldn't mind making 2012.12.05 the last meeting of the year
19:48:38 <rtyler> next week is a total wash as far as I'm concerned :P
19:48:38 <kohsuke> is 12/12 (the day after that) some special day?
19:49:01 <kohsuke> 12/5 would be out of bi-weekly cycle though
19:49:06 <rtyler> it would
19:49:20 <rtyler> the question I meant to ask is more, will we have sufficient business to discuss
19:49:44 <kohsuke> I probably won't be able to make 12/5
19:49:47 <kohsuke> I'm flying somewhere
19:49:54 <rtyler> you always are
19:50:01 <rtyler> we could just skip to 12/12 then IMO
19:50:19 <hare_brain> Well aren't we getting ahead of ourselves?
19:50:26 <rtyler> I don't think we'll have much to talk about if we meet 11/28
19:50:42 <hare_brain> Oh, so you're proposing skipping one
19:50:47 <rtyler> yes
19:51:11 <hare_brain> Skip straight to 12/12 then?
19:51:13 <kohsuke> I'm fine either way
19:51:25 <LisaWells_> anyone want to talk about events sooner than that?
19:51:40 <rtyler> the mailing list will be good for that :)
19:52:15 <kohsuke> #agreed next meeting is in 4 weeks, 12/12
19:52:20 <hare_brain> +1
19:52:49 <kohsuke> Anything else?
19:53:16 <kohsuke> #endmeeting