#jenkins Meeting

Meeting started by rtyler at 00:57:46 UTC (full logs).

Meeting summary

    1. The meeting agenda can be found here https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-JenkinsUserConferenceMeeting@SanFrancisco (rtyler, 00:58:02)

  1. Discussion about future funding source/plan / fiance report (rtyler, 00:59:19)
    1. meetings are recorded and logged under meetings.jenkins-ci.org (rtyler, 00:59:36)
    2. our financial management group/parent organization is the SPI http://spi-inc.org (rtyler, 01:00:41)
    3. aslanb is transcribing live (rtyler, 01:00:49)
    4. IDEA: perhaps we should do more of the grant proposals? (kohsuke2, 01:08:55)
    5. we started using freedomsponsors.org that's somewhat related to this (kohsuke2, 01:09:18)
    6. ACTION: project to start a targeted donation drive for FOSDEM travel grants (rtyler, 01:10:33)
    7. AGREED: project to try a targeted donation drive for FOSDEM travel grangts (rtyler, 01:11:05)

  2. How can we fix documentation/make it better (rtyler, 01:12:51)
    1. IDEA: maybe a reverse map of the "extension point list" wiki page (kohsuke2, 01:17:36)
    2. ACTION: kohsuke to look into building a reverse mapping for extension points (rtyler, 01:18:14)
    3. IDEA: skeleton code generation for more extensions (ala jenkins.rb) (kohsuke2, 01:19:55)
    4. IDEA: code generation hooked up in the UI --- "click this button if you add stuff here" (kohsuke2, 01:20:32)
    5. ACTION: kohsuke to talk more and open up his prototype extension point thingie (rtyler, 01:21:53)

  3. How can we improve the stable releases (rtyler, 01:23:52)
    1. IDEA: part of the project meeting should maybe address "project management" in a sense of what is prioritized, etc (rtyler, 01:29:09)
    2. to have your voice heard into what gets implemented, 1) fill in the survey 2) vote on issues (kohsuke2, 01:29:42)
    3. IDEA: perhaps we should send out a bi-weekly report of what is being focused on, or at least being considered for future releases (rtyler, 01:33:57)
    4. so far according to the running tally of the survey, documentation, examples, and quality does come high (kohsuke2, 01:34:11)
    5. IDEA: encourage plugin developers to document as they learn things in the core/extension points (rtyler, 01:34:50)

  4. next meeting (rtyler, 01:36:38)
    1. IDEA: I suggest October 10th (rtyler, 01:37:27)

  5. next meeting time (kohsuke2, 01:38:17)
    1. AGREED: Oct 17th 2012, next meeting (rtyler, 01:38:58)


Meeting ended at 01:39:07 UTC (full logs).

Action items

  1. project to start a targeted donation drive for FOSDEM travel grants
  2. kohsuke to look into building a reverse mapping for extension points
  3. kohsuke to talk more and open up his prototype extension point thingie


People present (lines said)

  1. aslanb (136)
  2. rtyler (27)
  3. kohsuke2 (14)
  4. jieryn (11)
  5. abayer (3)
  6. EricL (2)
  7. robobutler (2)
  8. dapak (2)
  9. lifeless (2)
  10. pradeepto (1)


Generated by MeetBot 0.1.4.