19:00:02 <rtyler> #startmeeting
19:00:03 <robobutler> Let the Jenkins meeting commence!
19:00:18 <rtyler> #topic Recap of last meeting's action items
19:00:19 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-Jan11thMeeting
19:00:23 <rtyler> #chairs abayer kohsuke
19:00:31 <rtyler> #chair abayer kohsuke
19:00:31 <robobutler> Current chairs: abayer kohsuke rtyler
19:00:47 <rtyler> no dean, bummer
19:00:55 <rtyler> I'll go ahead and run down the list of my AIs
19:01:00 <kohsuke> he sent us a regret. Food poisoning
19:01:05 <rtyler> oh yikes
19:01:17 <rtyler> #info aheritier now in the users-core module
19:01:41 <rtyler> #info backups at Contegix are actually blocked on me setting up a role account on the machine
19:02:06 <rtyler> #info The 'contingency' plans on the infra wiki are still not really fleshed out, shame on me
19:02:15 <rtyler> kohsuke: you're up :)
19:02:17 <kohsuke> #info fund-raising is concluded successfully, and the post added. rtyler still needs to submit the reimbursement request.
19:02:32 <kohsuke> #info SCALE10x CI dinner --- oops
19:03:02 <kohsuke> I think rtyler and I need to sync up a bit more
19:03:13 <kohsuke> ... on the date
19:03:17 <rtyler> indeed
19:03:49 <kohsuke> #info The great seal of the Jenkins CIA program is ready for action, but not the slides
19:04:13 <kohsuke> #action rtyler to post a template of Jenkins CIA intro slides
19:04:43 <kohsuke> and imod and I should probably start putting contents in parallel and apply the template when it's ready
19:04:59 <imod> yep
19:05:12 <kohsuke> #info LTS 1.424.2 is RC-ed, tested, and released.
19:05:30 <kohsuke> ... mad props to vjuranek and others as alwaysy
19:05:49 <kohsuke> abayer: are you there?
19:05:57 <abayer> Mostly. =)
19:06:12 <kohsuke> there's one action of yours to ping GitHub about a private repo
19:06:56 <abayer> Ah, yeah - I think we opted to go with one on one of our personal accounts for now, yes?
19:07:10 <rtyler> that's what I said I'd do for the infra secrets
19:07:57 <kohsuke> abayer: if you feel this won't happen, then that's OK. We just need to figure out another plan.
19:08:09 <kohsuke> But if you think we just need to ask, then I think we should ask.
19:08:19 <abayer> Ah. I'll deal with it,t hen. Sorry.
19:08:38 <rtyler> next?
19:08:40 <kohsuke> #action abayer to ping github again for a private repo for CLA (and infra secrets)
19:08:59 <kohsuke> I think that's it for actions
19:09:00 <abayer> brb
19:09:06 <rtyler> #topic Autopopulating Affected Version/s and Fix Version/s in JIRA
19:09:10 <rtyler> fredg02: you're up
19:09:36 <fredg02> thx, I just wanted to get the discussion started again.
19:10:04 <fredg02> it's been a long pending plan, so I thought it would be a good idea to bring it up again
19:10:20 <kohsuke> I'm now generating LTS changelogs from git-log and ticket IDs in the commit messages
19:10:35 <kohsuke> (That's http://jenkins-ci.org/changelog-stable)
19:10:53 <fredg02> I think it would be a good idea to popuplate the mentioned fields in JIRA (automatically if possible)
19:11:05 <kohsuke> So if we can define the appropriate field in JIRA, then I think expanding this script to fill that in would be easy enough.
19:11:27 <imod> but thats for core only - right?
19:11:41 <kohsuke> Yes.
19:11:53 <kohsuke> I think we need a bit more work to make it work to plugins
19:12:12 <imod> separate components in JIRA?
19:12:31 <fredg02> so before the fields get populated core and plugins need to be split right?
19:12:54 <kohsuke> fredg02: There are actually many ways to do it
19:13:10 <kohsuke> It's less useful but it can be done without moving plugins to separate JIRA projects
19:13:17 <imod> didn't someone start some investigation on this?
19:13:18 <fredg02> ok.
19:13:28 <kohsuke> ... by making them all share the same pool of version numbers
19:14:08 <kohsuke> imod: yes, aheritier, but to be fair, I think the arrangement was that we first give them the second instance to play with those new scheme
19:14:15 <kohsuke> ... which we haven't delivered.
19:14:22 <fredg02> I think it would be nice to give plugin developers some more freedom by making plugins separate JIRA projects
19:14:32 <imod> ok, understandable :)
19:15:14 <kohsuke> fredg02: IIRC, the downside is that multiple projects require higher admin overheads on our side
19:15:35 <kohsuke> ... and updating some existing automations, like jenkins-admin
19:15:37 <rpetti> where would the list of versions come from?
19:15:57 <rpetti> often, you might not know what next release's version number is going to be
19:16:06 <kohsuke> rpetti: If there's an API to create a new version, then the automated filler program would be the right one to create it, I think
19:16:27 <kohsuke> rpetti: exactly, that's why I'm advocating for retroactively parsing it from git-log
19:16:34 <rpetti> i agree
19:16:38 <kohsuke> ... after a release is made
19:16:44 <rpetti> +1
19:17:04 <kohsuke> And e-mail generated by that update would serve as a nice reminder to encourage people to use it
19:17:38 <fredg02> I can't judge how big the admin overhead is. but it would be worth a try in a sandbox environment, I guess
19:17:42 <imod> love it already!
19:18:09 <kohsuke> fredg02: maybe we can do this in parallel.
19:18:38 <kohsuke> Hmm, not sure what I mean by that
19:19:09 <fredg02> if you need any help with this, feel free to contact me :)
19:19:13 <kohsuke> Evidently the main obstacle was that we failed to prepare the secondary JIRA instance necessary to play with this.
19:19:35 <fredg02> action item?
19:19:54 <kohsuke> I think JIRA not wanting to be puppet-ed discouraged us enough not to tackle it
19:20:14 <kohsuke> (or was it something else? am I fabricating the history?)
19:20:40 <kohsuke> rtyler: do you have any thoughts on the best way to start a secondary instance?
19:21:00 <rtyler> if only we had this monstrosity puppeted...
19:21:12 <rtyler> yeah, i'm not really sure
19:21:17 <kohsuke> I vaguely recall we were also waiting for another server to come online to house this.
19:21:20 <kohsuke> Was it cabbage?
19:21:25 <evilchili> you'll run into licensing problems with a second jira too :/
19:21:27 <rtyler> cabbage or lettuce
19:21:46 <rtyler> could we give fredg02 a backup and let him figure it out? :D
19:21:46 <kohsuke> evilchili: I'm sure we can get a FLOSS license for it too
19:21:57 <evilchili> indeed
19:21:59 <kohsuke> rtyler: fredg02: works for me
19:22:13 <kohsuke> but he also needs to have access to the infra, right?
19:22:27 <kohsuke> for him to do the experiment on this local system won't do any good
19:23:11 <rtyler> can we AI this to figure out, it's wider in scope than is suitable for this meeting IMHO
19:23:21 <kohsuke> #info Possibly related is that eggplant, the current server of JIRA, has a number of problems
19:23:36 <kohsuke> ranging from smaller disk space to the database option being not friendly to JIRA...
19:24:01 <kohsuke> rtyler: would you want to phrase the AI?
19:24:32 <rtyler> fredg02: how much does puppet scare you? :P
19:25:07 <fredg02> dunno yet. I'm definitely interested. wanted to talk to you about puppet at FOSDEM anyways ;)
19:25:14 <rtyler> if we could kill two birds with one stone: https://github.com/jenkinsci/infra-puppet/issues/1
19:25:37 <rtyler> #action fredg02 and rtyler to work together on figuring out bringing up a issues-beta.jenkins-ci.org on our infrastructure
19:25:45 <kohsuke> rtyler: fredg02: we might as well get paid by Atlassian to do it!
19:25:53 <rtyler> paid o_O
19:26:05 <fredg02> sounds good B)
19:26:06 <rtyler> if we can figure out a way to use puppet for this great, if not, so be it
19:26:16 <kohsuke> I mean, they don't even have a debian package
19:26:45 <kohsuke> I think I'm going to improve my changelog generator script slowly & steadily.
19:26:45 <rtyler> I've been in contact with the guy who coauthored Pro Puppet (also helped with puppet-jenkins)
19:26:50 <rtyler> I wonder if he'd be willing to help
19:27:11 <Majost> I have debian packaging experience
19:27:19 <Majost> pretty extensive really
19:27:20 <Majost> heh
19:27:41 <Majost> though time is something which has been hard for me to find lately. =/
19:28:21 <fredg02> as a side note, because it was asked yesterday: JIRA can handle multiple affects versions and multiple fix versions
19:28:27 <kohsuke> I think making JIRA a debian package is a nice separation of work.
19:29:48 <rtyler> we should close out the meeting if there are no more topics
19:29:57 <kohsuke> rtyler: I've added two
19:30:03 <rtyler> ah
19:30:03 <rtyler> heh
19:30:09 <rtyler> then let's move on xD
19:30:13 <kohsuke> And I was going to ask Majost if he's volunteering
19:30:18 <kohsuke> for jira.deb
19:30:21 <rtyler> he's always volunteering
19:30:25 <Majost> hah
19:30:25 <kohsuke> :-)
19:31:07 <kohsuke> Let's ask i386 if we can get some help from Atlassian
19:31:28 <kohsuke> #action kohsuke to ping i386 about JIRA debian package
19:31:34 <Majost> Right now, I can code review...
19:31:49 <kohsuke> OK, I think we are done with this topic
19:31:55 <Majost> np
19:32:21 <kohsuke> #topic funding give-away items
19:32:33 <rtyler> is abayer awake still? :D
19:32:44 <abayer> Sorry, distracted by work. =)
19:33:05 <kohsuke> So, we got SCALE10x, FOSDEM, and Jenkins CIA program, and as well as various local meet ups
19:33:10 <kohsuke> Not to mention 4 Jenkins User Conferences
19:33:27 <kohsuke> And we got a bit of money thanks to the fund-raising drive.
19:33:58 <kohsuke> So I wanted to see if people think it's a goo use of our money to buy some give-away materials for those events and efforts
19:34:24 <kohsuke> More concretely, stickers as a general give away
19:34:32 <kohsuke> ... and T-shirts for CIA agents
19:34:58 <ndeloof> Are stickers expensive ?
19:35:10 <kohsuke> I don't have the exact price, but a few hundreds for 1000
19:35:28 <kohsuke> based on Alyssa, who has done one for JUC
19:35:29 <kohsuke> http://www.stickermule.com/products/custom-die-cut-stickers
19:35:46 <fredg02> I'd pay for a t-shirt! :) (even more than retail if it's a donation)
19:35:54 <kohsuke> T-shirts are more expensive, so they aren't give aways for everyone.
19:36:12 <ndeloof> I did 1000 of them for my JUG and distribute to speakers & attendees, that was a nice advertising to find more audience
19:36:13 <kohsuke> But rtyler and I thought it'd be a great incentive for recruiting CIA agents
19:36:19 * rtyler nods
19:36:32 <ndeloof> I thing this makes sense to have such (low cost) goodies on conferences
19:36:36 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CIA+Program
19:36:38 <imod> I'm all in for this
19:37:07 <kohsuke> To try to be fair, the arguments on the other side is that we need to live cheaply
19:37:19 <kohsuke> I don't think we want to do fund-raising every year like Wikipedia does.
19:37:57 <imod> true, but I think now its the time to get more people into the Jenkins world and that will pay out again...
19:38:18 <ndeloof> agree
19:38:18 <fredg02> hehe. I like kohsuke staring at me from a banner more than those wikipedia guys
19:38:52 <kohsuke> abayer: your thoughts?
19:38:57 <rtyler> we'll have to get some more fun images next time around ;)
19:39:11 <abayer> I think we've got some cash to burn. =)
19:39:14 <rtyler> I'll have to see if kohsuke can do a buddy christ impression: http://upload.wikimedia.org/wikipedia/en/thumb/9/93/Buddy_christ.jpg/300px-Buddy_christ.jpg
19:39:35 <rtyler> kohsuke: I think setting a quarterly or annual budget for this makes sense
19:40:01 <rtyler> if we were to say we have a $1500 evangelism budget this year or something like that, that would guide our decisions much better IMHO
19:40:31 <kohsuke> We have about $6K in our bank right now (excluding what's already committed)
19:40:38 <imod> CIA Agents should make a note about donation at every presentation...
19:41:21 <rtyler> kohsuke: I'm inclined to be more conservative with the funds honestly, I don't like begging :P
19:41:31 <kohsuke> rtyler: Me too
19:42:13 <fredg02> how about putting a small donation fee on every merchandise item?
19:43:03 <kohsuke> How about we allocate $500 for stickers and $500 for T-shirts (when CIA is ready to launch), and see how long it lasts?
19:43:12 <rtyler> I like that
19:43:15 * rtyler pokes abayer
19:43:25 <abayer> +1
19:43:27 <kohsuke> I got some CloudBees-funded stickers on my way, so it should last.
19:43:56 <kohsuke> Any other +1/-1s?
19:44:02 <imod> +1
19:44:07 <fredg02> +1
19:44:15 <rtyler> #info How about we allocate $500 for stickers and $500 for T-shirts (when CIA is ready to launch), and see how long it lasts?
19:44:32 <ndeloof> +1
19:44:34 <kohsuke> #action kohsuke to get +1 from hare_brain for it
19:44:44 <imod> rtyler: your right about the conservative fund raising!
19:44:47 <Majost> you might be able to setup some pre-orders too
19:44:57 <Majost> could offset the cost a little
19:45:08 <kohsuke> fredg02: the tricky part is to make the markup go to SPI without going through any individuals
19:45:24 <fredg02> ok.
19:45:36 <kohsuke> I suspect the said individual has to deal with taxes and other stuff, too
19:45:56 <kohsuke> but if you figure it out, let us know
19:46:07 <fredg02> ok :P
19:46:09 <ndeloof> agree : thinks aren't simple if we introduce local payments
19:46:32 <kohsuke> OK, I think that's it for this
19:46:42 <kohsuke> #topic CLA collection
19:47:10 <kohsuke> This last one is just to say that we will start collecting CLAs for the core, even while we figure out the final destinations of those PDFs
19:47:28 <kohsuke> More of a note to myself to get this ball rolling
19:47:49 <kohsuke> #action kohsuke to start whipping us to sign CLAs
19:47:52 <ndeloof> link to template for the doc ?
19:48:04 <kohsuke> It's in the governance document somewhere
19:48:07 <ndeloof> ok
19:48:30 <kohsuke> #topic next meeting
19:48:35 <ndeloof> #info https://raw.github.com/jenkinsci/infra-cla/approved/icla.txt
19:48:41 <ndeloof> #info https://raw.github.com/jenkinsci/infra-cla/approved/ccla.txt
19:49:03 <kohsuke> 1/25, same time?
19:49:18 <rtyler> works for me, that'll be right after SCALE so we'll have much to talk about
19:49:20 <rtyler> and right before FOSDEM!
19:50:02 <kohsuke> #agreed next meeting is two weeks from now, same time
19:50:19 <kohsuke> Anyone wants to talk about anything else?
19:50:46 <rtyler> I have this rash on my side..
19:50:53 <kohsuke> Guess not. Thanks!
19:50:55 <kohsuke> #endmeeting