18:04:53 <kohsuke> #startmeeting
18:04:53 <robobutler> Let the Jenkins meeting commence!
18:05:05 <kohsuke> #chairs abayer rtyler hare_brain__
18:05:19 <kohsuke> or was it #chair?
18:05:24 <kohsuke> #chair abayer rtyler hare_brain__
18:05:24 <robobutler> Current chairs: abayer hare_brain__ kohsuke rtyler
18:05:53 <rtyler> meeting agenda: https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:05:58 <jorgenpt> cowboyd: Turns out my rvm was old as molasses, which is why I was using 1.5.6 (default rvm install jruby on that one) :-)
18:06:07 <kohsuke> rtyler: thanks
18:06:10 <rtyler> jorgenpt: time to find another channel, or wait a little while
18:06:17 * jorgenpt waits a little while
18:06:21 <kohsuke> I dont' know if kutzi is here
18:06:27 <rtyler> he's not :/
18:06:42 <hare_brain__> Well this could be quick then...
18:07:08 <rtyler> I'm going to add some more agenda items really quick :D
18:07:09 <jieryn> i have an item on the agenda too
18:07:14 <abayer> We should probably wait a bit for him. =)
18:07:34 <rtyler> #topic Bringing old Jenkins plugins up to a common requiredCore
18:07:39 <rtyler> jieryn: you have the fllor
18:07:40 <rtyler> floor too
18:07:43 <rtyler> take'em both
18:08:45 <jieryn> i put out a post the other week about standardizing plugin requiredCore - which is the parent version
18:09:07 <jieryn> we have a large range of parents which plugins depend on, and i was interested in taking the community temperature about standardizing
18:09:22 <abayer> I'm a fan of that personally.
18:09:23 <jieryn> PROS: creates concept of a 'rally' release, fits very nicely with LTS; speed up dev efficiency to reuse existing .m2/repo downloads
18:09:26 <jieryn> CONS: while few, there are old deployments; don't touch what ain't broken
18:09:55 <abayer> I've been saying that part of the appeal/value of the LTS is to give a stable target for plugin parenting.
18:10:20 <jieryn> you're ahead of your time then :) as i think that's a great target
18:10:38 <jieryn> i don't want to force jenkins just yet ,... but getting a 'rally' under our belts would be good experience to do just that
18:10:44 <kohsuke> Although this isn't proposing to bring them up to 1.409, right?
18:10:44 <pelegri> How do I add a topic?  "Adding Google Analytics to Jenkins community site"
18:10:48 <abayer> Though I also think it's reasonable to treat 1.395 as a de facto stable target for that regard.
18:10:59 <kohsuke> pelegri: I can add it for you
18:11:00 <rtyler> pelegri: agenda: https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-Oct26thMeeting
18:11:03 <pelegri> thanks
18:11:18 <jieryn> 1.392 is what i'm pitching, because of an m-hpi-p problem which didn't put the requiredCore into the manifest -- we can fix that easily though
18:11:25 <abayer> Ah, good point.
18:11:29 <abayer> Forgot about that.
18:11:35 <jieryn> either way, the hands will already be in the till .. it's not a problem either way
18:12:01 <jieryn> anyhow, if w ethink this is good- then i will create JonJ to automatically update to the latest level and run the build
18:12:11 <jieryn> for each down level plugin
18:12:31 <jieryn> or..don't bother? :) i'm up for suggestions
18:12:34 <abayer> I think it's worth trying, yeah.
18:13:02 <abayer> Hell, I think it'd be worth aggregating the parent version info for each plugin somewhere, if nothing else.
18:13:12 <kohsuke> I'm fine either way.
18:14:05 <jieryn> ok then!
18:14:10 <kohsuke> Maybe I have data showing how many still runs older releases
18:14:32 <jieryn> we can probably pull it from the anon data, i just got busy before mtg
18:14:42 <abayer> Nifty.
18:15:06 <kohsuke> What if we first do <=1.320 to 1.392?
18:15:11 <abayer> +1
18:15:28 <hare_brain__> How did you pick 1.320 for the cut-off?
18:15:30 <kohsuke> There's good number of them in there, and 1.320 is like 2 years old release, right?
18:15:38 <abayer> Though I don't think we need to do this for plugins which themselves haven't been released in ages.
18:16:20 <kohsuke> There are enough number requiring pre 1.320, and 1.320 seems old enough that it's less likely to negative impact users
18:16:36 <abayer> Yeah, that seems as good an arbitrary cutoff as any.
18:16:43 <kohsuke> and doing this gradually allows users to notice and complain
18:16:48 <rtyler> just for my on context, how long ago was that released?
18:16:55 <hare_brain__> OK, just wondering if you had metrics that let you pick that one.
18:17:05 <kohsuke> I'm still looking for the metrics
18:17:38 <hare_brain__> 8/14/2009
18:17:42 <abayer> Wow.
18:17:43 <rtyler> damn
18:17:46 <rtyler> heh
18:17:50 <rtyler> that's pretty damned old :D
18:18:04 <jieryn> ok
18:19:11 <kohsuke> and for the context, update center was first added in 1.312
18:19:18 <rtyler> O_O
18:20:44 <kohsuke> I take it back, that's incorrect. It's just that I don't have any more tags that go back beyond that
18:20:55 <abayer> heehee
18:21:03 <kohsuke> It was added in 1.220
18:21:08 <kohsuke> anyway
18:21:36 <kohsuke> jieryn: does it sound like a reasonable start?
18:21:39 <jieryn> yes
18:22:28 <pelegri> I have to leave now (flight arriving early).  Andrew, I'll mail you what I meant to write...
18:22:30 <rtyler> shall we move on?
18:22:44 <rtyler> (still no kutzi
18:22:48 <abayer> pelegri: Alrightie.
18:22:53 <kohsuke> #agreed jieryn to go through first 46 plugins that currently requires core <=1.320 and bump them up to 1.392. We'll see the reactions then.
18:23:02 <rtyler> #topic Infrastructure update
18:23:14 <rtyler> we had an issue yesterday due to backups filling up eggplant's disk
18:23:19 * rtyler sighs
18:23:36 <rtyler> it's a stupid problem that I don't have a good solution for right now for automating the secure off-site backing up of that data
18:23:55 <rtyler> #action rtyler to work out shuffling JIRA backups off eggplant
18:24:20 <kohsuke> I can offer my home NAS
18:24:27 <rtyler> I spent last weekend hacking with some puppet engineers, so I have some good ideas on how/where to move our puppet manifests forward
18:24:37 <rtyler> kohsuke: ah right, that reminds me
18:24:40 <kohsuke> Or we can just remove some old backups
18:24:49 <rtyler> #action rtyler needs to buy that damned NIC for cucumber for our backups with Contegix
18:25:09 <rtyler> basically we still have an outstanding offer of free backups at Contegix
18:25:13 <rtyler> just need a NIC to bridge the networks
18:25:34 <rtyler> which leads me into this
18:25:51 <rtyler> we'll have to have a new contract drawn up for cucumber, to properly assign ownership to the SPI
18:26:22 <rtyler> I'm currently working with our account rep at Contegix to work that out, I am hoping to square that away before the end of november
18:26:30 <kohsuke> cool
18:26:45 <rtyler> we haven't blown through our bandwidth the last couple months
18:26:51 <abayer> hooray!
18:26:52 <rtyler> so we're in good shape there, mirrors working properly :)
18:27:04 * rtyler is hoping for a big christmas present from the SPI though
18:27:25 <rtyler> I think that might be the extent of the infra updates
18:27:33 <rtyler> anything else to add under it
18:27:34 <rtyler> ?
18:28:03 <rtyler> still no kutzi, might have to punt that agenda item
18:28:10 <kohsuke> I guess we'll have to figure out how to have the cost of NIC paid from SPI
18:28:21 <kohsuke> First ever purchase of the project!
18:28:21 <rtyler> kohsuke: that's easy
18:28:24 <kohsuke> oh
18:28:27 <rtyler> kohsuke: I buy it, and then get reimbursed
18:28:34 <rtyler> unless we have a Jenkins Project Credit Card :P
18:28:43 <kohsuke> OK. If you already know how to do it, that's great.
18:29:03 <rtyler> without kutzi shall we set a next meeting time and wrap up early?
18:29:11 <kohsuke> Yes
18:29:13 <abayer> Wait!
18:29:19 <rtyler> pelegri's item?
18:29:25 <abayer> pelegri wanted us to talk about Google Analytics, yeah.
18:29:34 <kohsuke> #info Just quick donation update: as of today, we've raised $4040 up $140 from a month ago
18:29:35 <rtyler> #topic Google Analytics for jenkins-ci.org
18:29:44 <abayer> lemme c&p his email.
18:29:46 <abayer> Simple proposal: Add Google Analytics to the Jenkins community site.
18:29:50 <abayer> Rationale is that this helps show & quantify adoption growth, and...
18:29:54 <abayer> also helps in detecting geographic adoption patterns - like "high here, low there"
18:29:58 <abayer> Google Analytics provides pretty detailed demographic information.  Several of us have used in the past, including when at Hudson, and we found it very useful.
18:30:03 <abayer> Only issue I can think of is that the Google Analytics agreement. http://www.google.com/analytics/tos.html  Section 8. Indemnification...
18:30:48 <abayer> (that's the email)
18:30:53 <rtyler> so
18:30:58 * rtyler coughs
18:31:09 <abayer> I don't know anything about the TOS, but other than that, I have no issue, but I defer to rtyler on website matters.
18:31:17 <rtyler> we actually have it already
18:31:21 <rtyler> and I have historical data
18:31:23 * rtyler coughs
18:31:24 <abayer> …ha!
18:31:29 <rtyler> I've had GA enabled since the blog.hudson-ci.org days
18:31:44 <abayer> Well, then we should maybe do something with said data, I guess?
18:32:02 <rtyler> opening this data up is a little tricky AFAIK
18:32:12 <rtyler> since you basically have to have a google account, and I have to add access for it
18:32:51 <rtyler> so I think the take-away here is
18:33:05 <rtyler> #action rtyler to work with pelegri on finding a good way to expose/open up GA data to the community
18:33:28 <abayer> woot.
18:34:08 <kohsuke> Sounds good
18:34:13 <rtyler> next meeting?
18:34:17 <rtyler> #topic Next meeting times
18:34:23 <abayer> 2 weeks from now, I assume.
18:34:26 <kohsuke> +1
18:34:42 <rtyler> if that works for Mr. Globe Trotter, it works for me :D
18:34:43 <abayer> I'll be at Apachecon but will find a table and wifi. =)
18:34:53 <rtyler> Nov 9th, agreed?
18:35:12 <kohsuke> yes, works for me
18:35:18 <rtyler> alright, i'll bump kutzi's items
18:35:25 <majost> regarding offsite backups; you may want to look at crashplan. I have been using it for personal use, and have been pretty happy with it.
18:35:47 <rtyler> #endmeeting