#jenkins: Jenkins Project Meeting (2011.08.31)

Meeting started by rtyler at 18:00:30 UTC (full logs).

Meeting summary

    1. For everybody's reference, agenda: https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-ForAug31stMeeting%28rescheduledfromAugust24th%29 (rtyler, 18:00:51)

  1. Plugin Deprecations (rtyler, 18:01:29)
    1. Proposed plugin deprecation discussion https://wiki.jenkins-ci.org/display/JENKINS/Proposed+Plugin+Deprecation (rtyler, 18:01:53)

  2. The Jenkins User Conference (rtyler, 18:02:59)
    1. Details pertaining to the JUC can be found here: http://jenkins-ci.org/content/jenkins-user-conference (rtyler, 18:03:26)
    2. we are starting to see submissions coming in (kohsuke, 18:03:36)
    3. : I think it's at around 140 registrations now (kohsuke, 18:04:18)
    4. We have at this point over 150 people registered (rtyler, 18:04:29)
    5. Current signed up sponsors include: CloudBees, RedHat, Liferay, New Relic (rtyler, 18:04:51)
    6. and Sauce Labs (rtyler, 18:05:16)
    7. And anyone who's willing to sponsor or anyone who knows someone who might would be greatly appreciated, too (kohsuke, 18:05:47)
    8. ACTION: rtyler to prod kohsuke and the dev list to guage interest for a JavaOne Jenkins Hackathon (rtyler, 18:06:59)

  3. Jenkins mailing list spam, what to do about it (rtyler, 18:07:48)
    1. Google Groups document on cutting down spam: http://groups.google.com/support/bin/answer.py?hl=en&answer=186997 (rtyler, 18:08:25)
    2. AGREED: (rtyler, 18:11:09)
    3. ACTION: jieryn to speak up again for spam list action if the problem gets out of hand (rtyler, 18:11:22)

  4. Pull requests that lie in wait for 30+ days (rtyler, 18:11:40)
    1. https://wiki.jenkins-ci.org/display/JENKINS/Pending+Pull+Requests (rtyler, 18:11:53)
    2. I did a partial sweep over the last weekend (kohsuke, 18:11:54)
    3. For now, "those who can do a sweep on pull requests, please do" (rtyler, 18:22:35)
    4. New contributors should be encouraged to include tests with their pull requests (rtyler, 18:22:50)

  5. LTS 1.409.2, test status, ready to release? (rtyler, 18:23:04)
    1. Test progress: https://wiki.jenkins-ci.org/display/JENKINS/LTS+1.409.x+RC+Testing (rtyler, 18:23:58)
    2. I want to publicly recognize and thank vjuranek for the hard work that's been put in from his end on testing the LTS line (rtyler, 18:24:35)
    3. IDEA: I think @jenkinsci should tweet about this page and solicit more volunteers (kohsuke, 18:25:56)
    4. ACTION: rtyler to tweet out the LTS test matrix page to solicit help from the broader community (rtyler, 18:26:26)
    5. ACTION: vjuranek to follow up on the dev list after he's finished more testing (rtyler, 18:27:25)
    6. I'd also encourage people to start thinking about the base version for the next LTS (kohsuke, 18:27:37)
    7. ACTION: kutzi to update the LTS 1.409.x testing page with his own findings as well (rtyler, 18:27:52)
    8. Y! targetting 1.424 as the base of their next internal Jenkins stable release (rtyler, 18:28:52)
    9. ACTION: hare_brain to follow up on the dev list with Y!'s findings on using 1.424 as the next LTS base (rtyler, 18:29:55)
    10. https://fedorahosted.org/beaker/ apparently is more up to date (kohsuke, 18:31:58)

  6. Official commit workflow for core committers (rtyler, 18:33:45)
    1. ACTION: kohsuke to write a draft for core contributor workflow (abayer, 18:41:22)
    2. Git's document, for reference: http://git.kernel.org/?p=git/git.git;a=blob;f=Documentation/SubmittingPatches;h=938eccf2a5ac9dd629be1bc6bb53a59723c99083;hb=HEAD (rtyler, 18:41:46)

  7. Featuring the issue tracking page in a more prominent place (rtyler, 18:42:24)
    1. IDEA: should "bug tracker" in http://jenkins-ci.org/ link to that? (kohsuke, 18:43:06)
    2. "that" being: https://wiki.jenkins-ci.org/display/JENKINS/Issue+Tracking (rtyler, 18:43:19)
    3. ACTION: rtyler to update the "bug tracker" link on jenkins-ci.org (rtyler, 18:44:11)
    4. IDEA: Put a link to the issue tracker in the side bar on Use Jenkins (hare_brain, 18:45:39)

  8. Feedback on the request for official definitions of stable, unstable, failure (rtyler, 18:46:40)
    1. https://issues.jenkins-ci.org/browse/JENKINS-10763 (rtyler, 18:46:48)
    2. related discussion on the dev list: https://groups.google.com/forum/?hl=de#!topic/jenkinsci-dev/2rMdYX3WMwo (rtyler, 18:48:00)
    3. AGREED: (rtyler, 18:48:15)
    4. ACTION: everybody should start thinking of how to clear up some of these terms across the widest cross-section of our userbase (rtyler, 18:55:06)
    5. Terms somewhat enumerated here: https://wiki.jenkins-ci.org/display/JENKINS/Terminology (rtyler, 18:55:49)
    6. ACTION: kutzi to write down his proposal in the wiki (kutzi, 18:55:56)

  9. Donation drive! (rtyler, 18:56:08)
    1. the SPI's donation page is here: http://spi-inc.org/donations/ (rtyler, 18:58:17)
    2. so far I still haven't heard back from SPI that the account is set up (kohsuke, 18:58:17)
    3. I've started talking with a Contegix accountant to get their donations of bandwidth and colocation space assigned to the SPI (rtyler, 18:59:20)
    4. And we do have some random expenses that some of us have been paying out of pocket (kohsuke, 19:00:35)
    5. ACTION: kohsuke to ping Rackspace about transferring assets to the SPI and starting to write off their donations as well (rtyler, 19:01:16)
    6. IDEA: Add a donation drive slide to JUC presentation template (hare_brain, 19:01:40)

  10. Infrastructure update (rtyler, 19:02:18)
    1. Contegix has donated another 4TB of bandwidth to our machine, cucumber (rtyler, 19:02:41)
    2. cabbage and lettuce are both racked at the OSL (rtyler, 19:02:55)
    3. rtyler has made the painful executive decision that Jenkins infra will standardize on Ubuntu+Puppet (rtyler, 19:03:20)
    4. for reference, here's our bandwidth spike on cucumber: http://strongspace.com/rtyler/public/year_cucumber_bw.png (rtyler, 19:06:31)
    5. ACTION: rtyler to move mirrorbrain from cucumber to lettuce (rtyler, 19:06:53)
    6. FishEye has been unstable, too. There's a ticket open on Atlassian Support to find out what's going on. (kohsuke, 19:08:01)
    7. Jenkins puppet manifests are being collected here: github.com/jenkinsci/infra-puppet (rtyler, 19:08:37)

  11. Next meeting (rtyler, 19:10:23)
    1. Next project meeting 2011.09.14 at 18:00 UTC (rtyler, 19:11:30)


Meeting ended at 19:11:33 UTC (full logs).

Action items

  1. rtyler to prod kohsuke and the dev list to guage interest for a JavaOne Jenkins Hackathon
  2. jieryn to speak up again for spam list action if the problem gets out of hand
  3. rtyler to tweet out the LTS test matrix page to solicit help from the broader community
  4. vjuranek to follow up on the dev list after he's finished more testing
  5. kutzi to update the LTS 1.409.x testing page with his own findings as well
  6. hare_brain to follow up on the dev list with Y!'s findings on using 1.424 as the next LTS base
  7. kohsuke to write a draft for core contributor workflow
  8. rtyler to update the "bug tracker" link on jenkins-ci.org
  9. everybody should start thinking of how to clear up some of these terms across the widest cross-section of our userbase
  10. kutzi to write down his proposal in the wiki
  11. kohsuke to ping Rackspace about transferring assets to the SPI and starting to write off their donations as well
  12. rtyler to move mirrorbrain from cucumber to lettuce


Action items, by person

  1. hare_brain
    1. hare_brain to follow up on the dev list with Y!'s findings on using 1.424 as the next LTS base
  2. jieryn
    1. jieryn to speak up again for spam list action if the problem gets out of hand
  3. kohsuke
    1. rtyler to prod kohsuke and the dev list to guage interest for a JavaOne Jenkins Hackathon
    2. kohsuke to write a draft for core contributor workflow
    3. kohsuke to ping Rackspace about transferring assets to the SPI and starting to write off their donations as well
  4. kutzi
    1. kutzi to update the LTS 1.409.x testing page with his own findings as well
    2. kutzi to write down his proposal in the wiki
  5. rg
    1. rtyler to update the "bug tracker" link on jenkins-ci.org
  6. rtyler
    1. rtyler to prod kohsuke and the dev list to guage interest for a JavaOne Jenkins Hackathon
    2. rtyler to tweet out the LTS test matrix page to solicit help from the broader community
    3. rtyler to update the "bug tracker" link on jenkins-ci.org
    4. rtyler to move mirrorbrain from cucumber to lettuce
  7. vjuranek
    1. vjuranek to follow up on the dev list after he's finished more testing


People present (lines said)

  1. rtyler (163)
  2. kohsuke (92)
  3. hare_brain (41)
  4. jieryn (29)
  5. kutzi (28)
  6. abayer (26)
  7. stigkj (15)
  8. vjuranek (12)
  9. orrc (9)
  10. robobutler (4)
  11. ksawicki (3)
  12. P4G0 (3)
  13. norro (3)
  14. imod (2)
  15. mns (2)
  16. rg (2)
  17. jenkins-admin (1)
  18. jweinberg (1)


Generated by MeetBot 0.1.4.