18:04:59 <oleg-nenashev> #startmeeting
18:04:59 <robobutler> Let the Jenkins meeting commence!
18:05:39 <oleg-nenashev> I'd guess I am the meeting chair today. Ok
18:05:50 <oleg-nenashev> #info https://wiki.jenkins.io/display/JENKINS/Governance+Meeting+Agenda
18:06:03 <tracymiranda> #chair oleg-nenashev
18:06:12 <tracymiranda> :-)
18:06:14 <oleg-nenashev> #chair oleg-nenashev
18:06:14 <robobutler> Current chairs: oleg-nenashev
18:06:18 <oleg-nenashev> Exactly
18:06:32 <oleg-nenashev> #topic Last meeting actions
18:07:13 <oleg-nenashev> we had a meeting on Aug 31 in order to have some budget approvals. Everything was copleted
18:07:48 <oleg-nenashev> There are some follow-ups like JEP-8 approvals, but nothing important. Moving on
18:07:57 <oleg-nenashev> #topic LTS status check
18:08:13 <oleg-nenashev> #info LTS status check has been moved to mailing lists
18:09:00 <oleg-nenashev> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/oQ8PD1hgYBE FTR
18:09:14 <oleg-nenashev> So I'd guess we will remove it from the template
18:09:26 <oleg-nenashev> 2.190.1 RC date is today BTW
18:09:40 <oleg-nenashev> Does anyone want to say something about this topic?
18:10:02 <markewaite> My interactive testing of 2.190 looked good
18:10:10 <markewaite> Nothing else to report
18:10:46 <oleg-nenashev> #info Backporting thread: https://groups.google.com/forum/#!topic/jenkinsci-dev/SUl-0uG61Bo . Please comment there if you see any issues
18:10:52 <oleg-nenashev> Moving on then
18:11:14 <oleg-nenashev> #topic Jenkins Board & Officer Elections 2019
18:11:39 <oleg-nenashev> #info https://groups.google.com/forum/#!topic/jenkinsci-dev/vKi9JpxTQxY
18:12:09 <tracymiranda> am I up?
18:12:13 <oleg-nenashev> So we will have a discussion (if needed), then vote for motions, and then vote for the final proposal
18:12:35 <oleg-nenashev> tracymiranda: Yes, please summarize the proposal while people are going through it
18:13:27 <tracymiranda> I have put forward a proposal to run Jenkins elections for Governance Board & Officers
18:13:55 <tracymiranda> This is largely based on existing Jenkins processes, but some changes and clarifications were needed
18:14:08 <oleg-nenashev> #info https://wiki.jenkins.io/display/JENKINS/Board+Election+Process
18:14:14 <tracymiranda> To spell these out they are listed as a set of motions
18:14:17 <oleg-nenashev> #info https://wiki.jenkins.io/display/JENKINS/Governance+Board
18:14:55 <tracymiranda> I invite anyone to ask for any further clarification on the motions or any questions related to the elections
18:15:35 <markyjackson> no questions but a comment: Thank you for doing this tracymiranda
18:16:01 <tracymiranda> My pleasure
18:16:04 <oleg-nenashev> We also had a discussion yesterday at the Advocacy&Outreach SIG meeting.. Meeting notes: https://docs.google.com/document/d/1K5dTSqe56chFhDSGNfg_MCy-LmseUs_S3ys_tg60sTs/edit#heading=h.ae5z3dazo3o5
18:16:14 <tracymiranda> Actually I have a question
18:16:24 <oleg-nenashev> :+1
18:16:45 <tracymiranda> Just noticed the update first motion - the 2020 part does not seem clear to me - All officer positions will be voted on in 2019 will be voted on in 2020 (Team Leads)
18:16:57 <tracymiranda> maybe just a word missing?
18:17:13 <oleg-nenashev> It is my bad
18:17:17 <oleg-nenashev> fixing
18:17:27 <oleg-nenashev> "All officer positions will be voted on in 2019"
18:17:58 <oleg-nenashev> and "3 Board positions instead of 2 in the proposal will be voted in 2019. 2 will be voted in 2020". IIUC this is was the intent
18:18:30 <tracymiranda> Yes, that captures it well
18:18:38 <oleg-nenashev> Fixing
18:19:09 <oleg-nenashev> I do not have questions about the board elections. IMHO we desperately need it to move the project forward
18:19:17 <markyjackson> +1
18:19:25 <alyssat_> +1
18:19:34 <oleg-nenashev> Frankly speaking, the fact that I am chairing this meeting is a justification on its own
18:20:18 * markewaite agrees
18:20:31 <oleg-nenashev> We have got +1 from kohsuke in the mailing list. And rtyler was supportive about the board elections during the CDF discussions. So I believe we have support from the board
18:21:34 <tracymiranda> Let me throw in my formal +1 too then
18:21:50 <oleg-nenashev> We got 6 +1s in the thread by tracymiranda . No -1s
18:22:32 <markyjackson> +1 from me as well
18:22:54 <oleg-nenashev> Should we proceed with motions then?
18:23:03 <oleg-nenashev> formal +1 from me
18:23:13 <markyjackson> formal +1 from me
18:23:16 <markewaite> +1 from me
18:23:22 <alyssat_> +1
18:23:48 <oleg-nenashev> #agreed : We proceed with the Governance Board and Officer Elections proposal
18:24:11 <oleg-nenashev> #topic: Motion: All officer positions will be voted on in 2019 (Team Leads)
18:24:23 <oleg-nenashev> #info https://wiki.jenkins.io/display/JENKINS/Team+Leads
18:24:50 <oleg-nenashev> We have 4 officer positions: Infra, Events, Security, and LTS
18:25:11 <oleg-nenashev> Looks like only alyssat_ (Events officer) is around
18:25:46 <alyssat_> 😊
18:25:51 <oleg-nenashev> All officer positions are overdue according to https://wiki.jenkins.io/display/JENKINS/Governance+Board
18:26:14 <oleg-nenashev> Any questions before we proceed with voting?
18:26:38 <oleg-nenashev> #info See https://wiki.jenkins.io/display/JENKINS/Governance+Board for the active officers and terms
18:26:54 <oleg-nenashev> or maybe "acting". whatever
18:27:30 <oleg-nenashev> OK, let's vote
18:27:36 <oleg-nenashev> +1 from me
18:27:38 <tracymiranda> +1
18:27:39 <markyjackson> +!
18:27:43 <markyjackson> +1
18:27:47 <alyssat_> +1
18:28:14 <oleg-nenashev> anyone opposed?
18:28:30 <markewaite> Not opposed +1 from me
18:29:08 <oleg-nenashev> #agree Motion: "All officer positions will be voted on in 2019" is accepted
18:29:51 * oleg-nenashev the ayes have it, the ayes have it!
18:30:32 <oleg-nenashev> #topic: Motion: 3 Board positions instead of 2 in the proposal will be voted on in 2019 (Dean Yu's seat + 2 new seats). 2 will be voted on in 2020
18:30:43 <oleg-nenashev> oops
18:30:54 <oleg-nenashev> #topic: Motion: All officer positions will be voted on in 2019 (Team Leads)
18:31:00 <oleg-nenashev> #agreed Motion: "All officer positions will be voted on in 2019" is accepted
18:31:13 <oleg-nenashev> #topic: Motion: 3 Board positions instead of 2 in the proposal will be voted on in 2019 (Dean Yu's seat + 2 new seats). 2 will be voted on in 2020
18:32:11 <oleg-nenashev> The essense of this motion is that we fill in the Dean Yu's position . Dean (harebrain) has been inactive in the community since 2016 or so
18:32:55 <oleg-nenashev> One of the reasons to have a seat is to have an active board member and to prevent deadlocks in the case of 4 votes
18:33:11 <oleg-nenashev> Any questions about this motion?
18:33:26 <tracymiranda> thanks for clarifying about the deadlocks
18:34:15 <markewaite> I thought the essence was "replace Dean, add 2 additional seats (total of 5 seats), vote for 3 of the 5 seats". Did I misunderstand?
18:34:19 <oleg-nenashev> Technically the board's decision can be overridden by the governance meeting, so it is not a full deadlock. But some processes are fully up to the board
18:34:52 <oleg-nenashev> markewaite: we already have 5 seats defined in https://wiki.jenkins.io/display/JENKINS/Board+Election+Process
18:35:09 <oleg-nenashev> so it is not a part of the motion which is essentially a diff
18:35:14 <markewaite> Thanks for the clarification oleg-nenashev.
18:35:41 <oleg-nenashev> To simplify the things, after the election the board will be: kohsuke, rtyler, and 3 newly elected board members
18:36:44 <oleg-nenashev> FTR I cannot longer login to Confluence due to whatever reason
18:37:08 <oleg-nenashev> olblak: ^ . Not that we need it, so it is not urgent
18:37:16 <oleg-nenashev> Any questions? Or do we vote?
18:37:39 <oleg-nenashev> OK, let's vote
18:37:43 <oleg-nenashev> +1 from me
18:37:50 <tracymiranda> +1
18:37:57 <markewaite> +1
18:37:59 <alyssat_> +1 from me
18:38:06 <markyjackson> +1
18:38:17 <oleg-nenashev> let's wait for 2 min
18:39:03 <oleg-nenashev> uhm
18:39:32 <oleg-nenashev> will reduce to 1min for the next motions
18:40:37 <oleg-nenashev> #agreed Motion "3 Board positions instead of 2 in the proposal will be voted on in 2019 (Dean Yu's seat + 2 new seats). 2 will be voted on in 2020" is accepted
18:40:53 <oleg-nenashev> #topic Motion: "CDF will supervise the election and run the voting using The Condorcet Internet voting system instead of Single Transferable Vote"
18:41:04 <oleg-nenashev> tracymiranda: would you like to describe it?
18:41:12 <tracymiranda> sure
18:41:49 <tracymiranda> one of the services CDF can assist with is community elections - they are already well set up to do this for technical oversight committee, governing board, etc
18:42:13 <oleg-nenashev> #info https://civs.cs.cornell.edu/
18:42:26 <oleg-nenashev> #info https://en.wikipedia.org/wiki/Single_transferable_vote
18:42:39 <tracymiranda> For this they use the Condorcet Internet voting system as provided by the Cornell University
18:43:04 <tracymiranda> This is pretty commonly used i.e. by Linux Foundation and also for Eclipse Foundation board elections
18:43:31 <tracymiranda> Condorcet internet voting system(civs) offers ranked choice voting
18:43:31 <oleg-nenashev> One of the reasons why we cannot use Single transferable vote is that there is no ready-to-fly implementation for it
18:43:58 <tracymiranda> here is some info on the two systems https://civs.cs.cornell.edu/
18:45:09 <oleg-nenashev> At some point olblak invested time to implement something, and it was presented at the contributor hackfest at DW-JW 2017 IIRC. But the system is not ready, and at the yesterday's discussion at Advocacy&Outreach SIG there was a consensus that it is better to use an external system if the motion is accepted
18:45:58 <tracymiranda> Finally I'll add in practice what it means is voters get a list of candidates and a drop down box for each - they use the drop down box to select a ranking i.e. 1, 2, 3
18:46:09 <tracymiranda> Full instructions are provided with the ballot
18:46:14 <tracymiranda> Any questions/comments?
18:46:17 <oleg-nenashev> 👍
18:46:21 <oleg-nenashev> nothing from me
18:46:27 <markyjackson> nothing from me
18:46:33 <oleg-nenashev> +1 for the motion
18:46:33 <markewaite> none from me.
18:46:39 <markyjackson> +1 for the motion
18:46:43 <markewaite> +1 for the motion
18:46:47 <tracymiranda> +1
18:46:49 <oleg-nenashev> I am ready to vote even by mail if it moves the story forward
18:47:26 <oleg-nenashev> waiting for 30 more secondss
18:47:39 <alyssat_> +1
18:48:10 <oleg-nenashev> #agreed Motion "CDF will supervise the election and run the voting using The Condorcet Internet voting system instead of Single Transferable Vote" is accepted
18:48:26 <oleg-nenashev> #topic: Motion: "The election cut-off date for valid jenkins.io accounts for the 2019 election is 1st September 2019"
18:48:33 <oleg-nenashev> should be straightforward
18:48:43 <oleg-nenashev> should we just vote?
18:48:52 <markyjackson> yes
18:48:56 <oleg-nenashev> +1
18:49:00 <markyjackson> +1
18:49:05 <tracymiranda> +1
18:49:09 <alyssat_> +1
18:49:13 <markewaite> +1
18:49:26 <oleg-nenashev> 30sec timeout
18:50:04 <oleg-nenashev> #agreed Motion: "The election cut-off date for valid jenkins.io accounts for the 2019 election is 1st September 2019" is accepted
18:50:34 <oleg-nenashev> #topic Motion: "The proposed election schedule will start on 13 September 2019 and conclude on 4 November 2019 with intermediate dates as per dev list thread"
18:50:49 <oleg-nenashev> Straightforward as well
18:51:00 <oleg-nenashev> #info https://groups.google.com/d/msg/jenkinsci-dev/vKi9JpxTQxY/pBidPImHAQAJ , first message
18:51:12 <markyjackson> +1
18:51:15 <tracymiranda> +1
18:51:18 <oleg-nenashev> https://www.irccloud.com/pastebin/9UwmJWJI/
18:51:30 <oleg-nenashev> +1
18:51:33 <tracymiranda> cool didn't know you could do that
18:51:36 <alyssat_> +1
18:51:40 <markewaite> +1
18:51:46 <oleg-nenashev> 30 sec timeout
18:52:14 <oleg-nenashev> tracymiranda: it is pastebin, so standard broewsers and IRC clients can autoexpand it
18:52:30 <tracymiranda> neat
18:52:39 <oleg-nenashev> IRCCloud makes it Ctrl+C/Ctrl+V basically
18:52:58 <oleg-nenashev> #agreed Motion: "The proposed election schedule will start on 13 September 2019 and conclude on 4 November 2019 with intermediate dates as per dev list thread" is accepted
18:53:40 <oleg-nenashev> #topic: Motion: "Adding new officer role: Documentation officer"
18:53:57 <oleg-nenashev> #info https://wiki.jenkins.io/display/JENKINS/Proposal+-+Project+sub-teams - new teams suggested in 2015
18:54:18 <oleg-nenashev> Basically it reimplements the "Content officer", more or less
18:54:32 <oleg-nenashev> Any questions before we vote?
18:54:42 <tracymiranda> So in some ways this is just a rename of the 'Website' role?
18:54:56 <tracymiranda> Similar I guess to how we often refer to LTS as 'Release officer'
18:55:02 <oleg-nenashev> yup
18:55:04 <markewaite> Yes tracymiranda, I think it is a rename of the website role
18:55:14 <tracymiranda> sounds good
18:55:45 <oleg-nenashev> #info https://jenkins.io/sigs/docs/ as a new entity introduced in 2018
18:56:03 <oleg-nenashev> IMO it is critical to the project to have better docs, so I am +1
18:56:09 <tracymiranda> +1
18:56:19 <markyjackson> +1
18:56:22 <markewaite> +1
18:56:29 <alyssat_> +1
18:56:34 <oleg-nenashev> 30 sec timeout
18:57:04 <oleg-nenashev> #agreed Motion: "Adding new officer role: Documentation officer" is accepted
18:57:54 <oleg-nenashev> #topic Voting for the amended https://wiki.jenkins.io/display/JENKINS/Board+Election+Process and for the board election proposal
18:58:04 <oleg-nenashev> #info All motions have been accepted
18:58:25 <oleg-nenashev> Any comments before we proceed with the final vote?
18:58:54 <oleg-nenashev> We are going to go overtime a bit, maybe 5min
18:59:04 <tracymiranda> what is the final vote?
18:59:21 <oleg-nenashev> "Approve with the proposal"
18:59:43 <tracymiranda> ok
18:59:48 <oleg-nenashev> "Approve with the proposal with amendments by motions" actually
19:00:01 <oleg-nenashev> I am +1
19:00:04 <markyjackson> +1
19:00:09 <alyssat_> +1
19:00:09 <tracymiranda> +1
19:00:34 <markewaite> +1
19:00:43 <oleg-nenashev> 30 sec timeout
19:01:52 <oleg-nenashev> #agreed Jenkins Board & Officer Elections 2019 is accepted. We will follow the https://wiki.jenkins.io/display/JENKINS/Board+Election+Process process, with 6 amendments approved before
19:02:27 <tracymiranda> Great, I will take the action to sync with existing board to get a nomination email sent to dev list on 13 sep
19:02:27 <oleg-nenashev> #action all to send their nominations for 3 board members and 5 officers by October 04, 2019
19:02:44 <oleg-nenashev> #action tracymiranda to sync with existing board to get a nomination email sent to dev list on 13 sep
19:03:02 <tracymiranda> Other actions would be to update https://wiki.jenkins.io/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-September11 with motions (as per Lloyd suggestion in original thread)
19:03:12 <oleg-nenashev> #action tracymiranda to communicate the Governance meeting results in the developer mailing list
19:03:19 <tracymiranda> And add election dates to Jenkins calendar
19:03:24 <oleg-nenashev> tracymiranda: All motions are already listed there
19:03:37 <tracymiranda> sorry should be other page
19:03:50 <tracymiranda> https://wiki.jenkins.io/display/JENKINS/Board+Election+Process
19:03:54 <oleg-nenashev> #action oleg-nenashev to add key election dates to the Jenkins event calendar
19:04:16 <oleg-nenashev> I doubt I have permissions to https://wiki.jenkins.io/display/JENKINS/Board+Election+Process
19:04:38 <oleg-nenashev> #action tracymiranda to ensure that the https://wiki.jenkins.io/display/JENKINS/Board+Election+Process get updated after the motions
19:04:41 <tracymiranda> ok when I email dev list I will ask board members to update that page too
19:04:50 <oleg-nenashev> great!
19:05:29 <oleg-nenashev> #action tracymiranda to ask Governance board to update https://wiki.jenkins.io/display/JENKINS/Governance+Board : add Infrastructure and Documentation officers there + links to the elections
19:05:48 <oleg-nenashev> Am I missing something?
19:06:03 <tracymiranda> that all sounds good to me
19:06:11 <markewaite> Good to me
19:06:12 <oleg-nenashev> Likely we should move the Board page to jenkins.io
19:06:22 <oleg-nenashev> But this is rather a follow-up
19:06:37 <oleg-nenashev> So, anything else before we close the meeting?
19:06:59 <markyjackson> nothing from me
19:06:59 <tracymiranda> no, that was plenty :-)
19:07:04 <tracymiranda> go forth and nominate!
19:07:15 <oleg-nenashev> tracymiranda: Should we run regular governance meeting while the elections are in progress?
19:07:31 <oleg-nenashev> Or just ML + ad-hoc meetings if needed ?
19:07:37 <tracymiranda> when would next one be?
19:07:49 <oleg-nenashev> in 2 weeks if we follow the schedule
19:08:13 <oleg-nenashev> I will unlikely be available to run it tho
19:08:28 <tracymiranda> think that is a good one to target any clarifications on the process (i.e. all loose ends tied up around then)
19:08:37 <oleg-nenashev> OK
19:08:53 <oleg-nenashev> #agreed Next meeting will happen on Sep 25
19:09:11 <tracymiranda> then the one on 9th will be just after list of nominees is available so good timing (almost like someone thought this thru :)
19:09:12 <oleg-nenashev> #action oleg-nenashev to ensure somebody can run it, grant permissions if needed
19:09:49 <oleg-nenashev> I'd guess that's it, thanks everybody!
19:10:02 <markyjackson> Have a great day/night everyone
19:10:09 <oleg-nenashev> #endmeeting