18:00:24 <kohsuke> #startmeeting
18:00:24 <robobutler> Let the Jenkins meeting commence!
18:00:34 <rtyler> \o/
18:00:39 <kohsuke> #chair rtyler  kohsuke
18:00:39 <robobutler> Current chairs: kohsuke rtyler
18:00:52 <kohsuke> #topic Recap last meeting actions
18:01:03 <kohsuke> #info http://meetings.jenkins-ci.org/jenkins-meeting/2018/jenkins-meeting.2018-12-05-18.01.html
18:01:26 <kohsuke> "oleg_nenashev to clarify the Java 11 experimental update center in the JEP-211"
18:02:21 <kohsuke> "kohsuke or rtyler to update https://wiki.jenkins.io/display/JENKINS/Approved+Trademark+Usage" didn't happen, but hopefully there's a whole batch to add from this week anyway
18:02:29 <kohsuke> I guess oleg-nenashev is not here
18:03:06 <kohsuke> I'll just carry forward that one till the next year, assuming it's a real action item
18:03:18 <kohsuke> #action oleg-nenashev to clarify the Java 11 experimental update center in the JEP-211 (carry over from Dec 5th)
18:03:36 <kohsuke> Moving on ...
18:03:44 <kohsuke> #topic LTS status check
18:04:24 <rtyler> welp, ogondza isn't around and I don't know about danielbeck
18:04:50 <kohsuke> danielbeck is done for the year I think
18:05:03 <rtyler> did somebody put him back in his stasis pod already?
18:05:15 <bitwiseman> Rejuvinator
18:05:22 <bitwiseman> Just a quick stint.
18:05:35 <rtyler> he
18:05:47 <rtyler> kohsuke: we're not doing anything LTS until the new year anyways I thought
18:05:57 <kohsuke> I think the 2.150.2 release schedule is pushed out by two weeks so I think we can safely punt this today
18:06:25 <kohsuke> #topic trademark sublicensing requests
18:06:55 <kohsuke> So there are 5 all in all
18:07:00 <rtyler> good grief
18:07:04 <bitwiseman> Yup.
18:07:24 <bitwiseman> #info https://groups.google.com/d/topic/jenkinsci-dev/MGZDWfhFaZI/discussion
18:07:43 <bitwiseman> #info https://groups.google.com/d/topic/jenkinsci-dev/jv8oFl9PMM4/discussion
18:07:54 * kohsuke would have loved to have more people around
18:08:24 <bitwiseman> We could table this to the next meeting if we feel it is needed.
18:08:27 <kohsuke> But I do think it all falls well within the line of past patterns of approvals: https://wiki.jenkins.io/display/JENKINS/Approved+Trademark+Usage
18:08:50 <rtyler> instead of just linking to Google Groups, can we go through these one by one please
18:09:01 <bitwiseman> sure.
18:09:16 <bitwiseman> There are 4 trainings and one distribution.
18:09:31 <bitwiseman> Let's start with the dist.
18:09:54 <bitwiseman> CloudBees Jenkins X Distribution
18:10:09 <bitwiseman> Jenkins X folks approved in email.
18:10:25 <rtyler> nobody from the Jenkins X core team balked at that, so as far as I am concerned that's a +1
18:10:37 <rtyler> in line with previously existing items
18:10:54 <rtyler> kohsuke: ?
18:11:01 <kohsuke> I think this is quite in line with the earlier $COMPANY Jenkins $SOMETHING format
18:11:24 <kohsuke> I'm +1 myself, and in my best attempt to channel everyone else, I can't think of anyone who might object
18:11:42 <kohsuke> So I think we are in good standing to approve this today
18:11:56 <rtyler> #agreed CloudBees Jenkins X Distribution sublicense is granted with the usaul stipulations around usage, etc
18:12:03 <rtyler> #action kohsuke to update the approved trademarks page
18:12:18 <bitwiseman> Next: Jenkins CI/CD Workshop by CloudBees
18:12:36 <rtyler> so all these trainings are just "Foo" by CloudBees right?
18:13:01 <kohsuke> What do you mean by "Foo"?
18:13:16 <bitwiseman> <something>
18:13:20 <kohsuke> Right
18:13:35 <bitwiseman> <your text here>
18:14:08 <kohsuke> We haven't approved this pattern for a while, but I think it's still safely within the line of the spirit -- avoiding the confusion about the origin of the effort
18:14:35 <kohsuke> Again on this one, I'm +1 myself, and in my best attempt to channel everyone else, I can't think of anyone who might object
18:15:09 <rtyler> generally speaking "Jenkins thing" by "Jenkins supporting company" whether it's CloudBees, Praqma, Microsoft, etc, I am comfortable with so long as the mark isn't being abused and the $thing is relevant to Jenkins
18:15:10 <kohsuke> Ah, I take "haven't approved this pattern for a while" back. We had "Jenkins Days by CloudBees"
18:15:38 <rtyler> also presuming the mark doesn't present confusion to Jenkins users, but IMHO "by Commpany" does that suitably
18:16:08 <bitwiseman> +1
18:16:26 <rtyler> frankly, I'm +1 on all four trainings with the usual stipulations, for example that attribution is in place, and the company is using the full sublicensed mark in their materials, including the "by CloudBees"
18:16:42 <kohsuke> Well, you asked for going through this one by one, so let's go through the ceremony
18:17:08 <kohsuke> #agreed "Jenkins CI/CD Workshop by CloudBees sublicense" is granted, same fine print as above
18:17:23 <rtyler> kohsuke: you read my mind :)
18:17:27 <kohsuke> Next: Jenkins Jumpstart by CloudBees
18:17:39 <rtyler> +1
18:17:41 <kohsuke> Same reasoning as before, +1
18:17:44 <bitwiseman> +1
18:17:59 <kohsuke> #agreed "Jenkins Jumpstart by CloudBees" is granted, same fine print as above
18:18:02 <bitwiseman> Next: Jenkins Virtuoso Workshop by CloudBees
18:18:13 <kohsuke> Same reasoning as before, +1
18:18:16 <bitwiseman> +1
18:18:34 <rtyler> who comes up with these names? :P
18:18:35 <rtyler> +1
18:18:55 <bitwiseman> (ex-microsofties for sure)
18:19:00 <kohsuke> #agreed "Jenkins Virtuoso Workshop by CloudBees" is granted, same fine print as above
18:19:09 <bitwiseman> Next: Jenkins X Cloud Native CI/CD Workshop by CloudBees
18:19:17 <kohsuke> +1
18:19:21 <bitwiseman> +1
18:19:37 <rtyler> needs more buzzword, +1
18:19:47 <bitwiseman> (blockchain)
18:19:52 <kohsuke> (btw if anyone else is watching and forming thought, please say so)
18:19:52 <rtyler> heh
18:20:01 <kohsuke> #agreed "Jenkins X Cloud Native CI/CD Workshop by CloudBees" is granted, same fine print as above
18:20:45 <kohsuke> I think it's time to propose some well-known patterns of blanket approvals
18:21:00 <rtyler> I remember bringing that up last year to you ;)
18:21:05 <rtyler> we can tackle that in 2019
18:21:10 <kohsuke> Yes
18:21:31 <kohsuke> I think the argument is that much strong now and more obvious
18:21:37 <rtyler> is that end of this topic
18:21:41 <kohsuke> #topic next meeting
18:21:45 <rtyler> hold on smokey
18:21:48 <kohsuke> OK
18:21:50 <rtyler> #topic SPI business
18:22:13 <rtyler> #info the Jenkins marks have been renewed with the US Patent and Trademark Office by our friends at Software in the Public Interest
18:22:22 <rtyler> I believe the filing fee was around $350 if anybody cares
18:23:02 <rtyler> I'm not sure where we are on the budget, or how the Outreachy stipends are/were paid
18:23:08 * kohsuke feels the government is not charging what the market bears
18:23:09 <rtyler> but we're in the black
18:23:29 <kohsuke> There was an email from tracymiranda about how Outreachy can invoice SPI
18:23:31 <rtyler> kohsuke: if you would like to pay more for stuff, please let me sell you some old junk :)
18:24:17 <kohsuke> I'm just saying good old "Uncle Sam should charge more from other people" American pass time
18:24:37 <rtyler> that's all the SPI things I wanted to bring up
18:24:46 <kohsuke> Great
18:25:06 <kohsuke> Anything else on other topics?
18:25:15 <rtyler> not at this time
18:25:22 <kohsuke> #topic next meeting
18:25:41 <kohsuke> #info next meeting is Jan 2nd
18:25:49 <bitwiseman> Woot.
18:25:51 <kohsuke> the same time as this one
18:26:11 <bitwiseman> The day after hangover day.
18:26:15 <kohsuke> I think 2018 has been an amazing year for the Jenkins project. I'm thinking about doing some quick "year in review" post
18:26:38 <kohsuke> Here's to hope that 2019 will up the game
18:26:44 <bitwiseman> +1
18:26:59 <kohsuke> On that note, happy Christmas and new year everyone. See you in 2019.
18:27:13 <kohsuke> #endmeeting