#jenkins-meeting Meeting

Meeting started by rtyler at 18:01:28 UTC (full logs).

Meeting summary

  1. Last meeting items (rtyler, 18:01:33)
  2. LTS status check (rtyler, 18:02:15)
    1. https://groups.google.com/forum/#!topic/jenkinsci-dev/Nnkr_2Kfz7E (oleg-nenashev, 18:03:23)
    2. agenda is here btw https://wiki.jenkins.io/display/JENKINS/Governance+Meeting+Agenda#GovernanceMeetingAgenda-January17thmeeting (rtyler, 18:07:13)

  3. JEP-200 status update / Q&A (rtyler, 18:07:24)
    1. we landed JEP-200 in 2.102 (oleg-nenashev, 18:07:45)
    2. It caused regressions, as expected: https://wiki.jenkins.io/display/JENKINS/Plugins+affected+by+fix+for+JEP-200 (oleg-nenashev, 18:07:59)
    3. https://github.com/jenkinsci/jep/tree/master/jep/200 (rtyler, 18:08:41)
    4. JEP-200 ETA in LTS is March 14 according to the current plans (if it gets accepted to LTS) (oleg-nenashev, 18:10:05)
    5. JEP-200 is switching of XStream/Remoting class filters from blacklist to whitelist (oleg-nenashev, 18:11:20)
    6. So, if a class is not in a plugin/core/module, it will be rejected if not whitelisted. Common examples: Java internal classes, 3rd-party libraries (Guava & Co) (oleg-nenashev, 18:12:11)
    7. https://github.com/jenkinsci/jenkins/blob/master/core/src/main/resources/jenkins/security/whitelisted-classes.txt got updated since 2.102. It could close some regressions in plugins not reported yet (oleg-nenashev, 18:13:17)
    8. Developer guidelines: https://jenkins.io/blog/2018/01/13/jep-200/#for-plugin-developers (oleg-nenashev, 18:20:44)
    9. JEP-200 includes a "warranty period". A team is investigating all reported issues and trying to fix them if possible. So far the "team" is oleg-nenashev and jglick (oleg-nenashev, 18:21:44)
    10. https://github.com/jenkinsci/ghprb-plugin/pull/616 (oleg-nenashev, 18:22:10)
    11. ACTION: oleg-nenashev to send a post-mortem doc once the dust settles (oleg-nenashev, 18:22:39)

  4. GSoC 2018: Discussion - Do we want to kick-it off (rtyler, 18:23:44)
    1. GSoC is the Google Summer of Code program (rtyler, 18:24:58)
    2. Call formentors: https://jenkins.io/blog/2018/01/06/gsoc2018-call-for-mentors/ (oleg-nenashev, 18:25:17)
    3. : https://docs.google.com/document/d/1q2p_XZEdbkcVDMpEPTtjPS15i2Oq3CQgH_geJjPhofY/edit#heading=h.iu2aqxlb7caw (oleg-nenashev, 18:26:40)
    4. Application deadline: January 23 (oleg-nenashev, 18:29:31)

  5. Request for mark usage, "JUC Paris" by JFrog (rtyler, 18:33:44)
    1. our trademark guidelines can be found here: https://jenkins.io/project/governance/#trademark (rtyler, 18:34:58)
    2. AGREED: Trademark sublicense granted to JFrog, Inc. for "Jenkins User Conference Paris" and "Jenkins User Conference Israel" (rtyler, 18:43:12)
    3. ACTION: rtyler to update the approved trademark usage wiki page (rtyler, 18:43:21)
    4. ACTION: alyssat_ to help JFrog understand our trademark guidelines :) (rtyler, 18:44:33)

  6. FOSDEM planning update (rtyler, 18:45:58)
    1. https://wiki.jenkins.io/display/JENKINS/FOSDEM+2018 (alyssat_, 18:46:06)
    2. please RSVP to the FOSDEM related events as soon as possible: https://www.meetup.com/jenkinsmeetup/ (rtyler, 18:51:37)
    3. ACTION: oleg-nenashev to add Demos section to the Wiki page (oleg-nenashev, 18:53:41)
    4. Jenkins contributors at FOSDEM, please bring and wear your squad t-shirts :P (rtyler, 18:54:55)
    5. ACTION: oleg-nenashev and markewaite to bring as much T-shorts as he can (oleg-nenashev, 18:57:04)

  7. Next meeting (rtyler, 18:57:47)
    1. the next meeting will be at 18:00 UTC ON January 31st (rtyler, 18:58:08)


Meeting ended at 18:58:20 UTC (full logs).

Action items

  1. oleg-nenashev to send a post-mortem doc once the dust settles
  2. rtyler to update the approved trademark usage wiki page
  3. alyssat_ to help JFrog understand our trademark guidelines :)
  4. oleg-nenashev to add Demos section to the Wiki page
  5. oleg-nenashev and markewaite to bring as much T-shorts as he can


Action items, by person

  1. alyssat_
    1. alyssat_ to help JFrog understand our trademark guidelines :)
  2. markewaite
    1. oleg-nenashev and markewaite to bring as much T-shorts as he can
  3. oleg-nenashev
    1. oleg-nenashev to send a post-mortem doc once the dust settles
    2. oleg-nenashev to add Demos section to the Wiki page
    3. oleg-nenashev and markewaite to bring as much T-shorts as he can
  4. rtyler
    1. rtyler to update the approved trademark usage wiki page


People present (lines said)

  1. rtyler (94)
  2. oleg-nenashev (83)
  3. alyssat_ (38)
  4. KatrinJFrog (29)
  5. samrocketman (14)
  6. markewaite (6)
  7. ogondza (5)
  8. andresrc (1)
  9. robobutler (1)
  10. jglick (1)


Generated by MeetBot 0.1.4.