#jenkins-meeting Meeting

Meeting started by danielbeck at 19:01:28 UTC (full logs).

Meeting summary

  1. Recap last meeting's actions (danielbeck, 19:02:08)
    1. http://meetings.jenkins-ci.org/jenkins-meeting/2015/jenkins-meeting.2015-12-09-19.01.html (danielbeck, 19:02:22)
    2. Governance document https://wiki.jenkins-ci.org/display/JENKINS/Governance+Document (rtyler, 19:03:21)
    3. Board election process https://wiki.jenkins-ci.org/display/JENKINS/Board+Election+Process (rtyler, 19:03:39)
    4. Code of Conduct https://wiki.jenkins-ci.org/display/JENKINS/Code+of+Conduct (rtyler, 19:04:30)

  2. LTS status check - discuss baseline change (danielbeck, 19:05:46)
    1. https://groups.google.com/forum/#!topic/jenkinsci-dev/K06ny0sozWM (danielbeck, 19:05:55)
    2. https://jenkins.ci.cloudbees.com/job/core/job/acceptance-test-harness-stable-1.642/1/console (ogondza, 19:07:38)
    3. https://github.com/jenkinsci/jenkins/tree/stable-1.636 but not found for 1.642? (batmat, 19:07:38)
    4. https://jenkins.ci.cloudbees.com/job/core/job/acceptance-test-harness-stable/549/console (ogondza, 19:07:42)
    5. https://github.com/jenkinsci/jenkins/compare/jenkins-1.642...jenkinsci:jenkins-1.643 FWIW (batmat, 19:16:04)
    6. AGREED: let's move the LTS baseline to 1.642 (danielbeck, 19:21:19)
    7. ACTION: ogondza to prepare the branch and inform KK that we need an RC (danielbeck, 19:21:43)

  3. Q1 Patron messages approval (danielbeck, 19:22:56)
    1. https://github.com/jenkinsci/patron/pull/8 (danielbeck, 19:23:02)
    2. https://wiki.jenkins-ci.org/display/JENKINS/Patron+of+Jenkins+program "Format of the patron message" paragraph 2 is the guidelines (danielbeck, 19:28:15)
    3. AGREED: Q1 patron messages are approved, JFrog needs to have 'Only' removed from title (danielbeck, 19:30:54)

  4. Review/adopt a Code of Conduct (danielbeck, 19:31:42)
  5. Q1 Patron messages approval (danielbeck, 19:31:54)
  6. Review/adopt a Code of Conduct (danielbeck, 19:34:12)
    1. Code of Conduct document here https://wiki.jenkins-ci.org/display/JENKINS/Code+of+Conduct (rtyler, 19:34:14)
    2. the only differences to the document from last meeting https://wiki.jenkins-ci.org/pages/diffpagesbyversion.action?pageId=84705386&selectedPageVersions=15&selectedPageVersions=13 (rtyler, 19:34:26)
    3. AGREED: the current version (v15) of the Code of Conduct document is approved (rtyler, 19:43:55)
    4. ACTION: rtyler to work to duplicate the CoC under jenkins-ci.org/conduct similar to golang.org/conduct (rtyler, 19:44:32)

  7. Discuss requiring pull requests for all non-release-process changes to core/master (danielbeck, 19:46:26)
  8. Review/adopt a Code of Conduct (danielbeck, 19:47:42)
    1. for the current topic: https://groups.google.com/d/topic/jenkinsci-dev/d64UIypbzh0/discussion (orrc, 19:49:19)

  9. Discuss requiring pull requests for all non-release-process changes to core/master (danielbeck, 19:49:43)
    1. https://groups.google.com/d/topic/jenkinsci-dev/d64UIypbzh0/discussion (danielbeck, 19:49:52)
    2. GitHub allows enforcing this via a concept called Protected Branches https://help.github.com/articles/defining-the-mergeability-of-pull-requests/ (rtyler, 19:51:28)
    3. https://help.github.com/articles/about-protected-branches/ (danielbeck, 19:58:25)
    4. https://help.github.com/articles/about-protected-branches/ (teilo, 20:01:09)
    5. ACTION: orrc to draft a proposal on the PR requirement (danielbeck, 20:06:58)

  10. Spam problems on wiki and possible solutions (rtyler, 20:07:15)
    1. rtyler formally recognizes larrys for his valor in the Great Spam Wars (rtyler, 20:08:14)
    2. confluence upgrade is tracked https://issues.jenkins-ci.org/browse/INFRA-325 (rtyler, 20:09:28)
    3. AGREED: account app to restricting signup to one email == one account (rtyler, 20:13:35)

  11. next meeting (danielbeck, 20:14:36)


Meeting ended at 20:15:13 UTC (full logs).

Action items

  1. ogondza to prepare the branch and inform KK that we need an RC
  2. rtyler to work to duplicate the CoC under jenkins-ci.org/conduct similar to golang.org/conduct
  3. orrc to draft a proposal on the PR requirement


Action items, by person

  1. ogondza
    1. ogondza to prepare the branch and inform KK that we need an RC
  2. orrc
    1. orrc to draft a proposal on the PR requirement
  3. rtyler
    1. rtyler to work to duplicate the CoC under jenkins-ci.org/conduct similar to golang.org/conduct


People present (lines said)

  1. rtyler (96)
  2. danielbeck (96)
  3. oleg-nenashev (33)
  4. KostyaSha (31)
  5. teilo (31)
  6. orrc (29)
  7. batmat (22)
  8. ogondza (17)
  9. larrys (17)
  10. jglick (5)
  11. alyssat (4)
  12. abayer (4)
  13. robobutler (2)


Generated by MeetBot 0.1.4.