19:00:08 <kohsuke> #startmeeting
19:00:08 <robobutler> Let the Jenkins meeting commence!
19:00:19 <kohsuke> #topic Recap last meeting's actions
19:00:33 <kohsuke> #chair rtyler danielbeck
19:00:33 <robobutler> Current chairs: danielbeck kohsuke rtyler
19:00:44 <kohsuke> Anything outstanding?
19:00:54 <rtyler> meeting actions? yeah
19:01:06 <rtyler> I believe abayer is out for the day
19:01:08 <rtyler> so I can speak to his
19:01:12 <rtyler> and then mine :P
19:01:18 <kohsuke> #info "kk to link the stickermule parameters/coordinates for stickers" -> https://wiki.jenkins-ci.org/display/JENKINS/Stickers
19:01:30 <rtyler> \o/
19:01:56 <rtyler> the single-transferrable-vote research on abayer's plate I'm fairly certain he hasn't gotten to yet, I hit him with a truck of work since last meeting :P
19:02:05 <rtyler> I'll harass/remind him about that next monday
19:02:31 <rtyler> I have some WEBSITE tickets tracking my previous requests for the static site
19:03:00 <kohsuke> #info https://issues.jenkins-ci.org/secure/RapidBoard.jspa?projectKey=WEBSITE&useStoredSettings=true&rapidView=1
19:03:04 <rtyler> the question of "non-story" content being imported outside of the /blog/ namespace is complete, as you can see here: http://jenkins.lasagna.io/content/jenkins-20-proposals/
19:03:34 <kohsuke> I LOVE THAT!!
19:03:37 <rtyler> the changelog is also being incorporated and part of the generated site: http://jenkins.lasagna.io/changelog/
19:04:23 <rtyler> I have not yet had the opportunity to evaluage our current apache configurations and redirects, but that's under https://issues.jenkins-ci.org/browse/WEBSITE-36
19:04:29 <rtyler> evaluate*
19:04:52 <rtyler> so the website work is definitely humming along, I pretty much have all the current dynamic content (latest version and changelog) being included when the page is generated
19:05:22 <kohsuke> great
19:05:28 <rtyler> the gaps right now, are WEBSITE-36, determining where to deploy it to (WEBSITE-38)
19:05:44 <rtyler> I do not yet have the continuous delivery pipeline running from the repository
19:05:58 <rtyler> #info the static site repo is here: https://github.com/jenkinsci/jenkins.io
19:06:14 <rtyler> I'm not sure if I had it done last meeting
19:06:22 <rtyler> but we own (well, technically I do) the jenkins.io domain
19:06:46 <rtyler> the current plan is to use that for the new version of the site, so the design you see on jenkins-ci.org will not ever be hosted under that domain
19:07:03 <rtyler> I will update in our next meeting where the "2.0" version of the site can be evaluated
19:07:33 <rtyler> the other action i had was: rtyler to update election proposal based on meeting
19:07:42 <rtyler> I have not done that yet, mea culpa
19:07:46 <rtyler> kohsuke: that's it
19:07:54 <kohsuke> #info we acquired jenkins.io
19:08:03 <kohsuke> Moving on...
19:08:18 <kohsuke> #topic LTS RC status check
19:08:31 <kohsuke> ogondza: ^^?
19:09:05 <kohsuke> hmm, he was around earlier
19:09:13 <ogondza> There is one issue stephenc asked me to backport
19:09:25 <kohsuke> oh, remoting 2.53.1 I assume
19:09:35 <ogondza> https://issues.jenkins-ci.org/browse/JENKINS-31718
19:09:51 <ogondza> exactly
19:10:00 <ogondza> Jesse seems to be +1 as well
19:10:30 <kohsuke> We don't want to make it a norm, as I understand your concern about this bypassing the process.
19:10:39 <danielbeck> jglick any input on this?
19:10:58 <teilo> +1 from me
19:11:24 <kohsuke> But in this case I think it's OK to allow this, given that (1) this is a regression and (2) the change in 2.53.1 is fairly safe.
19:11:25 <ogondza> well, I do not understand the problem/fix well enough to give my ack on that
19:11:52 <jglick> yeah I am +1 to put this in .3
19:12:07 <danielbeck> would doing a 2.52.1 without the random changes on master that were in 2.53 be feasible?
19:12:32 <ogondza> https://github.com/jenkinsci/jenkins/pull/1927 seems to be well received so far
19:12:34 <danielbeck> i.e. back out all that stuff to a version that worked + the security fixes from 1.625.2?
19:13:04 <teilo> danielbeck: backwards compatibility with people that have the new remoting?
19:13:22 <danielbeck> teilo isn't remoting (slave.jar) backwards compatible in both directions?
19:13:24 <kohsuke> ogondza: if you feel strongly, I respect your call as a LTS officer.
19:14:07 <ogondza> it seems to have enough +1s
19:14:09 <kohsuke> I don't want you to feel like we are forcing your hands
19:14:15 <jglick> danielbeck: that is also an option, though it means producing a remoting release that has not been through any testing yet, whereas 2.53.1 has gotten some hammering already
19:14:40 <ogondza> let me backport that
19:14:47 <kohsuke> OK, great.
19:14:48 <jglick> I also feel queasy about deleting protocol features in an LTS update. Yes we erred in *adding* them.
19:15:13 <kohsuke> danielbeck: do you have a problem going with 2.53.1?
19:15:52 <danielbeck> kohsuke No.
19:15:52 <kohsuke> #agreed pull in https://github.com/jenkinsci/jenkins/pull/1927 into 1.625.3. This isn't a norm, but an exception.
19:16:19 <kohsuke> ogondza: ping me when done so that I can post RC.
19:16:32 <kohsuke> or maybe I can just do that one fix
19:16:33 <ogondza> jglick: should I be around for the PR merge or will you cherry-pick that?
19:16:41 <ogondza> kohsuke: ^
19:17:00 <kohsuke> #action kohsuke to push JENKINS-31718 fix into stable-1.625 and post RC
19:17:07 <kohsuke> that'd be simpler
19:17:13 <kohsuke> I think we can move on...
19:17:16 <jglick> Sure.
19:17:26 <ogondza> thanks
19:17:30 <kohsuke> #topic Announce security officer
19:17:36 <rtyler> \o/
19:17:38 <kohsuke> floor is yours, rtyler
19:17:43 * rtyler moon walks
19:18:08 <rtyler> so a couple of weeks ago, on behalf of the board I sent out a request for candidates for the "Security Officer" position
19:18:11 <rtyler> (aka security team lead)
19:18:26 <kohsuke> (drum roll)
19:18:28 <rtyler> this was under the structure we approved last month: https://wiki.jenkins-ci.org/display/JENKINS/Proposal+-+Project+sub-teams
19:18:37 <rtyler> after thorough deliberation
19:18:40 <rtyler> the board
19:18:44 <rtyler> has decided
19:18:53 <rtyler> to punish danielbeck by naming him our first Security Officer
19:18:54 <rtyler> \o/
19:19:05 <kohsuke> http://www.ragefacecomics.com/faces/svg/misc-will-smith-tada.svg
19:19:05 <rtyler> #info Daniel Beck acting on the board's behalf as our first jenkins Security Officer
19:19:14 <rtyler> I have updated this page https://wiki.jenkins-ci.org/display/JENKINS/Governance+Board
19:19:34 <rtyler> this entitles danielbeck to make business cards and diamond necklaces that identify him as the Jenkins Security Officer
19:19:47 <rtyler> for a period of 12 months from now, unless he recuses himself from duty before that term is up
19:19:50 <danielbeck> name plate for my apartment door!
19:20:01 <kohsuke> thanks danielbeck
19:20:26 <rtyler> I have a late breaking topic to add on at the end if we're done with this
19:20:34 <kohsuke> I think we are done
19:20:38 <kohsuke> sure, ga
19:20:51 <rtyler> #topic Plugin hosting process follow-up
19:21:05 <rtyler> batmat had asked earlier for a followup or recap of where this proposal was
19:21:07 * kohsuke steps aside for biocall
19:21:26 <rtyler> as I remember, danielbeck you were exploring using JIRA to help organize this a bit better?
19:21:48 <danielbeck> rtyler Right… just need to get around to implementing it.
19:21:53 <danielbeck> Sorry about the delay
19:22:15 <rtyler> okay, so it's still on-going
19:22:18 <rtyler> that I think is enough
19:22:21 * kohsuke comes back
19:22:42 <rtyler> I think we can jump to next meeting now
19:22:47 <kohsuke> OK, so I think we are done.
19:22:50 <kohsuke> #topic next meeting
19:22:59 <kohsuke> Let's see, two weeks from now is...
19:23:08 <rtyler> Dec 9th
19:23:14 <kohsuke> #info next meeting is Dec 9th, the usual time
19:23:18 <rtyler> in that meeting I would like us to get the board election stuff hammered out
19:23:25 <rtyler> no foolin' around this time!
19:23:38 <rtyler> so i'll get my AIs done by then, and harangue abayer to do so as well
19:23:39 <kohsuke> ... especially if we are aiming for an election in the anniversary
19:23:45 <rtyler> righto
19:23:58 <kohsuke> OK, I think that's it. Happy Thanksgiving
19:24:06 <rtyler> #info dec 9th
19:24:10 <rtyler> oh you got it already
19:24:11 <kohsuke> ... says a Japanese who has no appreciation of that.
19:24:11 <rtyler> whoops
19:24:15 <kohsuke> #endmeeting