19:01:16 <kohsuke> #startmeeting
19:01:16 <robobutler> Let the Jenkins meeting commence!
19:01:20 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
19:01:34 <kohsuke> I see that CERT team meeting is running over
19:01:54 <kohsuke> #topic recap of actions
19:02:09 <kohsuke> #info I got stickers all ready
19:02:43 <kohsuke> and we just had finished the security roll out more or less
19:03:10 <danielbeck> kohsuke Kostya asked for some specifics about printing details on the events list so he can print some himself.
19:03:25 <rtyler> those should go on a wiki page if possible
19:03:31 <rtyler> info spof and all that jazz :)
19:03:46 <kohsuke> Okay, it's not like we care or dictate those things
19:04:02 <rtyler> it's useful to have guidelines though, in case community members want to make their own
19:04:29 <kohsuke> I can point to how I do things in Stickermule
19:04:38 <danielbeck> should be good enough
19:04:59 <kohsuke> #action kk to link the stickermule parameters/coordinates for stickers
19:05:08 <kohsuke> anything else before we move on?
19:05:13 <batmat> Btw, not sure it's the right time to ask: but organizing an event in the next few weeks, should I prefer print them by myself?
19:05:26 <batmat> or ask for someone to send to us? (JAM and another event)
19:05:46 <rtyler> from a practical standpoint it kind of depends on how fast we might be able to send them to your location
19:05:53 <kohsuke> if there's time we should be able to send them, right? Within the boundaries of CIA anda ll, right?
19:06:19 <kohsuke> maybe a conversation to be taken in the events list
19:06:29 <batmat> Ok, already asked on the events list, just wanted to check. Thanks
19:06:37 * rtyler nods
19:06:43 <kohsuke> #topic Review proposed www site change from Drupal to static site generation (current repo and generated version of site)
19:07:01 <kohsuke> #info http://jenkins.lasagna.io/
19:07:10 <oleg-nenashev> Is there a design doc for the change?
19:07:12 <kohsuke> #info the source is here: https://github.com/rtyler/jenkins.io
19:07:33 <rtyler> ah thanks
19:07:44 <abayer> So at this point, it's mainly just a change in how the site is generated, not in content or design, yes?
19:07:49 <rtyler> correct
19:08:00 <rtyler> the only thing missing is the changelog and download links in the sidebar, which I simply haven't added yet
19:08:00 <abayer> Then so long as it works, I see no issue.
19:08:09 <rtyler> that's already statically generated content on the primary www machine
19:08:11 <danielbeck> Well, there is this link at the bottom "improve this page" to Github :-)
19:08:13 <teilo> so the sites both look different atm
19:08:22 <rtyler> teilo: there's some slight differences
19:08:22 <oleg-nenashev> Would be great to see drafts of a plugin page and of an abstract blogpost
19:08:31 <kohsuke> are we trying to switch the production traffic?
19:08:31 <teilo> missing the jenkins 2.0 is a pretty biggy!
19:08:37 <rtyler> heh
19:08:44 <rtyler> teilo: that banner goes away at the end of this week anyways
19:08:46 <rtyler> anyway
19:09:08 <rtyler> the reason I wanted to bring this up isn't to discuss huge website changes per se, so much as a change in the structure here to move jenkins-ci.org over to this
19:09:25 <danielbeck> +1000
19:09:28 <rtyler> this doesn't contain any substantial changes from the existing site, but wijll give us tremendous flexibility to make changes in the coming months
19:09:28 <abayer> And, fwiw, the benefits are?
19:09:33 <rtyler> since it's all on githubv
19:09:46 <rtyler> which means the authorship isn't limited to who has drupal access
19:09:55 <oleg-nenashev> Pros: easy contribution, better change tracking
19:09:58 <rtyler> to be clear, there is *no pipeline* for making theme changes with drupal
19:09:59 <kohsuke> I think URLs like http://jenkins.lasagna.io/content/mailing-lists redirecting to http://jenkins.lasagna.io/blog/2010/05/31/mailing-lists/ is problematic
19:10:04 <oleg-nenashev> Cons: All kinds of performance issues
19:10:14 <kohsuke> it only makes the eventual redirection in 2.0 switch harder.
19:11:03 <abayer> Really? Performance issues? I'd've thought that Drupal -> static would be pretty much guaranteed better performance...
19:11:32 <kohsuke> Yes, I don't see how performance can degrade here
19:11:52 <oleg-nenashev> abayer kohsuke +/-. Drupal has caching of raw HTMLs
19:11:55 <rtyler> kohsuke: I think you're overemphasizing the impact of URL redirection
19:12:05 <batmat> oleg-nenashev: well, it's static vs. cache
19:12:12 <rtyler> it seriously doesn't matter in any objective metric other than "oh the URL doesn't look nice"
19:12:19 <batmat> hard time seeing why it would have less perfs
19:12:19 <rtyler> SEO doesn't change, accessibility doesn't change
19:12:46 <abayer> Will we need to have redirects from the Drupal URL and the new static URL in the 2.0 situation?
19:12:52 <kohsuke> http://www.w3.org/Provider/Style/URI.html
19:12:52 <rtyler> we should
19:12:59 <oleg-nenashev> In any case static sites can be easily scaled
19:14:16 <rtyler> none of the existing site content has been deleted or changed, it's all still accessible
19:14:33 <teilo> what about cache timeouts for when the site is updated?
19:14:51 <rtyler> those definitely go away with a static site :P
19:15:00 <kohsuke> I'm just saying when 2.0 moves the content around we need redirects from both the Drupal URLs like /content/mailing-lists and this temporary URL like /blog/2010/05/31/mailing-lists/
19:15:05 * rtyler sighs
19:15:14 <rtyler> dude, this isn't about 2.0
19:15:18 <rtyler> you're muddying the discussion
19:15:28 <rtyler> that's why I wanted to talk about this now
19:15:36 <abayer> Let's not think of what kk's referring to as "2.0" as much as "future-proofing URL stuffs".
19:15:38 <rtyler> I'm not saying I want to go re-org the whole bloody site
19:16:08 <rtyler> I'm saying, I am sick and tired of drupal, it's limit to contribution and I have a static site port ready to drop in
19:16:17 <abayer> So long as there's a consistent logic to the URLs, then any time we do a redesign/reorg/relayout/whatever of the URLs, it's easy enough to just keep the chain going.
19:16:21 <rtyler> building that jenkins <3 docker landing page was a tedious pain in the ass
19:16:42 <abayer> And it's not like we have a redonkulous amount of content to do redirects for in the first place.
19:17:09 <kohsuke> abayer: yeah, that's what I'm trying to say
19:17:35 <rtyler> I still don't understand your fear of redirects
19:17:39 <rtyler> that's literally why they exist
19:18:08 <rtyler> but again, not the point of the topic
19:18:21 <abayer> I think it's reasonable to carry generations of redirects around.
19:18:29 <abayer> The alternative is never changing your URL layout, which is a bit odd.
19:18:57 <rtyler> see also http://i0.kym-cdn.com/photos/images/facebook/000/251/010/5d5.jpg
19:19:06 <kohsuke> Maybe I lack appreciation on how hard it is control URLs for pages
19:19:18 <kohsuke> I thought it's pretty easy to have blog/2010/05/31/mailing-lists/ appear as /content/mailing-lists
19:19:37 <danielbeck> or *gasp* /mailing-lists
19:19:49 <kohsuke> and so I'm like, why don't we just do that so we save the trouble of creating two URLs
19:19:54 <rtyler> then /content/mailing-lists would still need to be a redirect to blog/2010/05/31/mailing-lists/
19:19:58 <rtyler> dude
19:20:07 <rtyler> those URLs have to be preserved
19:20:13 <rtyler> they're linked and archived in various forms throughout the internet
19:20:17 <abayer> Which ones?
19:20:23 <rtyler> *all* of them
19:20:36 <teilo> well redirect those with a moved permentant....
19:20:37 <danielbeck> rtyler To clarify, the canonical URL of every future page will be /blog/yyyy/mm/dd/${title} rather than something sane?
19:20:38 <abayer> Ok, so we're not talking about new URLs here, just the same ones and existing redirects.
19:20:42 <rtyler> 2010/05/31/mailing-lists a URL alias in drupal for /content/mailing-list
19:20:45 <kohsuke> I'm confused. http://jenkins-ci.org/blog/2010/05/31/mailing-lists/ doesn't exist today
19:20:45 <rtyler> danielbeck: no
19:20:49 <teilo> but the main pages in the site should never redirect
19:20:57 <hare_brain> I could have a bookmark of a blog entry on jenkins-ci.org. When the current site gets replaced with this new structure, my bookmark should be redirected to the same post on the new site.
19:21:03 <teilo> thats a sucky browsing experience on high latency lines
19:21:25 <hare_brain> Right?
19:21:40 <danielbeck> rtyler So maybe the question is why are non-story pages imported using /blog/ URLs, and is there an alternative to use the real URLs from the start?
19:21:44 <rtyler> kohsuke: that is correct, but /content/mailing-lists and /node/123 whatever does, those are what's being preserved
19:21:57 <rtyler> gagh this is so frustrating
19:22:19 <teilo> we should just have a nice 404 page
19:22:20 <danielbeck> FWIW I'm totally +1 for switching, even with these URLs
19:22:24 <teilo> and be done with it
19:22:36 <rtyler> so I understand the desire to have good URLs
19:22:48 <kohsuke> if rtyler and danielbeck are on the same page I don't want to a blocker
19:22:55 <rtyler> there's an implementation detail on how non-story type pages are being imported right now
19:23:20 <rtyler> I'm loathe to spend time adjusting the importer script at the outset because I have to run the importer script *every day* right now
19:23:24 <rtyler> to make sure i'm keeping sync
19:23:29 <abayer> My brain melted a little, so I'm just staying out of this. =)
19:23:31 <rtyler> I'm tired of running two forks of the same content
19:23:48 <rtyler> all I'm trying to do right now, is get to the point to where I don't have to fork *content*
19:23:51 <abayer> If it works and is maintainable, I'm indifferent.
19:23:57 <rtyler> or mirror redundant content rather
19:24:12 <teilo> well until the changelog and download links are correct its a blocker for me.
19:24:14 <rtyler> #action rtyler needs to ensure "non-story" content doesn't end up in the /blog/ namespace
19:24:28 <rtyler> teilo: agreed, that's part of the switchover, those files are dumped on the www host right now
19:24:33 <rtyler> so I can't really pull them in :/
19:24:54 <rtyler> #action rtyler needs to make site generate on cucumber so changelog content is incorporated
19:24:56 <teilo> rtyler: ok. so does this mean that the packaging scripts need to be updated?
19:25:03 <oleg-nenashev> I'm +1 for static hosting on GitHub, don't care about the technology beneath if it works reliably
19:25:22 <rtyler> teilo: jenkins.lasagna.io is just github pages, which is why I've not done this yet, don't want to give jenkins infra deploy keys to any of my personal erpos if I can avoid it :P
19:25:37 <rtyler> teilo: no, those changelog files are just generated as HTML chunks
19:25:49 <rtyler> so here's what I'm understanding
19:25:56 <kohsuke> telio: no, it's the site generation process that needs updating
19:25:57 <rtyler> 1. most people are either positive or indifferent to moving
19:26:11 <rtyler> 2. there's some more work that needs to be done to make sure everybody is happy
19:26:33 <rtyler> 3. so long as that work gets done, there are no objections to this work moving fowrard, provided the site is available, blah blah blah
19:26:45 <rtyler> is this an accurate summation?
19:26:46 <kohsuke> We are not using GitHub pages, right? It'll be still hosted on cucumber.
19:27:12 <kohsuke> Yes, I hink it's a good summary
19:27:19 <rtyler> kohsuke: I'd rather sweep that implementation detail under the carpet, haven't really done much work on that
19:27:25 <rtyler> there are benefits to hosting fully on GH pages
19:27:40 <rtyler> right now content must be generated on cucumber, it needn't be hosted there necessarily though
19:28:08 <rtyler> #info there is a WEBSITE project in issues.jenkins-ci.org which has more tickets and where you should go if you're interested in helping drive this forward
19:28:53 <rtyler> kohsuke: I think as we draw up more of a "new website plan" we'll have to cross the bridge of migrating content, or archiving content from the existing site
19:28:57 <rtyler> that's a discussion for another day though IMO
19:29:01 <rtyler> one I'm not ready to speak to
19:29:25 <kohsuke> You should also take a look at apache config file for jenkins-ci.org that has various extra redirects defined
19:29:42 <rtyler> ahh, good point
19:29:42 <kohsuke> rtyler: are you done? should we move on?
19:29:51 <rtyler> #action rtyler needs to example apache configs for redirects we might have in place there
19:29:56 <rtyler> yeah, let's jump to the CERT stuff
19:30:10 <kohsuke> #topic CERT membership requests from Ivan Meredith and Ben Walding
19:30:14 <danielbeck> https://groups.google.com/forum/#!msg/jenkinsci-dev/TachZG6zw44/UMBz91HMAgAJ
19:30:18 <danielbeck> https://groups.google.com/forum/#!msg/jenkinsci-dev/TachZG6zw44/v2sG6UvPAgAJ
19:31:00 <danielbeck> Both are CloudBees employees and run the hosted Jenkins there (DEV@cloud).
19:31:32 <danielbeck> Ben also has reported an issue, which we fixed today.
19:31:50 <rtyler> danielbeck: for #info where's the details on the cert team?
19:31:56 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+CERT+team
19:32:35 <kohsuke> I think their role in managing a large cluster of Jenkins masters make them qualified
19:32:56 <kohsuke> And they have vested interest in securing Jenkins, as can be seen by Ben's contribution
19:33:18 <kohsuke> Any objections/concerns/problems?
19:33:32 <kohsuke> Here's my +1
19:33:47 <rtyler> I don't object
19:34:10 <rtyler> kohsuke: do we maintain a list of current cert team members anywhere public?
19:34:14 <batmat> +1 for Ben knowing him a wee bit from Codehaus, no opinion for Ivan +0.
19:34:24 <danielbeck> rtyler Closed infra wiki has a list.
19:34:46 <rtyler> yeah, that doesn't really help people not already on the CERT team :P
19:35:08 <kohsuke> I think we can record blessing and move on
19:35:22 <oleg-nenashev> +1. Ben discovers much security issues + he really needs early access to test their stuff before the release. It's a win-win IMHO
19:35:36 <kohsuke> danielbeck: you are endorsing this, right?
19:35:46 <danielbeck> Of course. Those guys really want well tested fixes so they can help with that.
19:35:50 <kohsuke> so you have implicit +1
19:36:00 <danielbeck> Plus the trust is there through the role alone.
19:36:21 <kohsuke> #agreed Thanks Ben and Ivan for joining the CERT team
19:36:24 <kohsuke> moving on
19:36:34 <kohsuke> #topic Review Board Election Process Proposal and either move forward with the proposal or take feedback so we can have elections next year
19:36:46 <rtyler> yay
19:36:50 <rtyler> another tyler topic
19:36:50 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Board+Election+Process+Proposal
19:37:06 <kohsuke> it's great that this is moving forward
19:37:16 <abayer> Yeah - I gave up waiting for it. =)
19:37:27 <oleg-nenashev> I've added #4 according to my previous AI
19:38:05 <fredg02> the proposal looks good!
19:38:30 <rtyler> so this proposal is v7 of this page, I like it
19:38:32 <teilo> can we increase the 2 weeks for nominations (some people may be on holiday)
19:38:33 <kohsuke> I believe during the board meeting hare_brain rtyler and I wanted to propose one more change in that #4
19:39:02 <rtyler> kohsuke: the "kohsuke is a permanent member for life" thing? :P
19:39:03 <kohsuke> that is, instead of scheduling a new election out of cycle, the board will appoint a replacement
19:39:10 <rtyler> ah, that one
19:39:20 <kohsuke> so that the term and stuff are predictable
19:39:35 <rtyler> teilo: how long is long enough?
19:40:02 <teilo> 3 weeks is doog. 4 is better but that may stretch out the process a little too long?
19:40:06 <teilo> doog=good
19:40:07 <abayer> Yeah, I'd prefer an appointment for interim members.
19:40:31 <rtyler> I'll put three weeks in
19:40:40 <teilo> rtyler: thanks
19:40:51 <oleg-nenashev> kohsuke abayer: No strong opinion. Maybe better if the board gets approval on the governance meeting
19:40:52 <fredg02> kohsuke should be a BBMFL (Benevolent board member for life) :)
19:41:05 <rtyler> fredg02: I agree
19:41:18 <rtyler> a Jenkins board without kohsuke involved, unless he resigns, is silly
19:41:20 <rtyler> to me at elast
19:41:27 <oleg-nenashev> But in general I agree with such replacement proposal approach
19:41:37 <danielbeck> like anyone would ever get more votes than KK
19:41:52 <oleg-nenashev> +1 for promoting KK to KKK :P
19:41:56 <abayer> oleg-nenashev: Yeah, getting the blessing or at least lack of significant opposition from the governance meeting would make sense.
19:41:57 <rtyler> >_<
19:41:57 <abayer> Um.
19:42:01 <rtyler> heh
19:42:07 <rtyler> I'm guessing he means King KK
19:42:10 <rtyler> heh
19:42:25 <jieryn> lol
19:42:28 <danielbeck> How does STV work with quotas?
19:42:40 <danielbeck> And by quota I mean the company rule
19:42:46 <kohsuke> I'd love to have my permanent seat codified if people are OK.
19:42:51 <jieryn> oleg-nenashev, kkk is an extremist group here in usa, your statement is funny in that context :)
19:42:57 <teilo> +1 for KKK
19:43:00 <rtyler> lulz
19:43:07 <hare_brain> oleg-nenashev are you proposing approving board *nominees* in governance meeting, or using the governance meeting as the election forum?
19:43:10 <rtyler> okay, I'm going to update the proposal suggesting a permanent seat
19:43:14 <abayer> I'd say if too many people from one company get elected, then the highest placing two of them get on and the others are disqualified.
19:43:19 <hare_brain> The latter seems to go against the voting proposal entirely.
19:43:21 <teilo> so cloudbees can have a max of one other person on the board.
19:43:22 <abayer> hare_brain: We're talking about the replacements.
19:43:25 <danielbeck> abayer And how do you do this in mid-STV?
19:43:38 <hare_brain> abayer thank
19:43:44 <oleg-nenashev> hare_brain: only governance meeting for replacement
19:43:47 <danielbeck> abayer https://en.wikipedia.org/wiki/Single_transferable_vote
19:43:58 <rtyler> alright v9 of the document updated with King Kohsuke item
19:44:04 <abayer> danielbeck: I'd have to check the details for exactly how that works out, but I know it's doable.
19:44:19 <danielbeck> abayer Okay, great. Could you look that up?
19:44:27 <abayer> Hit me with an action.
19:44:37 <oleg-nenashev> jieryn: Don't forget to exclude IS operator from C# and Python ;)
19:44:53 <danielbeck> #action abayer to look up how to do STV with company rule (item 4)
19:44:53 <kohsuke> #action abayer to look into implication of having the company quota with STV
19:45:04 <kohsuke> So do it twice please, abayer
19:45:05 <teilo> so for companies are you voting for the company or a person from that company?
19:45:08 <danielbeck> LOL
19:45:10 <rtyler> heh
19:45:24 <abayer> I'll look up how to do it *and* look into implications.
19:45:28 <rtyler> this is great, I didn't want to necessarily get things signed off on this meeting, but at least forward momentum
19:45:44 <kohsuke> teilo: we'll be voting for human beings, not legal entities
19:45:47 <rtyler> in our next governance meeting I would like to get approval on a proposal so we can schedule election day for Feb 2nd 2016
19:45:49 <oleg-nenashev> Who will make changes in #4 and add #7 for KKK?
19:45:54 <abayer> Stop saying KKK!
19:45:57 * rtyler is a human bean
19:45:58 <abayer> =)
19:46:15 <abayer> And I personally will be voting for ephemeral concepts, not human beings.
19:46:18 <teilo> oleg-nenashev: KKK has been done
19:46:28 <abayer> Gaaaaaaaah
19:46:30 <abayer> No KKK!
19:46:31 * rtyler facepalms
19:46:33 <teilo> in #1
19:46:33 <abayer> No Grand Wizards!
19:46:39 <kohsuke> Guys, we already got dumb slaves going against us, please no KKK
19:46:41 <oleg-nenashev> Ok. #7 for permanent board member
19:47:14 <teilo> oleg-nenashev: thats in #1 "Kohsuke Kawaguchi holding a permanent board seat until such a time he decides to resign."
19:47:29 <danielbeck> "You earn the voting right by having an account on jenkins-ci.org prior to the last election." --- so I am not allowed to vote?
19:47:31 <oleg-nenashev> +1 for such wording of #7
19:47:42 <Mark_______> Hello
19:48:08 <kohsuke> Let's just say last election is when interim board has happened
19:48:10 <rtyler> danielbeck: we should probably put something in there to make it clearer for this first time
19:48:17 <rtyler> kohsuke: that was years ago!
19:48:28 <danielbeck> kohsuke I registered in 2011 or so, after the interim board.
19:48:30 <rtyler> why don't we just say for the first election at teh end of this calendar year?
19:48:44 <teilo> as elections are every year, why not say for more than 1 year at the time of the election
19:48:45 <kohsuke> oh oh, sorry, I didn't read too carefully
19:48:51 <hare_brain> Or people who are registered at the formal adoption of this process.
19:49:03 <rtyler> hare_brain: +1
19:49:09 <kohsuke> +1
19:49:13 <fredg02> +1
19:49:15 <danielbeck> +1
19:49:21 <danielbeck> (Just want to vote!)
19:49:21 <oleg-nenashev> +1
19:49:27 <abayer> +cats
19:49:41 <kohsuke> rtyler: you said you are not seeking the blessing of this today.
19:49:48 <kohsuke> Does that mean we should move on?
19:49:50 <kohsuke> Anything else on this?
19:50:01 <fredg02> as long as the formal adoption is before election day
19:50:03 <oleg-nenashev> LTS beer party? :)
19:50:10 <danielbeck> #action rtyler to update election proposal based on meeting
19:50:19 <rtyler> heh
19:50:28 <rtyler> kohsuke: yeah, this is enough progress for now
19:50:28 <kohsuke> I'm all for the security roll out beer party man
19:50:38 <rtyler> Ill seek blessing at the next meeting
19:50:41 <kohsuke> #topic Jenkins 2.0 proposal recap
19:50:56 <rtyler> let me dig up a link
19:51:06 <rtyler> #info http://jenkins-ci.org/content/jenkins-20-proposals
19:51:22 <abayer> *flees*
19:51:27 <rtyler> I published a few blog posts highlighting some fairly important proposals
19:51:40 <rtyler> I suggested a feedback window to jump into the JIRAs of a couple weeks
19:51:48 <rtyler> so we can get goin' already!
19:52:02 <rtyler> the last suggested feedback window will be over on friday
19:52:10 <kohsuke> OK
19:52:20 <kohsuke> Great
19:52:29 <rtyler> I put this on the agenda mostly because I wanted to say "hey y'all, let's build a thing already"
19:52:38 <kohsuke> I'd love to get the symbolic 2.0 branch created
19:52:51 <oleg-nenashev> +1
19:52:54 <kohsuke> setting up builds and all that
19:52:56 <rtyler> that's what all branches are in git :P
19:53:11 <oleg-nenashev> kohsuke: Are UX changes ready for 2.0 branch?
19:53:15 <kohsuke> I mean symbloic to humans?
19:53:19 <rtyler> heh
19:53:27 <kohsuke> oleg-nenashev: some of them are, more work to come
19:53:39 <abayer> https://en.wikipedia.org/wiki/Symbolics?
19:53:39 <rtyler> I'm +1 on getting the 2.0 branch, can we nominate somebody to be release manager for it like we do for LTS?
19:53:42 <rtyler> that way it's merged up
19:53:45 <rtyler> and refreshed, etc
19:54:00 <abayer> +1 to having a RM.
19:54:12 * kohsuke looks at danielbeck
19:54:23 <abayer> *also looks at danielbeck*
19:54:26 <rtyler> I would nominate abayer but I think working with me full time will be punishment enough
19:54:29 <danielbeck> whaat?
19:54:32 <abayer> Also I am a terrible RM.
19:54:48 <rtyler> heh
19:55:15 <kohsuke> or is this where we should nominate product management kind of person?
19:55:16 <abayer> If someone else wants to step up, that'd be great, but danielbeck as fallback seems reasonable. =)
19:55:18 <rtyler> we don't need to figure out an RM in this meeting necessarily, but I would love to see somebody on point
19:55:31 <kohsuke> for SPOF reasons I'll be still the human function that produces signed bits
19:55:34 <rtyler> kohsuke: I see it much closer to the LTS owner role, somebody to play traffic cop a bit
19:56:46 <abayer> I'd suggest we email the list and see if anyone else is interested.
19:56:52 <rtyler> I'm not sure a product management role makes as much sense, since there's some execution oriented responsibilities to make sure that things are getting merged in cleanly/correctly/etc
19:57:00 <rtyler> I'm cool with that idea abayer
19:57:05 <abayer> And then make danielbeck do it anyway.
19:57:08 <rtyler> 1, 2, 3 NOT IT
19:57:18 <abayer> I don't do emails.
19:57:26 <abayer> *looks at danielbeck again* =)
19:57:33 <abayer> *then looks at kohsuke instead*
19:57:46 <danielbeck> If I volunteer, would that move the conversation along?
19:57:53 <kohsuke> I think so.
19:57:55 <rtyler> I don't think repeatedly claiming to not want to do it is useful :P
19:58:05 <kohsuke> Or that.
19:58:17 <rtyler> until you pass off the responsibilities I'm fine with you taking point initially danielbeck
19:58:20 <rtyler> get things started
19:58:24 <danielbeck> sure
19:58:44 <kohsuke> #agreed danielbeck is appointed as 2.0 release manager
19:58:48 <kohsuke> moving on...
19:58:57 <kohsuke> #topic next meeting
19:59:17 <kohsuke> Nov 25th the same time
19:59:22 <rtyler> two weeks from now is pretty close to thanksgiving
19:59:26 <hare_brain> Yeah
19:59:26 <abayer> Yeah.
19:59:33 <abayer> Lots of Americans will be in transit.
19:59:38 <rtyler> I know lots of folks take wednesday off to travel
19:59:39 <abayer> Or leaving work early, etc.
19:59:47 <hare_brain> I'll be in the kitchen.
19:59:48 <abayer> Or hacking for Tyler. =)
19:59:50 <rtyler> could we do dec 2nd?
19:59:53 <abayer> +1
20:00:02 <danielbeck> That'll also mess up our LTS schedule.
20:00:05 <kohsuke> Historically we stuck to 2 week cadence
20:00:06 <hare_brain> What did we do last year?
20:00:20 <abayer> We probably forgot to have a meeting.
20:00:23 <hare_brain> I think we just skipped if a date doesn't work out.
20:00:29 <rtyler> nah, we did
20:00:30 <kohsuke> When we skip, the next one will be 4 weeks away
20:00:33 <rtyler> https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Archive+2014
20:00:55 <rtyler> we can try to do the meeting, but I'm loathe to put the board election proposal up for final signoff if the attendance is paltry
20:01:11 <danielbeck> Then skip that item if nobody's present.
20:01:22 <kohsuke> Can we meet if just to get LTS status check
20:01:42 <rtyler> would it be possible to just do the LTS status check on the 25th and a full meeting on the 2nd perhaps?
20:01:48 <rtyler> best of both worlds, more meetings!
20:01:52 <kohsuke> slackers can skip, but hard-working Americans are welcome to stick around
20:02:03 <rtyler> lulz
20:02:14 <danielbeck> rtyler And the next meeting on Dec 9 then?
20:02:21 <abayer> Let's just never stop meeting.
20:02:45 * rtyler shrugs
20:02:48 <danielbeck> rtyler Also, for the other week, remember we want office hours to happen
20:02:50 <rtyler> fuck it let's do the 25th
20:02:51 <danielbeck> same time
20:02:51 <hare_brain> OK, 11/25
20:03:10 <kohsuke> #agreed we'll stick next meeting being 11/25
20:03:21 <kohsuke> will hope to keep the agenda light
20:03:28 <kohsuke> I think that's it
20:03:29 <rtyler> well, I'm going to have beefy topics :)
20:03:41 <rtyler> thanks everybody for joining today though
20:03:48 * rtyler jumps back to #jenkins and #jenkins-community
20:03:48 <abayer> Not turkey topics?
20:03:50 <kohsuke> and helping the release out
20:04:00 <kohsuke> #endmeeting