18:00:44 <kohsuke> #startmeeting
18:00:44 <robobutler> Let the Jenkins meeting commence!
18:00:51 <kohsuke> #charis rtyler  hare_brain danielbeck
18:01:00 <kohsuke> #chairs rtyler hare_brain danielbeck
18:01:08 <kohsuke> #chair rtyler hare_brain danielbeck
18:01:08 <robobutler> Current chairs: danielbeck hare_brain kohsuke rtyler
18:01:10 <kohsuke> There
18:01:20 <kohsuke> #topic Recap last meeting's actions
18:01:56 <danielbeck> I wrote an overdue wiki page and made up the rules for it: https://wiki.jenkins-ci.org/display/JENKINS/Rewards+for+reporting+security+issues
18:02:28 <danielbeck> It was a meeting action from ~February or so
18:02:45 <kohsuke> LGTM
18:02:52 <danielbeck> That's it from me
18:03:13 <danielbeck> (Oh, and fork requests are still via mailing list, Jira project is still WIP)
18:03:50 <kohsuke> Now that we have the JIRA agile set up, maybe this is a good opportunity to revive the MEETING project
18:04:07 <kohsuke> #topic LTS status check
18:04:29 <ogondza> kohsuke: once https://jenkins.ci.cloudbees.com/job/core/job/jenkins_lts_branch/155/ is happy, we are ready for RC
18:04:33 <kohsuke> danielbeck: actually, can you run the meeting? I'm in a meeting and multi-tasking here
18:04:38 <danielbeck> kohsuke can do
18:04:50 <kohsuke> ogondza: great!
18:04:53 <kohsuke> danielbeck: thanks
18:05:03 <danielbeck> kohsuke Don't close the laptop, there's two items from you
18:05:18 <kohsuke> yes
18:06:03 <danielbeck> ogondza So you expect that build to be successful, and once it is, KK can post the RC, and you'll post the testing wiki pages?
18:06:24 <ogondza> danielbeck: I will this time, I promise
18:06:56 <ogondza> there was a ;at minute backport, but I expect it to succeed
18:07:01 <kohsuke> Got it. I'll check back in an hour or so and start RC
18:07:15 <danielbeck> ogondza Which one was that?
18:07:19 <ogondza> *last
18:07:33 <ogondza> https://issues.jenkins-ci.org/browse/JENKINS-10629
18:08:09 <danielbeck> \o/
18:08:17 <danielbeck> awesome thanks!
18:08:30 <oleg-nenashev> That guy also contained lib updates, but it should be safe enough
18:08:35 <danielbeck> anything that was refused?
18:08:42 <ogondza> nope
18:08:56 <ogondza> I will update the ML
18:09:02 <danielbeck> great
18:09:20 <danielbeck> #topic Proposal - Revisiting JUC in 2016
18:09:27 <danielbeck> https://wiki.jenkins-ci.org/display/JENKINS/Proposal+-+Revisiting+JUC+in+2016
18:09:44 <danielbeck> kohsuke ^ your topic
18:10:02 <kohsuke> Right
18:10:21 <kohsuke> So there was a round of conversatiosn about this in the ML
18:10:45 <kohsuke> I've seen some sentiment for losing a big European event,
18:10:53 <kohsuke> but otherwise people generally seem to be OK with the concept
18:11:00 <danielbeck> #info https://groups.google.com/forum/#!msg/jenkinsci-dev/YGEGjYvRzfs/fPRPUg41CwAJ
18:11:04 <kohsuke> ... presumably including the name as well
18:11:20 <teilo> (a collection of butlers is a sneer)
18:11:59 <oleg-nenashev> kohsuke: Does CB owns the Jenkins User Conference brand? Technically, could it be granted to another conference like JCPH?
18:13:16 <oleg-nenashev> I don't see much reasons to kill such format till there re relatively big conferences in Europe
18:13:40 <danielbeck> alyssat This may be interesting for you as well
18:14:33 <danielbeck> oleg-nenashev If you look at the proposal, there's CloudBees-Jenkins Summit
18:14:39 <kohsuke> oleg-nenashev: nobody owns any name aside from SPI owning Jenkins mark
18:14:53 <danielbeck> They're not a lot smaller than the European JUCes we had AFAICT
18:15:16 <kohsuke> but no one is stepping up to offer doing JUC in Europe right now, so the conversation about whether that's being killed or not seems little hypothetical to me
18:16:01 <danielbeck> Right, and Praqma is using the 'JUES' name anyway, at least so far.
18:16:11 <kohsuke> Any further thoughts on the events?
18:16:33 <kohsuke> Ideally I'd like to record that this plan is acknowledged & blessed.
18:16:52 <oleg-nenashev> No. Jenkins World should be good enough. +1
18:17:17 <oleg-nenashev> It does not mean I 100% support it from a community member perspective
18:17:17 <teilo> sounds like a theme park :-P
18:17:29 <kohsuke> It should be!
18:17:50 * rtyler jumps in
18:18:26 <rtyler> kohsuke: fwiw I like the proposal that is linked from the agenda
18:18:40 <rtyler> I'm happy that CB is willing to invest in a full community track
18:19:12 <kohsuke> Any more +1/-1 ?
18:19:21 <rtyler> PLUS INFINITY
18:19:38 <kohsuke> I'm excited to be able to bring the whole community around the globe to one place
18:19:39 <rtyler> as long as it's in california, or some place fun like big sur :P
18:19:44 <rtyler> montana maybe :P
18:19:54 <kohsuke> We should be able to do some interesting contributor event, etc
18:19:54 <oleg-nenashev> rtyler sponsors his Infinity to Jenkins community. Cool, we will send him a T-short :D
18:19:55 * rtyler wants to vacation in jenkinsworld
18:20:52 <danielbeck> Yep, while there's only a single very large conference left, there's a pretty big travel grant
18:21:05 * rtyler nods
18:21:30 <oleg-nenashev> Should be enough to pay for the hotel...
18:21:40 <kohsuke> should we move on?
18:21:43 * rtyler shrugs
18:21:44 <rtyler> sure
18:22:15 <danielbeck> rtyler's plus infinity beats everything, so no +1/-1 are coming
18:22:21 <rtyler> heh
18:22:42 <rtyler> danielbeck: https://twitter.com/agentdero/status/650709702238597120
18:22:43 <rtyler> xD
18:23:09 <rtyler> kohsuke: sticker time?
18:23:30 <danielbeck> #topic Sticker purchase approval
18:23:33 <kohsuke> #agreed not much active discussion about the events, but I think people are OK
18:23:34 <kohsuke> oops
18:23:39 <kohsuke> stickers
18:23:51 <kohsuke> so I run out of all the stickers a while ago mostly in JUC
18:24:04 <oleg-nenashev> +1 for stickers
18:24:09 <kohsuke> In preparation for FOSDEM, SCaLE, and 2016 I need more
18:24:23 <danielbeck> Nobody here can even imagine how popular the 'angry Jenkins' stickers are, it's insane
18:24:29 <kohsuke> I'm planning to make 500 of all 6 kinds, and maybe another 1000 of the standard sticker
18:24:31 <danielbeck> Clearly, people don't see that one often enough
18:24:52 <kohsuke> Should cost $1.5K
18:25:02 <rtyler> kohsuke: does it get any cheaper to get more stickers?
18:25:03 <danielbeck> kohsuke Is 500 each going to be enough?
18:25:09 <rtyler> like why 1000 instead of 2000?
18:25:14 <rtyler> it's not like the logo changes :P
18:25:32 <kohsuke> That's true
18:25:36 <kohsuke> Should I just get more?
18:25:47 <danielbeck> yes, it's terrible to run out
18:25:53 <rtyler> I guarantee we will go thorugh nearly almost all of the 500 sets
18:26:00 <oleg-nenashev> Why not? How much $$$ do we have in reserve?
18:26:00 <rtyler> maybe before the end of the fosdem
18:26:00 <kohsuke> OK, then I can like double them
18:26:08 <rtyler> good question oleg-nenashev
18:26:12 <danielbeck> 500 sounds a lot like 0 after two days.
18:26:13 <kohsuke> We have enough money in the bank to buy a cheap car right now
18:26:16 <danielbeck> oleg-nenashev 20k+
18:26:23 <orrc> do the JAMs get stickets sent to them?
18:26:32 <rtyler> yeah
18:26:34 <oleg-nenashev> We can order a truck of stickers....
18:26:53 <rtyler> hah
18:27:02 <rtyler> JENKINS TESLA
18:27:19 <kohsuke> danielbeck: I feel like I have a blessing to move forward
18:27:36 <danielbeck> kohsuke How many are you planning to buy now?
18:27:37 <rtyler> kohsuke: double the standard, I'd leave the others the same
18:27:58 <KostyaSha> with wood wheels
18:28:01 <rtyler> the 6-jenkins' should be more special, we can make it so we give them out in smaller special batches at FOSDEM
18:28:13 <kohsuke> ok
18:28:30 <rtyler> we can make a quota for those at FOSDEM and build up excitement around them
18:28:40 <oleg-nenashev> Would be cool to have a new Jenkins 2.0 sticker...
18:28:44 <rtyler> like at the top of the hour we do a 2.0 nightly demo and give out those stickers
18:29:02 <danielbeck> rtyler You're evil, I like it. Make people work for them!
18:29:09 <kohsuke> oleg-nenashev: 2.0 sticker would a be a great idea
18:29:19 <rtyler> danielbeck: I've learned a lot from alyssat and heidi :P
18:29:53 <rtyler> oleg-nenashev: we will have some other special materials around jenkins 2.0
18:30:04 <rtyler> but I'll see if there's anything I can rustle up for a "special editoin"
18:30:07 <rtyler> separate from this meeting
18:30:08 <kohsuke> danielbeck: back to you, Mr.Chair
18:30:14 * kohsuke sneaks out
18:31:06 <danielbeck> rtyler Do we need a vote?
18:31:07 <oleg-nenashev> Ehh, Hudson became too old: http://www.dreamstime.com/stock-photography-butler-image25112082
18:31:10 <rtyler> danielbeck: FOR WHICH?
18:31:18 <danielbeck> sticker buying
18:31:25 <rtyler> er, sorry about the caps
18:31:34 <rtyler> danielbeck: I don't think so, no large dissent here
18:31:41 <danielbeck> Right, everyone loves stickers
18:31:53 <rtyler> heh
18:31:59 <danielbeck> #agreed kohsuke to buy stickers for 2016. A lot of stickers.
18:32:17 <danielbeck> #topic Should we require squashing commits in the core?
18:32:21 <danielbeck> oleg-nenashev
18:32:34 <danielbeck> #info https://groups.google.com/forum/#!searchin/jenkinsci-dev/squash/jenkinsci-dev/kqvuDqXwPZw/oF-KMdNbCwAJ
18:32:39 <oleg-nenashev> Шеэы ф ащддщц-гз ещ https://groups.google.com/forum/#!searchin/jenkinsci-dev/squash/jenkinsci-dev/kqvuDqXwPZw/oF-KMdNbCwAJ
18:32:43 <oleg-nenashev> sorry
18:32:50 <oleg-nenashev> *It's a follow-up
18:33:13 <kohsuke> Personally, I hate making those things a rule for us
18:33:32 <kohsuke> in a project like this, we all need to tolerate other people's tastes: https://en.wikipedia.org/wiki/Robustness_principle
18:33:33 <oleg-nenashev> BTW we need to agree on the common approach
18:33:34 <danielbeck> FWIW jglick has good counter arguments
18:33:50 <KostyaSha> oleg-nenashev, пышь-пышь
18:34:06 <rtyler> english only please :)
18:34:23 <KostyaSha> rtyler, joke to his wrong keyboard)
18:34:40 * rtyler shrugs
18:34:49 <oleg-nenashev> If we don't squash, then OK. If we squash, then it should be a practice for all merges to make a value
18:35:55 <ogondza> I do not like to squash every PR into single commit
18:35:56 <teilo> oleg disagree with forcing a sqaush
18:36:13 <rtyler> oleg-nenashev: are there existing commit guidelines?
18:36:16 <teilo> a test and fix could be two separate commits in one PR and having the test separate is golden
18:36:26 <rtyler> this comes to mind for me http://tbaggery.com/2008/04/19/a-note-about-git-commit-messages.html
18:36:40 <KostyaSha> ogondza, multiple times everybody already said that squashing all doesn't make sense, people just want to see every commit as normal change and not tones of "fix style"
18:36:48 <oleg-nenashev> I propose to perform squashes for non-sensitive commits. I don't propose 1 PR = 1 commit rule
18:36:57 <KostyaSha> ogondza, commit should be logically ended
18:37:20 <ogondza> How about adding something like "maintain meaningful commit history" and request authors to rearrange
18:37:33 <oleg-nenashev> Or to do it during the merge
18:37:35 <ogondza> adding it to contribution guidelines ^
18:37:59 <jglick> Then you are forcing contributors to deal with `git rebase -i` madness.
18:37:59 <KostyaSha> ogondza, that's what we initially proposed, but stephenc wants keeping all commits even 30 styling changes commits
18:38:24 <KostyaSha> jglick, you enforce contributors dealing with 10y old code, rearrange PR is 1 min of work
18:38:59 <oleg-nenashev> Persons who merge PRs may perform re-arrange on their own. Or autommate the work in simple cases
18:39:01 <KostyaSha> jglick, not you directly, but project
18:39:38 <jglick> Well this is just going to be a flamewar and using IRC is not going to make it any better. I have stated my position and arguments, as have others, so someone in authority should just make a decision.
18:39:38 <kohsuke> One of the motivation for Jenkins for me is to be against code policing
18:40:03 <KostyaSha> kohsuke, you don't process any PRs last 2 years
18:40:05 <oleg-nenashev> jglick: So the agenda topic was "voting"
18:40:15 <kohsuke> I contributed in the past to some project that enforces checkstyle rules that limited me to a method length of 30 lines, etc., and I hate those
18:40:24 <jglick> Well who has a vote, and what are the candidates?
18:40:37 <KostyaSha> jglick, interesting question
18:40:49 <oleg-nenashev> Every meeting attendee has a vote
18:41:13 <oleg-nenashev> 1) Not squash commits at all
18:41:13 <oleg-nenashev> 2) Agree on a policy to prevent the history pollution
18:41:13 <kohsuke> For a project to successfully accomodate lots of contributors each working little time, we need to be lax about these things, even if it has some associated downsides
18:41:17 <KostyaSha> jglick, let's start with statement that stephenc wants: "Don't chnage commits in PR"
18:41:57 <danielbeck> kohsuke What about the argument that overly lax rules turn some people away as it looks like uncontrolled chaos?
18:42:18 <KostyaSha> kohsuke, frankly speaking i have tones of feedbacks how people hates your code and style :)
18:42:28 <kohsuke> I don't think our lack of rule about squashing the commit is one o fthem
18:42:36 <KostyaSha> kohsuke, and all this people run away from jenkins
18:42:55 * KostyaSha just a fact
18:43:18 <oleg-nenashev> Any project should have a feasible amount of rules and common practices
18:43:21 <kohsuke> I don't know, I consider it pretty successful that we have this many people contributed so far
18:43:42 <orrc> I hate redundant commits in PRs, but I can't imagine that people are "running away" due to unsquashed commits. weird code style or bad documentation, perhaps, but unsquashed commits..?
18:44:01 * rtyler agrees
18:44:03 <danielbeck> How about we encourage squashing once the number of commits hits two digits?
18:44:13 <KostyaSha> orrc, today there is a mix of normal commits and unsquashed = trashed
18:44:16 <danielbeck> I mean if a PR has 4 commits, how harmful can that possibly be?
18:44:33 <KostyaSha> orrc, so to dig history you forced jumping between -m1 parent flags and showing all commits
18:44:42 <oleg-nenashev> As a Jenkins instance maintainer, I used GitHub a lot to navigate changes and select useful ones for backporting into my internal fork
18:45:01 <KostyaSha> orrc, it was not a problem because before last years all PRs was good and logically separated
18:45:02 * rtyler runs off
18:45:14 <KostyaSha> orrc, as soon ad CB started fast development, they started merging PRs as is
18:45:36 <KostyaSha> orrc, this mades commit history hardly researchable
18:45:50 <oleg-nenashev> I have to abstain regarding the comment above
18:46:08 <KostyaSha> arguments about github ui - wait for future features, develop git browsing tools...
18:46:37 <KostyaSha> so i can suggest try discuss it by steps
18:47:00 <KostyaSha> 1) Stephenc wants keep PR as is that doesn't allow picking PR for somebodies fixuping
18:47:04 <KostyaSha> + -?
18:47:30 <oleg-nenashev> 1) Not squash commits at all
18:47:30 <oleg-nenashev> 2) Agree on a policy to prevent the history pollution
18:47:45 <KostyaSha> i see a problem that many useful PRs authors keeping without answers and we need end them manually
18:47:55 <oleg-nenashev> ^^^ I propose to vote for the bullets above
18:47:57 <KostyaSha> so i'm -1 for this point
18:48:08 <oleg-nenashev> ================
18:48:33 <teilo> -1 on both option 1 and option 2
18:48:51 <oleg-nenashev> teilo: And what do you propose?
18:48:54 <danielbeck> It doesn't look to me like this is even remotely ready for voting on it.
18:49:00 <teilo> recomendations to PR authors
18:49:18 <danielbeck> This is missing an actual proposal that addresses concerns etc.
18:49:23 <KostyaSha> danielbeck, i think this discussion mostly depends on kohsuke as he always do veto on any proposals
18:49:27 <oleg-nenashev> I would propose to develop recommendations for PR reviewers
18:49:49 <teilo> oleg-nenashev: should exist for PR authors
18:50:02 <teilo> aswel
18:50:21 <oleg-nenashev> agreed
18:50:23 <KostyaSha> danielbeck, as kohsuke has only 1 hour a two weeks and very busy, we should provide our opinion to him here
18:50:37 <KostyaSha> and hope to some resolution :)
18:51:11 <oleg-nenashev> It should be agreement within jenkinsci/core
18:51:33 <oleg-nenashev> There is no need to have a dictator in such topics
18:51:49 <oleg-nenashev> KostyaSha: So your point is invalid IMO
18:52:20 <KostyaSha> oleg-nenashev, what point? what stephenc wants? it not my point :) just trying to extract logical statements from email thread
18:53:11 <oleg-nenashev> If we don't vote now, what are the action items?
18:53:41 <oleg-nenashev> I can propose recommendations, but I'll likely get a push-back from kohsuke, stephenc and jglick
18:53:43 <KostyaSha> if we can't vote and email thread has no final solution - what actions expected from this meeting?
18:53:55 <danielbeck> oleg-nenashev Write a coherent proposal and solicit feedback on it. Seems to be right now that opinions are too far apart and concerns not addressed.
18:54:26 <KostyaSha> danielbeck, he wrote proposal in email thread
18:54:37 <KostyaSha> danielbeck, and everybody provided feedback
18:54:37 <danielbeck> he, Oleg?
18:55:02 <KostyaSha> danielbeck, yes, he even showed a tool for squashing :)
18:55:25 <oleg-nenashev> Nt a tool
18:55:39 <oleg-nenashev> Just an aux utility for primitive cases
18:56:13 <KostyaSha> ogondza, what is your opinion?
18:56:30 <oleg-nenashev> I'm having a hardstop within 4 minutes
18:56:31 <KostyaSha> ogondza,  as i see LTS backporting tools can't deal with -m1 merges
18:58:39 <KostyaSha> seems kohsuke is busy with twitter and posting about stickers
18:58:57 <KostyaSha> oleg-nenashev,  no answers, postpone topic and shift to other?
18:59:06 <oleg-nenashev> Probably
19:00:47 <danielbeck> KostyaSha oleg-nenashev So we're going to continue this discussion next time?
19:01:14 <oleg-nenashev> Yep. Wpuld be great if somebody joins the discussion in the ML
19:01:15 <KostyaSha> danielbeck, obviously yes
19:01:37 <batmat> 2) for me => as danielbeck said I have already been in the past in the position where I actually find those rule more reassuring than having none stated and you discover when you push/propose the patch.
19:01:58 <danielbeck> I'll try to poke KK about it
19:02:03 <danielbeck> #topic next meeting
19:02:17 <danielbeck> Next meeting on Nov 11
19:02:25 <rtyler> works for me
19:02:44 <danielbeck> 10 am PST by then I think, so be aware of off by one errrors
19:02:45 <autojack> can someone link to the mailing list discussion? I can take a look.
19:03:07 <danielbeck> *11 am
19:03:07 <KostyaSha> autojack, yes, channel will have +m soon, will post in jenkins
19:03:08 <autojack> I didn't arrive for the meeting until a few minutes ago.
19:03:11 <autojack> OK
19:03:18 <danielbeck> #endmeeting