18:00:29 <kohsuke> #startmeeting
18:00:29 <robobutler> Let the Jenkins meeting commence!
18:00:36 <kohsuke> #chair rtyler  hare_brain danielbeck
18:00:36 <robobutler> Current chairs: danielbeck hare_brain kohsuke rtyler
18:00:48 <kohsuke> #info https://wiki.jenkins-ci.org/display/JENKINS/Governance+Meeting+Agenda
18:00:51 <rtyler> yay
18:01:05 <batmat> I would argue it's more 8pm actually :)
18:01:08 <kohsuke> #topic re-cap of actions
18:01:16 <kohsuke> oops, my bad batmat
18:01:36 <batmat> kohsuke: np, just joking
18:01:47 <danielbeck> No progress regarding trademark usage by the jenkins hosting guys
18:02:00 <kohsuke> There's actually a long list of actions here: http://meetings.jenkins-ci.org/jenkins-meeting/2015/jenkins-meeting.2015-09-30-18.00.html
18:02:12 <danielbeck> But I did update the wiki page to list all trademark approvals so far (that I know of)
18:02:39 <danielbeck> I just provided status of 1.-3.
18:02:43 <kohsuke> LTS and board role we have upcoming topics for that
18:02:57 <kohsuke> OK, let's move on?
18:03:06 <kohsuke> #topic LTS status check
18:03:15 <ogondza> we are good to go
18:03:22 <kohsuke> Aye aye sir
18:03:37 <kohsuke> #agreed 1.625.1 is good to go
18:03:46 <danielbeck> #action danielbeck to set up 1.625 update site once the build is up
18:03:51 <kohsuke> #topic New Website JIRA project to organize website efforts under
18:03:59 <rtyler> zomg kohsuke you're killing me
18:04:03 <rtyler> refresh your agenda page :P
18:04:07 <kohsuke> oh
18:04:11 <rtyler> we can do this topic first though
18:04:23 <kohsuke> No, I'll go in the order
18:04:24 <kohsuke> #topic Quick announcement of #jenkins-community
18:04:29 <danielbeck> rtyler the idea is to add stuff to the end of the list
18:04:29 <rtyler> hah, okay
18:04:30 <danielbeck> ;-)
18:04:56 <rtyler> #info #jenkins-community has been created on Freenode to help organize events, documentation and more "meta-conversations" around trhe jenkins project itself
18:05:14 <rtyler> I would like to invite folks interested in building up and expanding the community to join the discussion there
18:05:23 <rtyler> JAMs, blogging, etc
18:05:28 <rtyler> that's all, we can move on now :)
18:05:32 <danielbeck> #action danielbeck to update IRC Channel wiki page
18:06:18 <rtyler> kohsuke: next?
18:06:21 <kohsuke> Right, this will prevent those communtiy building conversations from getting drawned in the user/support/dev conversations
18:06:40 <kohsuke> #topic New Website JIRA project to organize website efforts under
18:06:46 <rtyler> okay so this is also a topic of mine
18:07:02 <rtyler> there's a lot of interest in restructuring and improving the jenkins website
18:07:13 <rtyler> and I'd like to create a WEBSITE project in JIRA to keep all that work organized
18:07:21 <rtyler> comments/questions/objections?
18:07:36 <batmat> +1
18:07:39 <oleg-nenashev> rtyler: probably it's just a part of INFRA
18:07:42 <kohsuke> I supppose the idea is that the set of people working on the new website is different from the current infra stuff
18:07:45 <danielbeck> looks reasonable, especially if the future site becomes bigger than it's now
18:07:55 <danielbeck> right now it's the blog and five links to the downloads
18:07:56 <kohsuke> stuff -> staff
18:08:07 <oleg-nenashev> rtyler: I'm ok with a new project as well
18:08:11 <ogondza> +1
18:08:12 <kohsuke> +1
18:08:18 <rtyler> oleg-nenashev: the folks I expect to be interested in web changes are different from us bearded infra types :P
18:08:32 <rtyler> like, somebody who knows anything about graphic design
18:08:37 <rtyler> probably doesn't care about puppet :P
18:08:41 <oleg-nenashev> +0.5
18:08:43 <rtyler> hah
18:08:44 <kohsuke> I need to grow some beard to blend in
18:08:56 <rtyler> kohsuke: add it to JIRA
18:08:57 <rtyler> xD
18:09:08 <rtyler> xD# rather
18:09:24 <batmat> :)
18:09:27 <kohsuke> #agreed JIRA will get new WEBSITE project to keep track of the new website project
18:09:31 <rtyler> #action rtyler to create WEBSITE project in JIRA
18:09:39 <rtyler> MOVING ON
18:09:44 <kohsuke> #topic Approval of new Q4 patron messages by CloudBees
18:10:04 <rtyler> where's that PR again?
18:10:07 <danielbeck> So last time I still thought we could run the same messages in Q4 as in Q3... turns out, not.
18:10:08 <danielbeck> https://github.com/jenkinsci/patron/pull/5
18:10:08 * rtyler digs thorugh open tabs
18:10:23 <danielbeck> Check out the linked PR, it links to the tester app where you can see the messages
18:10:56 <oleg-nenashev> "Templating Jenkins Environments with Docker" is a bit vague, but it's a business of CB marketing
18:11:00 <danielbeck> CloudBees is asking us to run these messages in Q4.
18:11:18 * rtyler shrugs
18:11:25 <rtyler> agreed on the vagueness, but it's not a big deal to me
18:11:33 <rtyler> Shrugs as a Service
18:11:34 <kohsuke> I think they are OK
18:12:02 <danielbeck> They certainly fit the criteria we have, relevant and supportive.
18:12:06 <kohsuke> From my PoV, the main thing I'm looking out for is for the message not to be overly advertising or against Jenkins
18:12:14 * rtyler nods
18:12:32 <oleg-nenashev> Too much Docker for a HW engineer like me. CB is eligible to do it according to the patroning policy, so +1
18:12:38 <rtyler> +1 on the messaging
18:12:39 <kohsuke> Any objections to blessing this?
18:13:19 <kohsuke> it'd be nice to get some votes from people outside the payroll of CB
18:13:28 <rtyler> I've not received a paycheck yet so.. :P
18:13:30 <rtyler> does that count?
18:13:50 <kohsuke> Going ...
18:14:01 <kohsuke> going ...
18:14:08 <ogondza> +1
18:14:09 <rtyler> c-c-c-c-combo breaker
18:14:14 <batmat> +1
18:14:18 <kohsuke> Thanks!
18:14:37 <kohsuke> #agreed new Q4 patron messages by CloudBees (https://github.com/jenkinsci/patron/pull/5) are blessed
18:14:49 <kohsuke> #topic Proposal - Project sub-teams
18:14:58 <rtyler> #info proposal here https://wiki.jenkins-ci.org/display/JENKINS/Proposal+-+Project+sub-teams
18:15:13 <rtyler> for anybody that hasn't yet seen the document, please take some time to read it
18:15:25 * rtyler thinks we should wait 5 minutes to make sure folks have read it
18:15:30 <danielbeck> agreed
18:15:40 <rtyler> kohsuke: did you add your edits this morning yet?
18:15:44 <oleg-nenashev> I added LTS and Community teams
18:15:49 <kohsuke> Yes, edited
18:15:56 <rtyler> thanks
18:16:14 <kohsuke> I can imagine what LTS team does, but what does the community team do?
18:16:18 <rtyler> the high level goal here is to empower leaders within the community to drive their different areas forward
18:16:25 <rtyler> kohsuke: see the document :P
18:16:49 <kohsuke> oh wow, this document is changing live
18:17:05 <rtyler> #info I am not proposing team leads at this point, only proposing the structure which will allow team leads
18:17:32 <oleg-nenashev> We need somebody to handle incoming requests. I and danielbeck do it right now, but there's no sync in these activities
18:17:38 <danielbeck> Do we need LTS or should that be "core"?
18:17:43 <rtyler> the teams that are most important to me to identify are: Security, Website, Events and LTS
18:18:05 <rtyler> IMHO LTS team is a good idea because that gives people in the community a point of contact for the LTS activities
18:18:17 <batmat> Aren't somehow events & community close?
18:18:35 <danielbeck> batmat Very different fields though
18:18:46 <rtyler> I had originally scrapped a team I was calling "Plugins" wihch is what oleg-nenashev refers to as "Community"
18:18:54 <danielbeck> They sound similar but the tasks are very different
18:19:00 <rtyler> but I think the "Community" team here, is enabling the developer community
18:19:05 <kohsuke> The two tasks for the community team feel very different in nature
18:19:05 <oleg-nenashev> My POV is a bit different
18:19:08 <rtyler> whereas events is organizing around developer and user communities
18:19:17 <orrc> yeah, plugin herding seems like a job of its own
18:19:22 <rtyler> heh
18:19:32 <rtyler> says the man who I would name chief shepherder :P
18:19:50 <oleg-nenashev> "Community" team may provide advices for hanging PRs
18:20:00 <autojack> fine time for work internet to go down
18:20:27 <rtyler> so at this time I hope almost everybody has read through the proposal at least at a high level
18:21:08 <rtyler> I think the community should be empowered to propose new team leadership positions as we see necessary in future project meetings
18:21:17 <ogondza> I would like to see a team responsible for development, be it the one responsible for LTS or separate
18:21:33 <oleg-nenashev> ogondza +1
18:21:34 <danielbeck> ogondza What would the specific job be?
18:21:46 <oleg-nenashev> We have technical tracks for Jenkins 2.0
18:22:03 <oleg-nenashev> But some kind of roadmaps would be useful
18:22:06 <kohsuke> I think there's two separate parts to this proposal, the notion of sub-teams and then what the actual teams are
18:22:08 <rtyler> I think this is diverging from what I want to get done first in this topic: agreement on the structure and appointment process
18:22:25 <danielbeck> True, we can always fine-tune later
18:22:26 <kohsuke> I think rtyler is trying to get us bless the former before spending too much on the latter
18:22:27 <ogondza> danielbeck: from last meeting agenda "Time to move to Java 8 and servlet 3.1?"
18:22:35 <ogondza> does not seem to fit anywhere
18:22:54 <oleg-nenashev> yep, "roadmaps"
18:22:56 <danielbeck> ogondza "Roadmap Team"?
18:22:57 <ogondza> pending PRs, urgent releases, reverts, etc
18:23:01 <rtyler> heh
18:23:07 <oleg-nenashev> They could be useful to focus the community efforts
18:23:20 <danielbeck> Like that won't result in heads rolling
18:23:22 <rtyler> orrc: I'm curious on your opinion on this in particular, since I've seen you lead some different efforts over the year
18:23:25 <rtyler> years*
18:23:45 <oleg-nenashev> jenkinsci/core is supposed to handle PRs. It's not 100% true right now
18:23:53 <rtyler> to me an important aspect of my proposal is sending, basically an RFP, to the commnuity for leads
18:24:04 <danielbeck> RFP?
18:24:09 <rtyler> request for participation
18:24:16 <rtyler> sorry, will de-acronym as much as possible
18:24:28 <autojack> OK, trying to read the doc again now that internet is back.
18:25:36 <orrc> I think the proposal makes sense
18:25:53 <batmat> At least I like the problem description, about the fact it's certainly wasteful to ping the board abt subjects of little importance, sure. Do we examples of that btw?
18:26:02 <danielbeck> Yep, also +1 from me
18:26:41 <oleg-nenashev> rtyler: ${WHATEVER} Officer
18:26:44 <rtyler> haha
18:26:50 <oleg-nenashev> or ${whatever} king :(
18:26:53 <kohsuke> batmat: yeah, for example to contact SPI & ffis.de
18:26:57 <rtyler> (.*) person
18:27:05 <autojack> +1. the recent dust-up over a potential security vuln is a good example of how this would be useful.
18:27:21 <rtyler> autojack: that was one of my primary motivators here :P
18:27:28 <kohsuke> Right, getting CVE IDs assigned is another one
18:27:33 <rtyler> the concept is basically pilfered in its entirely from FreeBSD
18:27:33 <batmat> kohsuke: yeah, wasteful and putting ppl on the critical path unnecessarily
18:27:34 <rtyler> :P
18:27:36 <batmat> +1 for me
18:27:55 <kohsuke> hare_brain: are you here?
18:27:56 <autojack> rtyler: free-what now? is that some kind of open source thing?
18:27:57 <autojack> ;)
18:28:02 <rtyler> my hope is that we can extend the "executive authority" to domain specific leaders who may be more qualified and more able to react such as Security in paritcular
18:28:09 <rtyler> autojack: I heard it was dead :P
18:28:15 <autojack> lolz.
18:28:20 <rtyler> as it's my proposal, I'm obv. +1 on it :p
18:28:21 <kohsuke> I think a board blessing this would be nie on this because this is delegating some of your power to others
18:28:28 <autojack> another term for this type of group that I have heard used is Assembly of Experts.
18:28:31 <kohsuke> nie -> nice
18:28:48 <hare_brain> +1 on the structure of the proposal/
18:28:50 <autojack> although... that might be what they call it in the Iranian government?
18:28:53 <oleg-nenashev> +1
18:29:04 <kohsuke> OK, my +1 as well
18:29:06 <danielbeck> +1
18:29:07 <rtyler> okay, I think it's safe to say we're largely in agreement here
18:29:25 <rtyler> can we agree right now to the need for a Security post at least?
18:29:31 <danielbeck> That leaves just figuring out which teams and responsibilities make sense :-)
18:29:34 <danielbeck> "just"
18:29:35 <batmat> autojack: dead for some at least https://twitter.com/randileeharper/status/651483473392234500
18:29:35 <autojack> yes, +1 to security post especially.
18:29:41 <rtyler> I would like to get started on Security, Infra and Events ASAP
18:29:51 <autojack> and +1 for community. I have tried to help out in that area over the years.
18:29:53 <rtyler> (infra is me though, :/)
18:29:54 <kohsuke> #agreed the subteam structure is blessed as of versrsion 10 of https://wiki.jenkins-ci.org/pages/viewpage.action?pageId=82674793
18:30:00 <rtyler> thakns kohsuke
18:30:10 <oleg-nenashev> +1 for security
18:30:38 <rtyler> #action rtyler to work with the rest of the board to create a request for participation for a Security team lead
18:31:29 <kohsuke> As a board member I'd like to see the events team up & running toward FOSDEM & SCALE
18:31:30 <rtyler> I think we should flesh out responsibilities of Security team lead, and others in separate documents
18:31:49 <rtyler> kohsuke: I agree on that, so those don't crush me :P
18:32:02 <danielbeck> Security, events and infra should be pretty straightforward wrt responsibilities.
18:32:04 <kohsuke> Those things do require a lot of external coordinations where a clearly marked responsible person really helps
18:32:10 <rtyler> alyssa__: could I ask for your help to define the Events team lead responsibilities?
18:32:24 <rtyler> then we can go thorugh the team lead proposal process once that's defined?
18:32:28 <alyssa__> rtyler: sure thing
18:32:48 <rtyler> I'll create a page nuder the governance document for team lead specifications
18:32:51 <rtyler> er
18:33:00 <autojack> heh
18:33:02 <rtyler> #action rtlyer to create a page under the governance document outlining the team leadership responsibilities
18:33:05 <rtyler> GAK
18:33:08 <rtyler> I CAN SPELL MY NAME
18:33:12 <danielbeck> no?
18:33:14 <rtyler> #action rtyler to do that thing up there
18:33:20 <rtyler> <>_<
18:33:37 <kohsuke> LTS & infra are existing functionalities that I think we should be able to bless more formally with this new structure
18:33:49 <rtyler> if there's no objections, I'll put together the infra team lead responsibilities
18:34:14 <rtyler> kohsuke: who can define the LTS team leadership role?
18:34:14 <kohsuke> If i'm not mistaken, I think we are all pretty clear what we do in those spaces because we've been doing it for so long
18:34:22 <kohsuke> ogondza?
18:34:27 <rtyler> that works for me
18:34:32 <ogondza> yeah, sure
18:34:35 <KostyaSha> but kohsuke usually do decisions about lts?
18:34:39 <oleg-nenashev> +1
18:34:40 <autojack> rtyler: as an aside, if you need help with infra support, I might be able to contribute.
18:34:45 <rtyler> #action ogondza to define the LTS team leadership role
18:34:53 <rtyler> autojack: are you in #jenkins-infra?
18:35:01 <KostyaSha> +1 for ogondza
18:35:32 <rtyler> bear in mind, we're just defining teams right now, the board will follow the process outlined in the proposal above
18:35:58 <rtyler> so we've got somebody to define Security, Infra, Events and LTS
18:36:04 <rtyler> I'm happy with that for now TBH
18:36:21 <rtyler> that's already plenty of work :P
18:36:31 <kohsuke> I agree, is that OK oleg-nenashev ?
18:36:41 <kohsuke> Can we come back to some of the other teams you proposed later?
18:36:57 <oleg-nenashev> +1
18:37:10 <autojack> rtyler: no, but I can be.
18:37:21 <rtyler> orrc: would you mind pondering some of the plugin/community responsibilities in the meantime
18:37:39 <kohsuke> Should we move on to the next topic?
18:37:46 <rtyler> I think you and oleg-nenashev could/should work together to collate responsibilities there
18:37:47 <autojack> rtyler: orrc: I would be interested in talking about that too, pursuant to my comments in #jenkins earlier today.
18:37:53 * rtyler nods
18:38:00 <oleg-nenashev> kohsuke: yes, no need to handle everything now
18:38:08 <rtyler> kohsuke: I am fine moving on
18:38:12 <rtyler> thanks for the input folks
18:38:28 <kohsuke> #info autojack orrc oleg-nenashev will get together to ponder plugin/community responsibilities
18:38:35 <kohsuke> #topic Permission request - Admin access to jenkinsci org
18:38:43 <rtyler> what does this mean? :P
18:38:45 <kohsuke> I assume you mean the github org, oleg-nenashev
18:38:46 <oleg-nenashev> this is mine
18:38:48 <danielbeck> GitHub org
18:39:00 <rtyler> AH
18:39:01 <oleg-nenashev> Lost something in the meeting agenda
18:39:07 <oleg-nenashev> See the e-mail thread
18:39:13 <rtyler> oleg-nenashev: which thread?
18:39:19 <rtyler> what access is needed here/why?
18:39:29 <oleg-nenashev> https://groups.google.com/forum/#!topic/jenkinsci-dev/pFWSnJ3uHFU
18:40:25 <rtyler> +1 to this
18:40:39 <kohsuke> Yeah, given his involvement to plugin onboarding work, let's unblock him
18:40:40 <rtyler> danielbeck: you had some questions last week about updating the github org ACLs and way we handle things right?
18:40:48 <batmat> Already gave my +1 in the email thread, echoing here
18:40:54 <danielbeck> rtyler Out of scope for today I think
18:40:57 <kohsuke> And he has CLA in place, so there's that.
18:41:12 <danielbeck> +1 for Oleg's request
18:41:14 <rtyler> definitely out of scope, but I'm thinking perhaps the two of you could work on a proposal for how to make this work go away or easier in the future
18:41:15 <ogondza> oleg-nenashev: thank for volunteering for this job
18:41:24 <danielbeck> rtyler Will do
18:41:40 <danielbeck> rtyler FWIW I added an agenda item that kind of already does
18:41:40 <rtyler> very happy to have people volunteering for work, but if we can make the work go away, even better :)
18:41:50 <kohsuke> that's coming to the next topic
18:41:57 <oleg-nenashev> It's my responsibility to deal with that jenkins-admin, because I too lazy to fox it :)
18:42:01 <autojack> +1 and thanks to oleg-nenashev
18:42:12 <rtyler> #agreed on granting oleg-nenashev github org admin access
18:42:15 <rtyler> kohsuke: next!
18:42:19 <kohsuke> #agreed oleg-nenashev will step up to more github repo house-keeping work & get admin access to the org for that
18:42:30 <kohsuke> #topic JIRA project for plugin hosting (and possibly similar) requests
18:42:45 <oleg-nenashev> Yes, another guy
18:42:49 <danielbeck> So Oleg and I discussed recently the problems we have with plugin hosting requests
18:42:50 <rtyler> danielbeck: would this just be moving this out of the mailing list?
18:42:55 <rtyler> and IRC channel?
18:43:01 <oleg-nenashev> Kinda
18:43:09 <oleg-nenashev> + workflow improvement
18:43:17 <danielbeck> For now. A big problem is that we miss some requests
18:43:27 <danielbeck> especially when they're not immediately resolved
18:43:28 <oleg-nenashev> The idea is to use JIRA workflow to avoid missing requests
18:43:33 <ogondza> that should stop with the project
18:43:39 <ogondza> +1
18:43:42 <rtyler> yeah, that makes a lot of sense to me
18:43:42 <rtyler> +1
18:43:55 <danielbeck> Moving requests into Jira would still not automate, but it would make it basically impossible to lose some
18:44:03 <kohsuke> +1
18:44:06 <rtyler> and better to have an audit trail for the discussion I hope
18:44:11 <kohsuke> Can someone create a custom project with custom field & all that?
18:44:11 <oleg-nenashev> BTW the automation is also possible
18:44:23 <batmat> issue might be: how do discuss usefulness/possible duplicate as now?
18:44:33 <oleg-nenashev> IIRC danielbeck has already created the project
18:44:41 <batmat> Or worse https://groups.google.com/forum/#!topic/jenkinsci-dev/bMXeWrOyEN4
18:44:56 <rtyler> batmat: we could notify jenkinsci-dev on new issue creation in that project
18:44:57 <danielbeck> batmat We can email jenkinci-dev when an issue gets created and resolved
18:45:07 <danielbeck> nothing in between, just those two
18:45:10 <rtyler> zomg ur so smart danielbeck
18:45:11 <batmat> danielbeck: rtyler yeah right
18:45:22 <ogondza> -0.5 on the noise
18:45:28 <danielbeck> ogondza Less than today
18:45:39 <rtyler> is the resolved mail necessary?'
18:45:43 <danielbeck> I'd really like there to be visibility to the dev community
18:45:47 <oleg-nenashev> I doubt it's a "noice"
18:45:58 <KostyaSha> -1 for dev list email
18:45:59 <oleg-nenashev> But probably a separate mailing list is better
18:46:02 <danielbeck> rtyler Possibly not. I'd consider this fine-tuning
18:46:12 <danielbeck> Would also work, but reduce visibility
18:46:28 <rtyler> well, I think at a high level, we need some way to communicate requests to the dev community
18:46:31 <KostyaSha> danielbeck, you can create separate google group list like for issues
18:46:37 <ogondza> actually, one main with initial request (and possible rejection) sounds good to me
18:46:39 <oleg-nenashev> Probably it's also a topic for "Website 2.0"
18:46:45 <danielbeck> KostyaSha Nobody ever subscribes to those extra lists
18:46:49 <oleg-nenashev> It could display such requests
18:46:56 <KostyaSha> danielbeck, that's mean that nobody needs this info
18:46:56 <ogondza> s/main/mail/
18:47:08 <rtyler> can we try the "request created" email to the dev list and see at least if it's better or worse first?
18:47:19 <KostyaSha> danielbeck, + CloudBees forks plugins without any requests, so monitoring new plugins is impossible via dev list
18:47:22 <danielbeck> rtyler looks good
18:47:23 <kohsuke> Fine either way. I don't like existing devs turning new people away just because they don't think it's a good idea or there's an overlap.
18:47:31 <rtyler> every third mailing list thread is about new hosting anyways
18:48:02 <rtyler> KostyaSha: I think the right expectation to set here is that all such requests go through JIRA
18:48:06 <kohsuke> And that's not inconsistent with us suggesting related plugins to consolidate or encourage communication between them
18:48:08 <rtyler> wihch would be better IMO
18:48:14 <oleg-nenashev> KostyaSha: It's a very orthogonal topic, because every jenkinsci/core member is eligible to do it. BTW it's reasonable complain in particular cases
18:48:17 <KostyaSha> rtyler, imho just don't flood mail list
18:48:31 * rtyler nods
18:48:39 <danielbeck> KostyaSha Two emails per request is strictly less than today
18:48:44 <rtyler> does this mean we should restrict who can fork via jenkins-admin?
18:49:12 <batmat> I thing that there shouold be at least one email on the dev list when the request gets done or created?
18:49:13 <danielbeck> rtyler I think it should suffice to define a process. If we know we should not fork without request in Jira, we won't.
18:49:13 <kohsuke> rtyler: my operating principle is that we should be free to create new plugins
18:49:14 <rtyler> if we were to create oleg-nenashev's community team, I would expect members of that team to be responsible for that forking
18:49:24 <oleg-nenashev> rtyler: kinda
18:49:45 <oleg-nenashev> rtyler: I doubt it should be too restricted, but who knows
18:49:49 <KostyaSha> kohsuke's principal = make bazaar from project
18:49:56 <rtyler> kohsuke: nobody's stopping you from making a plugin, but this does consolidate hosting inside of jenkinsci which is IMO reasonable
18:50:14 <batmat> kohsuke: I see your point, but I tend to disagree some review/encouraging to merge efforts is not good.
18:50:25 <KostyaSha> rtyler, you can't also limit publishing into repo + UC, so limiting fork wouldn't make anything.
18:50:47 <kohsuke> batmat: I'm all for *encouraging* consolidation, so long as that's not used as a reason to block somebody
18:50:50 <KostyaSha> and we started this discussion from danielbeck's idea to post JIRA issues about plugin requests
18:51:03 <batmat> IMO, it's somehow not beneficial to users to have 3 or 4 plugins that generally only have parts of the picture, and IMO OSS is also about collaboration. So that's a pity
18:51:14 <danielbeck> I think we're going off track here right now
18:51:14 <oleg-nenashev> +1
18:51:18 <rtyler> heh, true
18:51:26 <KostyaSha> batmat, i said the same about cloudbees-docker-* but kohsuke likes it
18:51:44 <KostyaSha> and it other topic
18:51:45 <danielbeck> it seems this is something we'll need to discuss at a separate time, but it is out of scope today IMO
18:51:57 <rtyler> danielbeck oleg-nenashev AFAICT from this discussion you've got the green light
18:52:03 <danielbeck> \o/
18:52:13 <rtyler> but clearly lots of varying opinions about the plugin process :)
18:52:13 <oleg-nenashev> KostyaSha: could you create a topic for the next meeting?
18:52:14 <batmat> +1 for the current subject, right.
18:52:37 <kohsuke> OK, so "the current subject" is to create JIRA and redirect email plugin forking requst to there
18:52:39 <kohsuke> right?
18:52:42 <rtyler> AYE
18:52:47 <oleg-nenashev> yes
18:52:55 <KostyaSha> oleg-nenashev, no
18:53:04 <kohsuke> is there a name for that project in JIRA?
18:53:05 * rtyler looks at the time
18:53:15 <batmat> oleg-nenashev: yes, I think this is indeed a discussion that would clarify things. IMO the projects needs to define *some* rules of thumbs.
18:53:38 <kohsuke> #agreed we'll create a new JIRA project to receive plugin hosting request, and direct people to use it instead of sending emails to the dev list
18:53:45 <danielbeck> #action danielbeck to set up Jira project for plugin hosting requests and update dev docs to point there
18:53:50 <kohsuke> Sounds like the name is TBD
18:53:52 <rtyler> next topic!
18:54:03 <danielbeck> next meeting :-)
18:54:05 <kohsuke> That's it
18:54:09 <kohsuke> #topic next meeting
18:54:14 <oleg-nenashev> batmat: Yes, probably we're too restrictive
18:54:16 <KostyaSha> #MYCUTEPLUGIN-*
18:54:21 <rtyler> 10/28th looks fine to me
18:54:25 <rtyler> er, oct 28th
18:54:34 <kohsuke> #info the next meeting is Oct 28th
18:54:43 <kohsuke> When is the DST switch over in US & Europe?
18:54:53 <kohsuke> Whenever that is, just be careful
18:54:58 <danielbeck> #action danielbeck to put up warning in wiki about DST
18:55:01 <batmat> 24 / 25-10 in France
18:55:03 <rtyler> hheh
18:55:21 <kohsuke> #endmeeting